X

excel - numerowanie kolumn z wypełnionymi wierszami

06 Jul 2009 17:10 SZszczepanek_6
  • #1 06 Jul 2009 17:10
    szczepanek_6
    Level 8  
    Helpful post? (0)
    Witam serdecznie,

    mam taki mały problem z excelem i poszukuję pomocy.

    Mianowice szukam opcji, która umożliwiłaby wstawienie w kolumnę liczb porządkowych (od 1 do 100 przykładowo) ale tylko w przypadku gdy w kolumnie obok będzie jakaś treść (dowolna)

    wiem że można seryjnie wstawić numery przez "wypełnienie" ale zależy mi na tym żeby nie numerować pustych kolumn.

    z góry dziękuje za wszelkie pomysł
  • Helpful post
    #2 06 Jul 2009 17:22
    vampire86
    Level 35  
    Helpful post? (0)
    Dla kolumny A:

    A1=1
    reszta komórek w kolumnie funkcja:
    =JEŻELI(NIE(B2="");A1+1;"")

    EDIT:
    Oczywiście co do funkcji to dale komórek:
    A2 = JEŻELI(NIE(B2="");A1+1;"")
    A3 = JEŻELI(NIE(B3="");A2+1;"")
    A4 = JEŻELI(NIE(B4="");A3+1;"")
    A5 = JEŻELI(NIE(B5="");A4+1;"")
    itp. wystarczy wypełnić serią.
  • #3 06 Jul 2009 17:32
    szczepanek_6
    Level 8  
    Topic author Helpful post? (0)
    reszta już prosta :)

    dziękuje pięknie - kombinowałem kombinowałem ale na taki prosty pomysł nie wpadłem :P

    to może pomożesz jeszcze w jednym - mam makro drukujące zaznaczony w arkuszu obszar ale poszukuje możliwości zapisania w makro na której drukarce ma zostać wykonany wydruk - mam dwie i chciałbym drukować tylko na jednym z nich.
  • #4 06 Jul 2009 18:34
    adamas_nt
    Moderator Programowanie
    Helpful post? (+1)
    Na logikę to nawet pasuje, ale Excel z pewnością się "zjeży" przy wierszu następnym po pustym :)
    Proponuję: =JEŻELI(B2<>"";MAX(A$1:A1)+1;"")
    Dlaczego? Jeśli pierwsza pozycja Np faktury zajmuje dwa wiersze, to jaka będzie Lp. w trzecim wierszu?

    excel - numerowanie kolumn z wypełnionymi wierszami

    Ad. VBA Drukowanie
    Poszukaj w pomocy właściwości: ActivePrinter polecenia: PrintOut

    Możesz sprawdzić nazwę (aktywnej drukarki) poleceniem:
    MsgBox Application.ActivePrinter

    Po aktywowaniu drukarki innej niż domyślna, na końcu procedury możesz ustawić tę, która domyślna być powinna:
    Application.ActivePrinter = "Nazwa Drukarki"

    p.s. :arrow: vampire86 - po dogrywce, remis w ilości postów :)
  • #5 07 Jul 2009 13:55
    szczepanek_6
    Level 8  
    Topic author Helpful post? (0)
    z drukarką się udało :)

    a powiedzcie mi jeszcze taką rzecz:

    po numerowaniu otrzymuje wiersze w których mam liczbę porządkową ale nie mam pozostałych kolumn wypełnionych i teraz jak można by je usunać??

    chodzi mi o marko na zasadzie
    jesli kolumna 'B' jest pusta usuń całe wiersze od tej (np. 30 ) do 2000.

    nie mam problemu pustych kolumn po drodze bo kolumna B zawsze ma wartość jesli jej nie ma to znaczy że jest do wyrzucenia
  • #6 07 Jul 2009 22:59
    adamas_nt
    Moderator Programowanie
    Helpful post? (0)
    Nie do końca łapię co chcesz zrobić. Makro musi mieć zdefiniowane zakresy i/lub warunki, jeśli ma coś zrobić, Np jeśli w wierszu wystąpi pusta komórka w kol B, to usuń wiersz, usuń n wierszy, usuń wiersze do następnego zawierającego COŚ itp. Napisz ciut więcej lub najlepiej wrzuć przykład (plik Excela jako załącznik).
  • #7 08 Dec 2010 11:30
    kalep
    Level 12  
    Helpful post? (0)
    Moja propozycja: =JEŻELI(B1<>"";MAX(ADR.POŚR("A1:A"&WIERSZ()-1))+1;"")
  • #8 09 Dec 2010 09:18
    marek003
    Level 39  
    Helpful post? (0)
    kalep wrote:
    Moja propozycja: =JEŻELI(B1<>"";MAX(ADR.POŚR("A1:A"&WIERSZ()-1))+1;"")


    Po co odgrzebujesz temat z przed półtora roku? tym bardziej że to to samo co proponował kolega adamas_nt a tylko bardziej skomplikowane.
    adamas_nt wrote:
    Proponuję:=JEŻELI(B2<>"";MAX(A$1:A1)+1;"")
Mouser  Search 4 million + Products
Browse Products