Forum elektroda.pl

Regulamin  | Punkty  | Dodaj...  | Ostatnie  | Szukaj | Rejestracja | Zaloguj



excel - numerowanie kolumn z wypełnionymi wierszami


  Strona Główna -> Forum elektroda.pl-> Komputery Serwis -> Komputery Software ->excel - numerowanie kolumn z wypełnionymi wierszami Napisz nowy temat  Odpowiedz do tematu 
AutorSchowaj lewą kolumnę Wiadomość
szczepanek_6
Poziom 3
Poziom 3


Dołączył: 27 Maj 2009
Posty: 5
Miasto: Warszawa

szczepanek_6
Poziom 3
Post#1 06 Lip 2009 17:10  Autor tematu   

excel - numerowanie kolumn z wypełnionymi wierszami


Witam serdecznie,

mam taki mały problem z excelem i poszukuję pomocy.

Mianowice szukam opcji, która umożliwiłaby wstawienie w kolumnę liczb porządkowych (od 1 do 100 przykładowo) ale tylko w przypadku gdy w kolumnie obok będzie jakaś treść (dowolna)

wiem że można seryjnie wstawić numery przez "wypełnienie" ale zależy mi na tym żeby nie numerować pustych kolumn.

z góry dziękuje za wszelkie pomysł

Czy wiadomość jest pomocna? + 0 -
Powrót do góry
Google


Google Adsense


Google


Powrót do góry
vampire86
Poziom 23
Poziom 23


Dołączył: 02 Kwi 2008
Posty: 2524
Miasto: Warszawa

vampire86
Poziom 23
Post#2 06 Lip 2009 17:22Pomocny post    

Re: excel - numerowanie kolumn z wypełnionymi wierszami


Dla kolumny A:

A1=1
reszta komórek w kolumnie funkcja:
=JEŻELI(NIE(B2="");A1+1;"")

EDIT:
Oczywiście co do funkcji to dale komórek:
A2 = JEŻELI(NIE(B2="");A1+1;"")
A3 = JEŻELI(NIE(B3="");A2+1;"")
A4 = JEŻELI(NIE(B4="");A3+1;"")
A5 = JEŻELI(NIE(B5="");A4+1;"")
itp. wystarczy wypełnić serią.

Czy wiadomość jest pomocna? + 0 -
Powrót do góry
Google


Google Adsense


Google


Powrót do góry
szczepanek_6
Poziom 3
Poziom 3


Dołączył: 27 Maj 2009
Posty: 5
Miasto: Warszawa

szczepanek_6
Poziom 3
Post#3 06 Lip 2009 17:32  Autor tematu   

Re: excel - numerowanie kolumn z wypełnionymi wierszami


reszta już prosta Smile

dziękuje pięknie - kombinowałem kombinowałem ale na taki prosty pomysł nie wpadłem Razz

to może pomożesz jeszcze w jednym - mam makro drukujące zaznaczony w arkuszu obszar ale poszukuje możliwości zapisania w makro na której drukarce ma zostać wykonany wydruk - mam dwie i chciałbym drukować tylko na jednym z nich.

Czy wiadomość jest pomocna? + 0 -
Powrót do góry
Google


Google Adsense


Google


Powrót do góry
adamas_nt
Moderator Programowanie
Moderator Programowanie


Dołączył: 26 Sty 2008
Posty: 4208
Miasto: Nowy Tomyśl

adamas_nt
Moderator Programowanie
Post#4 06 Lip 2009 18:34    

Re: excel - numerowanie kolumn z wypełnionymi wierszami


Na logikę to nawet pasuje, ale Excel z pewnością się "zjeży" przy wierszu następnym po pustym Smile
Proponuję: =JEŻELI(B2<>"";MAX(A$1:A1)+1;"")
Dlaczego? Jeśli pierwsza pozycja Np faktury zajmuje dwa wiersze, to jaka będzie Lp. w trzecim wierszu?

excel - numerowanie kolumn z wypełnionymi wierszami

Ad. VBA Drukowanie
Poszukaj w pomocy właściwości: ActivePrinter polecenia: PrintOut

Możesz sprawdzić nazwę (aktywnej drukarki) poleceniem:
MsgBox Application.ActivePrinter

Po aktywowaniu drukarki innej niż domyślna, na końcu procedury możesz ustawić tę, która domyślna być powinna:
Application.ActivePrinter = "Nazwa Drukarki"

p.s. Arrow vampire86 - po dogrywce, remis w ilości postów Smile

Czy wiadomość jest pomocna? + +1 -
Powrót do góry
szczepanek_6
Poziom 3
Poziom 3


Dołączył: 27 Maj 2009
Posty: 5
Miasto: Warszawa

szczepanek_6
Poziom 3
Post#5 07 Lip 2009 13:55  Autor tematu   

Re: excel - numerowanie kolumn z wypełnionymi wierszami


z drukarką się udało Smile

a powiedzcie mi jeszcze taką rzecz:

po numerowaniu otrzymuje wiersze w których mam liczbę porządkową ale nie mam pozostałych kolumn wypełnionych i teraz jak można by je usunać??

chodzi mi o marko na zasadzie
jesli kolumna 'B' jest pusta usuń całe wiersze od tej (np. 30 ) do 2000.

nie mam problemu pustych kolumn po drodze bo kolumna B zawsze ma wartość jesli jej nie ma to znaczy że jest do wyrzucenia

Czy wiadomość jest pomocna? + 0 -
Powrót do góry
Google


Google Adsense


Google


Powrót do góry
adamas_nt
Moderator Programowanie
Moderator Programowanie


Dołączył: 26 Sty 2008
Posty: 4208
Miasto: Nowy Tomyśl

adamas_nt
Moderator Programowanie
Post#6 07 Lip 2009 22:59    

Re: excel - numerowanie kolumn z wypełnionymi wierszami


Nie do końca łapię co chcesz zrobić. Makro musi mieć zdefiniowane zakresy i/lub warunki, jeśli ma coś zrobić, Np jeśli w wierszu wystąpi pusta komórka w kol B, to usuń wiersz, usuń n wierszy, usuń wiersze do następnego zawierającego COŚ itp. Napisz ciut więcej lub najlepiej wrzuć przykład (plik Excela jako załącznik).

Czy wiadomość jest pomocna? + 0 -
Powrót do góry
Google


Google Adsense


Google


Powrót do góry
kalep
Poziom 12
Poziom 12


Dołączył: 05 Wrz 2005
Posty: 80
Miasto: Lublin

kalep
Poziom 12
Post#7 08 Gru 2010 11:30    

Re: excel - numerowanie kolumn z wypełnionymi wierszami


Moja propozycja: =JEŻELI(B1<>"";MAX(ADR.POŚR("A1:A"&WIERSZ()-1))+1;"")

Czy wiadomość jest pomocna? + 0 -
Powrót do góry
marek003
Poziom 24
Poziom 24


Dołączył: 10 Wrz 2002
Posty: 4080
Miasto: Lublin

marek003
Poziom 24
Post#8 09 Gru 2010 09:18    

Re: excel - numerowanie kolumn z wypełnionymi wierszami


kalep napisał:
Moja propozycja: =JEŻELI(B1<>"";MAX(ADR.POŚR("A1:A"&WIERSZ()-1))+1;"")


Po co odgrzebujesz temat z przed półtora roku? tym bardziej że to to samo co proponował kolega adamas_nt a tylko bardziej skomplikowane.
adamas_nt napisał:
Proponuję:=JEŻELI(B2<>"";MAX(A$1:A1)+1;"")


Czy wiadomość jest pomocna? + 0 -
Powrót do góry
Google


Google Adsense


Google


Powrót do góry
Napisz nowy temat  Odpowiedz do tematu     Strona Główna -> Forum elektroda.pl-> Komputery Serwis -> Komputery Software -> excel - numerowanie kolumn z wypełnionymi wierszami
Strona 1 z 1
Podobne tematy
Excel - numerowanie stron tylko na jednej zakładce (7)
Excel- Kopiowanie listy z inego arkusza i jej numerowanie (8)
Excel- VBA Automatyczne numerowanie i sortowanie na podstawie zadanego numeru LP (6)
Excel - automatyczne numerowanie we własnym formacie (dot.wypełnionych wierszy) (7)
EXCEL 2010 - Zliczanie i numerowanie wystąpień wartości tekstowej w kolumnie (4)
EXCEL - EXCEL-kopiowanie kolumn z kilku arkuszy i usówanie duplikatów (4)
Excel - mnożenie 2 kolumn obok siebie i dodanie nastęnych 2 pomnożonych kolumn. (2)
excel - porównanie kolumn (8)
excel - porównanie kolumn (11)
excel - z 2 kolumn ma dopisac 3 (4)



Administrator || Moderatorzy || Regulamin forum || Regulamin ogólny || Informacja o cookies || Kontakt

Page generation time: 0.055 seconds

elektroda.pl temat RSS