Elektroda.pl
Elektroda.pl
X

Wyszukiwarki naszych partnerów

Kategoria: Kamery IP / Alarmy / Automatyka Bram
Montersi
Kategoria: Akumulatorki / Baterie / Ładowarki
  • #1 13 Kwi 2010 13:53
    C3lin
    Poziom 2  

    Witam,

    Próbowałem rozwiązac problem funkcjami zagnieżdżonymi z wykorzystaniem wyszukaj.pionowo, jezeli, suma jednak nie mogę sobie poradzić, więc proszę o pomoc.

    Podstawowe założenia:
    - w pierwszej kolumnie znajdują się daty w formacie dd.mm.rrrr, są to konkretne dni na przykład 12.04.2009, 25.01.2010, itd. Każda data w osobnej komóre w jednej kolumnie
    - w drugiej kolumnie sa kwoty, które sa przyporządkowane do konkretnych dat po ich lewej stronie

    Z takimi danymi mam kilka zakładek w arkuszu.

    Problem polega na tym, iż poszukuję w jaki sposób w oddzielnej zakładce obliczyć sumę kwot dla każdego miesiąca. Czyli jest osobna kolumna w której są pionowo miesiące i chce aby w kolumnie obok podał mi sume kwot w tym miesiącu.

    Wiem, że należy z zakresu wszystkich dat wyszukać daty na przyklad dla stycznia 2009, następnie dla każdej takiej daty wyszukac kwoty z kolumny obok i na koniec zsumować wszystkie te kwoty.

  • #2 13 Kwi 2010 15:08
    marek003
    Poziom 39  

    Wystarczy funkcja:
    Suma.jeżeli(zakres;kryteria dotyczące zakresu;faktycznie sumowany zakres)

    Tu jest pytanie czy data jest w formacie "data" (tu będzie więcej zabawy) czy to zwykły ciąg cyfr.

    Jeżeli chcesz przykład załącz fragment twojego skoroszytu.

  • #3 13 Kwi 2010 15:13
    C3lin
    Poziom 2  

    powoli to rozgryzłem :)
    data jest jako ciąg cyfr więc używam kryteria na przykład jako **.01.2009
    z tego co pamietam to excel 2003 ma ograniczone zagniezdzenie do 8 funkcji więc przy zakładkach w ilości powyżej 8 nie obejdzie sie bez dodatkowych kolum, czy mam rację?

  • #4 13 Kwi 2010 15:19
    Informacja
    Poziom 18  

    Zagnieżdżenie to nie użycie funkcji.
    Nie słyszałem aby nie można użyć więcej niż 8 razy tej samej funkcji.
    Można przecierz wykonać dwanaście czy więcej okienek z tą samą funkcją, a jedynie ze zmodyfikowanym zakresem jej działania.

  • #5 13 Kwi 2010 15:24
    paweliw
    Spec od komputerów

    Można także użyć formuł tablicowych i sumowania arkuszy.
    Uważam, ze najprościej wydzielić w każdym arkuszu zakres gdzie zsumujemy potrzebne nam miesiące a potem poprzez odwołania wielopoziomowe zsumować wszystko w jednym arkuszu.
    W załączeniu przykładowy plik.

  • #6 13 Kwi 2010 15:48
    C3lin
    Poziom 2  

    @ Informacja
    chodzi o zagnieżdzanie funkcji w funkcji, na przykład to co teraz użylem to: =SUMA(SUMA.JEŻELI('WiW 1232'!H6:H17;"**.03.2009";'WiW 1232'!I6:I17);SUMA.JEŻELI('WiW 2445'!$H$6:$H$43;"**.03.2009";'WiW 2445'!$I$6:$I$43))
    czyli tutaj 2 funkcje (suma.jeżeli) w jednej funkcji (suma)

    @paweliw
    dzieki, też dobre. jednak takie cos za bardzo by skomplikowalo czytelność zakładek, tam mam o wiele więcej danych. ostatecznie już poradziłem sobie robiąc w oddzilenj zakładce sumy danych z podobnymi wyrażeniami (w przykładzie powyżej jest WiW i nastepnie suma wszystkich razem :)

    do zamknięcia, dzięki wszystkim za pomoc

  Szukaj w 4mln produktów
Przeglądaj produkty