Forum elektroda.pl

Regulamin  | Punkty  | Dodaj...  | Ostatnie  | Szukaj  | Rejestracja  | Zaloguj

Ta strona używa cookie. Dowiedz się więcej o celu ich używania i zmianie ustawień cookie w przeglądarce.
Korzystając ze strony wyrażasz zgodę na używanie cookie, zgodnie z aktualnymi ustawieniami przeglądarki.

Excel - Numeracja i sumowanie


Napisz nowy temat  Odpowiedz do tematu      Strona Główna -> Forum elektroda.pl -> Komputery Serwis -> Komputery Software -> Excel - Numeracja i sumowanie
Autor
Wiadomość
jochen_a
Poziom 9
Poziom 9


Dołączył: 23 Kwi 2007
Posty: 42
Miasto: Chrzanów

Post#1 Post autora tematu 25 Wrz 2012 06:57   

Excel - Numeracja i sumowanie


Mam problem z "automatyzacją" tego arkusza. Wszystkie wartości wprowadzone ręcznie. Może jest jakaś formuła ułatwiająca wpisanie całego roku :)

W pierwszej kolumnie jest data, w drugiej wpisujemy czas. Teraz chodzi o to by sumowało czas co 7 dzień, ale z początkiem miesiąca numeracja zaczyna się od początku.

Załączniki:
Powrót do góry
   
adamas_nt
Moderator
Moderator


Dołączył: 26 Sty 2008
Posty: 3961
Miasto: Nowy Tomyśl

Post#2 25 Wrz 2012 07:53pomocny post - solucja   

Re: Excel - Numeracja i sumowanie


Spróbuj:
Cytat:
=JEŻELI(MOD(DZIEŃ(A7);7)=0;SUMA(ADR.POŚR("B"&WIERSZ()&":B"&WIERSZ()-6));"")
Oczywiście formułę kopiujesz od wiersza 7 w dół.
Powrót do góry
   
Google


Google Adsense


Post# 25 Wrz 2012 07:53pomocny post - solucja   





Powrót do góry
   
jochen_a
Poziom 9
Poziom 9


Dołączył: 23 Kwi 2007
Posty: 42
Miasto: Chrzanów

Post#3 Post autora tematu 25 Wrz 2012 08:00   

Re: Excel - Numeracja i sumowanie


Wszystko ekstra ładnie :)

Ale chciałbym jeszcze by w ostatni dzień miesiąca też była suma czasu tych ostatnich trzech dni.
Powrót do góry
   
Google


Google Adsense


Post# 25 Wrz 2012 08:00   





Powrót do góry
   
adamas_nt
Moderator
Moderator


Dołączył: 26 Sty 2008
Posty: 3961
Miasto: Nowy Tomyśl

Post#4 25 Wrz 2012 08:08pomocny post - solucja   

Re: Excel - Numeracja i sumowanie


A, to musisz sobie dopisać drugi warunek wg schematu:
JEŻELI(MIESIĄC(komórka)<>MIESIĄC(komórka niżej);SUMA(ADR.POŚR(na trzy w górę);to co już mamy)

Edit: Hmm, zerknąłem jeszcze raz i tak sobie myślę: trzy dni to akurat w tym, konkretnym miesiącu, a Ty chciałbyś pewnie, żeby liczyło od ostatniej sumy do końca miesiąca?
Powrót do góry
   
Google


Google Adsense


Post# 25 Wrz 2012 08:08pomocny post - solucja   





Powrót do góry
   
jochen_a
Poziom 9
Poziom 9


Dołączył: 23 Kwi 2007
Posty: 42
Miasto: Chrzanów

Post#5 Post autora tematu 25 Wrz 2012 08:32   

Re: Excel - Numeracja i sumowanie


Sęk w tym, że te trzy dni są ruchome. Może zostać 3, 4 a nawet 6.
Powrót do góry
   
adamas_nt
Moderator
Moderator


Dołączył: 26 Sty 2008
Posty: 3961
Miasto: Nowy Tomyśl

Post#6 25 Wrz 2012 09:03   

Re: Excel - Numeracja i sumowanie


Z dwoma kolumnami pomocniczymi wychodzi jak w załączniku. Sprawdź, może da się to jeszcze uprościć...

Załączniki:
Powrót do góry
   
jochen_a
Poziom 9
Poziom 9


Dołączył: 23 Kwi 2007
Posty: 42
Miasto: Chrzanów

Post#7 Post autora tematu 25 Wrz 2012 09:23   

Re: Excel - Numeracja i sumowanie


Formuły w kolumnie F odwołują się do kolumny D, której ma nie być bo te wartości mają być w E.

Na pewnym forum excela dostałem takie rozwiązanie:
Cytat:
=JEŻELI(NR.SER.OST.DN.MIES(A1;0)=A1;SUMA(PRZESUNIĘCIE(B1;-MOD(DZIEŃ(A1);7)+1;0;MOD(DZIEŃ(A1);7);1));JEŻELI(MOD(DZIEŃ(A1);7)=0;SUMA(PRZESUNIĘCIE(B1;-6;0;7;1));""))

Powrót do góry
   
adamas_nt
Moderator
Moderator


Dołączył: 26 Sty 2008
Posty: 3961
Miasto: Nowy Tomyśl

Post#8 25 Wrz 2012 11:38   

Re: Excel - Numeracja i sumowanie


jochen_a napisał:
Na pewnym forum excela dostałem takie rozwiązanie
Ba, ale to trzeba najnowszej wersji Excela. U mnie "stara" 2007 :)
Powrót do góry
   
Google


Google Adsense


Post# 25 Wrz 2012 11:38   





Powrót do góry
   
marek003
Poziom 23
Poziom 23


Dołączył: 10 Wrz 2002
Posty: 3558
Miasto: Lublin

Post#9 25 Wrz 2012 14:17   

Re: Excel - Numeracja i sumowanie


Nie wiem czy dobrze zrozumiałem ale poniżej rozwiązanie bez kolumn pomocniczych i ruszy na E97. :)
Formuła licząca dni
Cytat:
=JEŻELI(MIESIĄC(A1)<>MIESIĄC(A2);1;JEŻELI(E1=7;1;E1+1))


i sumująca czas w odwołaniu do tej liczącej dni. (pierwsza jedynka jest tylko stała)
Cytat:
=JEŻELI(LUB(MOD(DZIEŃ(A2);7)=0;MIESIĄC(A2)<>MIESIĄC(A3));SUMA(ADR.POŚR(ADRES(WIERSZ()-E2+1;2)&":"&ADRES(WIERSZ();2)));"")


Na marginesie przyznam że mam 2010 ale jeszcze nie znam jego nowych funkcji (co prawda wydaje mi się że zapewne można to samo osiągnąć "starymi" funkcjami ale zawsze to jakieś ułatwienie).

Załączniki:
Powrót do góry
   
Napisz nowy temat  Odpowiedz do tematu      Strona Główna -> Forum elektroda.pl -> Komputery Serwis -> Komputery Software -> Excel - Numeracja i sumowanie
Strona 1 z 1
Podobne tematy
Excel/ automatyczne numeracja (2)
Excel/Word automatyczna numeracja wydruku (7)
Excel/Word/Libreoffice/cokolwiek automatyczna numeracja wydruku (6)
excel makro - numeracja komórek w wierszu arkuszu skoroszycie (5)
MS Excel sumowanie (4)
Excel: inteligentne sumowanie (2)
Excel - sumowanie odpowiednich komórek (7)
Excel sumowanie wybranych pól (1)
Excel - sumowanie, jak to zrobić? (5)
Excel - sumowanie w zaleznosci od daty (4)


Administrator || Moderatorzy || Regulamin forum || Regulamin ogólny || Informacja o cookies || Reklama || Kontakt

Page generation time: 0.067 seconds

elektroda.pl temat RSS