Forum Index

Rules  | Points  | Add...  | Recent posts  | Search  | Register  | Log in

This site uses cookies. Learn more about cookies and changing the settings in your browser.

Excel - Numeracja i sumowanie


Post new topic  Reply to topic      Main Page -> Forum Index -> Computer Service -> Computer Software -> Excel - Numeracja i sumowanie
Author
Message
jochen_a
Poziom 9
Poziom 9


Joined: 23 Apr 2007
Posts: 41
Location: Chrzanów

Post#1 Post from the author of the topic 25 Sep 2012 06:57   

Excel - Numeracja i sumowanie


Mam problem z "automatyzacją" tego arkusza. Wszystkie wartości wprowadzone ręcznie. Może jest jakaś formuła ułatwiająca wpisanie całego roku Smile

W pierwszej kolumnie jest data, w drugiej wpisujemy czas. Teraz chodzi o to by sumowało czas co 7 dzień, ale z początkiem miesiąca numeracja zaczyna się od początku.

Attachments:

Helpful message? + -

Back to top
   
Google


Google Adsense


Post# 25 Sep 2012 06:57   





Back to top
   
adamas_nt
Moderator Programowanie
Moderator Programowanie


Joined: 26 Jan 2008
Posts: 4111
Location: Nowy Tomyśl

Post#2 25 Sep 2012 07:53helpful post - solution   

Re: Excel - Numeracja i sumowanie


Spróbuj:
Quote:
=JEŻELI(MOD(DZIEŃ(A7);7)=0;SUMA(ADR.POŚR("B"&WIERSZ()&":B"&WIERSZ()-6));"")
Oczywiście formułę kopiujesz od wiersza 7 w dół.

Helpful message? + -

Back to top
   
jochen_a
Poziom 9
Poziom 9


Joined: 23 Apr 2007
Posts: 41
Location: Chrzanów

Post#3 Post from the author of the topic 25 Sep 2012 08:00   

Re: Excel - Numeracja i sumowanie


Wszystko ekstra ładnie Smile

Ale chciałbym jeszcze by w ostatni dzień miesiąca też była suma czasu tych ostatnich trzech dni.

Helpful message? + -

Back to top
   
Google


Google Adsense


Post# 25 Sep 2012 08:00   





Back to top
   
adamas_nt
Moderator Programowanie
Moderator Programowanie


Joined: 26 Jan 2008
Posts: 4111
Location: Nowy Tomyśl

Post#4 25 Sep 2012 08:08helpful post - solution   

Re: Excel - Numeracja i sumowanie


A, to musisz sobie dopisać drugi warunek wg schematu:
JEŻELI(MIESIĄC(komórka)<>MIESIĄC(komórka niżej);SUMA(ADR.POŚR(na trzy w górę);to co już mamy)

Edit: Hmm, zerknąłem jeszcze raz i tak sobie myślę: trzy dni to akurat w tym, konkretnym miesiącu, a Ty chciałbyś pewnie, żeby liczyło od ostatniej sumy do końca miesiąca?

Helpful message? + -

Back to top
   
Google


Google Adsense


Post# 25 Sep 2012 08:08helpful post - solution   





Back to top
   
jochen_a
Poziom 9
Poziom 9


Joined: 23 Apr 2007
Posts: 41
Location: Chrzanów

Post#5 Post from the author of the topic 25 Sep 2012 08:32   

Re: Excel - Numeracja i sumowanie


Sęk w tym, że te trzy dni są ruchome. Może zostać 3, 4 a nawet 6.

Helpful message? + -

Back to top
   
adamas_nt
Moderator Programowanie
Moderator Programowanie


Joined: 26 Jan 2008
Posts: 4111
Location: Nowy Tomyśl

Post#6 25 Sep 2012 09:03   

Re: Excel - Numeracja i sumowanie


Z dwoma kolumnami pomocniczymi wychodzi jak w załączniku. Sprawdź, może da się to jeszcze uprościć...

Attachments:

Helpful message? + -

Back to top
   
jochen_a
Poziom 9
Poziom 9


Joined: 23 Apr 2007
Posts: 41
Location: Chrzanów

Post#7 Post from the author of the topic 25 Sep 2012 09:23   

Re: Excel - Numeracja i sumowanie


Formuły w kolumnie F odwołują się do kolumny D, której ma nie być bo te wartości mają być w E.

Na pewnym forum excela dostałem takie rozwiązanie:
Quote:
=JEŻELI(NR.SER.OST.DN.MIES(A1;0)=A1;SUMA(PRZESUNIĘCIE(B1;-MOD(DZIEŃ(A1);7)+1;0;MOD(DZIEŃ(A1);7);1));JEŻELI(MOD(DZIEŃ(A1);7)=0;SUMA(PRZESUNIĘCIE(B1;-6;0;7;1));""))

Helpful message? + -

Back to top
   
adamas_nt
Moderator Programowanie
Moderator Programowanie


Joined: 26 Jan 2008
Posts: 4111
Location: Nowy Tomyśl

Post#8 25 Sep 2012 11:38   

Re: Excel - Numeracja i sumowanie


jochen_a wrote:
Na pewnym forum excela dostałem takie rozwiązanie
Ba, ale to trzeba najnowszej wersji Excela. U mnie "stara" 2007 Smile

Helpful message? + -

Back to top
   
Google


Google Adsense


Post# 25 Sep 2012 11:38   





Back to top
   
marek003
Poziom 23
Poziom 23


Joined: 10 Sep 2002
Posts: 3910
Location: Lublin

Post#9 25 Sep 2012 14:17   

Re: Excel - Numeracja i sumowanie


Nie wiem czy dobrze zrozumiałem ale poniżej rozwiązanie bez kolumn pomocniczych i ruszy na E97. Smile
Formuła licząca dni
Quote:
=JEŻELI(MIESIĄC(A1)<>MIESIĄC(A2);1;JEŻELI(E1=7;1;E1+1))


i sumująca czas w odwołaniu do tej liczącej dni. (pierwsza jedynka jest tylko stała)
Quote:
=JEŻELI(LUB(MOD(DZIEŃ(A2);7)=0;MIESIĄC(A2)<>MIESIĄC(A3));SUMA(ADR.POŚR(ADRES(WIERSZ()-E2+1;2)&":"&ADRES(WIERSZ();2)));"")


Na marginesie przyznam że mam 2010 ale jeszcze nie znam jego nowych funkcji (co prawda wydaje mi się że zapewne można to samo osiągnąć "starymi" funkcjami ale zawsze to jakieś ułatwienie).

Attachments:

Helpful message? + -

Back to top
   
Post new topic  Reply to topic      Main Page -> Forum Index -> Computer Service -> Computer Software -> Excel - Numeracja i sumowanie
Page 1 of 1
Similar topics
MS Excel - sumy - Specyficzne sumowanie - excel (12)
Excel/ automatyczne numeracja (2)
Excel/Word automatyczna numeracja wydruku (7)
Excel/Word/Libreoffice/cokolwiek automatyczna numeracja wydruku (6)
excel makro - numeracja komórek w wierszu arkuszu skoroszycie (5)
MS Excel sumowanie (4)
Excel: inteligentne sumowanie (2)
Excel - sumowanie odpowiednich komórek (7)
Excel sumowanie wybranych pól (1)
Excel - sumowanie, jak to zrobić? (5)


Administrator || Moderators || Forum Rules || General Rules || Cookies information || Contact

Page generation time: 0.047 seconds

elektroda.pl topic RSS feed