Forum Index

Rules  | Points  | Add...  | Recent posts  | Search | Register | Log in



Excel - Numeracja i sumowanie


  Main Page -> Forum Index -> Computer Service -> Computer Software ->Excel - Numeracja i sumowanie Post new topic  Reply to topic 
Author
Hide the left column
Show left column Message
jochen_a
Level 10
Location: Chrzanów
Joined: 23 Apr 2007
Posts: 45
jochen_a
Level 10
Post#1 25 Sep 2012 06:57  Topic author   

Excel - Numeracja i sumowanie


Mam problem z "automatyzacją" tego arkusza. Wszystkie wartości wprowadzone ręcznie. Może jest jakaś formuła ułatwiająca wpisanie całego roku :)

W pierwszej kolumnie jest data, w drugiej wpisujemy czas. Teraz chodzi o to by sumowało czas co 7 dzień, ale z początkiem miesiąca numeracja zaczyna się od początku.

Attachments:

Helpful post? + 0
Back to top

Google Adsense
Google


Back to top
adamas_nt
Moderator Programowanie
Location: Nowy Tomyśl
Joined: 26 Jan 2008
Posts: 4490
Helped: 1239
Post rating: 133
adamas_nt
Moderator Programowanie
Post#2 25 Sep 2012 07:53Helpful post    

Re: Excel - Numeracja i sumowanie


Spróbuj:
Quote:
=JEŻELI(MOD(DZIEŃ(A7);7)=0;SUMA(ADR.POŚR("B"&WIERSZ()&":B"&WIERSZ()-6));"")
Oczywiście formułę kopiujesz od wiersza 7 w dół.

Helpful post? + 0
Back to top

Google Adsense
Google


Back to top
jochen_a
Level 10
Location: Chrzanów
Joined: 23 Apr 2007
Posts: 45
jochen_a
Level 10
Post#3 25 Sep 2012 08:00  Topic author   

Re: Excel - Numeracja i sumowanie


Wszystko ekstra ładnie :)

Ale chciałbym jeszcze by w ostatni dzień miesiąca też była suma czasu tych ostatnich trzech dni.

Helpful post? + 0
Back to top
adamas_nt
Moderator Programowanie
Location: Nowy Tomyśl
Joined: 26 Jan 2008
Posts: 4490
Helped: 1239
Post rating: 133
adamas_nt
Moderator Programowanie
Post#4 25 Sep 2012 08:08Helpful post    

Re: Excel - Numeracja i sumowanie


A, to musisz sobie dopisać drugi warunek wg schematu:
JEŻELI(MIESIĄC(komórka)<>MIESIĄC(komórka niżej);SUMA(ADR.POŚR(na trzy w górę);to co już mamy)

Edit: Hmm, zerknąłem jeszcze raz i tak sobie myślę: trzy dni to akurat w tym, konkretnym miesiącu, a Ty chciałbyś pewnie, żeby liczyło od ostatniej sumy do końca miesiąca?

Helpful post? + 0
Back to top

Google Adsense
Google


Back to top
jochen_a
Level 10
Location: Chrzanów
Joined: 23 Apr 2007
Posts: 45
jochen_a
Level 10
Post#5 25 Sep 2012 08:32  Topic author   

Re: Excel - Numeracja i sumowanie


Sęk w tym, że te trzy dni są ruchome. Może zostać 3, 4 a nawet 6.

Helpful post? + 0
Back to top

Google Adsense
Google


Back to top
adamas_nt
Moderator Programowanie
Location: Nowy Tomyśl
Joined: 26 Jan 2008
Posts: 4490
Helped: 1239
Post rating: 133
adamas_nt
Moderator Programowanie
Post#6 25 Sep 2012 09:03    

Re: Excel - Numeracja i sumowanie


Z dwoma kolumnami pomocniczymi wychodzi jak w załączniku. Sprawdź, może da się to jeszcze uprościć...

Attachments:

Helpful post? + 0
Back to top
jochen_a
Level 10
Location: Chrzanów
Joined: 23 Apr 2007
Posts: 45
jochen_a
Level 10
Post#7 25 Sep 2012 09:23  Topic author   

Re: Excel - Numeracja i sumowanie


Formuły w kolumnie F odwołują się do kolumny D, której ma nie być bo te wartości mają być w E.

Na pewnym forum excela dostałem takie rozwiązanie:
Quote:
=JEŻELI(NR.SER.OST.DN.MIES(A1;0)=A1;SUMA(PRZESUNIĘCIE(B1;-MOD(DZIEŃ(A1);7)+1;0;MOD(DZIEŃ(A1);7);1));JEŻELI(MOD(DZIEŃ(A1);7)=0;SUMA(PRZESUNIĘCIE(B1;-6;0;7;1));""))


Helpful post? + 0
Back to top

Google Adsense
Google


Back to top
adamas_nt
Moderator Programowanie
Location: Nowy Tomyśl
Joined: 26 Jan 2008
Posts: 4490
Helped: 1239
Post rating: 133
adamas_nt
Moderator Programowanie
Post#8 25 Sep 2012 11:38    

Re: Excel - Numeracja i sumowanie


jochen_a wrote:
Na pewnym forum excela dostałem takie rozwiązanie
Ba, ale to trzeba najnowszej wersji Excela. U mnie "stara" 2007 :)

Helpful post? + 0
Back to top

Google Adsense
Google


Back to top
marek003
Level 39
Location: Lublin
Joined: 10 Sep 2002
Posts: 4238
Helped: 739
Post rating: 138
marek003
Level 39
Post#9 25 Sep 2012 14:17    

Re: Excel - Numeracja i sumowanie


Nie wiem czy dobrze zrozumiałem ale poniżej rozwiązanie bez kolumn pomocniczych i ruszy na E97. :)
Formuła licząca dni
Quote:
=JEŻELI(MIESIĄC(A1)<>MIESIĄC(A2);1;JEŻELI(E1=7;1;E1+1))


i sumująca czas w odwołaniu do tej liczącej dni. (pierwsza jedynka jest tylko stała)
Quote:
=JEŻELI(LUB(MOD(DZIEŃ(A2);7)=0;MIESIĄC(A2)<>MIESIĄC(A3));SUMA(ADR.POŚR(ADRES(WIERSZ()-E2+1;2)&":"&ADRES(WIERSZ();2)));"")


Na marginesie przyznam że mam 2010 ale jeszcze nie znam jego nowych funkcji (co prawda wydaje mi się że zapewne można to samo osiągnąć "starymi" funkcjami ale zawsze to jakieś ułatwienie).

Attachments:

Helpful post? + 0
Back to top
Post new topic  Reply to topic     Main Page -> Forum Index -> Computer Service -> Computer Software -> Excel - Numeracja i sumowanie
Page 1 of 1

Similar topics to excel - Numeracja i sumowanie

MS Excel - sumy - Specyficzne sumowanie - excel (12)
Excel/ automatyczne numeracja (2)
Excel/Word automatyczna numeracja wydruku (7)
Excel/Word/Libreoffice/cokolwiek automatyczna numeracja wydruku (6)
excel makro - numeracja komórek w wierszu arkuszu skoroszycie (5)
MS Excel sumowanie (4)
Excel: inteligentne sumowanie (2)
Excel - sumowanie odpowiednich komórek (7)
Excel sumowanie wybranych pól (1)
Excel - sumowanie, jak to zrobić? (5)


Switch to mobile version Switch to version for desktops

Administrator || Moderators || Forum Rules || General Rules || Cookies information || Editors || Contact for companies || Contact

Page generation time: 0.139 seconds