Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Excel - Numeracja i sumowanie

jochen_a 25 Wrz 2012 06:57 1332 8
  • #1 25 Wrz 2012 06:57
    jochen_a
    Poziom 10  

    Mam problem z "automatyzacją" tego arkusza. Wszystkie wartości wprowadzone ręcznie. Może jest jakaś formuła ułatwiająca wpisanie całego roku :)

    W pierwszej kolumnie jest data, w drugiej wpisujemy czas. Teraz chodzi o to by sumowało czas co 7 dzień, ale z początkiem miesiąca numeracja zaczyna się od początku.

  • Pomocny post
    #2 25 Wrz 2012 07:53
    adamas_nt
    Moderator Programowanie

    Spróbuj:

    Cytat:
    =JEŻELI(MOD(DZIEŃ(A7);7)=0;SUMA(ADR.POŚR("B"&WIERSZ()&":B"&WIERSZ()-6));"")
    Oczywiście formułę kopiujesz od wiersza 7 w dół.

  • #3 25 Wrz 2012 08:00
    jochen_a
    Poziom 10  

    Wszystko ekstra ładnie :)

    Ale chciałbym jeszcze by w ostatni dzień miesiąca też była suma czasu tych ostatnich trzech dni.

  • Pomocny post
    #4 25 Wrz 2012 08:08
    adamas_nt
    Moderator Programowanie

    A, to musisz sobie dopisać drugi warunek wg schematu:
    JEŻELI(MIESIĄC(komórka)<>MIESIĄC(komórka niżej);SUMA(ADR.POŚR(na trzy w górę);to co już mamy)

    Edit: Hmm, zerknąłem jeszcze raz i tak sobie myślę: trzy dni to akurat w tym, konkretnym miesiącu, a Ty chciałbyś pewnie, żeby liczyło od ostatniej sumy do końca miesiąca?

  • #5 25 Wrz 2012 08:32
    jochen_a
    Poziom 10  

    Sęk w tym, że te trzy dni są ruchome. Może zostać 3, 4 a nawet 6.

  • #7 25 Wrz 2012 09:23
    jochen_a
    Poziom 10  

    Formuły w kolumnie F odwołują się do kolumny D, której ma nie być bo te wartości mają być w E.

    Na pewnym forum excela dostałem takie rozwiązanie:

    Cytat:
    =JEŻELI(NR.SER.OST.DN.MIES(A1;0)=A1;SUMA(PRZESUNIĘCIE(B1;-MOD(DZIEŃ(A1);7)+1;0;MOD(DZIEŃ(A1);7);1));JEŻELI(MOD(DZIEŃ(A1);7)=0;SUMA(PRZESUNIĘCIE(B1;-6;0;7;1));""))

  • #8 25 Wrz 2012 11:38
    adamas_nt
    Moderator Programowanie

    jochen_a napisał:
    Na pewnym forum excela dostałem takie rozwiązanie
    Ba, ale to trzeba najnowszej wersji Excela. U mnie "stara" 2007 :)

  • #9 25 Wrz 2012 14:17
    marek003
    Poziom 40  

    Nie wiem czy dobrze zrozumiałem ale poniżej rozwiązanie bez kolumn pomocniczych i ruszy na E97. :)
    Formuła licząca dni

    Cytat:
    =JEŻELI(MIESIĄC(A1)<>MIESIĄC(A2);1;JEŻELI(E1=7;1;E1+1))


    i sumująca czas w odwołaniu do tej liczącej dni. (pierwsza jedynka jest tylko stała)
    Cytat:
    =JEŻELI(LUB(MOD(DZIEŃ(A2);7)=0;MIESIĄC(A2)<>MIESIĄC(A3));SUMA(ADR.POŚR(ADRES(WIERSZ()-E2+1;2)&":"&ADRES(WIERSZ();2)));"")


    Na marginesie przyznam że mam 2010 ale jeszcze nie znam jego nowych funkcji (co prawda wydaje mi się że zapewne można to samo osiągnąć "starymi" funkcjami ale zawsze to jakieś ułatwienie).