Elektroda.pl
Elektroda.pl
X

Wyszukiwarki naszych partnerów

Kategoria: Kamery IP / Alarmy / Automatyka Bram
Montersi
Kategoria: Akumulatorki / Baterie / Ładowarki
  • #1 05 Sty 2017 14:18
    pepsi2092
    Poziom 8  

    Witam,

    Mam problem z napisaniem programu sterującego serwonapędem tak aby zadawać z jego poziomu prędkość i pozycję. Na samym początku dodam że sterowanie ze STARTERA śmiga bez żadnego problemu. Do komunikacji sterownika z S120 wykorzystuję następujące ramki: Dla Control Unit SIEMENS TELEGRAM 390 PZD -2/2 zaś dla servonapędu SIEMENS telegram 11 PZD- 12/12. Jak widać na screenach napisany przeze mnie program przypisuje wartości poszczególnym słowom co jest widoczne w STARTERZE. Sam przekształtnik włącza się, jednak silnik stoi w miejscu. Czy ktoś jest w stanie pomóc/doradzić czy jakiś dodatkowy bit jeszcze jest wymagany ? Z góry dzięki za odpowiedź.

    Sterowanie SINAMICS S120 ze sterownika PLC Siemens S7 300 Sterowanie SINAMICS S120 ze sterownika PLC Siemens S7 300 Sterowanie SINAMICS S120 ze sterownika PLC Siemens S7 300 Sterowanie SINAMICS S120 ze sterownika PLC Siemens S7 300 Sterowanie SINAMICS S120 ze sterownika PLC Siemens S7 300 Sterowanie SINAMICS S120 ze sterownika PLC Siemens S7 300

  • #2 05 Sty 2017 20:56
    czaruta
    Poziom 12  

    Od strony S120 również poprawnie skonfigurowałeś? Potrafisz ruszyć serwem w trybie ręcznym? Na podstawie tych Screenow to ciężko coś pomoc.. Dobrze by było wiedzieć, co aktualnie czyta sterownik i czy w ogóle widzi S120 w sieci.

  • #3 06 Sty 2017 17:42
    cyp3k
    Poziom 12  

    O ile mnie pamiec nie myli to w tym protokole wymagany byl jeszcze jeden bit potwierdzajacy zasilanie falownika.

  • #4 11 Sty 2017 09:06
    pepsi2092
    Poziom 8  

    Tak w trybie ręcznym wszystko działa, dodatkowo w zakładce homing zrobiłem kalibrację pozycji początkowej i działa także dojazd przy zadawaniu pozycji absolutnej. Sterownik na pewno widzi S120 w sieci, ponieważ gdy napisałem program sterujący przy zadawaniu tylko prędkości czyli bez enkodera to normalnie wszystko działało i nie było problemu z komunikacją sterownika PLC i S120. Jakie informacje mogę jeszcze tutaj zamieścić aby ktoś był w stanie pomóc ?

    Dodano po 1 [godziny] 22 [minuty]:

    cyp3k napisał:
    O ile mnie pamiec nie myli to w tym protokole wymagany byl jeszcze jeden bit potwierdzajacy zasilanie falownika.


    Tak zgadza się, za zasilanie falownika odpowiada bit bodajże infeed operation, ale podczas konfiguracji ustawiłem go aby cały czas był na 1.

  Szukaj w 4mln produktów
Przeglądaj produkty