Elektroda.pl
Elektroda.pl
X

Wyszukiwarki naszych partnerów

Wyszukaj w ofercie 200 tys. produktów TME
Proszę, dodaj wyjątek elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Jak korzystać z internetu przy użyciu Raspberry Pi.

keseszel 02 Maj 2017 00:39 636 14
  • #1 02 Maj 2017 00:39
    keseszel
    Poziom 26  

    Witam.
    Jakiś czas temu dostałem wersję A. Chciałbym korzystać z niej podłączając do netu i telewizora. Generalnie Youtube.
    Podłączyłem ją kablem sieciowym do routera, który jest podłączony do stałego łącza.
    Na Raspberry jest Kodi. I tu głupia sprawa- nie ma netu. Co trzeba wpisywać, z jakiej przeglądarki skorzystać. Jest tam trochę opcji, przeglądałem i po 2 godzinach poddałem się. W necie też jest sporo informacji, ale nie mogłem dopasować do mojej sytuacji.
    Wifi na razie nie wchodzi w rachubę, do Raspberry podłączona jest myszka bezprzewodowa. Do tej pory puszczałem tylko niewymagające filmy z pendriva.

  • #2 02 Maj 2017 10:06
    dedito
    Poziom 39  

    Kodi to tylko program.
    Sprawdź czy system operacyjny Raspberry otrzymuje adres IP i ma dostęp do Internetu.

  • #3 02 Maj 2017 19:26
    keseszel
    Poziom 26  

    Uruchamia mi się od razu Kodi. Jak sprawdzić czy jest adres IP? W końcu jest podłączony do routera to łaski nie robi.

  • #4 02 Maj 2017 21:33
    dedito
    Poziom 39  

    Rapberry to komputer samo podłączenie do routera nie wystarcza.
    Skonfiguruj połączenie z siecią zgodnie z wymaganiami systemu na jakim pracuje.
    Co do robienia łaski: to jest maszyna nie człowiek, jak ją zaprogramujesz tak będzie działać.
    Skoro masz kolego w specjalizacji "elektronika i komputery" to powinieneś wiedzieć o takich podstawach.

  • #5 03 Maj 2017 17:21
    keseszel
    Poziom 26  

    Mam Kodi. Nie żadnego Raspbiana. Wiem co to Raspberry. Podłączając laptopa do routera po kablu nic nie muszę konfigurować.
    Jak korzystać z internetu przy użyciu Raspberry Pi.
    Tak mi się zgłasza Raspberry.
    Obstawiam, ze nie ma możliwości wejścia do netu. W ustawieniach Kodi mam opcje internet. Mogę wybrać proxy lub bez. Domyślnie nie ma proxy.

  • #6 03 Maj 2017 18:40
    dedito
    Poziom 39  

    keseszel napisał:
    Mam Kodi. Nie żadnego Raspbiana.

    Ok, niech Ci będzie, że Kodi.
    A gdzie ja pisałem, że masz Raspbiana?
    keseszel napisał:
    Wiem co to Raspberry.
    To zaloguj się na konsolę i pokaż wynik
    Code:
    cat /etc/os-release

  • #7 03 Maj 2017 19:53
    miszczo997
    Poziom 27  

    keseszel napisał:
    Mam Kodi
    Nie masz kodi, masz raspbmc/openelec. Przeinstaluj, przetestuj oba systemy, bo internet powinien działać od razu po podłączeniu wtyczki do gniazda ethernet.
    dedito napisał:
    To zaloguj się na konsolę i pokaż wynik
    W tych systemach nie ma terminala. Można się dostać do niego jedynie przez ssh, a domyślam się, że będzie miał z tym nie lada problem.

  • #8 03 Maj 2017 20:31
    dedito
    Poziom 39  

    miszczo997 napisał:
    W tych systemach nie ma terminala. Można się dostać do niego jedynie przez ssh, a domyślam się, że będzie miał z tym nie lada problem.

    A SSH to niby do czego daje dostęp? Nie jest to czasem konsola?
    A to, że nie ma terminala to też bzdura.
    Ech ... starczy mojej bytności w tym wątku.

  • #9 03 Maj 2017 22:09
    keseszel
    Poziom 26  

    Panowie, bez spinki. Jestem zielony, miało działać od strzału. Jedyne co na tym cudzie używałem to pena z multimediami. Mam czas, próbuję odpalić. Mogę sam- zajmie mi x czasu straconego bez sensu. Moge się zapytać- będzie szybciej.

    Logika - jest raspberry, to jest i rasbian. Błędna. Tu system chwali się, że jest Kodi. Ok, taką informację przyjąłem, twierdzy bronić nie będę.

    Nieważne co jest- ważne by ruszyło. To jest ustrojstwo do oglądania multimediów w necie, przeglądarka do www inwalida i tyle.

    Terminal jest w programach obstawiam. Tam poszukam.
    Aha, dostałem to z Kodi na pokładzie.

  • #10 03 Maj 2017 22:24
    PiotrPitucha
    Poziom 32  

    Witam
    Obstawiam że masz uszkodzony kabel, Kodi na kablu zgłasza się automatycznie, chyba że pokopałeś ustawienia.
    Chcesz sprawdzić czy nadało Ci IP to SYSTEM -> O systemie i masz tam informacje.
    Co do ustawień to chyba nie szukałeś..... są jawne i proste:
    SYSTEM -> OpenELEC -> Sieć i sprawdzasz czy masz ustawione aktywne sieci przewodowe.
    Potem idziesz dalej:
    SYSTEM -> OpenELEC -> Połączenia i wyświetla ci wszystkie połączenia na malince.
    Miszczo997 a zastanowiłeś się jak się dostać po SSH jak nie ma sieci?, może lepiej pomyśleć nim się napisze.
    Pozdrawiam,

  • #11 03 Maj 2017 22:29
    miszczo997
    Poziom 27  

    PiotrPitucha napisał:

    Miszczo997 a zastanowiłeś się jak się dostać po SSH jak nie ma sieci?, może lepiej pomyśleć nim się napisze.
    Pozdrawiam,

    Rozumiem, że późna pora, ale polecam najpierw przeczytać ze zrozumieniem to co napisałem, a dopiero potem zarzucać brak myślenia.

  • #12 03 Maj 2017 22:49
    keseszel
    Poziom 26  

    <ciach> Kabel używałem przy necie po Linuxie i Windzie. Działało od strzału.

    Moderowany przez dondu:

    Zbędne wyciąłem.

  • #13 03 Maj 2017 23:38
    PiotrPitucha
    Poziom 32  

    Witam
    A zaglądnąłeś w ustawienia tak jak pisałem?
    Napisałem jak sprawdzić czy Ci przydzieliło IP.
    Jak masz nowszy system to zamiast OpenELEC może być LibreELEC, natomiast postępowanie jest identyczne, leży mi malinka na stole i sprawdziłem, zajęło to ze startem systemu minutę albo i mniej.
    Pozdrawiam

  • #14 18 Maj 2017 19:26
    keseszel
    Poziom 26  

    Witam. Na razie nie mam czasu robić cokolwiek z Raspberry, zbyt ładna pogoda i nowych rzeczy do ogarnięcia by zamknąć się przed TV. Podane metody sprawdzę w wolnym czasie i dam znać co wyszło. Generalnie chciałbym RP wykorzystywać nie tylko do TV. Za dużo możliwości by uwięzić go przed pudłem ;-) Myślę nawet, ze zrobię taki system na karcie i będę tylko żonglował kartami. ;-)

  • #15 19 Maj 2017 11:24
    Vytautas_YT
    Poziom 23  

    keseszel napisał:
    Myślę nawet, ze zrobię taki system na karcie i będę tylko żonglował kartami.


    No bo tak to się właśnie robi. Chyba że chcesz mieć 10 RPi.

    Sprawdź sobie ustawienia sieciowe bo piszesz że dostałeś to RPi w takim konfigu. Ja obstawiam że ktoś sobie po prostu ustawił adresację sieciową na sztywno i z Twoją adresacją to po prostu nie działa.

Szybka odpowiedź lub zadaj pytanie
Dziękuję Ci. Ta wiadomość oczekuje na moderatora.
 Szukaj w ofercie
Wyszukaj w ofercie 200 tys. produktów TME