Elektroda.pl
Elektroda.pl
X

Wyszukiwarki naszych partnerów

Wyszukaj w ofercie 200 tys. produktów TME
Kategoria: Kamery IP / Alarmy / Automatyka Bram
Montersi
Proszę, dodaj wyjątek elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Pomiar napięcia w układzie z źródłem prądowym

rvsh 16 Lip 2017 18:46 1083 15
  • #1 16 Lip 2017 18:46
    rvsh
    Poziom 9  

    Witam,

    Mam zasilacz stabilizowany, w którym można regulować napięcie i prąd. Producent napisał, że w przypadku regulacji prądu zasilacz zamienia się w źródło prądowe.
    Regulacja: 0-1A i 0-50V.

    Chciałbym wyświetlać napięcie i prąd poprzez mikrokontroler (przetwornik A/D)- stąd poniższy układ do pomiaru napięcia i prądu. Zasymulowałem układ (poniżej link do symulacji):

    http://tinyurl.com/yapv5qzc

    O ile pomiar prądu na ACS712 nie jest problemem o tyle pomiar napięcia przez dzielnik wygląda na symulacji dziwnie w przypadku, gdy zasilacz byłby źródłem prądowym. Wygląda na to, że na rezystorze 1k napięcie wyniesie 1000V.

    Prosiłbym o poradę i ewentualne wyjaśnienie przez kogoś bardziej doświadczonego i o pomoc w stworzeniu schematu, który pozwoliłby zmierzyć napięcie w tym zasilaczu i dostarczenie sygnału analogowego w formie 0-5V oczywiście odseparowanego galwanicznie.

    Pomiar napięcia w układzie z źródłem prądowym



    Z góry dziękuję za pomoc.
    Krzysztof

  • Pomocny post
    #2 16 Lip 2017 20:04
    satanistik
    Poziom 27  

    Napięcie na rezystorze nie będzie większe niż zasilające zasilacz. Symulacja przyjmuje idealne źródło prądowe, które stara się wymusić zadany prąd "za wszelką cenę". Napięcie mierzymy oczywiście jak w zwykłym układzie, po prostu gdy prąd przekroczy zadaną wartość, napięcie będzie spadać aby go ograniczyć.
    Co do separacji galwanicznej - sam transoptor nie zapewni liniowego pomiaru, są transoptory które mają dodatkowy opto-tranzustor do linearyzacji, ale można też użyć specjalnego układu scalonego lub przetwornika U/f.

    Najprościej jednak nie stosować separacji, dać dzielnik obliczony tak aby przy najwyższym napięciu wyjściowym, nie przekroczyć maksymalnego napięcia ADC procesora. Jeżeli jest problem z kilkoma kanałami o różnych masach można dać dwa procesory i połączyć je np przez uart izolowany transoptorami.

  • #3 16 Lip 2017 22:31
    rvsh
    Poziom 9  

    Dzięki. Rozjaśniłeś mi trochę temat, dzięki temu wiedziałem czego szukać i znalazłem to:

    Link

    Czyli zasada działania źródła prądowego kontra zabezpieczenie nadprądowe.

    Co do separacji to chciałbym jednak ją mieć, gdyż może się zdarzyć podłączenie do zasilania jakiegoś "siejącego zakłócenia" elementu dodatkowo generującego prąd jak np. silnik dc i wtedy (wiem z doświadczenia) mikrokontroler zazwyczaj pada.

    Czy masz jakiś przykład specjalnego układu do takiej separacji?
    Na razie pozostaje przy zastosowaniu optoizolatora liniowego np. HCNR201 + wzm. operacyjne, ale szukam czegoś z mniejszą liczbą elementów niezbędnych do lutowania.

  • #4 16 Lip 2017 22:50
    satanistik
    Poziom 27  

    Ja bym dał układ z diodą Zenera - za dzielnikiem dioda Zenera do masy i opornik np 10Ω do procka. Układ izolacji będzie droższy od atmegi.

  • #5 18 Lip 2017 21:40
    rvsh
    Poziom 9  

    Zmodyfikowałem trochę schemat pod optoizolator liniowy.

    Na wejściu V+ V- będzie max +120VDC, potem dzielnik napięcia do +5V (R1,R2). Rezystor ograniczający prąd diody R4 100 Ohm. Pozostałe dobrałem (chyba) zgodnie z datasheetem il300 vishay.

    Po jednej stronie byłby jeden LM358D, a po drugiej drugi ze względu na separację napięcia zasilającego(+5V2 i +5V) i masy. Dwa oddzielne zasilacze.
    Nie jestem do końca przekonany o zasadności potrzeby rezystora R_vsen.

    Proszę o opinie.

    Z góry dziękuję.

    Pomiar napięcia w układzie z źródłem prądowym

  • #6 19 Lip 2017 20:14
    satanistik
    Poziom 27  

    Potencjał V- na wyjściu powinien być połączony z gnd2. Ten opornik faktycznie jest zbędny, można dać jakiś filtr RC żeby zmniejszyć zakłócenia.

  • #7 05 Sie 2017 19:09
    rvsh
    Poziom 9  

    Z IL300 na razie dałem sobie spokój.

    Natomiast zrobiłem schemat z HCNR201, ale mam problem. Wszystko niby działa, a po podaniu napięcia powyżej 50V na wejście czyli po podzieleniu przez dzielnik napięcia: 1,9V dalej napięcie na wyjściu pierwszego wzmacniacza nie zmienia się. Dlaczego tak się dzieje? Co zrobić, aby mieć pełny zakres 5V?

    Pomiar napięcia w układzie z źródłem prądowym

  • Pomocny post
    #8 05 Sie 2017 20:06
    jarek_lnx
    Poziom 43  

    Cytat:
    Wszystko niby działa, a po podaniu napięcia powyżej 50V na wejście czyli po podzieleniu przez dzielnik napięcia: 1,9V dalej napięcie na wyjściu pierwszego wzmacniacza nie zmienia się.
    Zapewne wzmacniacz sie nasycił, w takim układzie prąd diody LED nie przekroczy 4mA, prąd fotodiody 0,5% z tego to 20µA co da (około) 2V na wyjściu.

  • #9 05 Sie 2017 20:38
    rvsh
    Poziom 9  

    Rozumiem, że się nasycił, jakaś wskazówka co zmienić, żeby działało do 5V? Zakres prądu diody LED musi się zwiększyć dwukrotnie. Zmniejszyć wartości R1 i R2 o połowe?

    Dodano po 22 [minuty]:

    Eksperymentalnie sprawdziłem po zmianie R1 i R2 ( po zwiększeniu wartości rezystorów do 220k każdy bo akurat takie rezystory miałem) napięcie wzrosło do 4,1V. Już wiem o co chodzi :) Dzięki!!!

  • #10 06 Sie 2017 21:02
    rvsh
    Poziom 9  

    Ok. Czyli zastosowałem R1 i R2 o wartościach 220k.
    Dzielnik napięcia dzieli napięcie 100V do 2,28V bo postanowiłem użyć ADC z napięciem referencyjnym 2,56V.

    Natomiast to co mnie zastanawia to dosyć spore różnice napięć. Poniżej pomierzone napięcia na wejściu czyli za dzielnikiem napięcia i na wyjściu całego układu (za drugim wzmacniaczem):
    Wej- 2,28 Wyj - 2,25
    Wej- 1,97 Wyj - 1,94
    Wej- 1,31 Wyj - 1,29
    Wej- 0,88 Wyj - 0,87
    Wej- 0,55 Wyj - 0,54
    Wej- 0,16 Wyj - 0,16

    Czy jest możliwość zmniejszenia tych różnic bo różnica (2,28-2,25) 0,03V to jakieś 1,3%, a to bardzo dużo jak dla tej aplikacji (pomiar 100V da 1,3V błędu).
    Co zrobić aby poprawić ten wynik? Dokładniej dobrać wartości rezystorów czy co?

  • #11 06 Sie 2017 21:40
    jarek_lnx
    Poziom 43  

    rvsh napisał:
    Co zrobić aby poprawić ten wynik? Dokładniej dobrać wartości rezystorów czy co?
    Skorygować R1 lub R2, nie wiem jak dokładne rezystory dałeś ale już sam HCNR201 może wprowadzić do 5% błędu, jest to błąd stały który można skorygować. Są też składniki błędu zależne od temperatury i napięcia których łatwo nie skorygujesz ale ich wpływ jest znacznie mniejszy.

  • #12 07 Sie 2017 23:18
    rvsh
    Poziom 9  

    Dobra powoli zamykam temat.
    Poniżej załączam działający na 100% schemat wraz z płytką pcb.

    Ogólnie pomierzyłem napięcie po dzielniku i po całym układzie i wyszły róznice ok. -1,2% czyli dodam do wyniku końcowego składową stałą czyli -1,1% i błąd wtedy zamyka się w ok. 0,1% co dla 100V daje jakieś maks. ~0,1V błędu - co mnie w zupełności satysfakcjonuje.

    Pomiar napięcia w układzie z źródłem prądowym

    Pomiar napięcia w układzie z źródłem prądowym

    Jeżeli są jeszcze jakieś sugestie jak zwiększyć precyzję to proszę pisać, jak nie to zamykam temat.

    Dziękuję wszystkim za pomoc!
    Krzysztof

  • #13 08 Sie 2017 22:06
    jarek_lnx
    Poziom 43  

    rvsh napisał:
    Ogólnie pomierzyłem napięcie po dzielniku i po całym układzie i wyszły róznice ok. -1,2% czyli dodam do wyniku końcowego składową stałą czyli -1,1% i błąd wtedy zamyka się w ok. 0,1% co dla 100V daje jakieś maks. ~0,1V błędu - co mnie w zupełności satysfakcjonuje.
    Kiedy piszesz o składowej stałej, to nie wiem czy dobrze cie rozumiem, chyba nie chcesz dodać stałej wartości?

  • #14 08 Sie 2017 23:38
    rvsh
    Poziom 9  

    Masz rację, nieprecyzyjnie sie wyraziłem. Chodziło mi o największą powtarzalną wartość procentową będącą wynikiem pomiarów w róźnych punktach charakterystyki napięcia wejściowego i wyjściowego. Procent czyli stosunek wartości błędu do napięcia zmierzonego na wyjściu układu, gdzie wartość błędu to róźnica pomiędzy napięciem zmierzonym na wyjściu układu i napięciem zmierzonym na wejściu za dzielnikiem napięcia. W tym przypadku 1,1%. W excelu, który załączyłem jest to chyba bardziej zrozumiałe.
    Chyba dobrze myślę? Mogę tak zrobić?

  • Pomocny post
    #15 09 Sie 2017 10:17
    Yano_X
    Poziom 22  

    Witam
    Jeśli nie będzie ograniczeń programowych z obliczeniami, to korzystniejszym rozwiązaniem będzie kalibracja dwupunktowa, zgodnie z y=ax+b.
    W twoim przypadku, w arkuszu do wyznaczenia a i b przyjąłem pomiary 4 i 11 (dobór zależny od zakresu napięć). W kolumnach H, I znajdują się wyniki po kalibracji.
    Docelowo wskazana jest kalibracja na podstawie napięć z "in" i "out".

 
Promocja -20%
Zamknij 
Wyszukaj w ofercie 200 tys. produktów TME
tme