Forum Index

Rules  | Points  | Add...  | Recent posts  | Search | Register | Log in



Podlaczenie enkodera do AVR - problem napiec


  Main Page -> Forum Index -> Microcontrollers Generally ->Podlaczenie enkodera do AVR - problem napiec Post new topic  Reply to topic 
Author
Hide the left column
Show left column Message
piapia
Level 24
Location: Gdańsk/Mława
Joined: 28 Apr 2003
Posts: 912
Helped: 56
Post rating: 1
piapia
Level 24
Post#1 11 Sep 2006 22:14  Topic author   

Podlaczenie enkodera do AVR - problem napiec


Witam.
Trafil mi sie enkoder przemyslowy inkrementalny z nieduza dokadnoscia -200krokow na obrot.
Ma sygnaly wyjciowe A, B i Z.
Sygnały wyjściowe są w standarcie jak w zalaczniku.
Zasilanie 12-24V - bede go zasilał 12V.
Low> Load current 20mA, Residual voltage Max. 0.5VDC
High>Load current -20mA, Output voltage Min. (Power Supply-1.5)VDC

Jak najproscie podlaczyc wyjscia z enkodera pod mikrokontroler AVR? (Atmega32).

pozdrawiam

Attachments:

Helpful post? + 0
Back to top

Google Adsense
Google


Back to top
Anderian
Level 18
Joined: 11 Apr 2003
Posts: 393
Helped: 9
Post rating: 1
Anderian
Level 18
Post#2 11 Sep 2006 22:40    

Re: Podlaczenie enkodera do AVR - problem napiec


chyba poprzez tranzystor bramkujacy (+rezystor) do masy albo jakis transoptor

Helpful post? + 0
Back to top

Google Adsense
Google


Back to top
bis
Level 21
Joined: 21 Nov 2005
Posts: 274
Helped: 53
Post rating: 1
bis
Level 21
Post#3 11 Sep 2006 23:07    

Re: Podlaczenie enkodera do AVR - problem napiec


Wystarczy dać szeregowy rezystor 1K na kazdej (A,B,Z) linii z enkodera.

bis

Helpful post? + 0
Back to top
Post new topic  Reply to topic     Main Page -> Forum Index -> Microcontrollers Generally -> Podlaczenie enkodera do AVR - problem napiec
Page 1 of 1

Similar topics to podlaczenie enkodera do AVR - problem napiec

podlaczenie enkodera do licznika (1)
AVR - Błędy w kodzie obsługi enkodera (6)
[AVR, C] Projekt enkodera inkrementalnego z elektroniką na dwóch uC (13)
LTC1384 - LTC1384 Poziomy napiec avr (3)
AT91SAM7XC256 problem z poziomem napiec (6)
Podlaczenie AVR Atmega 128 i SRAM (1)
Bascom AVR [wszystkie wersje] + AVR problem z? [kompilator] (10)
[AVR][bascom] rs-232 problem z transmisją do avr (2)
[AVR] Problem z Si-prog dla AVR (6)
Problem z AVR GCC i AVR Studio 3.56 (11)


Switch to mobile version Switch to version for desktops

Administrator || Moderators || Forum Rules || General Rules || Cookies information || Editors || Contact for companies || Contact

Page generation time: 0.097 seconds