X

Średnia ważona i arytmetyczna w Excelu

25 Mar 2007 11:23 MEmejlasek
  • #1 25 Mar 2007 11:23
    mejlasek
    Level 11  
    Helpful post? (0)
    witam, wczoraj po wielu kombinacjach utworzyłem formułe obliczającą średnią ważoną (sprawa dotyczy ocen z przemiotu), wynik obliczen pojawia się w jednej konkretnej komórce. Niby sprawa jest już zakończona, ale chciałbym zrobić jeszcze jedną rzecz i nie wiem jak sie za nią zabrać, a na necie nigdzie nie znalazłem dostatecznej odpowiedzi jak to zrobić. Otóż chciałbym, aby wynik takiego obliczenia zostawał kopiowany do innej komórki, w tym czasie możnaby wykonać kolejne obliczenie średniej ważonej i ten kolejny wynik także zostawałby przenoszony do komórki pod poprzednim wynikiem i tak w kółko, a potem ze skopiowanych wyników chciałbym otrzymać średnią arytmetyczną. Z tym ostatnim nie ma problemu, ale nie wiem jak zrobić żeby te wyniki sie kopiowały do innych komórek.

    Czy ktos wie jaka formuła do tego służy?

    dodam że mam Excela 2007

    pozdrawiam, mejlasek
  • #2 25 Mar 2007 11:53
    seta1
    Level 27  
    Helpful post? (0)
    Witam
    Trzeba coś pokombinować z makrami i Excel-Visual Basic. poszukaj na elektrodzie powinno coś być albo google się kłaniają

    zobacz ten pliczek pewnie o to chodziło, dopasuj w nim komórki do swoich potrzeb
  • #3 25 May 2010 20:34
    witek9875
    Level 1  
    Helpful post? (0)
    Arkusz do liczenia średnich ważonych w excelu. Działa tylko na Office 2007.

    http://www.victorcorp.site50.net/sredniewazone/

    http://www.victorcorp.ugu.pl/sredniewazone/
  • #4 25 May 2010 21:46
    marek003
    Level 39  
    Helpful post? (0)
    witek9875 wrote:
    Arkusz do liczenia średnich ważonych w excelu. Działa tylko na Office 2007.

    http://www.victorcorp.site50.net/sredniewazone/

    http://www.victorcorp.ugu.pl/sredniewazone/


    To żadna pomoc dla autora topiku

    Nie dość że gość proste funkcje ukrył w makrach to jeszcze "ohasłował" projekt, żeby a nuż się ktoś nie domyślił jak to zrobił. Żenada.

    W dodatku zamiast skorzystać z podstawowych funkcji korzystał z "nowości" więc nic dziwnego że tylko na 2007, tylko że to nie wersja excela a jego ograniczenia myślowe wyłączają użycie starszych wersji excela.
    No ale jak ktoś chce gotowca ... i będzie jedynie klikał jak baranek ... to właściwie nie ma na co narzekać.
  • #5 25 May 2010 22:01
    walek33
    Level 28  
    Helpful post? (0)
    Jeżeli chodzi o średnią ważoną to najprostszy wzór z wykorzystaniem formuł:
    Code:
    =SUMA.ILOCZYNÓW(A1:A6;B1:B6)/ILE.LICZB(A1:A6)


    Dodane:
    A tak na szybko w VBA:
    Code:
    Function srednia_wazona(waga As Range, ocena As Range)
    
        Application.Volatile
        wier = 0
        w1 = waga.Row - 1
        For Each kom In waga
            suma_tot = suma_tot + kom * ocena(kom.Row - w1)
            wier = wier + ocena(kom.Row - w1)
        Next
        srednia_wazona = suma_tot / wier
    End Function

    Można używać jako funkcji w arkuszu. I działa :D
Mouser  Search 4 million + Products
Browse Products