X

PSpice - ERROR Less than 2 connections at node xxxx

20 Apr 2007 17:42 LUlutek__1985
  • #1 20 Apr 2007 17:42
    lutek__1985
    Level 9  
    Helpful post? (+1)
    Witam.
    Mam następujący problem. Narysowałem w programie PSpice schemat układu pętli PLL, no i otrzymałem cztery komunikaty w stylu:

    ERROR PSpiceAD 05:40PM Less than 2 connections at node $N_0005

    Wiele razy je łączyłem, kasowałem druty, i kładłem od nowa, ale wciąż jest ten błąd. Czy ktoś może mi powiedzieć, z czym to się wiąże? Co jest nie tak?
  • #2 20 Apr 2007 21:50
    VirtualLabs
    Level 11  
    Helpful post? (+1)
    zalacz zbior, by bylo widac co w nim jest. Ewidentnie pluje sie jakby polaczena brakowalo gdzies. Zbior*.cir prawde Ci powie.
  • #3 21 Apr 2007 20:19
    lutek__1985
    Level 9  
    Topic author Helpful post? (+1)
    Zakładam, że chodzi o to:


    **** 04/21/107 20:17:45 ****** NT PSpice 8.0 (July 1997) ****** ID# 12345 ****

    * C:\Documents and Settings\root\Pulpit\Schematic2a.sch


    **** CIRCUIT DESCRIPTION


    ******************************************************************************




    * Schematics Version 8.0 - July 1997
    * Sat Apr 21 20:17:43 2007



    ** Analysis setup **
    .OP


    * From [SCHEMATICS NETLIST] section of msim.ini:
    .lib nom.lib

    .INC "Schematic2a.net"

    **** INCLUDING Schematic2a.net ****
    * Schematics Netlist *



    R_R2 0 $N_0001 370k
    R_R1 0 $N_0002 370k
    R_R13 0 $N_0003 1k
    C_C2 0 $N_0004 1p
    R_R3 $N_0004 $N_0005 27k
    R_Rwy2 0 $N_0013 1MEG
    R_R6 $N_0014 $N_0013 50
    C_C5 $N_0015 0 100n
    V_V2 $N_0015 0 0V
    C_C6 $N_0016 0 100n
    V_V3 0 $N_0016 0V
    X_U5A $N_0004 $N_0014 $N_0015 $N_0016 $N_0014 LF353/NS
    C_C3 $N_0017 0 100n
    C_C4 $N_0018 0 100n
    R_Rwy1 0 $N_0019 1MEG
    R_R5 $N_0020 $N_0019 50
    X_U2A $N_0006 $N_0020 $N_0017 $N_0018 $N_0020 LF353/NS

    **** RESUMING Schematic2a.cir ****
    .INC "Schematic2a.als"



    **** INCLUDING Schematic2a.als ****
    * Schematics Aliases *

    .ALIASES
    R_R2 R2(1=0 2=$N_0001 )
    R_R1 R1(1=0 2=$N_0002 )
    R_R13 R13(1=0 2=$N_0003 )
    C_C2 C2(1=0 2=$N_0004 )
    R_R3 R3(1=$N_0004 2=$N_0005 )
    _ U6(COMP_IN=$N_0006 INH=0 C1=$N_0007 C2=$N_0008 ZENER=$N_0009 SIG_IN=$N_0003
    + R1=$N_0002 R2=$N_0001 VCO_IN=$N_0004 PH_PULSE=$N_0010 COMP1_OUT=$N_0005
    + COMP2_OUT=$N_0011 VCO_OUT=$N_0006 DEMO_OUT=$N_0012 VDD=$G_CD4000_VDD
    + VSS=$G_CD4000_VSS )
    R_Rwy2 Rwy2(1=0 2=$N_0013 )
    R_R6 R6(1=$N_0014 2=$N_0013 )
    C_C5 C5(1=$N_0015 2=0 )
    V_V2 V2(+=$N_0015 -=0 )
    C_C6 C6(1=$N_0016 2=0 )
    V_V3 V3(+=0 -=$N_0016 )
    X_U5A U5A(+=$N_0004 -=$N_0014 V+=$N_0015 V-=$N_0016 OUT=$N_0014 )
    C_C3 C3(1=$N_0017 2=0 )
    C_C4 C4(1=$N_0018 2=0 )
    R_Rwy1 Rwy1(1=0 2=$N_0019 )
    R_R5 R5(1=$N_0020 2=$N_0019 )
    X_U2A U2A(+=$N_0006 -=$N_0020 V+=$N_0017 V-=$N_0018 OUT=$N_0020 )
    _ _($G_CD4000_VDD=$G_CD4000_VDD)
    _ _($G_CD4000_VSS=$G_CD4000_VSS)
    .ENDALIASES


    **** RESUMING Schematic2a.cir ****
    .probe


    .END

    ERROR -- Less than 2 connections at node $N_0001
    ERROR -- Less than 2 connections at node $N_0002
    ERROR -- Less than 2 connections at node $N_0003
    ERROR -- Less than 2 connections at node $N_0005
  • #4 21 Apr 2007 23:48
    VirtualLabs
    Level 11  
    Helpful post? (+1)
    Wylada, ze w netliscie faktycznie te nety sa jednikoncowkowe.

    Ciekawy jest ten fragment

    Quote:
    _ U6(COMP_IN=$N_0006 INH=0 C1=$N_0007 C2=$N_0008 ZENER=$N_0009 SIG_IN=$N_0003
    + R1=$N_0002 R2=$N_0001 VCO_IN=$N_0004 PH_PULSE=$N_0010 COMP1_OUT=$N_0005
    + COMP2_OUT=$N_0011 VCO_OUT=$N_0006 DEMO_OUT=$N_0012 VDD=$G_CD4000_VDD
    + VSS=$G_CD4000_VSS )


    Nie widac korespondujacego z tym fragmentu netlisty. Jakis nietypowy element uzyty? bez modelu lub bedacy jedynie symbolem graficznym?
    Bez watpienia, jesli istnieje U6, to z powodu jakichs brakow jest wyciachane z listy polacze, a zatem "wisi" wszystko, co podlaczone jest jedynie do niego.
  • #5 21 Apr 2007 23:51
    Jan001
    Level 11  
    Helpful post? (+1)
    SPICE korzysta z metody potencjałów wezłowych, w której jeden wezeł jest wyzróżniony. Jest to wezeł masy i ma przypisany numer 0. Pozostałym węzłom program PiSPICE nadaje nazwy $N_0001, $N_0002, itd.

    Z zawartości pliku CIR wynika, że rezystor R_R2 jedno wyprowadzenie ma podłączone do masy, a drugie do węzła $N_0001.

    R_R2 0 $N_0001 370k

    Ale do tego wezła, czyli do drugiego wyprowadzenia rezystora R_R2 nic nie jest podłączone (węzeł $N_0001 nie występuje więcej w * Schematics Netlist * ), a taka sytuacja jest niedozowlona w metodzie potencjałów węzłowych. Podobna sytuacja występuje w przypadku pozostałych błędów.
  • #6 22 Apr 2007 21:38
    lutek__1985
    Level 9  
    Topic author Helpful post? (+1)
    Wydaje mi się, że problem jest w tym, że PSpice ma tylko "obrazek" układu CD4046, a nie symuluje go. Ma ktoś może model do symulacji tego układu? Bo z tego, co szukałem, to nie ma nigdzie. Przynajmniej ja nie widzę... Chyba jakaś wyższa wersja PSpice dopiero go ma...Ja mam 8 i niestety nie chodzi.
Mouser  Search 4 million + Products
Browse Products