Elektroda.pl
Elektroda.pl
X
Elektroda.pl
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Abit se6e problem z aktualizacją biosu

01 Maj 2008 14:35 1828 21
  • Poziom 11  
    Witam

    Dziś kolejnym problemem, jaki wyprowadził mnie z równowagi jest Abicik se6e:
    Abit se6e problem z aktualizacją biosu

    Otóż płytka "nie chce" przyjąć biosiku. Próbowałem:
    -uniflash'em - nie wgrywa wogóle. Na pasku postępu są widoczne niezaprogamowane miejsca.
    -awdflash'em - podaje, iż podobno są zabezpieczenia "Flash ROM Write-Protect" na jumperach.
    Tylko ta płyta nie posiada jumperów służących do chronienia biosu. Przejrzałem całą płytę z każdej strony, również w manualu nic na ten temat nie ma:
    http://pdmit.ugu.pl/se6e.pdf
    przeglądając manual, możecie stwierdzić, że nie ma ustawień typu "Flash Write Protect" itp. w biosie.
    Jakie kroki podjąć?
  • Spec od komputerów
    Użyj flashera który jest na stronie Abita razem z biosem do tej płyty. Jaki Dos masz na dyskietce ? Uzyj Disk For BIOS Flashing z http://www.bootdisk.com/
  • Poziom 11  
    Użyłem boot500.exe do zrobienia dyskietki startowej w nieudanej próbie. Sprawdzę Twoją sugestię.

    Dodano po 3 [godziny] 30 [minuty]:

    No niestety, nie wyszło. Dalej nie chce biosu "wepchać".
    Ku mojej ciekawości - nawet tego zrzuconego z flash'a jako "stary.bin" nie chce też wgrać.
    Dalej ten sam komunikat o ochronie biosu przez zworki. :-/

    ------------------

    Użyłem starszych programatorów Awarda. Niestety one nie rozpoznają pamięci - "UNKNOWN Flash Type" się ukazuje przed moimi oczyma. Nowe flash'ery w wersji 8.16 rozpoznają kość, ale informują o zabezpieczeniach podanych w pierwszym poście.
    Myślę, że ewidentnie to wzkazuje na zabezpieczenia hardware na poziomie (bios/zworki) dlatego niektóre flash'ery nie programują, a inne typu Uniflash nie rozpoznają kości. Ale gdzież te zabezpieczonka mogą być na tak ubogiej płycie?
  • Spec od komputerów
    W manualu nic nie ma na ten temat. Robiłeś Clear Cmos ?
  • Poziom 11  
    Wiele, wiele razy....
    Nawet nie masz pojęcia.
    W różnej konfiguracji biosu też programować próbowałem:
    "Optimized Defaults", oraz "Fail-Safe Defaults".
    Po wyczyszczeniu CMOSu dostaje, checksum error, ale default ładuję i jest OK.
    Potem z dyskietki startuję i flash'er daje tylko zrzucic biosa na dyskietkę.
    Reszta - ten sam scenarusz. :-(

    Interesują mnie piny zaznaczone na obrazku:
    http://pdmit.ugu.pl/motherboard.PNG
    nic na ich temat nie ma w manualu, co to może być?
  • Spec od komputerów
    Z reguły to są opisane na płycie chociaż niekoniecznie przy samych pinach. Na S1 masz zworkę ? Załóż albo zdejmij i sprawdź, najwyżej się nie uruchomi. Przy wyłączonym komputerze oczywiście.
  • Poziom 11  
    Na s1 nie mam zworki założonej. Zobaczę co sie stanie jak założę, może nie wybuchnie :-D

    -------------------------
    Nie wybuchł po założeniu zworki, ale i nie przyczyniło się to do poprawy.. :-/ żadnych zmian.
  • Poziom 39  
    Cytat:
    Please do not use the Award flash memory writer version earlier than Version 7.52C to
    flash your SE6 motherboard BIOS.

    Pytanie: jaka wersja awdflash?

    ---edit---
    Doczytałem że wersja 8.x .. cóż, pogoglam trochę.
  • Poziom 11  
    To to ja wiem Panie movzx... Ten manual to przejrzałem już wiele razy, na pamięć chaptery zmam. Mam nawet do se6, w celu przeszukania rzeczy, które nie przyniósł ten manual, ale i w nim nic nie ma na temat S1 i JP4.
    Programować próbowałem wszystkimi wcześniejszymi wersjami od 5.35 poczynając. To pierwsza paskuda, która mi takie jaja zrobiła..

    ----------------------

    Zrobiłem dyskietkę startową ze wszystkimi flasherami od Awarda, mam na myśli wersje: 5,35 ; 6.60 ; 7.08 ; 7.52 ; 7.53 ; 764 ; 7.70 ; 7.72 ; 7.89 ; 8.00; 8.02 ; 8.03 ; 8.08 ; 8.10 ; 8.12 ; 8.16.
    Hardcore :twisted: ale żaden nie ma pozwolenia do mojej kości -> albo wymalowuje na ekraniku, że unknown flash type - szczególnie te starsze wersje, albo ładnie wypisują mi nazwę kości, a nie "wpychają" w przypadku tych nowszych wersji.
  • Poziom 39  
    Skoro nie ma zworki, instrukcja o niej nie wspomina i google (przynajmniej u mnie) milczą, to chyba trzeba doszukiwać się uszkodzenia w sprzęcie.
    Moje teorie: uszkodzony (nieprogramujący się) flash, brak napięcia programowania, WP błędnie podawane na kość.
    Odczytaj oznaczenie pamięci, może uda się po niej polatać z miernikiem.
    Innego pomysłu nie mam.
  • Poziom 11  
    Kosteczka to: SST 49LF004 a lata na 3,3V

    ----

    Kosteczka musi być pewnie dobra, bo zrobiłem "hot swapa", na kosteczkę SST 49LF004A (równiez na 3,3V) i też te same miejsca Uniflash nie chce programować.
  • Poziom 11  
    Instrukcja nic nie wnosi.
    Jest prosta i czytelna, ale w moim przypadku niepomocna. Wszystko wykonane wg schematu.

    ----------------------------------

    Przypominam, że nawet nie chce wepchać starego biosu.
  • Poziom 10  
    Z Twoich wypowiedzi wnioskuje, ze nie programujesz biosu pierwszy raz, ale sprawdz czy napewno wydajesz odpowiednie polecenia dla awdflash. W tej instrukcji podano za przyklad:
    Code:
    A:\>awdflash AB9_14.BIN /py /sn /cd /cp /cc /cks /R
    wszystki te polecenia maja znaczenie i wlasnie przez zle polecenie lub jego brak pamiec moze nie dawac sie zaprogramowac.

    Ponadto pamieci najlepiej jest programowac uzywajac programatora, mozna wowczas zweryfikowac zrzut, ponownie zczytac pamiec i sprawdzic czy nie jest uszkodzona. Dlatego polecam Tobie sprobowac ta pamiec na programatorze.

    Pozdrawiam
  • Poziom 39  
    Jedyne co ma w tym momencie znaczenie spośród opcji które wymieniłeś to /py i /sn. Reszta dotyczy operacji po programowaniu.
  • Poziom 11  
    Rozumiem te polecenia doskonale i używam tych które potrzebuję, bo po cóż mi np /cc, /cp lub /cd , które wykonują się po programowaniu w celu nie przestawiania zworki i wyjmowania baterii.

    -------

    A /R tym bardziej :-D
  • Poziom 10  
    Czy probowales wszytkich tak jak jest w instrukcji ?
    Ja rownierz rozumiem te polecenia i wiem, ze polecenie restart wydaje sie smieszne. :D
  • Poziom 11  
    W instrukcji... Hmm..
    Próbowałem teraz też i sprawdziła się moja teroria:
    flasher wykonuje po kolei polecenia i na nic mu, że ja napisze /cc skoro na samym flashowaniu się wykrzacza. I nie wykona się /cc lub /R w moim wypadku. Program wywala błęda i wychodzi do DOSa.

    Bo flash'er wykona następujące po flashowaniu instrukcje po udanym procesie flashowania, nigdy przed.
  • Poziom 11  
    No fajny stuff na tej stronce..
    Niestety, tak jak mówiłem - ten programik również nie chce wgrać - wywala o zabezpieczeniach. Aha, i widzi kość.
  • Spec od komputerów
    A nie masz innej płyty na której możesz zrobić hotflasha ? Albo inną kość, może ta jest uszkodzona ? Już się z tym kiedyś spotkałem, pomogła wymiana kości.
  • Poziom 11  
    Dlugo się nie pojawiałem chlopcy... No ale to za sprawą konferencji ktora była wyczerpująca. Uff.

    Więc, wracając do mojego problemu, ktory rozwiązałem na innej płycie (jakiś skromny asusik podajacy napiecie na kość 3,3V), który odpowiadal parametrami. No i się wgrało... Nic się nie czepiał komp.

    Podsumowując:
    Kości flash były sprawne - wina leży po stronie płyty, ale co takiego jej nie pasuje? To już pozostawiam do rozmyslenia... Ważne, ze biosik śmiga.

    Dziękuje za uwagę oraz pomoc wszystkim odwiedzającym ten temacik.

    Pozdrowionka