Elektroda.pl
Elektroda.pl
X

Wyszukiwarki naszych partnerów

Wyszukaj w ofercie 200 tys. produktów TME
Europejski lider sprzedaży techniki i elektroniki.
Proszę, dodaj wyjątek elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Simatic S5-100u - problem z uruchomieniem programu

patryk122 11 Maj 2008 01:02 2287 4
  • #1 11 Maj 2008 01:02
    patryk122
    Poziom 10  

    Witam!!!

    Mam mały problem z moim PLC Simatic S5-100u. Nie mogą załączyć maszyny z tym PLC. Według schematu wszystkie sygnały wejściowe dochodzą do modułów (są sygnalizowane poprzez diody na panelach wejściowych), ale nie można załaczyć maszyny. Po naciśnięciu START nic się nie dzieje.
    Czy ktoś się spotkał z takim problemem? Jeżeli tak to proszę o pomoc albo o jakieś sugestie.

    Po włożeniu karty z programem na pamięci EEPROM i naciśnieciu Copy dioda czerwona szybko miga przez jakiś czas i później załańcza sie dioda RUN ale nic sie nie dzieje.
    Innym razem jak włożę inną kartę to czerwona dioda miga powoli ale tylko przy przyciśnięciu przycisku COPY i później się nie załańcza dioda RUN jak i maszyna. Co może być przyczyną takiego stanu?

    Może ktoś ma jakieś materiały na temat tego sterownika: instrukcja obsługi itp.

  • #2 11 Maj 2008 10:26
    arwit
    Poziom 27  

    Witam!
    W twoim przypadku jeśli nie masz dostępu do programatora lub stepa 5 i konwertera to instrukcje obsługi na niewiele się zdają.
    Czy Epromy zawierały właściwe wersje oprogramowanie bo wszystko wskazuje na to iż z pamięci PLC wyleciał właściwy program. W przypadku drugiego Epromu program na pewno nie był właściwy dlatego sterownik nie przechodziła do RUN.

  • #3 11 Maj 2008 12:32
    patryk122
    Poziom 10  

    Z programami z EEPROM jest mały problem, ponieważ nie jestem ich pewien. Ale po włożeniu pamięci z programem z takiej samej maszyny, nic się nie działo.
    Czy po włożeniu tylko karty EEPROM to wystarczy do uruchomienia sterownika, czy trzeba pzrekopiować program z pamięci EEPROM do PLC?
    Jak wykasować pamięć PLC?
    Czy po włożeniu pamięci EEPROM i po załączeniu sterownika powinna migać jakaś dioda że jest program kopiowany do PLC? Bo w moim przypadku nic się nie dzieje po zmianie pamięci EEPROM.

  • #4 12 Maj 2008 12:57
    arwit
    Poziom 27  

    No właśnie jak nie jesteś pewien Epromów i nie masz programatora ani doświadczenia to ciemno to widzę.
    Aby mieć pewność, że program z Promu załaduje się dobrze powinieneś wyczyścić pamięci sterownika:
    1. Przełącznik trybu pracy na STOP
    2. Wyjść baterie podtrzymująca z zasilacza
    3. Przełącznik zasilania (O/I) na wył
    4. Przełącznik zasilania (O/I) na zal
    5. Włożyć baterię
    Teraz po ponownym wyłączeniu wkładasz EPROM załączasz i sterownik powinien sczytać Eprom do swojej pamięci.
    Jeśli zapali się zielona dioda RUN to znaczy, że program nie powoduje błędów, jednak to nie znaczy, że logicznie jest prawidłowy. Również w przypadku pustego Eproma ( co niestety dość często się zdarza- szczególnie w niemieckich maszynach) sterownik przejdzie w RUN. Jeśli zielona nie będzie chciała się zapalić znaczy to że z punktu widzenia PLC program jest błędny (np. odwołuje się do nie istniejących peryferii itp.)
    Niestety bez podglądu programu i sterownika nie wiele więcej da się zrobić
    W razie dalszych pytań pisz na PW.

  • #5 18 Maj 2008 23:21
    patryk122
    Poziom 10  

    dzieki Panowie za sugestie. obiie okazały się pomocne i problem został rozwiązany. Po pierwsze był zmieniony program do maszyny, a po drugie było trzeba dodać tylko czujnik położenia przenośnika. Czyli problemem był program.

 
Black Friday do -15%
Zamknij 
Wyszukaj w ofercie 200 tys. produktów TME
Ferguson