Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Crouzet Millenium I MAS 20 RCA - oprogramowanie

Andy74 12 Maj 2008 22:03 6153 9
  • #1 12 Maj 2008 22:03
    Andy74
    Poziom 24  

    Witam.
    W firmie (w której od niedawna pracuję) mamy dość nieskomplikowane urządzenie, które stało - z tego co wiem - przez kilka lat nieużywane.
    Dostałem zadanie uruchomienia tego urządzenia - i tu pojawił się problem. Całością zawiadywał mikrosterownik firmy Crouzet typu MAS 20 RCA. Po posprawdzaniu wszystkich obwodów i załączeniu zasilania okazało się, że w sterowniku nie ma programu. Załącza się on, na wyświetlaczu pokazuje prawidłowo stany wejść, jednak nie steruje wyjściami - stąd mój wniosek.

    Mam do niego kabelek programujący, a i ze sterownikami Millenium (II i 3) miałem już do czynienia, więc byłbym w stanie napisać ten program bez trudu, ale napotkałem na kolejny problem - nigdzie nie mogę namierzyć softu do programowania... Z tego co się zorientowałem jest to pierwsza wersja Millenium. Poszukiwania rozpocząłem od strony producenta, jednak do Millenium I nie znalazłem (discontinued). I tu moja prośba - wie ktoś może skąd można zdobyć to nieszczęsne oprogramowanie? Szukam bezskutecznie już kilka godzin...

    Chciałem wymienić ten sterownik na coś nowszego, ale na razie - z przyczyn niezależnych ode mnie - nie wchodzi to w grę...

    Pozdrawiam i liczę na pomoc, bo sprawa jest, że tak powiem, gardłowa...
    Andy

    0 9
  • Pomocny post
    #3 13 Maj 2008 04:11
    histeria
    Poziom 19  

    Sterownik Millenium obsługuje również oprogramowanie Mitsubishi Alfa.
    Inne są rozszerzenia plików wynikowych.Mitsubishi ma .vls,a Millenium .vcs.
    Oba sterowniki są robione prawdopodobnie na tej samej licencji.Pracowałem zarówno na jednym jak i drugim oprogramowaniu.
    To że na ekranie wyświetlane są stany wejść i wyjść wcale nie świadczy że sterownik nie ma programu.W programie sterującym jeśli nie zaprogramuje
    się ekranów do wyświetlania to tak będzie.Przecież ręcznie z klawiatury można sprawdzić czy w sterowniku jest program.
    Jeśli sterownik wyświetla stany wejść i wyjść to prawdopodobnie jest w trybie
    RUN.Sterownik bez programu w trybie RUN też tak będzie wyświetlał.

    1
  • #4 13 Maj 2008 08:22
    Andy74
    Poziom 24  

    W tryb RUN przestawiłem go ręcznie z klawiaturki. Normalnie załącza się w trybie STOP. Powinienem był o tym napisać. Przeglądałem też menu i wygląda na to, że programu jednak nie ma (właśnie byłem sprawdzić jeszcze raz)...
    Sterownik pokazuje stany wejść prawidłowo, ale nie steruje wyjściami w ogóle pomimo ustawienia w tryb RUN.
    Powiadasz kolego, że od Mitsubishi Alfa? Już pędzę szukać, tylko mam jeszcze pytanko czy da się tym zaprogramować sterownik bez problemu?
    Zresztą sam sprawdzę jak już znajdę :).

    @krk - mam soft do MII i M3, ale nie obsługują tego sterownika niestety.

    Bardzo dziękuję za zainteresowanie
    Pozdrawiam
    Andy

    EDIT: No rzeczywiście te strowniczki Mitsubishi nawet wyglądają identycznie. Znalazłem już soft - dla zainteresowanych - udostępniają za darmo (trzeba się tylko zarejestrować) >tutaj<
    Na razie nie testowałem, bo do instalacji program wymaga uprawnień administratora, a nasz informatyk postanowił wziąć dziś urlop (same kłody pod nogi)... Ale myślę, że będzie OK. Mam czas do końca tygodnia :)
    Jeszcze raz bardzo dziękuję!

    0
  • Pomocny post
    #5 13 Maj 2008 08:41
    histeria
    Poziom 19  

    Po przejściu w tryb STOP mamy póżniej możliwość wejść w tryb EDIT.
    Pojawi się prawdopodobnie wyjście Q1-jeśli przy nim nie ma żadnych bloków,ani przy pozostałych wyjściach to jednak brak jest programu.
    Ja nie miałem żadnych problemów posługując się oboma programami.Może
    te programy są w wersji DEMO.A może kolega korzysta z przejściówki USB>RS232 (potrzebne oprogramowanie) i przy kilku gniazdach USB trzeba
    znależć właściwe.Oprogramowanie wyższej wersji powinno pasować do sterownika niższego.

    0
  • #6 13 Maj 2008 09:48
    Andy74
    Poziom 24  

    Przepraszam - edytowałem poprzedniego posta w czasie gdy Ty odpisałeś.
    Sprawdzałem obecność programu właśnie w sposób jaki podałeś i nie ma go tam niestety. Korzystam ze zwykłego portu RS232 w laptopie (sprawny), a kabelek jest oryginalny - został po poprzednim automatyku. Programy od MII i M3 też mam w pełnych wersjach (moje prywatne), ale nie mogę się połączyć ze sterownikiem.
    Myślę że ten soft od Mitsubishi rozwiąże problem, ale muszę poczekać do jutra. Dam znać o wynikach. Co ciekawe - w całej firmie jest tylko ten jeden sterownik Crouzet na kilkadziesiąt maszyn (większość to SIMATIC plus parę Ge Fanuc) i do niego mam kabelek, ale nie mam softu. Do reszty mam soft, ale nie mam kabelków :).
    PS. Czy w tym sterowniku jest jakaś bateryjka podtrzymująca, którą powinno się wymienić?
    Pozdrawiam
    Andy

    PS2. Czy kolega w ogóle sypia? :)

    0
  • Pomocny post
    #7 13 Maj 2008 10:14
    histeria
    Poziom 19  

    A to ciekawy problem że zwykły RS nie działa.Zobaczymy na oprogramowaniu Alfa.Pobrałem wersje demo która jest 2.32.Ja mam wersję
    2.40.Przy tworzeniu nowego projektu trzeba wybrać Alfa,gdzie suma wejść i wyjść równa jest 20.Sterownik posiada podtrzymanie danych i zegara(20 dni-kondensator).Program zapisywany jest w eeprom.
    PS.Wstaję wcześnie i kładę się również wcześnie,a po obiadku drzemka żeby zawiązał się supełek.

    1
  • #8 14 Maj 2008 08:16
    Andy74
    Poziom 24  

    Witam ponownie.
    Zrobiłem już próbę i wygląda na to, że wszystko jest w porządku. Stworzyłem mały programik testowy uwzględniający na razie tylko dwa wejścia i sterujący jednym wyjściem. Sterownik programuje się bez problemu i działa bez zarzutu.
    Po raz kolejny wielkie dzięki kolego histeria - każdy Twój post w tym temacie był bardzo pomocny.
    Zabieram się za tworzenie całego programu.

    Aha. Pełna wersja programu, którą udostępnia Mitsubishi na stronie to 2.40.

    Pozdrawiam
    Andy

    0
  • #9 14 Maj 2008 08:45
    histeria
    Poziom 19  

    No to dobrze że się udało.Tylko dlaczego oryginalne,pełne oprogramowanie nie chciało działać.Już zacząłem podejrzewać sam sterownik.Prawdopodobnie ktoś przez przypadek lub celowo skasował oprogramowanie.W tych sterownikach chyba jest błąd bo program można skasować mimo założonego hasła.Ja zabezpieczam sterownik w ten sposób, że bez komputera i hasła nie można nic zrobić:Others>Menu Key>Not Use.W ten sposób klawisze OK+ESC
    są nieaktywne.

    0
  • #10 14 Maj 2008 09:26
    Andy74
    Poziom 24  

    Cytat:
    Tylko dlaczego oryginalne,pełne oprogramowanie nie chciało działać.

    Też mnie to mocno zastanawia. Ponieważ nie miałem wcześniej do czynienia z Millenium w pierwszej wersji - pomyślałem, że po prostu ten nowszy soft ich nie obsługuje. Wersje MII i M3 programowałem softem który mam nie raz i nie miałem żadnych problemów... Został on zakupiony swego czasu razem ze sterownikami w promocji, więc powinien być w porządku. Ja osobiście odkupiłem go od firmy w której poprzednio pracowałem, a która upadła - za dość symboliczną opłatę.

    Program do sterowniczka jest już prawie gotowy - dam znać jak zaprogramuję i uruchomię maszynę :).
    Andy

    EDIT 11:50: Maszyna już uruchomiona. Wszystko zadziałało praktycznie "od kopa" z jedną tylko małą poprawką programu na miejscu.
    Oryginalny program został najprawdopodobniej skasowany przez mojego poprzednika, bo dziś dowiedziałem się, że on też dostał zadanie uruchomienia tego urządzenia, ale nie zdążył (przez dwa tygodnie...).

    Jeszcze raz wielkie podziękowania za pomoc kolego histeria - jeśli będę się mógł jakoś, kiedyś odwdzięczyć - daj znać.

    Myślę że temat został wyczerpany, więc go zamykam.
    Pozdrawiam
    Andy

    0