Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Timer na NE555 nie wyłącza się

menda 21 Maj 2008 11:33 1524 6
  • #1 21 Maj 2008 11:33
    menda
    Poziom 17  

    Zbudowałem timer na NE555 wyzwalany dotykiem, na czas 5 minut. Układ steruje przekaźnikiem który załącza pozostałe urządzenia (przekaźniki na 220V). Problem jest w tym że po załączeniu nie zawsze się wyłącza. Czyjnik dotykowy to dwa kawałki blaszki przez które przelatuje żeton i załącza układ, czy np. problemem może być to że czujnik jest w odleglości około 3 m od timera poprowadzony przewodami 2x1,5 mm, oraz wyłacznk nie jest odseparowany galwanicznie. Płytka timera jest kupiona gotowa. Układ zasilany jest 12V z przetwornicy, pozostałe przekaźniki mają oddzielne zasilanie.

    menda

    0 6
  • #2 21 Maj 2008 13:35
    adams987
    Poziom 35  

    Może sprężyna w przekaźniku jest słaba a przekaźnik na mniej niż 12V i chociaż stan na wyjściu ne555 jest niski to nie znaczy że 0V ale około 2V i może dlatego przekaźnik nie puszcza. Spróbuj dać szeregowo z przekaźnikiem chociaż jedną diodę (spadek 0,6V) lub dwie (spadek na nich 1,2V).
    Czyli z wyjścia nr 3 ne555 dioda(lub dwie) i dopiero przekaźnik. (również dioda równolegle na przekaźniku odwrotnie spolaryzowana, zapobiega uszkodzeniu ne555)

    0
  • #3 21 Maj 2008 13:58
    menda
    Poziom 17  

    Dioda równolegle do cewki przekaźnika jest włączona, przekaźnik jest na 12V, spróbuję z tymi diodami w szereg z cewką, a czy to że czujnik dotykowy nie ma separacji galwanicznej może mieć na to wpływ? Zasilanie układu to dokładnie 12,6 V. A

    0
  • #4 21 Maj 2008 14:16
    adams987
    Poziom 35  

    Możesz zmniejszyć wartość rezystora miedzy +12V a nr2 (Tr) układu ne555 . Bo wyzwalasz minusem do Tr? (może jest 100k to daj 10k)

    C1 i R2 sądząc po wartościach wyznaczają czas 5 minut, a ja mówię o tym R do nóżki nr 2. Nie wiem bo nie mam schematu , ale jak jest duży np 100kΩ to daj mniejszy 10kΩ , nie wiem co oznacza " wyłacznk nie jest odseparowany galwanicznie". To że jest 3m przewodu nie przeszkadza chyba że idzie on razem z innymi przewodami i indukuje sie w nim napiecie to dlatego mniejszy rezystor wskazany.

    0
  • #5 21 Maj 2008 14:35
    menda
    Poziom 17  

    Timer jest zrobiony wg schematu kitu AVT1422, wartości C1-100 mikro, R2- 2,7 Mohma.

    R do 2 nózki mam 4,7 M tak jak na schemacie, sprawdzę tak jak podałeś z wartością mniejszą i dam znać. A fakt że przewody od czujnika dotykowego są położone razem z innymi kablami elektrycznymi.

    0
  • Pomocny post
    #6 21 Maj 2008 15:11
    adams987
    Poziom 35  

    Czyli wysoce prawdopodobne że zakłócenia powodują iż co chwile masz nowy impuls wyzwalający generator i liczy od nowa te 5 minut.
    Na czas sprawdzanie wlutuj równolegle do R2 100k a czas wyniesie wtedy 10 sekund

    0
  • #7 22 Maj 2008 10:06
    menda
    Poziom 17  

    Problem rozwiązany, dzięki adams897, po podłaczeniu bezpośrednio do czujnika wszystko działa poprawnie układ się wyłacza, wszystko wskazuje na to że zakłócały inne przewody elektryczne.

    menda

    0