Elektroda.pl
Elektroda.pl
X
Sklep HeluKabel
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

zakłócenia sygnału analogowego...

bratScyzoryk 05 Cze 2008 12:41 2233 7
  • #1 05 Cze 2008 12:41
    bratScyzoryk
    Poziom 9  

    Witajcie,
    nie do końca mogę sobie poradzić z problemem i pytanie do Was o radę co robić dalej, otóż, w maszynie jest przetwornik f/U czytający impulsy z enkodera jako miara prędkości, analogowy sygnał jest wprowadzony do sterownika jako sygnał korekcji/sprzężenia zwrotnego prędkości, problem polega na tym że któryś z kilkunastu napędów "śmieci" po zasilaniu sterowniczym 24V co na oscyloskopie jest widoczne jako "piki" dU ok 200mV o czasie trwania rzędu mikrosekund, naturalnie przetwornik f/U przenosi te śmieci na wyjście co powoduje że AI sterownika odczytuje błędne wartości prędkości. Na początek wsadziłem osobny zasilacz do tego toru i dałem ekranowane przewody co poprawiło sytuację w sposób widoczny acz nie do końca skuteczny, również kondensatory na zasilaniu i na wyjściu analogu trochę pomogły ale wciąż wchodzą te śmieci - o mniejszej amplitudzie ale jednak- co zrobić aby "z tła" analogu wyeliminować maksymalnie te "piki"?
    jakiś filtr RC?
    dzięki z góry za pomysły,
    Piotr

    0 7
  • Sklep HeluKabel
  • #2 05 Cze 2008 21:58
    gregor50+
    Poziom 19  

    Jakie poziomy napięć mają podstawowe sygnały oraz jaki kształt ,jaką długość itp.Opisz to lub naszkicuj aby to zobaczyć.Pokaż schemat połączeń.

    0
  • Sklep HeluKabel
  • #3 06 Cze 2008 13:51
    bratScyzoryk
    Poziom 9  

    dopiero w poniedziałek zrobię jakieś zdjęcia i skan żebym mógł wrzucić tutaj,
    przy prędkości pracy typowej na jakiej pracują operatorzy sygnał z przetwornika f/U jest na poziomie 3,6V, zrobię jeszcze kilka pomiarów i porównań ale skłaniam się coraz bardziej do wersji w której przyczyna leży poza wytypowanym przeze mnie układem, niestety jeżeli to się potwierdzi pozostanie pytanie czy w AI WE/WY rozproszonych PLC mogą indukować się zakłócenia wpływające na pomiar wartości analogu? nasuwa mi się taka myśl po sytuacji w której umieszczenie oscyloskopu blisko szafy i zwartych sondach powoduje dziwne wykresy na jego ekranie, odsunięcie od szafy przywraca normalne działanie oscyloskopu sic!
    brat

    0
  • #4 11 Cze 2008 23:27
    gregor50+
    Poziom 19  

    Te spostrzeżenia na temat oscyloskopu są prawdziwe.
    Bo tak naprawdę trzeba się nauczyć mierzyć oscyloskopem w warunkach zakłóceń.Także interpretacja zakłóconych przebiegów nie jest prosta.
    Bo to nie laboratorium.Mierz na krótkich przewodach(aby nie łapać sygnałów z powietrza )nie wliczamy w to części ekranowanej.Zewrzyj końcówki pomiarowe oscyloskopu i sprawdź, czy łapiesz zakłócenia na małej pętli.Umieść zwartą pętlę w pobliżu zakłóceń.Jeśli łapiesz zakłócenia to masz problem(zależy jaki poziom zakłóceń) na otwartych końcówkach przy połączeniu ekranu z masą musisz mieć niski poziom zakłóceń w stosunku do mierzonych przebiegów.Wtedy dopiero zlokalizujesz źródło zakłóceń.

    0
  • #5 12 Cze 2008 07:50
    sherif
    Poziom 15  

    Wymieniłeś przewód na ekranowany a uziemiłeś ekran tego przewodu (najlepiej z 2 stron chociaż z jednej też powinno działać), natomiast kondensator poprawi ale też wydłuży zatrzymanie silnika co przy sterowaniu precyzyjnym nie jest wskazane

    0
  • #6 12 Cze 2008 10:51
    bratScyzoryk
    Poziom 9  

    gregor50+
    oscyloskop mam prosty Metexa MS-2000 który nie ma ekranowanych sond, natomiast co ciekawe, maksymalnie odsuwając go od szafy z napędami na długość sond pomiarowych zakłócenia przy zwartych sondach znacznie się zmniejszały, niestety rozwarcie końcówek i pozostawienie ich w "powietrzu" powoduje szaleństwo na wyświetlaczu,
    jednak ekranowane przewody sygnałów i pomiar ich w innym miejscu maszyny daje już w miarę prawdziwy obraz przebiegów,

    sherif
    inaczej, wyraziłem się nieprecyzyjnie, zrobiłem osobny ekranowany tor zasilania do przetwornika f/U przy czym zwarcie ekranu z minusem odniosło znacznie lepszy skutek, niż połączenie ekranu zaciskami EMC z płytą szafy, do tego kondensator 1µ5 pomiędzy zaciski zasilania,
    natomiast kondensator na wyjściu przetwornika nie powoduje zmiany rampy bo filtruje on tylko pewne zakłócenia sygnału będącego sprzężeniem zwrotnym od prędkości drutu który jest nawijany, natomiast silnik i napęd mają własny enkoder, a sterownik mierząc sygnał f/U steruje napędem liniowym układacza drutu korygując jego położenie, PLC porównuje prędkość napędu szpuli z chwilową prędkością drutu którego miarą jest sygnał z przetwornika f/U odpowiednio sterując napędem liniowym układacza,
    jak znajdę chwile zeskanuję schemat,
    brat

    0
  • #7 12 Cze 2008 13:20
    sherif
    Poziom 15  

    Nie, mozna tych przewodów lub przewodów z napięciem przemiennym pościć oddzielnym korytem kablowym?

    0
  • #8 12 Cze 2008 13:51
    bratScyzoryk
    Poziom 9  

    problem zakłóceń sygnałów opanowałem przez osobne tory zasilania, ekranowane przewody i kondensatory,
    okazuje się że po uruchomieniu pokazał się jednak inny problem ale on już siedzi w S7 :/
    brat

    0