Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Grundig T55-830text CUC7303 nie przełącza programów

RAM128 12 Cze 2008 10:58 1875 14
  • #1 12 Cze 2008 10:58
    RAM128
    Poziom 12  

    Mam problem z odbiornikiem Grundig T55-830 text z chassis CUC7303 (procesor SDA5252-2 G002, pamięć 24C02, głowica zintegrowana typu Grundig 29504-301.01). Odbiornik po uruchomieniu działa poprawnie przez kilka minut - działają regulacje, strojenie, przełączanie kanałów. Po kilku minutach (do kilkunastu) od momentu włączenia nie da się już przełączać programów, ani stroić tunera - odbiornik pozostaje na ostatnio załączonym programie (jakby procesor stracił komunikację z głowicą po magistrali I2C). Po wyłączeniu odbiornika i odczekaniu kilku godzin, odbiornik znowu przez kilka minut pracuje normalnie. Czas poprawnego działania jest zależny od tego jak długo odbiornik "odpoczywa" (im więcej dni pozostaje niezałączony, tym dłużej poprawnie działa po włączeniu). Jeżeli włączy się go zaraz po tym jak się zablokuje, odbiornik nie odbiera sygnału.
    Wymieniłem: pamięć, głowicę zintegrowaną, procesor, stabilizator 5V i reset. Nie dało to żadnych rezultatów. Może ktoś z Was spotkał się już z taką usterką. Proszę o jakieś wskazówki.

    Pozdrawiam,
    Romek

    0 14
  • #2 12 Cze 2008 11:29
    Krawczak
    Poziom 31  

    Witaj ,wyglada na to że magistrala I2C się zawiesza albo jest blokowana ,oglądnij sobie SDA iSCL jak to wygląda przed i po usterce ,pózniej na piechote możesz odpinac scalaki od lini SDA iSCL ,możesz również sprawdzic czy defekt ustępuje po zmrażaniu scalaków lub elementów podpietych pod I2C

    0
  • #3 12 Cze 2008 11:46
    RAM128
    Poziom 12  

    Do magistrali podłączona jest jedynie pamięć i głowica. Przebiegi na magistrali, po wystąpieniu usterki, wyglądają podobnie jak zaraz po włączeniu odbiornika. By wyeliminować ewentualne braki połączeń odpiąłem wszystkie wyjścia odbiorników I2C i połączyłem je z procesorem przewodami, z pominięciem połączeń na PCB (podciągając obie szyny do 5V przez rezystory 3,3k). Jednak niczego to nie zmieniło. Podstawiałem kilka rożnych pamięci 24C02 i 24C04, zaprogramowanych wg oryginalnej wyjętej z odbiornika. Zastosowałem też nowy procesor i głowicę. Zaczyna brakować mi pomysłów :(

    0
  • #4 12 Cze 2008 12:17
    Krawczak
    Poziom 31  

    Witaj ,odłącz klawiature lokalna ,podstaw czujnik IR i kwarc przy procku ,popraw wszystkie luty w okolicy procesora mimo że wyglądają dobrze ,umyj płyte ,kondensatorki na lini I2C usuń może któryś ma upływność .Pozdr

    0
  • #5 12 Cze 2008 12:40
    RAM128
    Poziom 12  

    Witam.
    Dziękuję za informacje. Niestety wszystkie luty (na całej płycie) poprawiłem już wcześniej (jak niemal w każdym Grundigu "zimnych" lutów, w okolicy zasilacza, odchylania H i V, było sporo). Próbowałem też odłączać odbiornik podczerwieni i klawiaturę lokalną, a także wymieniłem rezonator kwarcowy przy procesorze, oraz kilka kondensatorów elektrolitycznych blokujących zasilania. Wszystko na nic. Usterka dalej występuje... :(

    0
  • #6 12 Cze 2008 16:25
    marek 2006
    Poziom 14  

    Witam! Proponuję wymienić odbiornik IR.

    0
  • #7 12 Cze 2008 19:25
    RAM128
    Poziom 12  

    Dziękuję za wszystkie wypowiedzi. Odbiornika IR jeszcze nie podmieniałem. Odłączyłem go jedynie dla przeprowadzenia próby i efekt był podobny jak z nim - odbiornik po kilku minutach normalnego działania przestał przerzucać kanały przy sterowaniu z klawiatury lokalnej (numer pozycji kanału oczywiście się zmieniał; siła głosu regulowała się poprawnie).
    Ciekawe jest to, że zdarzało się, że gdy przełączyłem program, przez chwile nic poza nowym numerem w grafice ekranowej się nie działo, a po 10 sekundach sam program przełączał się na nowo wybrany. Spróbuję jeszcze podmienić ten odbiornik IR i przemyje płytę, choć ta wygląda na zupełnie czystą.

    Pozdrawiam serdecznie,
    Romek

    0
  • #8 13 Cze 2008 12:05
    dorotata
    Poziom 16  

    Spróbuj FREEZa. Kolega z Sulechowa ma chyba rację.
    pozdr doro

    0
  • #9 17 Cze 2008 22:36
    RAM128
    Poziom 12  

    Witam.
    Dzisiaj, po kilku dniach choroby, wróciłem do naprawy odbiornika Grundig. Ponieważ telewizor pozostawał kilka dni nie włączony, więc dzisiaj przez okres 10 minut pracował zupełnie normalnie, po czym ponownie przestał przełączać programy. Wcześniej wymieniłem w nim procesor, pamięć, reset, rezonator przy procesorze, odbiornik IR, kondensatory elektrolityczne w okolicach procesora i głowicy, oraz przyciski klawiatury lokalnej. Umyłem też, zgodnie z sugestiami Kolegów, płytę i próbowałem stosować zmrażacz -65'C, oraz podgrzewać płytę suszarką do włosów. Wszytko na nic. Jedyną zależność jaką zauważyłem jest wpływ czasu pozostawania odbiornika w stanie wyłączonym (liczonego w dniach) na czas późniejszego poprawnego działania odbiornika (liczonego w minutach). Zanim Grundig trafił do mnie na warsztat, probowało go naprawić dwóch serwisantów, nie poradzili sobie jednak z usterką.
    Czy ktoś z Kolegów spotkał się już może z takim uszkodzeniem?

    Pozdrawiam,
    Romek

    0
  • #10 17 Cze 2008 22:40
    stanislaw piechucki
    Poziom 36  

    Kontakty chwilowe wlacznika sieciowego?.

    0
  • #11 17 Cze 2008 22:46
    RAM128
    Poziom 12  

    W tym odbiorniku nie zastosowano kontaktu chwilowego we włączniku sieciowym.
    Co najciekawsze, gdy odbiornik nie funkcjonuje, procesor poprawnie komunikuje się z pamięcią, wpiętą pod tą samą magistralę I2C co głowica - gdy np. ściemnię obraz, to po wyłączeniu i ponownym włączeniu odbiornika obraz pozostaje ściemniony.
    Co można by jeszcze sprawdzić?

    Pozdrawiam,
    Romek

    0
  • #12 17 Cze 2008 22:55
    stanislaw piechucki
    Poziom 36  

    Daj tymczasowy ekran na procesor i pamiec.

    0
  • #13 17 Cze 2008 22:56
    RAM128
    Poziom 12  

    Już próbowałem, ale nic to nie dało.

    EDIT: Próbowałem podmieniać zawartość eepromu, a także wkładać czystą pamięć. Jak wspomniałem komunikacja między procesorem a pamięcią jest cały czas poprawna (czysta pamięć jest zapisywana informacjami z procesora po włączeniu odbiornika).
    Gdy włączy się odbiornik (po dłuższej przerwie), można cały dzień oglądać "zapamiętany" w syntezie głowicy program i wszystkie inne funkcje (nie sprawdzałem tylko telegazety, której obwody znajdują się wewnątrz procesora) działają poprawnie.

    Pozdrawiam,
    Romek

    0
  • #14 18 Cze 2008 08:19
    Telo
    Poziom 39  

    Sprawdz po czasie stabilność napiec wychodzacych z przetwornicy i z trafopowielacza może takie numery robi któryś z elektrolitów w gałeźi zasilania.

    0
  • #15 20 Cze 2008 13:57
    RAM128
    Poziom 12  

    Witam.
    Panowie, sprawa Grundiga się wyjaśniła. Okazało się, że za brak komunikacji głowicy z procesorem odpowiada mały kondensatorek SMD o pojemności 1nF, włączony do wyprowadzenia nr. 3 głowicy zintegrowanej. Podłączony do miernika zapewniał prawidłowe odczyty (pojemność, brak upływności), jednak gdy dłużej znajdował się pod napięciem w odbiorniku, wykazywał niewielką upływność, która prowadziła do blokowania się głowicy na ostatnio oglądanym kanale. Niestety schemat telewizora nie zawiera szczegółów dotyczących budowy głowicy, a trzecie wyprowadzenie połączone jest jedynie przez ten kondensator z masą. Z tego powodu trudno było znaleźć przyczynę dziwnego zachowania się odbiornika.

    Pozdrawiam,
    Romek

    0