Elektroda.pl
Elektroda.pl
X
Arrow Multisolution Day
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Cyfrowy analizator widma ATmega8

traax 15 Cze 2008 00:00 24096 52
  • Cyfrowy analizator widma ATmega8

    Witam! W poszukiwaniach ciekawego analizatora natrafiłem, otóż na pewien projekt w pewnym czasopiśmie (kit AVT2864 w majowej EdW 2008// androot), który mnie zainteresował i postanowiłem go zmontować. Analizator po złożeniu działał od razu. Płytki dwustronne robiłem po raz pierwszy i nie było żadnych problemów, jedynie ze względu na brak metalizacji otworów musiałem scalaki wlutować bezpośrednio w płytkę. płytki składają się w kanapkę co ułatwia ich montaż w sprzęcie audio. Analizator posiada 3 tryby wyświetlania (słupkowy, punktowy, tryb pokazywania maksymalnej wartości amplitudy). Układ zostanie wmontowany do wzmacniacza na końcówkach symasyma z sterowaniem cyfrowym które zostanie w najbliższym czasie zmontowane.

    Filmik http://pl.youtube.com/watch?v=_ApJ54k6GiA

    Przepraszam za marnej jakości zdjęcia, brak aktualnie porządnego aparatu, w najbliższym czasie zrobię wyraźniejsze.
    Cyfrowy analizator widma ATmega8 Cyfrowy analizator widma ATmega8 Cyfrowy analizator widma ATmega8 Cyfrowy analizator widma ATmega8 Cyfrowy analizator widma ATmega8 Cyfrowy analizator widma ATmega8 Cyfrowy analizator widma ATmega8 Cyfrowy analizator widma ATmega8



    Moderowany przez androot:

    W DZIALE DIY NIE POBIERAMY PROWIZJI DLA SIEBIE!! Zamieszczone w pliku rar skany artykułu z EdW są kiepskiej jakości. Poczytaj coś o zasadach skanowania i zapisu takich plików, żeby nie zajmowały dużo miejsca. Udało się w ten sposób odchudzić archiwum o ponad 2MB.


    Fajne!
  • Arrow Multisolution Day
  • #2 15 Cze 2008 03:30
    Rotartos
    Poziom 1  

    Wykonanie ciekawe, zastanawia mnie szybkość reakcji układu na dźwięk (czy nadąża za muzyką:D), na filmiku nie wygląda to za ciekawie ;/
    8 pkt to "dużo za dużo' za informacje, wyrzuć z paczki zdjęcia i filmy (o ile są). Informacje powinny być tutaj a nie w "płatnej" paczce!

    Ogólnie wsadź to do jakiejś estetycznej obudowy i będzie dobrze :)
    Jeśli układ nie wyrabia to może warto by go podkręcić.

  • #3 15 Cze 2008 06:32
    Scalaq
    Poziom 10  

    Płytka wygląda na starannie wykonaną, na kogoś kto po raz pierwszy wytrawiał dwuwarstwowy laminat. Zadbaj jeszcze o jakąś estetyczną budowę i będzie OK. U mnie 4/5.

    P.S.
    Znieś może te punkty, taki projekt ukazał się już na łamach EdW w majowym numerze tego roku i można go pobrac zupełnie za FReee.
    Pozdrawiam.

  • Arrow Multisolution Day
  • #4 15 Cze 2008 10:09
    vertim
    Poziom 23  

    Ja tu nie widze estetyki wykonania scalaq.Popatrz jak krzywo sa ustawione elementy.

  • #5 15 Cze 2008 10:09
    ADI-mistrzu
    Poziom 30  

    Jaką metodą zrobiłeś płytki ? Ja zawsze mam problem z płytkami 2 stronami, nigdy obydwie strony nie chcą mi się idealnie odbić (metoda termo transferu) i zazwyczaj najpierw jedną strone odprasowuje, druga całą lakieruje i wytrawiam, a potem na odwrót.

    Jak ty Swoją wykonałeś ?

  • #6 15 Cze 2008 10:36
    traax
    Poziom 20  

    Przepraszam za prowizję, przypadkowo 1 się ustawiła. Co do odświeżania i grania według muzyki to działa świetnie ;d na filmiku nie słychać muzyki z kompa tylko z tv, a analizator podłączony był pod kompa. Zamieszczę dziś jeszcze filmik na którym słychać muzykę. Płytki dwustronne robiłem termotransferem, pierw jedna stronę trawiłem, a druga zaklejona taśmą, potem drugą stronę, lecz trzeba było ustawić równo kartkę, ja to zrobiłem za pomocą 2 połamanych wierteł 1mm wsadzonych w punkty lutownicze i kartę, a co do estetyki to nie było łatwo niektóre elementy przylutować prosto, bo było bardzo ciasno, po za tym płytki składają się w kanapkę wiec nierówność elementów nie przeszkadza. Analizator jak już pisałem zostanie umieszczony w obudowie wzmacniacza który powoli się składa w całość, brakuje tylko trafa i sterowania cyfrowego.

  • #7 15 Cze 2008 11:32
    mkpl
    Poziom 37  

    Wszystko ok ;) tylko niemasz przypadkiem atmegi na wewnetrznym oscylatorze? Wylutuj ten generator kwarcowy jesli nadal bedzie działac to znaczy ze nie ustawiłes fuse bit i dlatego tak spowalnia ;)

  • #8 15 Cze 2008 11:38
    pidpawel
    Red. Komputery FAQ

    Mam ten układ zrobiony z kitu ;) Wiem nie wysiliłem się, ale po prostu zamawiałem jeszcze kilka rzeczy i wychodziło mi taniej - do elektronika mam 30km, więc za paliwo zaoszczędziłem :P
    Działa fajnie, płtki wysokiej jakości, efekt też niczego sobie :P Łatwo przesterować no ale.... Trzeba go po prostu używać w sprzęcie który sami robimy i ładnie wszystko zaprojektować.

  • #10 15 Cze 2008 12:20
    Mariuszek15
    Poziom 24  

    traax Jak dla mnie to za szybko chodzą te słupki LED. Jeśli chcesz to możesz szybkość słupków zmienić na bardziej płynniejsze wyskoki słupków w programie. Cała dokumentacja znajduje się tutaj http://www.edw.com.pl/ftp_05/200805avt2864.zip Zdradź nam jak robiłeś dwustronna płytkę PCB. Pozdrawiam :]

  • #11 15 Cze 2008 14:00
    traax
    Poziom 20  

    wiem, trochę szybko , właśnie sie przymierzam do zmiany w programie tej szybkości na ciut wolniejszą. Płytkę dwustronna zrobiłem tak:

    -termotransfer na papierze kredowym.
    -odprasowanie jednej strony i zamoczenie w wodzie na parę minut
    -po zmoczeniu i oderwaniu papieru zaklejenie drugiej strony laminatu taśmą klejącą.
    -trawienie w b327
    -usunięcie toneru z płytki,
    -odbicie na drugiej stronie drugą mozaikę ścieżek, pozycjonowanie by równo się odbiły wykonałem tak: wywiercenie 2 najdalszych punktów lutowniczych w rogach płytki oraz na mozaice do prasowania(muszą być to te same 2 punkty), ja w te otwory wsadziłem 2 wiertła 1mm i nałożyłem mozaikę i sprasowałem
    -zaklejenie taśmą stronę wytrawioną
    -trawienie płytki

  • #12 15 Cze 2008 14:37
    pidpawel
    Red. Komputery FAQ

    Jak będziesz miał wolniejszą wersję to się podziel ;)

  • #13 15 Cze 2008 14:45
    mkpl
    Poziom 37  

    Najprosciej dać wolniejszy oscylator ;) np zamiast 18MHz dac z 16 lub nawet 14MHz

  • #15 15 Cze 2008 15:13
    pidpawel
    Red. Komputery FAQ

    A co mi tam :P Muszę najpierw okiełznac nowy programator a potem będę ryzykował z działającymi układami :P

  • #16 15 Cze 2008 20:13
    pidpawel
    Red. Komputery FAQ

    JmL(TM) napisał:
    Decado napisał:
    Ide o zakład że nie byłbyś w stanie wykonac takiego urządzenia...


    To twoja opinia...



    Ja tam twierdzę, że osoba inteligentna mając do pomocy internet byłaby w stanie zbudować takie coś. Poza tym w projekcie avt widzę kilka udziwnień, moim zdaniem niepotrzebnych, ale widać ktoś chciał to zrobić tak a nie inaczej. Dyskusję na temat czy ktoś jest w stanie to zrobić czy nie proszę zakończyć.
    Pozdr.
    Paweł

    Moderowany przez androot:

    Ci co rozpoczęli tą dyskusję dostali ostrzeżenia

  • #17 17 Cze 2008 12:12
    gemiel
    Poziom 21  

    Ja radzę sobie z płytkami dwustronnymi w prosty sposób. Siatkę otworów drukuję najpierw i nakłuwam. następnie wiercę otwory. Później przykładając papier sprawdzam prześwity. Co do braku metalizacji otworów to wystarczy użyć podstawek precyzyjnych. Bardzo łatwo lutuje się nóżki po obu stronach druku.

  • #18 17 Cze 2008 18:14
    DJ.TRoX
    Poziom 17  

    Bardzo ładne, nic dodać nic ująć,
    Gratuluje cierpliwości przy wierceniu,
    Kiedyś zrobiłem zegarek na 400 led'ach - wierciłem go przez miesiąc na raty i powiedziałem sobie nigdy więcej
    Pozdrawiam

  • #20 23 Lip 2008 09:35
    dyleks
    Poziom 11  

    Witam,
    ja zakupiłem ów układ płytki z elementami i po zmontowaniu nie działa wcale :/ Tzn niezależnie od położenia zworek ani źródła sygnału (z karty w laptopie, czy tez z mp3-playera) nie zapalają się żadne diody. Wiecie co może być nie tak ?? Gdzie szukać błędu.

  • #21 23 Lip 2008 10:37
    ADI-mistrzu
    Poziom 30  

    Odwrotnie wlutowane układy, źle wlutowane układy (nie stykają się ze ścieżką), przerwane ścieżki, jakiś układ uszkodzony...

    Jak pokażesz zdjęcia to będzie można bardziej sprecyzować, ostatnio moja szklana kula szwankuje i nie chce nic pokazywać :D

  • #23 23 Lip 2008 18:15
    dyleks
    Poziom 11  

    Tez mi taka myśl przeszła przez głowę. Teraz jestem w pracy więc sprawdzę to później. Układ montowałem wczoraj w nocy i już nie chciało mi się nic przy nim grzebać jak zobaczyłem że całkowita cisza jest na diodach. A sobie przeglądałem forum i widzę że ktoś pisał o tym układziku. Ale z tego co pamiętam to lutowałem dokładnie według wzorków na płytce.

    Dodano po 5 [godziny] 24 [minuty]:

    Witam ponownie. Diody są wlutowane poprawnie :/ W paczce umieszczam zdjęcia.

  • #24 23 Lip 2008 22:21
    mkpl
    Poziom 37  

    Jak chcesz pomocy to usun prowizje za plik i zamieść fotki zgonie z zasadami forum wracajac do tematu Atmega dobrze Ci sie zaprogramowala?

  • #25 23 Lip 2008 22:26
    Balu
    Poziom 38  

    Nie ma prowizji za plik dla Niego, wystarczy czytać ze zrozumieniem...

  • #26 23 Lip 2008 23:26
    dyleks
    Poziom 11  

    Układu nie programowałem sam jest taki jaki dostałem w komplecie myślicie że może to być tego wina?? Jeszcze jedno jak zewrę palcem z tyłu płytki nóżki tranzystora to odpowiednie wiersze się zapalają i mrygają "mniej więcej" w rytm muzyki, więc stwierdziłem że po prostu nie pojawiają się na bazach tranzystorów stany wysokie(te tranzystory podpięte bezpośrednio opornikami pod nóżki atmegi). Miernik względem masy na nóżkach tych pokazuje ciągle stałą wartość ok 4,5 V nie wiem jak to zinterpretować :/ Natomiast stany na wyjściach układu 4028 są w okolicach 1,5 V i się zmieniają ;o

  • #28 27 Lip 2008 11:29
    Mariuszek15
    Poziom 24  

    Jak układ jest kupiony w AVT to procesor musi być zaprogramowany i ustawione odpowiednio są "fusy". Jeśli kolega dotyka nóżek od strony ścieżek i zaświecają się diody to coś musi być z tranzystorami lub przerwami w ścieżkach bazy.

    dyleks Pokaż fotki jak to wszystko wygląda.

  • #29 28 Lip 2008 09:59
    dyleks
    Poziom 11  

    Fotki tego jak się układ zachowuje ?? Bo przerw w ścieżkach bazy nie ma. I zdjęcia płytek umieściłem kilka postów wyżej. Zmontowałem wiele układów bardziej skomplikowanych i takiego typu problemu nie miałem jeszcze. Może rzeczywiście atmega źle jest zaprogramowana albo uszkodzona :/ a ja na razie nie mogę zaprogramować od nowa bo mam lapka bez lpt. Wzmacniacz i 4028 podmieniałem po dwie różne sztuki i to samo więc one są OK.

  • #30 31 Paź 2008 11:25
    TripleH
    Poziom 12  

    Witam. Ja też właśnie składam ten zestaw i mam do Was pytanie. Czy można ten zestaw zasilać z zasilacza ATX? Jestem początkujący, dopiero się uczę i nie mam jeszcze zasilacza warsztatowego. Mam nowy zasilacz Fever 500W którego nie używam do komputera bo kosztował 50zl.