Elektroda.pl
Elektroda.pl
X

Search our partners

Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

Zestaw AVT2767 - niechciane napięcie na wyjściu

andrzejlisek 26 Jun 2008 19:14 2164 6
  • #1
    andrzejlisek
    Level 28  
    Chciałem zmontować zestaw AVT 2767 będący przystawką oscyloskopową do komputera.

    Kitu nie zamawiałem, części kupiłem osobno.

    Jednak zmontowany przeze mnie zestaw się nieco różni w sposobie zasilania. W opisie jest napisane, żeby wykorzystać port COM, który zapewni napięcia +10V i -10V. Ja zamiast tego postanowiłem wykorzystać dwie baterie 9V

    Po zmontowaniu zestawu okazało się że przy wejściach zwartych z masą, na wyjściu jest ok. 8V. Takie napięcie oczywiście nie może iść do karty dźwiękowej.

    W zasilaniu jest zrobione tak, że dla jednej baterii [-] idzie do masy, a [+] idzie na nóżkę 8 TL082, natomiast dla drugiej baterii [+] idzie do masy, a [-] idzie na nóżkę 4 TL082. Układ scalony jest w podstawce, więc jego ewentualna wymiana będzie łatwa.



    Napięcia mierzyłem względem masy.
    Napięcia samych baterii wynoszą 9,13 i 9,32
    Na nóżce 4 jest napięcie -9,13V, a na nóżce 8 jest +9,32

    Nóżka 2 i 6 mają 0V i są zwarte z masą (tak miało być przy minimalnym ustawieniu potencjometrów).

    Na obu wyjściach mam -7,8V, a powinno być 0V. Dlaczego tak jest? Zamieniłem baterie miejscami celem sprawdzenia, czy nierówne napięcia baterii są przyczyną, jest tak samo, czyli -7,9V.

    Sprawdziłem poprawność konstrukcji układu, nie widzę błędów konstrukcyjnych i są wszystkie połączenia. Czy jednak coś mogłem przeoczyć?

    Jeśli chodzi o numerację nóżek, to przyjąłem, że jak się położy układ napisami go góry i wgłębieniem od siebie, to numery nóżek wyglądają następująco:
    Code:

       +---\_/---+
       |         |
    1 -+         +- 8
       |         |
    2 -+         +- 7
       |         |
    3 -+         +- 6
       |         |
    4 -+         +- 5
       |         |
       +---------+


    PDF oscyloskopu.
  • #2
    qrdel
    Level 28  
    No nie wiem jaki idiota wymyślił ten schemat!!!
    Piszą w artykule o "wtórniku emiterowym" i realizują go na opampie.
    I robią to łącząc wyjście z wejściem nieodwracającym!
    W ten sposób zamiast wtórnika napięciowego uzyskują "układ losujący" - albo się na stałe ustawi na plusie zasilania, albo na minusie.

    ---

    Proponuję pozamieniać wejścia (odwracające i nieodwracające) to coś-niecoś powinno wyjść. Numery nóżek podali zgodnie ze schematem (czyli bez sensu).
  • #3
    Mariusz Ch.
    VIP Meritorious for electroda.pl
    Witam.

    Pomyłka w PDF. Wzmacniacze mają pracować jako wtórniki. Sygnał ma być podawany na wejście nieodwracające, a pętla sprzężenia musi być zamknięta do wejścia odwracającego. Wejście pin3 , razem łączysz pin1 i 2. Drugi podobnie. Wejście pin 5, razem pin6 i 7.

    Pzdr.
  • #4
    andrzejlisek
    Level 28  
    Wygląda na to, że rzeczywiście jest błąd w PDF. Gdzieś znalazłem schemat wtórnika i tam wejścia wzmacniacza były podłączone odwrotnie.

    Spróbuję to odwrócić w swojej konstrukcji.
  • #5
    andrzejlisek
    Level 28  
    Poprawki wykonałem, ale wydaje mi się, że otrzymywane przebiegi są trochę zniekształcone. Co jest tego przyczyną?

    Mam autotransformator taki z lat 80., pracujący w zakresie od 0 do 250V na wyjściu. Ustawiłem ok. 10V i obserwowałem przebieg. Potem ok. 20V (najpierw suwak do masy, żeby nie zepsuć karty dźwiękowej) i otrzymałem podobny przebieg. W stosunku do sinusoidy, wygląda, jakby wierzchołki były nieco spłaszczone.

    Zestaw AVT2767 - niechciane napięcie na wyjściu

    Posiadam prosty miernik uniwersalny, który ma w sobie prosty generator przebiegu prostokątnego. Jak się końcówki miernika gdzieś podłączy, to miernik pokazuje jakąś wartość, ale nie wiem, co pokazuje. Zamiast prostokąta zarejestrowałem taki przebieg:

    Zestaw AVT2767 - niechciane napięcie na wyjściu

    Czy urządzenia rzeczywiście generowały takie przebiegi, czy wzmacniasz je zniekształca, czy w karcie dźwiękowej się zniekształca. Mam SoundBlaster Audigy 2.


    Ostatnim testem było podłączenie napięcia stałego. Posiadam prostownik do ładowania akumulatorów, oddający napięcie 6V lub 12V wybierane przełącznikiem. Ponieważ prostownik nie miał nic oprócz transformatora i układu prostowniczego (wygląda tak, że są cztery płytki metalowe i między tymi płytkami są podłączone przewody), dodałem kondensator na wyjściu (zmieścił się w obudowie). Kondensator to chyba 3mF lub 30mF na 20 lub 30V (nie pamiętam, bo to dosyć dawno robiłem). Pamiętam, że kosztował ok. 20-25zł.

    Z tego prostownika uzyskuję napięcie niemalże stałe, miernik pokazuje ponad 9V bo to jest napięcie szczytowe z transformatora.

    Podłączyłem do układu wspomniany prostownik i obserwowałem rejestrowany przebieg. Niestety nie mogłem zarejestrować faktu obecności napięcia stałego. Tylko przy przesuwaniu suwaka małymi kroczkami widziałem małe podskoki napięcia. Podłączyłem woltomierz do wejścia karty dźwiękowej. Nawet, jak woltomierz pokazywał 0,8V to przebieg był taki, jak bez sygnału.

    Wyglądało to, jakby po drodze od wyjścia wzmacniacza do wejścia karty dźwiękowej był szeregowo kondensator. Dlaczego tak się dzieje?
  • #6
    Ptolek
    Level 36  
    Na wejściu karty dźwiękowej pewnie jest kodensator.
    Takie zniekształcenia sinusoidy z sieci energetycznej to "normalka".
    Co do przebiegu z miernika, to coś jest nie tak. Mój miernik generuje piękny prostokątny prostokąt. Wygląda jakby coś ograniczało pasmo od dołu. Wszystko by pasowało, jeśli na wejściu karty jest jakiś kondensator o niezbyt dużej pojemości.
  • #7
    andrzejlisek
    Level 28  
    Tak czy siak, za pomocą tego ustrojstwa chciałbym rejestrować przebiegi z sieci 230V. Według moich obliczeń wystarczy dodać opór ok. 30-50 megaomów szeregowo z wejściem sygnałowym.

    To ograniczenie do 24V jest chyba tylko umowne, bo mając precyzyjną rękę można rejestrować wyższe napięcia, ale trudniej ustawić poziom, który musi być blisko zera.

    Natomiast aby rejestrować natężenie prądu to trzeba szeregowo w obwodzie wstawić rezystancję 0,1om (nie wiem, czy taki opornik jest w handlu) u napięcie na oporniku wzrasta o 10V na 1A czyli przy natężeniu 500mA na oporniku jest 5V.

    I teraz pytania:
    Czy opornik do pomiaru dużych napięć może być standardowy, małej mocy? Wydaje mi się, że tak, bo prąd płynący przez opornik powiniwn być jak najmniejszy. Myślę, żeby jeszcze dokupić potencjometr o największym oporze w handlu.

    Czy jak chce się mieć większą moc opornika to czy jak kupię 4 równe oporniki i połączę je w pary szeregowo, a potem obie pary równolegle, to czy otrzymam opornik o 4-krotnej mocy i rezystancji równej jednego opornika?

    Słyszałem, że zakres napięć pojawiających się na wyjściu wzmacniaczy operacyjnych zależy od napięć zasilających. Czy w przypadku tego wzmacniacza wystarczą napięcia +/- 1,5V (jedna bateria R6 na stronę)? Wiem, że do karty dźwiękowej to aż nadto, ale czy tak zasilany wzmacniacz będzie poprawnie funkcjonować, no i wtedy nigdy na wyjściu nie pojawi się więcej niż +/- 1,5V, co jest pewnym zabezpieczeniem karty dźwiękowej.

    Czy są karty dżwiękowe bez kondensatora na wejściu? Czy zwykle ten kondensator jest widoczny i da się go zmostkować (zewrzeć)?
    Czy taka operacja polepszy kartę dźwiękową? Ewentualną składową satałą można wyeliminować po nagraniu muzyki.