Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

jak uratowac diboxa 2

arturo29 07 Lip 2008 22:33 3175 8
  • #1 07 Lip 2008 22:33
    arturo29
    Poziom 11  

    witam miałem neutrino by spenek, chciałem wgrać poprawke news v1.2 oczywiscie wgrałem, ale to juz co innego bo sie wiesza tuner pozdrawiam arturo

    0 8
  • #2 07 Lip 2008 23:26
    Jarek.b1
    Poziom 19  

    Wgraj enigme przez RS232 instrukcję najdziesz na forum.

    0
  • #3 08 Lip 2008 06:48
    okulik
    Poziom 28  

    Wgraj inne image, niekoniecznie przez rs.

    0
  • #4 08 Lip 2008 17:29
    arturo29
    Poziom 11  

    witam, dzieki za porady apropo nie moge wgrac inmage po lanie bo nie moge sobie przestawic ustawień sieci w diboxie ,poprostu ni sie wiesza i nie zdąrze w klepac sekwencji czyli tam 192.168.1.11 bo bo prostu jest brak reakcji, a tym programem ifa tez sie nie da ,nawet prubowałem pod win98,tak wiec prosze o wskazówki jak wgrać po rs232 a man kabel tak zkrosowany jak do philipsa 3010 .prosze tez o linki pozdrawiam arturo

    0
  • #5 08 Lip 2008 23:36
    Jarek.b1
    Poziom 19  

    Wgrywanie Image TYLKO za pomocą kabla NULLMODEM

    uruchamiamy hyperterminal w windozie
    w okienku z nowym połączeniem klikamy anuluj
    później wchodzimy w plik-właściwości-ustawiamy na którym COM-ie mamy podpiętego dboxa
    ustawiamy parametry

    Liczba bitów na sekunde- 9600
    bit danych - 8
    Parzystość - brak
    Bit stopu - 1
    Sterowanie przepływem Xon/Xoff

    dboxa włączyć poprzez reset naciskając power i strzałke w górę. Po zrestartowaniu się boxa puszczamy power, a strzałkę w górę trzymamy jeszcze przez chwilę. !!!!
    w hyperterminalu powinny pojawić się
    Cytat:

    xdebug: DDF: Calibrating delay loop... debug: DDF: 67.79 BogoMIPS
    debug: unknown demodulatordebug: BMon V1.0 mID 01
    debug: feID 00 gtxID 0b
    debug: fpID 5a dsID 01-2c.77.23.07.00.00-48
    debug: HWrev X5 SWrev 0.81
    debug: B/Ex/Fl(MB) 32/00/08
    WATCHDOG reset enabled
    debug: &_text 0x10000, &_etext 0x26160, &_data 0x26160, &_edata 0x29c50
    debug: &_end 0x347dc, &__stack 0x400000
    debug: Memory tests (0x400000 -- 0x2000000)
    debug: NumberTest: debug: passed
    debug: MarchTest: debug: passed
    debug: PermTest: debug:
    dbox2:root>


    teraz wpisujemy: dl 800000 [naciskamy enter]

    Cytat:

    dbox2:root> dl 800000
    S Record Load, offset: 800000


    teraz wybieramy z menu hyperterminala transfer-wyślij plik tekstowy-(pliki typy wszystkie pliki) wybieramy plik załączony rozpakowany u-boot.mot - klikamy otwórz i plik zostanie wysłany trwa to około 7 min (brak jest komunikatów o przebiegu transmisji)

    Cytat:

    dl: start address 0x800000
    dbox2:root>


    teraz wpisujemy: chorus 800000 [naciskamy enter]
    nastąpią cztery próby komunikacyjne karty sieciowe, które przerywamy naciskając ctrl +c

    Cytat:

    Branching to 0x40000

    U-Boot 1.1.2 (Tuxbox) (Feb 27 2005 - 07:41:57)

    CPU: PPC823ZTnnA at 67.100 MHz: 2 kB I-Cache 1 kB D-Cache
    *** Warning: CPU Core has Silicon Bugs -- Check the Errata ***
    Board: DBOX2, Nokia, BMon V1.0
    Watchdog enabled
    I2C: ready
    DRAM: 32 MB
    FLASH: 8 MB
    FB: ready
    LCD: ready
    In: serial
    Out: serial
    Err: serial
    Net: SCC ETHERNET
    BOOTP broadcast 1
    BOOTP broadcast 2
    BOOTP broadcast 3
    BOOTP broadcast 4

    Abort
    *** ERROR: `serverip' not set
    can't find logo
    BOOTP broadcast 1
    BOOTP broadcast 2

    Abort
    *** ERROR: `serverip' not set
    can't find logo

    Options:
    1: Console on null
    2: Console on ttyS0
    3: Console on framebuffer
    Select option (1-3), other keys to stop autoboot: 0
    *** ERROR: `serverip' not set
    ......................................................................
    Un-Protected 70 sectors
    ## Booting image at 00100000 ...
    Bad Magic Number


    teraz wpisujemy: loadb 120000 115200 [naciskamy enter]

    Cytat:

    => loadb 120000 115200
    ## Switch baudrate to 115200 bps and press ENTER ...


    teraz robimy to o co nas poprosi program, czyli zmieniamy szybkość transmisji, a więc z menu wywołanie-odłącz, włąściwości zmieniamy prędkość na 115200 po tym z menu wywołanie- wywołaj wtedy naciskamy [enter]

    wreszcie możemy wysłać nasze image ( standardowe bez bootloadera)
    wybieramy transfer-wyślij plik (wybieramy plik) i ustawiamy protokół na Kermit i klikamy wyślij i idziemy na piwo ta operacja trwa około godziny. O postępie jesteśmy powiadamiani paskiem postępu:


    po transmisji bedzie komunikat

    Cytat:

    ## Total Size = 0x007e0000 = 8257536 Bytes
    ## Start Addr = 0x00120000
    ## Switch baudrate to 9600 bps and press ESC ...


    więc znowu zmieniamy szybkość - najpierw wywołanie-odłącz później włąściwości i 9600 i wywołanie - wywołaj, nacisnać ESC

    teraz podajemy trzy rozkazy po sobie:

    protect off 10020000 107fffff [enter]

    erase 10020000 107fffff [enter]

    cp.l 120000 10020000 1F8000 [enter]

    Cytat:

    => protect off 10020000 107fffff
    ......................................................................
    Un-Protected 70 sectors
    => erase 10020000 107fffff

    done
    Erased 70 sectors
    => cp.l 120000 10020000 1F8000
    Copy to Flash... done
    =>


    Jak wszystko poszło ok imag został załadowany do boxa, zamykamy hyperterminala i restartujemy boxa.



    Sprawdzony i z każdym razem działa nie było tunera którym bym tym sposobem nie wskrzesił.

    Pozdrawiam

    0
  • #6 09 Lip 2008 10:29
    arturo29
    Poziom 11  

    witam !prubowałem tej metody z hyperterminalem i to na kilku komputerach i bez skutku ,brak komunikacji po rs232 moze sprubować przez putty pozdrawiam arturo

    0
  • #7 10 Lip 2008 14:14
    arturo29
    Poziom 11  

    witam właśnie udało mi sie ozywic diboxa poprzez hyperterminal ,dziekuje wszystkim za pomoc pozdrawiam arturo temat mozna zamknąć

    0
  • #8 16 Lis 2010 00:37
    kindziol
    Poziom 10  

    Witam !!!

    Jeśli można to chciałbym wrócić do tematu . Zrobiłem wszystko według opisu ale coś jest nie tak . Tu jest mój log z naprawy . Może mi podpowiecie co jest nie tak, może coś zle zrobiłem ?


    ˙debug: DDF: Calibrating delay loop... debug: DDF: 67.79 BogoMIPS
    debug: BMon V1.2 mID 01
    debug: feID dd gtxID 0b
    debug: fpID 5a dsID 01-2d.39.1c.07.00.00-e6
    debug: HWrev 09 FPrev 0.81
    debug: B/Ex/Fl(MB) 32/00/08
    WATCHDOG reset enabled
    dbox2:root> dl 800000
    S Record Load, offset: 800000
    dl: start address 0x800000
    dbox2:root>
    dbox2:root> chorus 800000
    Branching to 0x40000


    U-Boot 1.1.2 (Tuxbox) (Feb 27 2005 - 07:41:57)

    CPU: PPC823ZTnnB2 at 67.100 MHz: 2 kB I-Cache 1 kB D-Cache
    Board: DBOX2, Nokia, BMon V1.2
    Watchdog enabled
    I2C: ready
    DRAM: 32 MB
    FLASH: 8 MB
    FB: ready
    LCD: ready
    In: serial
    Out: serial
    Err: serial
    Net: SCC ETHERNET
    BOOTP broadcast 1
    BOOTP broadcast 2

    Abort
    *** ERROR: `serverip' not set
    can't find logo
    BOOTP broadcast 1

    Abort
    *** ERROR: `serverip' not set
    can't find logo

    Options:
    1: Console on null
    2: Console on ttyS0
    3: Console on framebuffer
    Select option (1-3), other keys to stop autoboot: 0
    *** ERROR: `serverip' not set
    ......................................................................
    Un-Protected 70 sectors
    ## Booting image at 00100000 ...
    Bad Magic Number
    => loadb 120000 115200
    ## Switch baudrate to 115200 bps and press ENTER ...
    ## Ready for binary (kermit) download to 0x00120000 at 115200 bps...
    ## Total Size = 0x007e0000 = 8257536 Bytes
    ## Start Addr = 0x00120000
    ## Switch baudrate to 9600 bps and press ESC ...
    => protect off 10020000 107ffff
    Usage:
    protect - enable or disable FLASH write protection

    => erase 10020000 107ffff
    Usage:
    erase - erase FLASH memory

    => cp.l 120000 1F8000
    Usage:
    cp - memory copy

    => protect off 10020000 107ffff
    Usage:
    protect - enable or disable FLASH write protection

    => erase 10020000 107FFFF
    Usage:
    erase - erase FLASH memory

    => cp.l 120000 10020000 1F8000
    Copy to Flash... Flash not Erased
    => erase 10020000 107ffff
    Usage:
    erase - erase FLASH memory

    => erase 10020000 107FFFF
    Unknown command 'erase' - try 'help'
    => erase 10020000 107ffff
    Usage:
    erase - erase FLASH memory

    => cp.l 120000 10020000 1F8000
    Copy to Flash... Flash not Erased
    => protect off 10020000 107ffff
    Usage:
    protect - enable or disable FLASH write protection

    =>protect off 10020000 107ffff
    Unknown command protect' - try 'help'
    => protect off 10020000 107ffff
    Usage:
    protect - enable or disable FLASH write protection

    => erase 10020000 107ffff
    Usage:
    erase - erase FLASH memory

    => cp.l 120000 10020000 1f8000
    Copy to Flash... Flash not Erased
    =>


    Zaczyna się problem z trzema ostatnimi komendami .

    Z góry dziękuję !

    POzdr.

    Chyba już wiem co źle zrobiłem > podczas włączania box-a nacisnąłem strzałkę w dół !!!!!

    Walcze dalej .....

    pozdr.

    Dodano po 2 [godziny] 21 [minuty]:

    Witam ponownie !!!

    Niestety nic to nie dało !!!

    Trzy ostatnie komendy nie działąją !!!

    Jakieś pomysły ?

    pozdr.

    0
  • #9 16 Lis 2010 17:37
    kindziol
    Poziom 10  

    Witam !!!

    Po walce z tunerkiem i komendami ....
    Tuner wstał i jest gotowy do pracy !!!!!!

    Oto moje logi, może komuś się to przyda :

    ˙debug: DDF: Calibrating delay loop... debug: DDF: 67.79 BogoMIPS
    debug: BMon V1.2 mID 01
    debug: feID dd gtxID 0b
    debug: fpID 5a dsID 01-2d.39.1c.07.00.00-e6
    debug: HWrev 09 FPrev 0.81
    debug: B/Ex/Fl(MB) 32/00/08
    WATCHDOG reset enabled
    debug: &_text 0x10000, &_etext 0x26218, &_data 0x26218, &_edata 0x29d08
    debug: &_end 0x34894, &__stack 0x400000
    debug: Memory tests (0x400000 -- 0x2000000)
    debug: NumberTest: debug: passed
    debug: MarchTest: debug: passed
    debug: PermTest: debug: passed
    dbox2:root> dl 800000
    S Record Load, offset: 800000
    dl: start address 0x800000
    dbox2:root>
    dbox2:root> chorus 800000
    Branching to 0x40000


    U-Boot 1.1.2 (Tuxbox) (Feb 27 2005 - 07:41:57)

    CPU: PPC823ZTnnB2 at 67.100 MHz: 2 kB I-Cache 1 kB D-Cache
    Board: DBOX2, Nokia, BMon V1.2
    Watchdog enabled
    I2C: ready
    DRAM: 32 MB
    FLASH: 8 MB
    FB: ready
    LCD: ready
    In: serial
    Out: serial
    Err: serial
    Net: SCC ETHERNET
    BOOTP broadcast 1
    BOOTP broadcast 2

    Abort
    *** ERROR: `serverip' not set
    can't find logo
    BOOTP broadcast 1

    Abort
    *** ERROR: `serverip' not set
    can't find logo

    Options:
    1: Console on null
    2: Console on ttyS0
    3: Console on framebuffer
    Select option (1-3), other keys to stop autoboot: 0
    *** ERROR: `serverip' not set
    ......................................................................
    Un-Protected 70 sectors
    ## Booting image at 00100000 ...
    Bad Magic Number
    => loadb 120000 115200
    ## Switch baudrate to 115200 bps and press ENTER ...
    ## Ready for binary (kermit) download to 0x00120000 at 115200 bps...
    ## Total Size = 0x007e0000 = 8257536 Bytes
    ## Start Addr = 0x00120000
    ## Switch baudrate to 9600 bps and press ESC ...
    => protect off 10020000 107ffff
    Usage:
    protect - enable or disable FLASH write protection

    => erase 10020000 107ffff
    Usage:
    erase - erase FLASH memory

    => cp.l 120000 10020000 1F8000
    Copy to Flash... Flash not Erased
    => erase all
    Erase Flash Bank # 1 - Warning: 1 protected sectors will not be erased!
    done
    Erase Flash Bank # 2 - can't erase unknown flash type - aborted
    => protect off all
    Un-Protect Flash Bank # 1
    ....................................................................... done
    => cp.l 120000 10020000 1F8000
    Copy to Flash... done
    =>


    Dziękuję i pozdr.

    kindziol

    0