Elektroda.pl
Elektroda.pl
X

Wyszukiwarki naszych partnerów

Wyszukaj w ofercie 200 tys. produktów TME
Proszę, dodaj wyjątek elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

wake up lan - przez internet

grabek_radek 23 Lip 2008 09:17 10834 11
  • #1 23 Lip 2008 09:17
    grabek_radek
    Poziom 21  

    A wiec zaczynajac od poczatku zrobilem u siebie w sieci domowej abym wlaczal zdalnie komputer i dziala mam neo i router, broucast to 192.168.1.127 bo dalem maske 255.255.255.128 bo nie mozna bylo w przekierowaniach ustawic portu 7 aby kierowalo na adres 255
    uzywam do tego programu wake up lan magic packed dodam ze mam jeszcze DDNS zeby nie bylo :) i tutaj wszystko dziala
    a terazz sprawa jest taka z dsl mam router edimaxa zrobilem przekierowanie portu 7 na adres 192.168.0.127 maska 255.255.255.128 i zewnatrz nic sie nie dzieje w sieci bez problemu sie wlacza komputer :( na 99% jest problem z routerem tylko jak to sprawdzic?

  • #2 23 Lip 2008 12:40
    598035
    Usunięty  
  • #3 23 Lip 2008 14:28
    grabek_radek
    Poziom 21  

    hmmm chyba sie nie rozumiemy to co podalem to wystarczylo bo tutaj chodzi glownie o broudcast - jako adres rozgloszeniowy - na routerze jest ustawione przekierowanie portu 7 na adres rozgloszeniowy w moim przypadku na 192.168.0.127 bo maska jest 255.255.255.128 niby port jest przekierowny a nie dziala przed routerem tez jest urzadzenie tomsona - ja to nazwalem modemem bo czy jest tam translacja adresu hmmm moze i jest bo wyjscie jest enternetowe - ale pozostalem porty na routerze edimac mam odpowiednio przekierowane np port 80 na kompa na ktorym stoi apache wiec dziala - czyli odpada kwestia tego modemu tomsona bo on jest nie widoczny dla sieci

  • #4 23 Lip 2008 14:48
    zibq
    Poziom 27  

    Router Thomsona jest tylko modemem, czy ustawiony jest na nim NAT?
    Co to za router ten Edimax? Zobacz w jego specyfikacji czy potrafi przepuszczać pakiety 'magic' czy WOL.
    Podajesz zbyt mało informacji. Podaj więcej szczegółów na temat sieci 'nie działającej'.

    P.S.
    Ciężko Cię zrozumieć, postaraj się używać znaków przestankowych i budować jakieś sensowne zdania, nie wspominając o panującej na forum zasadzie używania polskich znaków.

  • #5 23 Lip 2008 17:51
    598035
    Usunięty  
  • #6 23 Lip 2008 21:44
    mietekn
    Poziom 35  

    kines17 napisał:
    Z czego co czytałem wake up Lan:
    http://www.download32.com/wakeup-on-lan-d35025.html
    działa w sposób następujący:
    Wpisuję się do programu adres IP komputera,
    i po wcześniejszej konfiguracji biosu komputera wciska się przycisk "Turn ON PC"
    Czyli jeżeli chcesz aby komp włączył się po lanie wystarczy że otworzysz dla niego port na routerze i przekierujesz go na Ip Twojego komputera..

    Przykład:
    Otwierasz port 7 na ruterze i przekierowujesz go na IP komputera co chcesz włączyć przez LAN.
    Czyli nie na IP 192.168.0.127 czy routera Tylko komputera.
    Tylko że uśpiony komputer nie ma adresu IP i może odpowiadać jedynie na broadcast ( 255.255.255.255 ).

  • #7 23 Lip 2008 23:12
    grabek_radek
    Poziom 21  

    chyba znowu temat bladzi
    caly czas podaje wam adres broudcast jako 192.168.1.127 - to nie jest adres IP kompa tylko rozgloszeniowy bo maska jest 255.255.255.128 i jesli wezmiemy ip jakiegos hosta 192.168.1.4 to po przeliczeniu wyjdzie nam
    11000000.10101000.00000001.00000100 -broucast i juz pisalem ze port 7 przekierowny na 11000000.10101000.00000001.00000100
    i przestanmy bladzic w kolo bo to szkoda miejsca na to
    a poza tym pisalem ze robilem to na neo gdzie mam DDNS i przez program wake up lan taki jak na obrazku i to dziala
    problem jest jak chce to zrobic na dsl niby powinno dzialac z zewnatrz sieci a niestety nie dziala

    ROUTER EDIMAX br - 6104k - przekierowania innych portow dzialaja tj 80 21 i wyzsze

    a i jeszcze jedna kwestia tylko nie pytajcie dlaczego maska taka - bo odarazu odpowiem ze we wszystkich tanich routerach nie da sie przekierowac portu na broucast 255 i dlatego maska jest taka jaka jest aby broucast nie wyszel 255

  • #8 11 Lis 2009 14:18
    Arkain
    Poziom 10  

    Odświeżę temat :]

    Ruter D-link DI-524UP
    H/W: A2
    F/W:1.06B02

    Jeśli ktoś chce mieć WoL z internetu to należy wejść w zakładkę zaawansowane -> wirtualny serwer i przekierować np port 7 na 7 adresu rozgłoszeniowego sieci.

    Oczywiście oryginalne oprogramowanie na to nie zezwala w przypadku końcówki 255 jeśli jednak ktoś chce dodać takie przekierowanie należy w polu adres przeglądarki wkleić ten kod i nacisnąć enter :]

    http://IP_RUTERA/Advanced/adv_virtual.xgi?set...hedule/endDay=0&endSetPath=1&CMT=1&EXE=Vrtsrv

    gdzie:

    IP_RUTERA - to ip rutera w postaci xxx.xxx.xxx.xxx
    IP_ROZGLOSZENIOWE - to ip rozgłoszeniowe w postaci xxx.xxx.xxx.255
    privatePort=7 - to ta liczba to port wewnątrz sieci
    publicPort=7 - to port na który z poziomu internetu wysyłamy pakiet :]

    Na liście wirtualnych serwerów będziemy od tej pory mieli WoL :] :D POZDRAWIAM!

  • #9 22 Gru 2009 12:33
    mlesniew
    Poziom 10  

    Zastosowałem się do ww porad ale mimo wszystko budzenie z netu mi nie działa. W ramach lokalnej sieci jest OK.

    Mam router D-Link DI-524UP (Firmware Version: v1.06
    Firmware Date: Wed May 14 18:00:58 CST 2008)
    Moje ustawienia:

    LAN
    MAC Address 00:17:9A:9A:A9:20
    IP Address 192.168.0.1
    Subnet Mask 255.255.255.0
    DHCP Server Disabled

    WAN
    MAC Address: XX:XX:XX:XX:XX:XX
    Connection: DHCP Client Connected
    IP Address: XXX.XXX.XXX.XXX
    Subnet Mask: 255.255.252.0
    Default Gateway: XX.XX.51.254
    DNS: 192.168.1.250; 192.168.1.252

    Wszystkie kompy mają na stałe przypisane IP:
    Ten, który chcę budzić ma:
    Adres IP: 192.168.0.5
    Maska podsieci: 255.255.255.0
    Brama domyślna: 192.168.0.1
    Pref. DNS: 192.168.1.250
    Altern. DNS: 192.168.1.252

    W zakładce routera Advanced dodałem Virual serwer dodałem skrypt z powyższego postu i uzyskałem wpis: WoL: 192.168.0.255; UDP 7/7

    Czy coś spaprałem że nie działa mi pobudka przez internet?
    Proszę o rady.

  • #10 09 Lut 2012 11:53
    Arkain
    Poziom 10  

    Problemem może być statyczne ip przypisane na sztywno na kompach. U mnie było przez DHCP przypisane do MAC ;]

  • #11 09 Lut 2012 11:59
    hermes-80
    Poziom 43  

    No to żeś kolego odgrzał kotleta ;)

  • #12 09 Lut 2012 12:12
    Arkain
    Poziom 10  

    Chodzi ci że stary temat?

    No cóż na elektrodzie nie byłem już ze hmmm 3 lat a dziś zadałem nowe pytanie i tak sobie sprawdziłem co kiedyś pisałem i pomyślałem że ten temat może się komuś w przyszłości jeszcze przydać ;D

 Szukaj w ofercie
Zamknij 
Wyszukaj w ofercie 200 tys. produktów TME