Elektroda.pl
Elektroda.pl
X
Elektroda.pl
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

[Atmega16][bascom] Atmega 16 - jak włączyć ?

Hubold 24 Lip 2008 23:26 7691 50
  • #31
    Hubold
    Poziom 11  
    Witam!


    Generator pomógł. Okazało się ,że fusy atmegi się całkiem przestawiły i cksel0...3 były ustawione na 0000 a ja potrzebuję 1111. Teraz pytanie moje polega na tym ,że jak mam podłączony ten generator to nie mogę zaprogramować fusów w żadnym programie który mam ( ISPProg, Bascom-Avr, Pony Prog). Co z tym zrobić. Zn. ustawiam fusy daję zapisz i odczytanie fusów wyświetla mi te same ustawienia co wcześniej . ?

    Pozdrawiam
  • #32
    Balu
    Poziom 38  
    Tzn, że nie zapisuje ich...Albo nie umiesz...:)
    Klikasz potem write fuse? Albo write albo cokolwiek?
  • #33
    Hubold
    Poziom 11  
    Jak ustawię fusy a ustawiam je według tabelki bo akurat mi odpowiada takie ustawienie ze strony Link klikam w bascomie write FS w isprogu też write coś. Później klikam read i pokazuje mi tak jak bym nie zaprogramował.


    Edit

    Wkońcu udało mi się zaprogramować fusy przez Pony proga.
    Tak jak wcześniej pisałem topica nie zamykam , bym mógł wrzucać tu swoje pytania itp. i żeby nie tworzyć kolejnych topiców.
  • #35
    Hubold
    Poziom 11  
    Miło z Twojej strony :]

    Dodano po 1 [godziny] 21 [minuty]:

    Co może być przyczyną wolnego działania programu? Testuję teraz programy do obsługi ds18b20 i przy ostatnim wgraniu programu inicjacja lcd trwa dłużej niż normalnie oraz program wykonuje się znacznie wolniej . Jest w nim animacja przesuwającego sie tekstu ale on sie przesuwa bardzo powoli.
  • #36
    Dr.Vee
    VIP Zasłużony dla elektroda
    Witam,

    Pewnie znowu coś namieszałeś z fuse bitami ;), więc zmieniła się częstotliwość sygnału zegarowego taktującego rdzeń procesora...

    A inne przyczyny - ciężko powiedzieć nie wiedząc co zmieniłeś w programie :)

    Pozdrawiam,
    Dr.Vee
  • #37
    Hubold
    Poziom 11  
    No na pewno coś sknociłem lub samo się sknociło chociaż samo nic się nie robi. Fusy ustawiłem dobrze. I na początku jakieś chyba 3-4 programów normalnie działały. Ja chciałem sprawdzić je jeszcze raz więc wgrywałem i później zaczęły wolno działać a ja wciskałem tylko write .


    Edit


    Się okazało ,że przy wylutowywaniu kwarcu uszkodziła się ścieżka gnd przy jednym kondensatorze i kwarc padł. Wymieniłem go na 8 MHz i działa :)
  • #38
    adass
    Poziom 25  
    Co zmienić w kodzie żeby wyświetlał to samo ale w takim połączeniu jak na schemacie atmega16 z lcd ?
    Przypinam lcd i zmieniam kod do portów A działa ok.
    Przepinam lcd i zmieniam kod do portów B i D działa ok.
    Przepinam lcd i zmieniam kod do portów C nie działa czy porty C są zablokowane ? jak je odblokować ?
    Wyłączam OCDN i JTAGEN nic nie daje.
  • #39
    dawid512
    Poziom 32  
    RW ma być do masy podłączone a żeby korzystać z portu C trzeba wyłączyć JTAGA(czyli upewnij się czy jest wyłączony).
  • #40
    adass
    Poziom 25  
    Rw mam do masy i JTAGEN wyłączony i nie działa dalej.
  • #41
    Freddie Chopin
    Specjalista - Mikrokontrolery
    a ktorych nozek zasilania nie podlaczyles, o czym doskonale pisze w datasheecie? no ktorych?

    4\/3!!
  • #42
    adass
    Poziom 25  
    Na portcie C mam tak jak na schemacie . To które mają być podciągnięte ? bo nie wiem .
  • #43
    Freddie Chopin
    Specjalista - Mikrokontrolery
    to co ty tutaj wrzuciles, to nie jest schemat, tylko kropki z kreskami - nic z tego nie wynika. pytam ponownie - ktorych nozek zasilania nie podlaczyles? stwierdziles moze, ze skoro nie uzywasz przetwornika A/C to nie podlaczysz zasilania czesci analogowej?

    4\/3!!
  • #44
    adass
    Poziom 25  
    Nie podłączałem żadnych nóżek ( tylko te co na schemacie). Kropki to nóżki scalaków .
  • #46
    Freddie Chopin
    Specjalista - Mikrokontrolery
    adass napisał:
    Nie podłączałem żadnych nóżek ( tylko te co na schemacie). Kropki to nóżki scalaków .

    ty chyba nie wiesz jak wyglada schemat...

    4\/3!!
  • #47
    Balu
    Poziom 38  
    CO Ty od niego chcesz:D Wyczesany schemat :D:D
  • #48
    adass
    Poziom 25  
    Nie mam schematu tylko sam projektuje i każda pomoc mile widziana . To ma być sterownik z miękkim startem i hamowaniem z nastawem mocy silnika od 0 %- 100% furtką otwarcia od 0% do 100% przekaźniki oświetlenia zew. sterowany modułem radiowym itd.
  • #49
    Balu
    Poziom 38  
    Jemu chodziło o to, że to co pokazałeś TO NIE BYŁ SCHEMAT nawet Twój, to było coś na ksztalt, ale karygodne...
  • #50
    adass
    Poziom 25  
    A czyj to jest schemat jak nie mój to pokaż mi taki drugi .
  • #51
    Balu
    Poziom 38  
    Ehhh chodziło mi o to, że to NIE BYŁ SCHEMAT a coś na kształt (aczkolwiek daremne) z drugą częścią zdania, to nawet jeśli Ty to zrobiłeś, to wciąż NIE JEST TO SCHEMAT.

    Może za dużego skrótu użyłem myślowego, co do ostatniego Twojego posta... no cóż:) Tylko raport pozostaje.