Elektroda.pl
Elektroda.pl
X

Wyszukiwarki naszych partnerów

Wyszukaj w ofercie 200 tys. produktów TME
Europejski lider sprzedaży techniki i elektroniki.
Proszę, dodaj wyjątek elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

ThinkPad 560 - upgrade BIOSu, bez baterii, bez FLASH2.exe

MCbx 24 Lip 2008 01:20 1187 0
  • #1 24 Lip 2008 01:20
    MCbx
    Poziom 28  

    Mam IBM ThinkPada 560, jakiś starszy Pentium I. BIOS jest w wersji 1.04, a na stronie znalazłem 1.2, które ma wsparcie Win98 i dysków >2.1GB. Zależy mi głównie na tym wsparciu dysków.
    Tak więc przeszedłem do aktualizacji. Jak zwykle okazało się, że bateria jest zbyt słaba. Niestety na baterie Li-Ion nie ma takich lekarstw, jak zamrożenie, po czym upuszczenie na podłogę, po czym raz się ładuje (działało przy TP755CSE i TP850, gdzie były niklówki).
    Na dyskietce nie ma FLASH2.EXE, czyli zdalnego programu, który wywołany z parametrem /U powoduje bezwarunkowe wgranie BIOSu. Ta metoda odpada.
    Druga metoda (z programem PHLASH) też nie zadziała, bo tam trzeba mieć PLATFORM.BIN (w notacji IBMa plik .FL3) - u mnie jest tylko .FL1 czyli plik BIOSu właściwego.

    W sumie lista plików jest taka:
    CONFIG.SYS (zawiera DEVICE=flshbios.sys)
    FLSHBIOS.SYS
    COMMAND.COM
    USERINT.EXE (wyświetla menu: readme/flash)
    UTILINFO.EXE (readme)
    IBMBIO/IBMDOS.COM (systemowe)
    UPDTFLSH.EXE (sprawdza obecność AC i naładowanie baterii i jeżeli OK flashuje)
    $0020000.FL1 (BIOS właściwy)

    Uruchamianie z dysku, wiersza poleceń itp. skutkują tylko komunikatem o uszkodzonej dyskietce.

    Postanowiłem oszukać baterię. To Li-Ion 10.8V z dość złożoną elektroniką z dwoma płytkami pokrytymi mnóstwem scalaczków SMD. Otworzyłem ją i zajrzałem do środka.
    Jest tam 9 baterii połączonych chyba 3 po 3 szeregowo. Od baterii zauważyłem następujące wyprowadzenia:
    - Dwa (czarny i czerwony) przewody od końców zespołu
    - Trzy przewody cieńsze, od każdego bloku 3 baterii.

    Nie mam bladego pojęcia jak się zabrać do oszukania baterii, że są naładowane. Odłączyłem te dwa grube przewody od ogniw i podłączyłem doń komputerowy zasilacz AT, ale to nie działa, bo bateria chyba musi mieć "wywiad" z tych 3 mniejszych podłączeń. Połączyłem przewody z powrotem i wpiąłem zasilacz równolegle mierząc na bateriach napięcie. Woltomierz wskazuje max. 9.2V a laptop nadal twierdzi, że nie ma naładowanej baterii.

    Czy ma ktoś jakiś pomysł, jak zaktualizować BIOS? Męczę się z tym już dość długo.

    0 0
TME logo Szukaj w ofercie
Zamknij 
Wyszukaj w ofercie 200 tys. produktów TME
TME Logo