Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

ICL7107 kłamie - nieliniowość pomiaru...

ks_robak 29 Lip 2008 22:14 3154 10
  • #1 29 Lip 2008 22:14
    ks_robak
    Poziom 15  

    Chciałem sobie ułatwić życie i kupiłem termometr 4-kanałowy do samodzielnego montażu na ICL7107 + 4xLM35. No i zaczęło się.... Najpierw o mało nie uszkodziłem LM35, bo na płytce odwrotnie oznaczyli zasilanie dla czujników - napisałem o tym do serwisu producenta - przyznali się do błędu i chcieli wysłać czujniki. Teraz mam kolejny problem, który również zgłaszałem do serwisu, ale po radzie bym wymienił ICL nie wiedzą co dalej.

    A problem jest następujący: Kiedy czujniki dostarczają do ICL'a ok. 250mV to wskazanie na wyświetlaczu jest prawdziwe, czyli 25 st., natomiast kiedy czujniki (obudowane) zanurzę w wodzie o temp. ok. 85st. i czujniki serwują ok. 850mV, to wyświetlacz pokazuje ok. 65st. Napięcie z czujników dochodzi nie zaniżone do nogi 31 ICL'a. Pomiędzy nogą 35 i 36 mam ustawione 1000mV.
    Czy ktoś jest w stanie odgadnąć, z czego wynika ta nieliniowość pomiaru?

    ICL7107 kłamie - nieliniowość pomiaru...[/img]

    0 10
  • #2 29 Lip 2008 22:58
    GBW
    Poziom 28  

    Błędy; wyświetlacz jest zasilany przez opornik R8 R7.układ 7107 brak zasilania V+ na nogę 1 jednocześnie brak zasilania na potencjometr odniesienia.To tak na szybko .Na stronie www.elenota.pl znajdziesz schemat połączeń układu ICL7107 i sprawdż resztę.

    Cztałem i nadal twierdzę że R4 i noga nr 1 musi być zasilana z Vcc inaczej napięcie odniesienia ( noga 36) będzie pływać.

    0
  • #3 29 Lip 2008 23:53
    Wiech26
    Poziom 19  

    Czy na tym schemacie "połączenie pomiędzy płytkami"piny łączą się tak jak są narysowane? Dlaczego kropka DP1 zasilana przez R9 jest połączona z (+) anod wyświetlaczy.Pin5 od prawej 1 ICL łączy się z D DP4...a RESET z G2(25 ICL)....coś ten schemat pogięty.

    0
  • #5 30 Lip 2008 09:46
    ks_robak
    Poziom 15  

    GBW napisał:
    ...R4 i noga nr 1 musi być zasilana z Vcc inaczej napięcie odniesienia ( noga 36) będzie pływać.

    Nie ma tego na schemacie, ale noga 1 jest zwarta z Vcc.

    Wiech26 napisał:
    Czy na tym schemacie "połączenie pomiędzy płytkami"piny łączą się tak jak są narysowane? Dlaczego kropka DP1 zasilana przez R9 jest połączona z (+) anod wyświetlaczy.Pin5 od prawej 1 ICL łączy się z D DP4...a RESET z G2(25 ICL)....coś ten schemat pogięty.

    Jest pogięty, bo na płytce jest dobrze.

    GBW napisał:
    Jeszcze jeden problem; noga 32 ma być podłączona do masy.

    Podłączyłem - dało to tyle, że musiałem na nowo ustawiać napięcie odniesienia, błąd jest nadal.

    Wszystkie funkcje układu działają: przełączają się czujniki, napięcie z czujników do ICL dochodzi nienaruszone, przetwornica dostarcza -5V, wyświetlacz działa poprawnie.
    Kłopot jest tylko z nieliniowością pomiaru, tzn., przy 250mV z czujnika termometr pokazuje 25st, ale przy 800mV pokazuje 60st - a powinien 80st.

    0
  • #6 30 Lip 2008 23:00
    Wiech26
    Poziom 19  

    Zmierz jeszcze napięcie referecyjne(1000mV)przy różnej ilości zaświeconych elementów wyświetlacza.Być może stabilizacja napięcia zasilającego nawala i siada równocześnie referencyjne.Jeśli do wejścia pomiarowego dochodzi te 850mV z czujnika to musi tyle pokazać...chyba że napięcie odniesienia pływa i falszuje wynik pomiaru.Nic tu więcej nie można wymyśleć.Obejrzałem płytke do tego układu w EdW 12/2000...szyny zasilania prowadzone nieciekawie...długa szyna (+) zasila wszystko po drodze a na końcu ICL,Uref i wyświetlacze...być może tu tkwi błąd.

    0
  • #8 31 Lip 2008 09:24
    ks_robak
    Poziom 15  

    Jest sukces! Trafiłem z 3 metrów układem do kosza :-)
    Dziękuję wszystkim za pomoc, z braku czasu muszę się poddać.

    0
  • #9 24 Sie 2008 18:48
    Anonymous
    Użytkownik usunął konto  
  • #10 24 Sie 2008 18:55
    ks_robak
    Poziom 15  

    Odłącz R5 - jest szansa, że zadziała, ale nie będzie pomiaru ujemnych temperatur.

    0
  • #11 02 Wrz 2008 20:31
    cooltygrysek
    Warunkowo odblokowany

    zdaje mi się że odpowiedzią są klucze 4052 co dziwne bo przy małych napięciach pomiarowych rzędu milivolt nie powinno się ich stosować ( spadki napięć ).... polecił bym zmierzyć napięcie na wyjściu 4052. Dla mnie lepszym rozwiązaniem było by zastosowanie przekażników przełączanych sekwencyjnie zamiast kluczy!!!!!
    Według mnie układ nadaje się totalnie do kosza jest niedopracowany !!!

    0