Elektroda.pl
Elektroda.pl
X

Search our partners

Find the latest content on electronic components. Datasheets.com
Elektroda.pl
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

Triak załączający zwarcie - problem

25 Aug 2008 16:36 2162 10
  • Level 10  
    Witam.
    Mam problem następującej natury: Potrzebny jest mi układzik załączający zwarcie na transformatorze na bardzo krótki okres czasu (rzędu kilku ms). Wymyśliłem sobie żeby zrobić to na triaku wyzwalanym przez mikrokontroler. Tak więc wykombinowałem sobie taki układzik:
    Triak załączający zwarcie - problem
    gdzie: V2 - transformator dający 18V/50Hz o wydajności 1A, natomiast V3 ma symulować port mikrokontrolera. Na wyjściu tegoż układu spodziewałem się, przy 0V na bramce triaka, uzyskać ładną sinusoidę (tak też wynikałoby z symulacji w PSpice). Natomiast w rzeczywistości przebieg na wyjściu wygląda tak:
    Triak załączający zwarcie - problem
    Podkreślam że jest to przebieg gdy nie podaję napięcia na bramkę triaka.
    Byłbym bardzo wdzięczny gdyby ktoś był w stanie wyjaśnić mi dlaczego tak się dzieje i ewentualnie podsunąć jakieś rozwiązanie.

    Jeśli popełniłem jakieś kardynalne błędy przy obmyślaniu układu to proszę o wyrozumiałość ;)
    [Szkolenie 22.06.2021, g.9.30] Zabezpieczenia Internetu Rzeczy (IoT) programowe i sprzętowe. Zarejestruj się za darmo
  • User removed account  
  • Level 10  
    Hmm a jaką funkcję miałby pełnić mostek prostowniczy, bo w stanie niewyzwolonym chciałbym na wyjściu mieć jednak napięcie sinusoidalne?
  • Level 22  
    Być może nie zauważyłem, ale w jaki sposób przez R2 i R3 płynie prąd bramki? Ja mam wrażenie, że zamienione są wyprowadzenia A1 i A2. Sprawdź z załącznikiem.
  • User removed account  
  • Level 14  
    Najprawdopodobniej pomyliłeś wyprowadzenia T1 i T2.
    Wówczas prąd bramki zamyka się przez szeregowo połączone: R2, R3, złącze bramki i R4.
    Przy napięciu chwilowym źródła ok. 18V (Twój oscylogram), prąd w obwodzie bramki wynosi około 5mA, co jest wystarczające do wyzwolenia triaka (zobacz parametr Igt w tabeli "Static Characteristics" http://www.ladelec.com/datasheet/BT136-600F.pdf).

    Pozdrawiam.

    Przeoczyłem wypowiedź kolegi deseng.
  • Level 10  
    Quote:
    Ja mam wrażenie, że zamienione są wyprowadzenia A1 i A2. Sprawdź z załącznikiem.


    Fizycznie układ jest połączony dokładnie tak jak w załączniku.

    Quote:
    Odwrotne włączenie triaka odpada, bo to nie rzeczywistość tylko symulacja.


    Przebieg który jest na oscylogramie to jest rzeczywiste napięcie a nie symulacja.
  • Level 14  
    Spróbuj jednak zamienić miejscami T1 z T2.
  • Level 10  
    NIe wiem jak to możliwe ale pomogło przelutowanie od nowa jednego ze styków. Teraz przebieg wraz z wywołanym sztucznym zwarciem wygląda tak:
    Triak załączający zwarcie - problem
    Częstotliwość napięcia to 50Hz, więc jak widać zwarcie trwa dobre kilkadziesiąt ms. Problem w tym, że wyzwalam triak impulsem rzędu us. Czy to możliwe żeby triak miał takie opóźnienia?
  • Level 14  
    Co jest źródłem impulsów wyzwalających?
  • Level 10  
    Port mikrokontrolera. A dokładnie at89c5131.

    Dodano po 1 [godziny] 45 [minuty]:

    Problem nieaktualny. Okazało się że przy pisaniu programu na mikrokontroler nie wziąłem pod uwagę drgań styków przycisku którego używałem do uruchomienia mikrokontrolera. Sorry za zamieszanie:)
    Wygląda na to że układ jednak działa w postaci takiej jaką podałem na początku. W każdym razie dziękuję wszystkim.

    Pozdrawiam.
pcbway logo