Elektroda.pl
Elektroda.pl
X

Wyszukiwarki naszych partnerów

Wyszukaj w ofercie 200 tys. produktów TME
Europejski lider sprzedaży techniki i elektroniki.
Proszę, dodaj wyjątek elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Układ czasowy na 4541 - gdzie jest błąd?

ombre24 03 Wrz 2008 21:47 2798 15
  • #1 03 Wrz 2008 21:47
    ombre24
    Poziom 11  

    Proszę Was o pomoc bo nie mogę sobie sam poradzić.
    W dużym skrócie działanie układu: po włączeniu zasilania obydwa timery się zerują, jako pierwszy działa IC2, gdy "odliczy" ustawiony czas przełącza się na IC1 i tak na zmianę.
    Poniższy układ został przeze mnie sprawdzony i wszystko działało bardzo dobrze, zgodnie z obliczeniami teoretycznymi itd. Zbudowałem drugi układ - praktycznie taki sam, dołożyłem tylko mikroswitche i diody sygnalizacyjne na wyjściach 4541. Niby układ działa ale nie działa, tzn. przedziały czasowe realizowane są oki tylko IC1 jakby cały czas był wyłączony. Tego właśnie nie rozumiem. Niby IC1 odlicza ustawiony czas, ale na jego wyjściu jest 0 a powinien być stan wysoki.
    Sprawdzałem płytkę, sprawdzałem połączenia, sprawdzałem poprawność podłączeń i wszystko gra.
    Pomóżcie - gdzie szukać błędu?
    Coś mi się wydaje że SRES w ogóle nie spełnia swojej funkcji. Z czym go "ugryźć"?
    Układ czasowy na 4541 - gdzie jest błąd?

    0 15
  • #2 03 Wrz 2008 22:02
    Paweł Es.
    Pomocny dla użytkowników

    MASTER RESET podawany na nóżkę 6 jest aktywowany stanem wysokim, który podajesz cały czas z przełącznik SRES. Czyli jakby ten lewy czasomierz jest cały czas zerowany ?

    Czy te przełączniki to są stabilne czy to przyciski przełączne ?

    Poza tym mogą tu działać odbicia styków przy przełączaniu (tak jakbyś podał ciąg impulsów zamiast jednego.

    Przydał by się też od wejścia 6 do masy rezystor, np. 10k by w momencie rozwarcia górnych styków został na tej nóżce wymuszony stan niski (czyli umożliwiona praca układu).

    0
  • #3 03 Wrz 2008 22:06
    piotr_ino
    Poziom 17  

    Witam,
    jeżeli tak podłączyłeś SRES to to na IC1 RES stan wysoki wymusza niski na Q. Zamień wyprowadzenia 1 i 3 SRES i będzie OK.

    0
  • #4 04 Wrz 2008 15:53
    ombre24
    Poziom 11  

    Paweł Es. napisał:
    Czy te przełączniki to są stabilne czy to przyciski przełączne ?

    Wszystkie te przełączniki są bistabilne.

    Jeśli chodzi o przełącznik SRES - ma to działać w taki sposób, że albo podaje VDD na we RES IC1 i go blokuję a co za tym idzie IC2 działa cały czas (niezależnie od ustawionego czasu na oscylatorze), lub (w drugiej pozycji) wy Q IC2 jest zwarte z we RES IC1 i układy te działają naprzemiennie.

    Paweł Es. napisał:
    Przydał by się też od wejścia 6 do masy rezystor, np. 10k by w momencie rozwarcia górnych styków został na tej nóżce wymuszony stan niski (czyli umożliwiona praca układu).

    Mówisz o nóżce nr 6 IC1 ?

    Paweł Es. napisał:
    Poza tym mogą tu działać odbicia styków przy przełączaniu (tak jakbyś podał ciąg impulsów zamiast jednego.

    tzn.?

    0
  • #5 05 Wrz 2008 00:20
    elkard
    Poziom 35  

    A czy te układy według twoich zamierzeń mają pracować jako monostabilne czy astabilne ?

    Dodano po 18 [minuty]:

    Mogę się mylić bo pora już późna ale mi wychodzi że to powinno być tak.

    Układ czasowy na 4541 - gdzie jest błąd?

    0
  • #6 05 Wrz 2008 21:35
    ombre24
    Poziom 11  

    elkard napisał:
    A czy te układy według twoich zamierzeń mają pracować jako monostabilne czy astabilne ?

    monostabilnie
    AR i MO były źle podłączone - powinno być tak jak narysowałeś elkard. To co jeszcze znalazłem to źle były podłączone przełączniki SIC1 i SIC2 - jakieś tam niepotrzebne rezystory "się pojawiły" (wywaliłem to).
    Teraz znowu układ zachowuje się inaczej - po odliczeniu ustawionego czasu włącza się IC1, chociaż na wy IC2 (który powinien działać jako pierwszy) jest brak napięcia po włączeniu układu.
    Jak przełącze SRES tak aby IC1 był cały czas zerowany to gaśnie mi cały układ.
    Układ czasowy na 4541 - gdzie jest błąd?

    0
  • #7 05 Wrz 2008 21:44
    elkard
    Poziom 35  

    A próbowałeś dać przełącznik SRES tak jak Ci narysowałem ?

    0
  • #8 05 Wrz 2008 21:49
    ombre24
    Poziom 11  

    Nie próbowałem. Ale w sumie co to zmienia, przecież tak samo jest podłączony w moim układzie tylko na IC1. Chodzi mi o to żeby była możliwość blokowania IC1 i tym samym pracy ciągłej IC2.

    0
  • #9 05 Wrz 2008 21:53
    elkard
    Poziom 35  

    Może się mylę ale z mojej analizy wynika że jest to sposób na realizację twoich założeń. Ale jeszcze raz to prześledzę dla pewności. A jest duża trudność żeby to zmienić ?

    0
  • #10 05 Wrz 2008 22:01
    ombre24
    Poziom 11  

    elkard napisał:
    A jest duża trudność żeby to zmienić ?

    No trochę byłoby problemu. Twoim sposobem można by to zrobić, ale trochę inaczej podłączając przełącznik, mianowicie końcówkę 1 trzeba by podłączyć do masy, wtedy by miało sens.

    0
  • #11 06 Wrz 2008 03:24
    elkard
    Poziom 35  

    To jeżeli na nóżkę 6 IC2 będziesz podawał 0 (zero logiczne) to układ ten właśnie będzie odmierzał czas. Z tego co zrozumiałem przy tej pozycji przełącznika układ ma nie pracować (nie odmierzać czasu) a na nóżce 8 IC2 ma cały czas występować 1 (jedynka logiczna). Czy nie tak to zrozumiałem ?

    Dodano po 5 [godziny] 8 [minuty]:

    Jeżeli jest problem z przełożeniem przełącznika to możesz to zrobić w prostszy sposób. Przełącznik pozostaje w tym samym miejscu a potraktuj te układy jakby były w odwrotnej kolejności, czyli tranzystor podłącz do IC1, no i zmień stany wejść Q/Q.
    O coś takiego.

    Układ czasowy na 4541 - gdzie jest błąd?

    0
  • #12 06 Wrz 2008 08:04
    ombre24
    Poziom 11  

    elkard napisał:
    To jeżeli na nóżkę 6 IC2 będziesz podawał 0 (zero logiczne) to układ ten właśnie będzie odmierzał czas. Z tego co zrozumiałem przy tej pozycji przełącznika układ ma nie pracować (nie odmierzać czasu) a na nóżce 8 IC2 ma cały czas występować 1 (jedynka logiczna). Czy nie tak to zrozumiałem ?

    ombre24 napisał:
    Chodzi mi o to żeby była możliwość blokowania IC1 i tym samym pracy ciągłej IC2.


    W sumie przełożenie przełącznika jest problemem, ale chyba jednak najmniejszym, także lepiej byłoby dla mnie zostawić kolejność działania timerów a pokombinować z przełącznikiem. Jeszcze raz napisze, żeby nie było nieporozumień.
    Zależy mi na takiej opcji aby
    1. IC1 był zablokowany (na stałe) a IC2 żeby cały czas działał (niezależnie od ustawionego czasu)
    2. timery naprzemiennie się przełączały - jak jeden odliczy to załącza drugi i tak na przemian (a jak jeden z nich odlicza to blokuje drugi).

    Tak się zastanawiam nad podłączeniem końcówek Q/Q. Jeśli podamy na to wejście 0 to "po zliczeniu impulsów zmienia się stan wyjścia układu z 0 na 1", a wyjście to przecież jest podłączone do Q drugiego układu, czyli zamiast go uruchomić to blokuje. Dobrze to rozumuje czy się mylę?

    0
  • #13 06 Wrz 2008 14:42
    elkard
    Poziom 35  

    ombre24 napisał:

    Tak się zastanawiam nad podłączeniem końcówek Q/Q. Jeśli podamy na to wejście 0 to "po zliczeniu impulsów zmienia się stan wyjścia układu z 0 na 1", a wyjście to przecież jest podłączone do Q drugiego układu, czyli zamiast go uruchomić to blokuje. Dobrze to rozumuje czy się mylę?

    Tak to wszystko się zgadza, tylko musisz prześledzić to dalej, zresztą popatrz na to.

    Układ czasowy na 4541 - gdzie jest błąd?

    0
  • #14 06 Wrz 2008 20:20
    ombre24
    Poziom 11  

    elkard napisał:
    zresztą popatrz na to

    tzn. mam rozumieć, że IC2 po odliczeniu wysyła impuls, który załącza IC1?

    0
  • #15 06 Wrz 2008 20:42
    elkard
    Poziom 35  

    IC2 po odmierzeniu czasu ustawia na wyjściu 1 która jest podawane na wejście IC1 i je kasuje w wyniku czego na wyjściu IC1 pojawia się też 1 podawana jest ona na wej. IC2 kasuje go i ustawia na wyjściu 0 .
    Ten punkt wykresu czasowego to jest takie wzajemne zresetowanie się liczników, stąd pojawia się tylko taki krótki impuls w punkcie A-C.
    Po tym zresetowaniu w punkcie A pojawia się 0 i zaczyna się odmierzanie najpierw IC1 następnie IC2 a po tym powtórzy cię ten cykl z 1 kasującą obydwa liczniki.
    Trochę to zagmatwane i może trudno za tym nadążyć ale powinno działać. Proponował bym to jednak wypróbować.
    Możesz sobie taki wykres sam narysować śledząc po kolei co się będzie działo krok po kroku.

    0
  • #16 06 Wrz 2008 21:01
    ombre24
    Poziom 11  

    Teraz układ działa w ten sposób: IC1 jako pierwszy odliczy (czyli ok), po ustawionym czasie na wy IC1 pojawia się 0 i powinien liczyć IC2, ale wygląda na to że układ gaśnie, bo nie przełącza się na IC1. Teraz to już nie wiem co jest nie tak. W najbliższym czasie będę miał możliwość sprawdzenia układu na oscyloskopie to myślę że w końcu zobaczę co jest nie tak.

    0
TME logo Szukaj w ofercie
Zamknij 
Wyszukaj w ofercie 200 tys. produktów TME
TME Logo