Elektroda.pl
Elektroda.pl
X
PCBwayPCBway
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Compaq series PDP-124P model: PS-5181-1HFE 185W - warto naprawiać?

08 Wrz 2008 09:59 13682 24
  • Poziom 14  
    Witam.
    W komputerze HP COMPAQ D530 uszkodzeniu uległ zasilacz (185W).
    Zgodnie z informacjami na stronie PDP124P Repair Notes usiłowałem chociaż zdiagnozować usterkę - i okazało się że uszkodzony jest MOSFET.
    Lecz ponieważ jest on "przebity" - uszkodzenie objęło również jego sterowanie (wymiana nie dała żadnych rezultatów)

    Czy jest szansa (i sens) na jego naprawę?
    W przypadku "zwykłych" zasilaczy ATX do składaków, to wiem że nie warto, ale ten typ nie jest łatwy do zdobycia.

    Obecnie komputer zasilany jest przez zasilacz z komputera Fujitsu-Siemens, bo tylko on miał tak długie kable.
    I chyba tak zostanie na dłużej.

    Pozdr. Grasser.
  • PCBwayPCBway
  • PCBwayPCBway
  • Poziom 14  
    Zasilacz nie wydziela żadnych dźwięków, a napięcie podawane przez zasilacz wynosi:
    1V w gałęzi +12V i +5V na pinie 9 (stand-by)
    Wymieniłem tylko MOSFET, a jakie proponujesz dalsze działania?
    Pozdawiam. Grasser.
  • Poziom 14  
    Posprawdzałem jeszcze raz i R11 był uszkodzony - wręcz niezauważalnie - wymieniłem na 0,22Ω zalecany na stronie, (oryginalnie był 0,24Ω).
    MOS-fet wymieniłem - zamiast:
    2SK3548 - 900V/10A
    dałem:
    2SK2148 - 600V/12A - mieści się w parametrach pracy, akurat taki mam "w szufladzie".
    Obecnie zasilacz obciążony HDD zakręci wentylatorem, napięcie na gałęzi +12V pojawia się, ale zaraz opada do około 1V.
    Compaq series PDP-124P model: PS-5181-1HFE 185W - warto naprawiać?Compaq series PDP-124P model: PS-5181-1HFE 185W - warto naprawiać?Compaq series PDP-124P model: PS-5181-1HFE 185W - warto naprawiać?Compaq series PDP-124P model: PS-5181-1HFE 185W - warto naprawiać?
  • VIP Zasłużony dla elektroda
    Poskąpiłeś fotek... (wiem, że są ale takie malutkie)

    Od strony druku zdaje się że widać wyprowadzenia dwóch transoptorów. W tą większą płytkę wlutowana jest pionowo mniejsza - pewnie przetwornica dodatkowa i to ona daje +5V.

    Jeden transoptor to pewnie element sprzężenia zwrotnego dla UC3845, a drugi transoptor być może służy do załączania większej przetwornicy - jak się ma Q3=KSP2907A?

    Do sprawdzenia - w stanie załączenia - zasilanie (Vcc) dla UC3845 -> noga 7 względem 5 (masa gorąca).
    Jakimś sposobem na sprawdzenie UC3845 jest podanie mu na zewnątrz zasilania (12V) i sprawdzenie czy ma na nodze nr. 8 swoje Vref=5,0V.
    Tam na pewno był 2SK3548?
  • Poziom 14  
    Fotki poprawiłem.
    U3 i U2 - sprawdzone pod względem przewodzenia diody w jedną stronę, oraz brak zwarcia z drugiej strony. Niewykluczone że trzeba sprawdzić ich działanie w układzie. Sam miernik nie da rady.
    Q2, Q3 - sprawdzone.
    Zasilanie UC - podać mu "z zewnątrz" zasilanie 12V? Np. z zasilacza warsztatowego?
    Noga nr 7 podać plus?
    Noga nr 5 podać minus?
    Tak, MOSfet był 2SK3548

    Jutro zmierzę napięcia na UC, jeżeli będzie brak napięcia zasilającego (7 i 5 noga), podam zasilanie z zewnątrz.

    Pozdrawiam Grasser.
  • VIP Zasłużony dla elektroda
    Ok, czy w tym zasilaczu masz taki wtyk?
    Jak odpalasz "ręcznie" zasilacz (mam nadzieje że tak robisz bo nie napisałeś) to czy masz zmiany napięć na Q2=MPS6657 -> czyli Q2 zapewne odcina napięcie (wytwarzane przez obwód na pionowej płytce) do nogi 7 UC3845BN w zależnosci od stanu na pinie 'Power On-Standby'.

    Te porady to tak na ślepo wg. Twoich fotek :wink:
  • Poziom 14  
    Wtyczka zasilacza jest typowa ATX - nie jest w standardzie DELL. Tym bardziej że komputer jest teraz zasilany ze "zwykłego" zasilacza. No, prawie zwykłego :-)
    Model komputera - HP D530 SFF
    Zasilacz odpalam "ręcznie" - obciążam go starym HDD.
    Przy odpalaniu (zielonym do masy) - faktycznie na nogach 7 i 5 pojawia się na moment napięcie około 12V i znika.
    Poniżej - fotki płytki pionowej.
    Jeszcze mnie intryguje ten US - TOP 244P - z tego co pamiętam - już kiedyś dał mi w kość.
    Na ślepo - powiadasz?
    Oj, chciałbym mieć tak dobry wzrok.....

    Compaq series PDP-124P model: PS-5181-1HFE 185W - warto naprawiać?Compaq series PDP-124P model: PS-5181-1HFE 185W - warto naprawiać?Compaq series PDP-124P model: PS-5181-1HFE 185W - warto naprawiać?
  • VIP Zasłużony dla elektroda
    TOP244P z towarzyszami zajmuje się 'wytwarzaniem' +5V_Aux (co nawet na laminacie mniejszej płytki - na której siedzi TOP - jest napisane).
    Jest stabilne +5V (można czymś obciążyć) ?
    Jak tak to spełnia swoją role.

    Teraz przydałoby się te około 12V do zasilenia UC3845, mogłoby to być tak (z małymi modyfikacjami jak TOPSwitch-GX zamiast TOPSwich-II, gasik TVS+D zamiast RCD, itd.)

    Compaq series PDP-124P model: PS-5181-1HFE 185W - warto naprawiać?

    Poprostu sprawdź na pierwszej (jak podejrzewam) szpilce kątowego złącza od strony sieci obecność napięcia (względem masy gorącej), potem napięcie na bazie Q2 - MPS6657 lub B1116SY czy się zmienia w takt odpalania (zielonym do masy).
    Chyba czujesz o co chodzi :D

    Na większej płytce jest dłuższy rezystor R2 - czy jest sprawny i jaką ma wartość?
  • Poziom 14  
    Tak, z płytki uzyskuję +5V, który idzie do pin nr.9 na wtyczce ATX (fiolet).
    Jest stabilne - obciążyłem żarówką 6,3V/0,3A - żarówka świeci.
    Napięcie na pierwszym pinie od strony sieci - tak, jest 12V (względem masy gorącej - czyli noga nr. 5 UC3845BN), wchodzi na emiter Q2-B1116SY.

    Q2 - B1116SY (EBC)
    E - cały czas +12V, lekko spada przy próbie startu (+11,5V).
    B - cały czas +12V, lekko spada przy próbie startu.
    C- pojawia się napięcie przy próbie startu.

    Q3 - KSP2907A (EBC)
    E - pojawia się napięcie przy próbie startu.
    B - pojawia się napięcie przy próbie startu.
    C - brak napięcia cały czas.

    R2 - 150K tak sprawny.
  • VIP Zasłużony dla elektroda
    Odcinaniem zasilania UC3845BN prawdopodobnie zajmuje się Q2 - B1116SY (PNP)
    Napięcie na bazie Q2 (PNP) powinno spaść o ~ 0,65V w stosunku do napięcia na jego emiterze aby UC3845BN dostał napięcie zasilające (około +12V).
    Do emitera jest doprowadzone napięcie z pomocniczego uzwojenia FBT napędzanego przez TOPSwitch-GX (mniejsze PCB).
    Z kolektora Q2 - B1116SY powinno iść w kierunku nogi nr.7 UC3845BN.
    Bazą steruje poprzez jeden z transoptorów - obwód ze strony wtórnej

    Fotki są zbyt słabe by ocenić czym zajmuje się Q3 - KSP2907A.
    Nie widać też strony wtórnej.
    Musisz więc pokombinować, zobaczyć czy z jakiegos powodu układ z części wtórnej blokuje po chwili start większej przetwornicy.
    Czy oprócz +12V (pomijając oczywiście już +5V_AUX) podnoszą się inne napięcia.
    Można też na końcu metody hardcorowej :wink: - zasilacz szeregowo z żarówką do sieci i zobaczyć efekt ręcznego połączenia C-E Q2
  • Poziom 18  
    Trafił do mnie komputer HP DC7700p z zasilaczem PS-6361-4 o mocy 365W.
    Tranzystorem wykonawczym jest MOSfet 2SK3548,
    podmieniłem na 2SK956 (800V, 9A, 150W).
    Zasilacz na czas obecny pracuje, a macie może gdzieś więcej parametrów dla tajemniczego tranzystora 2SK3548?
  • Moderator
    mieszko I napisał:
    Macie może gdzieś więcej parametrów dla tajemniczego tranzystora 2SK3548 ?

    :arrow: Czy to, aż tak trudne? 2SK3548
  • Poziom 16  
    Czy mógłby ktoś podać wartość rezystora R3 zaznaczony na żółto na obrazku, właśnie trafił do mnie taki zasilacz, wybuchł U1 UC3845BN, i strasznie wszystko zasmoliło, że niemożna odczytać wartości, a spytam jeszcze co to za transoptor U3, i jaki jest jego zamiennik.
    Compaq series PDP-124P model: PS-5181-1HFE 185W - warto naprawiać?
  • Poziom 20  
    Wartość rezystora R3 33Ω i każdy transoptor 4 pin...
  • Poziom 21  
    Proszę o podanie wartości rezystora R5 , jest upalony w moim zasilaczu.
    U mnie siedzi mosfet z oznaczeniem S0322 lub SO 322, zna ktoś pełną nazwę ?
    Mam nadzieję, że mogę wstawić 2SK3548.
    Poprawiłem TONI_2003
  • Poziom 16  
    R5 - 1K , w moim zasilaczu był tranzystor FQA9N90 zamiast niego dałem 2SK2611 i narazie działa.
    :arrow: Dzięki kolego djbully wiem, że transoptor czteropinowy, chodziło mi o konkretny typ, ale już sam do tego doszedłem, jest to LTV816A, zamiast niego dałem LTV816B , różnią sie one parametrem CTR (Current Transfer Ratio),

    LTV816A ma CTR 80-160%
    , a
    LTV816B ma CTR 130-260%

    Jednocześnie w związku z tym mam pytanie jakie znaczenie ma ten parametr i czy jeśli już to lepiej jest dać większy czy mniejszy % ?
    Poprawiłem TONI_2003
  • Poziom 20  
    Ja sie nigdy na tym nie zastanawiałem wkładam co popadnie i działa.
    Oryginalny mosfet to FQA9N90, a jako zamiennik nie nadaje się 9NK90.
  • Poziom 12  
    Mam pytanko, czy zasilacz ten odpala się normalnie (zielony z czarnym pod obciążeniem), czy trzeba robić jakies modyfikacje z P9 zeby go odpalić.
    Probuje go odpalić na sucho po, ale zakreci tylko wiatrakami i tyle jakby zabezpieczenie zadziałało.
    Dodam, ze zasilacz po awarii UC3845, rezystor 22Ω, mosfet, 0,22Ω, oraz 1K.
  • Poziom 16  
    Z tego co pamiętam z mojego przypadku to zasilacz odłączony od komputera i na sztucznym obciążeniu napięć +3V, +5V i +12V miał zaniżone te napięcia, dopiero gdy go podłączyłem do komputera napięcia były poprawne.
  • Poziom 20  
    Arczi26 napisał:
    Mam pytanko, czy zasilacz ten odpala się normalnie (zielony z czarnym pod obciążeniem), czy trzeba robić jakies modyfikacje z P9 zeby go odpalić.
    Probuje go odpalić na sucho po, ale zakreci tylko wiatrakami i tyle jakby zabezpieczenie zadziałało.
    Dodam, ze zasilacz po awarii UC 3845, rezystor 22Ω, mosfet, 0,22Ω, oraz 1K.

    Nie pamietam, ale jeśli wymienileś tylko tyle co napisałeś, to moze ci nie ruszyć.
  • Poziom 12  
    Wszystko ruszyło, tak jak napisał kolega Raftronik trzeba tylko obciążyć wszystkie gałęzie: +3,3V, +5V, +12V, ja obciążyłem tylko: +5V i +12V i stad ten problem ze startem.
    Pozdrawiam