Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Instalacja windows bez CD, za to z linuxem (300pkt!!!)

lord_blaha 20 Wrz 2008 12:23 11535 42
  • #1 20 Wrz 2008 12:23
    lord_blaha
    Poziom 33  

    Witam,
    Sytuacja wygląda tak:: Laptop bez CD (MSI WIND), za to zainstalowanym Linuxem SUSE. Do dyspozycji mam: kartę sieciową, pendrive, kartę pamięci dysk 2,5" na USB. Laptop może bootować z USB i z LANu. Windows kupiony oddzielnie, oryginalny. Dysku nie można wyjąć (tzn. można i to nawet bez utraty gwarancji, ale po prostu nie czuję się na siłach).
    Jak zainstalować Windowsa? Próbowałem z pendrive (kingston data traveller)- wg sposobów opisanych tutaj:
    http://www.jcmiras.net/surge/p96.htm
    http://msiwindforum.pl/viewtopic.php?id=57
    Instalka się włącza, jednak wyrzuca blue screen z kodem błędu STOP. Może można jakoś postawić Windowsa na lapciaku przy pomocy dysku usb 2,5"? Albo można zainstalować Windkę z pod SUSE'a? Albo jakoś LANem?
    Szukałem na Elektrodzie, nawet niedawno był podobny temat, ale dyskusja zeszła na kwestie legalności Wina/gwarancji i nie bardzo coś z tego wyszło...

    Ewentualnie- chętnie pożyczę od kogoś zewnętrzny napęd CD na USB- za, powiedzmy, drobną opłatą- mogę też pokryć koszty wysyłki w obie strony.

    0 29
  • Pomocny post
    #2 20 Wrz 2008 13:01
    MARCIN.SLASK
    Specjalista AGD

    Laptop bez napędu optycznego?
    Jak nie chcesz Linuxa, to kupujesz napęd optyczny na USB Np. taki i instalujesz Windowsa. Przed instalką przydało by się usunąć partycje Linuxa.

    0
  • #3 20 Wrz 2008 13:02
    lord_blaha
    Poziom 33  

    Ok, jakbym chciał kupować DVD to bym dopłacił 100 do WINDa i miał wersje z Windowsem... Patrzyłem tez na obudowy 5,5"- ale w Lublnie w Vico chcieli 129pln...

    0
  • Pomocny post
    #4 20 Wrz 2008 13:40
    askr
    Poziom 35  

    Rybki albo akwarium...

    Pod susłem utwórz partycję FAT32 - taką, żeby CI weszły plik z płyty z windowsa i skopiuj je tam.

    Na alledrogo albo gdzieś kup stację dyskietek na usb.

    Zrób u kogoś dyskietkę startową do XP, odpal wind-a z niej i pod dosem przejdź do partycji gdzie masz zrzuconą instalkę WinXP.

    następnie:

    setup.exe

    Instalka powinna ruszy. Napewno zadziała z pirackimi płytami WInXp, jeśli nie wprowadzili jakichś nowych zabezpieczeń, to powinno ruszyć.

    Wada tej metody - zostanie Ci partycja o rozmiarze ~800 MB z która nie wiadomo co zrobić.

    Możesz też spróbować najpierw zrzucc na pendriva, ale nie wiem czy pod dosem go zobaczy bez dodatkowych zabaw.

    0
  • #5 20 Wrz 2008 14:26
    lord_blaha
    Poziom 33  

    Dobra, mam dyskietkę. MAm w SUse stworzoną partycję C: (tzn z dyskietki można zmienić dysk na C, więc chyba dobrze to zrobiłem. Płytka skopiowana na pendrive i gotowa do wrzucenia na dysk. Partycja jest w folderze "dev" jako sda5, ma ikonkę dysku z czerwonym krzyżykiem i nie bardzo wiem jak tam cokolwiek wrzucić... jakieś sugestie?
    Przy wykorzystaniu komendy (terminal otwarty na pendrivie, konto roota)

    Code:
    cp * sda5
    wyrzuca błąd, że 'sda5' nie jest katalogiem...

    0
  • #6 21 Wrz 2008 00:32
    askr
    Poziom 35  

    Nie używam susła i nie wiem jakie tam jest narzędzie do partycjonowania. Ale musisz w nim stworzy partycję fat 32.

    Następnie, nadal pod susłem skopiować z pena zawartość płyty z Win. Dopiero wtedy odpalasz z dyskietki.

    Zakładam jednak, że dobrze zrobiłeś, i na sda5 masz fat32. Teraz tylko musisz podmontowac to jako fat32.
    Stwórz katalog, np

    Code:
    /home/win
    a następnie, jako root:
    Code:
    mount -t fat32 /dev/sda1 /home/win


    Następnie skopiuj zawartoś pena do /home/win

    A sorrka za kolejny edit ale nie dzisiejszy jestem :)
    Partycja musi by sformatowana. Jako, że znów wyjdzie moja nieznajomoś susła, to z tym będziesz musiał sam sobie poradzic.

    0
  • Pomocny post
    #7 21 Wrz 2008 00:34
    melon2
    Poziom 10  

    sprobuj
    cp ./* /dev/sda5

    0
  • #9 21 Wrz 2008 00:40
    lord_blaha
    Poziom 33  

    hmm...douczyłem się dzisiaj trochę Linuxa. Stworzyłem 2 partycje, Windows przekopiowany. Siedzę aktualnie nad druga dyskietką, bo i dyskietka XP i 98se mówi mi, że setup.exe nie może być odpalony w trybie DOS...
    EDIT: nie odalamy setup.exe, tylko i386/ winnt.exe :) Instalka ruszyła! Bez smart drive,ale jednak :)

    0
  • #11 21 Wrz 2008 10:29
    lord_blaha
    Poziom 33  

    Jakby ktoś chciał przejść przez to tak jak ja, to wyglądało to mniej więcej tak (piszę z pamięci, mogą być błędy)

    Code:
    su
    
    fdisk -l
    <<robimy w YAst 2 partycje- jedną ok 1gb na pliki, drugą, wiekszą na windowsa>>
    mkfs.vfat /dev/sda*    <<*-numer partycji zabranje przez linuxa, któraą chcesz przystosować>>
    mkdir /mnt/inst <tworzymy katalog dla plików instalacyjnych
    mount /dev/sda* /mnt/inst <<montujemy mniejszą partycję>>
    mc
    <<kopiujemy pliki instalacyjne z pendrive albo dysków do /mnt/inst>>
    czyli F5, potem odznaczamy "Zachowanie atrybutów", klikamy ok ;potem ewnetualnie "napisz"
    fdisk /dev/sda
    t
    *- numer partycji z plikami instalki
    c
    w
    <<zmieniliśmy literkę dysku>>
    umount /dev/sda*

    <<po reboocie powinieneś mieć 2 partycje widziane z dos'u
    c:/ z instalką i d: z miejscem na instalke>>

    Potem wkłądamy dyskietke startową win98 albo XP (najlepiej z smartdrive...)
    Code:

    A:/smartdrv.exe
    <<----chwilkę czekamy, włącza się smart drive-->>
    cd C:
    dir
    <<---sprawdzamy czy pliki siedzą tu czy w następnym katalogu, jak tu to:--->>
    cd i386
    winnt.exe
    <<---instalacja rusza--->>
    wskazujemy C:/i386 jako źródło plików




    EDIT: Dodałem polecenie smartdrive'a

    0
  • #13 21 Wrz 2008 13:49
    lord_blaha
    Poziom 33  

    Heh, pojawił sie kolejny problem...
    Najpierw instalator skopiował pliki (bez smardrive)- kopiwał prawie 6h. Wyrzucił komunikat, żeby wyjąc dyskietkę i pyknąć Enter- komp miał się zrebootować i wznowić instalację. Niestety po reboocie szybciutko pokazał się bootscreent Linuxa i można było wybrać tylko reset do ustawień fabrycznych i susa- instalator Windowsa sie nie załadował. Myśle- coś przegapiłem. TYm razem skombinowałem smart drive, przegrałem pliki, znowu reboot- kupa- dalej to samo. Ktoś ma jakiś pomysł jak nie doprowadzić do przerwania instalacji po reboocie?

    EDIT: Próbowałem 2gi raz- to samo. Od razu bootuje do ekranu wyboru SUSE/Ustawienia fabryczne. Co robić?

    Za rozwiązanie problemu zakończone instalcją XP'ka daję 150pkt!!!

    0
  • Pomocny post
    #14 21 Wrz 2008 20:51
    Sam Sung
    Poziom 30  

    Jeśli bootujesz przez grub'a, to może dopisz do pliku /boot/grub/menu.lst takie coś:

    Code:
    title Windows
    
        chainloader (hd0,4)+1
    przy czym 4 odpowiada partycji 5. Po restarcie powinna być dostępna opcja Windows i jeśli już są tam skopiowane pliki, to może nawet zadziała. A jakby się nie chciał stamtąd zabootować, to jeszcze musiałbyś uruchomić znowu DOS-a z dyskietki startowej, zrobić sys a: c: (o ile ten dysk to C) i wrócić do 2. części postu https://www.elektroda.pl/rtvforum/viewtopic.php?p=5555706#5555706 .

    0
  • #15 21 Wrz 2008 20:57
    lord_blaha
    Poziom 33  

    Hmm- linux ok 16 dzisiaj umarł. Tzn wywaliłem go fdiskiem z pod dosa- myślałem, że to pomoże... No cóż, nie pomogło. Teraz próbuje poradzić sobie wg poradnika http://www.vandomburg.net/installing-windows-xp-from-usb/ ;wszystko jest pięknie aż do załadowania BartPE, bo po prostu wyświetla się ten "pulpit" barta, ale bez menu "GO"- no i nie mam pojęcia co mam teraz zrobić. Czekam już 30min a on jakby wisiał...
    Być może uda mi się pożyczyć dzisiaj od kumpla przejściówkę IDE-usb, to spróbuje podłączyć stacjonarny napęd cd do kompa i spróbować normalnej instalacji z płyty...

    0
  • Pomocny post
    #16 21 Wrz 2008 21:02
    tomus2k
    Poziom 23  

    zabotuj z dyskietki lub pena i napisz fdisk /mbr
    tylko skopiuj fdiska na dyskietkę potem zacznij instalkę w instalce usuń wszystkie dyski logiczne i utwórz nowy z ntfs i po sprawie.

    0
  • Pomocny post
    #17 21 Wrz 2008 21:16
    willyvmm
    Poziom 26  

    Zacznij od poprawnego sposobu instalacji, opis jest tu: http://www.3epc.pl/showthread.php?t=211
    Dotyczy to co prawda eee, ale zadziała wszędzie.

    Zanim jednak zaczniesz przygotuj poprawnie dysk, czyli wywal wszystkie partycje, NADPISZ mbr poprawną zawartością (w tej chwili masz tam grub'a prawdopodobnie). Można to zrobić np fdiskiem wpisująć komendę fdisk /mbr lub korzystająć np z programu RanishPartitionManager lub jakiegokolwiek innego który potrafi to zrobić.
    Po nadpisaniu mbr'a zrestartuj komputer aby mieć pewność że w mbr'ze nie ma już loadera linuksowego. JAk jest to jeszcze raz.
    JAk nie, możesz zacząć instalację wg podanego powyżej sposobu.

    Jeśli chodzi zaś o sam sposób instalacji, podany przepis nie jest jedynym możliwym i słusznym. Jeśli zawiedzie jest jeszcze wiele innych :D

    0
  • #18 21 Wrz 2008 21:29
    lord_blaha
    Poziom 33  

    Hmm... fdisk /mbr wyświetla

    Code:
    The master boot record has NOT been updated

    Tak ma być?
    wpisując fdisk, a potem "display partition information" widzę 3 partycję:
    1 EXT DOS 9217Mbytes 85%usage
    2 C: PRI DOS 1506Mbytes FAT32 14%usage <-tu jest chyba i386 i reszta
    3 D: PRI DOS 57545Mbytes FAT32 100% usage

    Co mam teraz zrobić?


    -------------------------------------

    Koledzy!
    Mam teraz napęd CD, mam też FDD. Wszytsko na USB. Próbuje normalnie instalować XPka z płyty, instalator uruchamia się, wgrywa podstawowe pliki i sterowniki (jeszcze przed pierwszym enterem i umową licencyjną) i wyrzuca bluescreen STOP.
    Code:
    STOP: 0x0000007B (0xF7A9463C,0XC0000034, 0X00000000,0X00000000)

    Mówi,żęby sprawdzić dyski itp... Co mam zrobić? Sformatować dyski z pod DOSa? Jest na to jakiś sposób?
    Próbowałem format c: i format d: ale nic nie dało ,wyzrzuca tak samo... 150pkt dalej aktualne...

    0
  • Pomocny post
    #19 21 Wrz 2008 23:05
    mat_ed
    Poziom 43  

    Ściągnij wersję dyskietkową programu Memtest i przetestuj pamięć w tym laptopie.

    0
  • Pomocny post
    #20 22 Wrz 2008 00:15
    PitD

    VIP Zasłużony dla elektroda

    Teraz masz błędy logiczne na dysku.
    Najlepiej to usuń wszystkie partycje za pomocą dyskietki.
    Wtedy powinno dać się zainstalować XP z płyty i nim utworzysz nowe partycje.

    0
  • #21 22 Wrz 2008 00:21
    lord_blaha
    Poziom 33  

    memtest86 v2.01

    Code:

    Pass:1
    Errors:0
    Pass complete, no errors, press Esc to exit

    Czyli pamięć w porządku, nie?
    Przeczytałem ,zę może to być problem spowodowany przez sterownik SATA- ale wydaje mi się, że sp2 załatwia tą kwestię. Czyż nie?

    Jak usunąć partycje dyskietką? Można jakieś krok-po-kroku? Próbuje fdiskiem ,ale nie wiem za bardzo co oznaczają partycje logiczne itp...

    0
  • Pomocny post
    #23 22 Wrz 2008 10:17
    askr
    Poziom 35  

    lord_blaha napisał:
    memtest86 v2.01
    Code:

    Pass:1
    Errors:0
    Pass complete, no errors, press Esc to exit

    Czyli pamięć w porządku, nie?
    Przeczytałem ,zę może to być problem spowodowany przez sterownik SATA- ale wydaje mi się, że sp2 załatwia tą kwestię. Czyż nie?

    Jak usunąć partycje dyskietką? Można jakieś krok-po-kroku? Próbuje fdiskiem ,ale nie wiem za bardzo co oznaczają partycje logiczne itp...


    Nie wiem, czy Sp2 sobie z tym poradzi. Może zachodzić konieczność zintegrowania sterownika sata (poszukaj czegoś takiego jak nlite (chyba tak się nazywa)).

    Ew. w biosie wyłącz sata i ustaw legacy albo ide.

    0
  • Pomocny post
    #24 22 Wrz 2008 10:57
    scalak77
    Poziom 12  

    Moja propozycja

    Znajdź sobie Windows miniPE
    Wypal płytkę z tym systemem
    Uruchom laptopa z tej płytki, jak pojawi się pasek startu to uruchom program do zmiany partycji, usuń wszystkie które są na dysku
    Zatwierdź zmiany
    Zrób restart laptopa
    odpal ponownie z tej płytki załóż nowe partycje i 1 ustaw jako botowalną ( z menu kontekstowego prawo kliku myszy)
    Zatwierdź zmiany
    Restart
    Uruchom z płyty instalacyjnej XP
    Jak się pokaże informacja o formatowaniu do daj szybkie formatowanie (FAT albo NTFS zależy jaką partycje założyłeś)
    Potem instalacja powinna przebiegać w normie

    Ja tak stosuje na kompie gdzie mam dysk na SATA i napęd DVD też na SATA
    Laptop to samo tylko że mam napęd w laptopie w środku i też jest na SATA

    Napisz przy okazji jaki model posiadasz ewentualnie link do niego

    0
  • Pomocny post
    #25 22 Wrz 2008 11:13
    Kakalia
    Poziom 18  

    Przepraszam na wstepie że sie wtrącam w dyskusje, ale czy nie lepiej skorzytać z wirtualizacji - jest to bezpieczniejsze i o wiele bardziej przyjazne uzytkownikowi. Podam prosty przyklad - pracujesz na maszynie gdzie jest tylko XP zainstalowane standardwow masz jakis pliks worda i sobie cos tam robisz, nagle system sie wiesza lub jest problem z zasilaniem, efekt jest taki ze tracisz cześć inforamcji w dokumencia. Natomiast pracujac pod Suse (lub inna dystrybucja) na której stawiasz sobie wirtualizacje (wmvare) stan pracy wirtylanej maszyny na której pracuje XP jest cały czas zaspisywany w efekcie nawet jak gwałtownie wyłączysz zasilanie to dla systemu odpoalonego na wirtualnej maszynie "czas sie zatrzymał" - bedziesz miał otwarte te okienka i dokumenty z którymi pracowałeś.


    Pod Suse proponuje vmware http://www.vmware.com/
    Pobierasz wersje pod tojego pingwinka i masz XP czy co tam chcesz.

    Któs powie że strata wydajności i tu sie myli gdyż takie rozwiązanie znacznie przyspiesza pracę, a z tego co widze i skoro kolega nie ma napedu optycznego to raczej ta maszynka do grania nie bedzie uzywana. Po drugie nic nie stoi na przeszkodzie aby mieć kilka instalacji XP w swojej wirtualnej maszynie i każda do innego celu (programowanie czy CAD/EDA).

    Pozdrawiam i mam nadzieje ze być może taka forma instalacji innego systemu zainteresuje przyszłego użytkownika.

    Pozdrawiam.

    0
  • #26 22 Wrz 2008 11:33
    lord_blaha
    Poziom 33  

    scalak77 napisał:
    Moja propozycja

    Znajdź sobie Windows miniPE
    Wypal płytkę z tym systemem


    Próbowałem BartPE- zawiesz się na "desktopie" barta.
    scalak77 napisał:
    Napisz przy okazji jaki model posiadasz ewentualnie link do niego

    Lapciak to MSI WInd, dysk siedzi w nim 80GB, Western Digital, 5400 o/min- dokładnego modelu nie mogę znaleźć. MSI nie wypuściło sterowników SATA do wind-owej płyty głównej, pozostaje mieć nadzieje w SP2.

    W tym momencie formatuje dyski, zrobiłem dwie partycje. Fdisk widział dysk jako 10gb, czym się specjalnie nie przejąłem, bo jak uda mi się zainstalować Windowsa to poradze sobie z tym jakimś programem do partycjonowania.

    Na wirtualizacje nie mam ochoty- nie lubię linuxów, jestem prostym użytkownikiem komputera, lubię mieć wszystko wyklikane, nie lubię mieć problemów z rootem, na nowo uczyć się komend itd...
    Wole komercyjne rozwiązania Microsoftu- jednak kilkanaście lat pracy na tych systemach jakoś mnie do nich przywiązało.

    0
  • #28 22 Wrz 2008 12:07
    lord_blaha
    Poziom 33  

    No więc tak:
    partycje dwie nowo zrobione, formatnięte. Instalator z płyty. Bluescreen z naszym dobrym znajomym- błędem STOP.

    W BIOSie w zakładce "ide information" jest opcja SATA port0 WDC WD 800BEVS- (80.0GB), niety, nie jest klikalna. Nie mam pojęcia, co mogę zrobić... Spróbuję wgrać na dyskietkę sterowniki od chipsetu, bo innych na płycie za bardzo nie ma...



    EDIT: instalator nie widzi plików od chipsetu na dyskietce, mówiąc żeby włożyc dyskietke obsługi sprzętu przygotowaną przez producenta. W tej chwili kombinuję płytkę ze zintegrowanym Serive Packiem 3- moze to pomoże?
    Kurczę, pierwszy raz taka sytaucja i naprawdę nie wiem co robić...

    0
  • #29 22 Wrz 2008 13:10
    scalak77
    Poziom 12  

    Ja używam Windows mini PE2-XT i nie mam problemów z formatowaniem czy zakładaniem innych partycji, BartPE mnie nie przekonał poniżej fotka z tego systemu
    Instalacja windows bez CD, za to z linuxem (300pkt!!!)

    Co do tego co widzi ci Fdisk to on ma ograniczenia co do wielkości dysku oraz nie widzi partycji innych niż FAT/FAT32 jeśli się nie mylę to nie widzi też NTFS, jedynie powinna się pojawić opcja do usunięcia innych partycji niż wymienione wyżej.

    0
  • #30 22 Wrz 2008 13:53
    lord_blaha
    Poziom 33  

    Ok, Koledzy- jest postęp :)
    Wypaliłem płytkę z Windowsem MX 7, ma zintegrowany SP3. ODpaliłem instalkę z CD po USB, doszedłem do ekranu formatowania. Instalator nie mógł sformatowac C: (5GB). Dałem więc spokój formatowaniu, jako że i tak formatowałem wcześniej pod fdiskiem, więc wybrałem opcję instalacji na dotychczasowym systemie plików. Instalator skopiował pliki na dysk i teraz problem:

    Code:
    Czekaj,aż Instalator zainicjuje konfigurację systemu Windows XP

    A na dole od 30 min jest:
    Cytat:
    Ładowanie pliku informacyjnego dmreg.inf...

    Shit, zawsze wiatr w oczy... Macie może jakieś sugestie?

    -------------------
    Kolejny postęp. Ustawiłem w biosie opcję AHCI na enabled.... i doszedłem do graficznego instalatora :D
    Teraz prosi o podanie pliku asms... skąd moge go wziąść? Patrzyłem http://support.microsoft.com/kb/311755/pl ale nie bardzo jarzę, o co w tym chodzi...

    0