Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Przetwornica AVT-2732 -mała wydajność prądowa przetwornicy.

Kuczus 21 Wrz 2008 11:06 14597 69
  • #1 21 Wrz 2008 11:06
    Kuczus
    Poziom 19  

    Witam, nie wnikając w moje wczorajsze pytania w innym temacie odnośnie rdzenia, mam z tą przetwornicą inny problem, dotąd myślałem że jest wszystko ok, lecz dopiero dziś postanowiłem zrobić pomiary odnośnie skuteczności. Problem tkwi w tym że przetwornica jest strasznie słaba wyniki pomiaru:
    Napięcie zasilania: 12.3 V (akumulator)
    Napięcie wyjściowe: 40V (na razie nawinięty tylko jeden "pęk" wtórny tzn 1x15 zwoi [pierwotne 2x5zwoi] )
    Gdy do wyjścia (wykorzystując zaciski GND oraz +zasilania) podpiąłem rezystor 16,4 ohm prąd pobierany przez przetwornicę wynosił ok 3A a prąd płynący przez ten rezystor na wyjściu, równy był 1,2 A, napięcie zasilania spadło do 11.6V a napięcie na wyjściu przetwornicy spadło o połowę czyli wynosiło 20V

    drugi pomiar to :
    Rezystor obciążający -8.2 ohm
    napięcie zasilania 12.3V akumulator
    prąd pobierany przez przetwornicę ok 3A
    prąd płynący przez rezystor 1.58A
    napięcie na wyjściu przetwornicy spadło do 13.2 V
    napięcie zasilania spadło do 11.6V

    W obu przypadkach częstotliwość pracy przetwornicy: 54kHz
    rdzeń :ETD44-3F3
    i tu moje pytania:
    Czy taka wydajność wynika z błędnie wykonanych pomiarów? (może jakoś inaczej powinien zbadać tą przetwornicę? )
    W przetwornicy zastosowane tranzystory IRFZ44N (ponieważ chwilowo innych nie miałem pod ręką )
    może jeszcze coś powinienem sprawdzić? bo wg moich obliczeń moc tej przetwornicy wynosi ok 30-40W... a to strasznie mało

    0 29
  • Pomocny post
    #2 21 Wrz 2008 22:13
    Qwet
    Poziom 33  

    No jedno wiadomo na pewno, coś jest nie tak. U mnie pod obciążeniem 64ohm napięcie wyjściowe spada z 120 do 90V a napięcie wejściowe z 13 do 12V. Zdarzało mi się że spadało bardziej, do tego zauważyłem że bardzo grzały się mosfety, a po zmniejszeniu opornika wyjściowego mosfety szły z dymem. Sprawdź co u ciebie się grzeje, czy to trafo czy mosfety pochłaniają tyle energii. Jeśli mosfety się grzeją to myślę że masz oscylacje, pewnie jakieś paskudne szpilki powodują krótkotrwałe przebicia tranzystorów i spore straty na ciepło. A robiłeś na płytce czy "na pająka" ??
    W zasadzie 30-40W możnaby osiągnąć bez radiatora, mi się kiedyś udało nawet 50W :) Ale układ udał mi się wtedy wyjątkowo, radiator mosfetów był chłodny przy mocy 120W, maksymalnie szło 220W mocy. W zasadzie mogłoby więcej ale trafo policzyłem tylko na 120W więc przy 220W grzało się potwornie. Jeśli chodzi o spadki to do mocy znamionowej transformatora napięcie było w miarę stabilne, spadało o pojedyncze volty. Dopiero powyżej 150-180W spadki były odczuwalne.

    Dodano po 4 [minuty]:

    Jeszcze jest taka sprawa. Kiedy spalił mi się jeden mosfet, przetwornica działała nadal, ale już takie objawy jak u ciebie, tzn. Spore spadki napięcia, mały prąd. Wymień tranzystory i zobacz czy będzie ok. Możesz nawet dać tranzystory na wyższe napięcie, np. IRF540 ;) Jedna para wystarczy na 100W.

    0
  • #3 22 Wrz 2008 16:08
    Kuczus
    Poziom 19  

    Oto oscylogramy mosfetów, w stanie jałowym przetwornicy:
    1- przebieg na DRENIE V/D=5 / 5us
    2-przebieg na BRAMCE V/D=2 / 5us
    1:Przetwornica AVT-2732 -mała wydajność prądowa przetwornicy.
    2:Przetwornica AVT-2732 -mała wydajność prądowa przetwornicy.
    dziś kupiłem te mosfety irf540, wieczorem przelutuje je i dam znać czy się coś zmieniło...

    0
  • Pomocny post
    #4 22 Wrz 2008 18:16
    Qwet
    Poziom 33  

    Nie znam się za bardzo na oscylogramach, ale nie widzę tu żadnych szpilek ani oscylacji, wykres napięcia na drenie to wzorcowy prostokąt.

    Na biegu jałowym może być wszystko ok, oscylacje mogą się pojawić dopiero na obciążeniu kiedy między masą sterownika a źródłem tranzystorów odkładają się jakieś napięcia. Daj oscylogramy bramki i drenu pod małym i dużym obciążeniem.

    0
  • Pomocny post
    #5 22 Wrz 2008 18:41
    lechoo
    Poziom 39  

    Pokaż oscylogramy w stanie obciążenia, gdy spada Ci to napięcie wyjściowe, postaraj się zrobić wyraźne zdjęcia.

    Zamiana IRFZ44 na IRF540 to przysłowiowa zamiana siekierki na kijek...

    0
  • #6 22 Wrz 2008 22:54
    Qwet
    Poziom 33  

    Tak, IRF540 ma większą rezystancję złącza, ale za to jest bardziej odporny na śmierć przez przebicie szpilkami napięcia.

    0
  • #7 23 Wrz 2008 14:25
    lechoo
    Poziom 39  

    Tak duży spadek napięcia wyjściowego świadczy o dużej indukcyjności rozproszenia i słabym sprzężeniu między uzwojeniami. W jaki sposób nawijałeś ten transformator? Czy rdzeń przypadkiem nie jest ze szczeliną w środkowej kolumnie?

    0
  • #8 24 Wrz 2008 19:20
    Kuczus
    Poziom 19  

    Przepraszam ze dopiero teraz, ale w szkole strasznie wymagają, dziś udało mi sie zrobić kila fotek (nistety ciężko strasznie uchwycić wyraźniej przebieg:( ) ale to co udało mi się zrobić zamieszczam poniżej :
    pomiar na drenie pod obciążeniem :
    aplituda nie uległa zmianie, jedynie do zdjęć zmieniłem podziałkę,
    trzecie zdjęcie to zbliżenie na te zakłucenia widoczne wcześniej na zdjęciach lecz napięcie na wyjściu z 40 znów spadło do 20... skoro amplituda wchodząca na wejście trafa nie ulega zmianie, wniosek z tego taki ze błąd tkwi albo w trafie albo dalej ? np. kondensatory, diody prostownicze ?:

    Jeszcze nie przelutowywałem tych tranzystorów, bo w końcu nie wiedziałem czy mam to robić czy nie ?
    Przetwornica AVT-2732 -mała wydajność prądowa przetwornicy.Przetwornica AVT-2732 -mała wydajność prądowa przetwornicy.Przetwornica AVT-2732 -mała wydajność prądowa przetwornicy.

    Przebiegi powyżej są błędnę, niżej wyjaśnienie

    0
  • #9 24 Wrz 2008 22:42
    trol.six
    Poziom 30  

    Zobacz jak wyglądają sygnały po stronie wtórnej transformatora, z małym obciążeniem (20% tego co masz) i z obiążeniem jak spada napięcie (100%), wstaw i porównaj. My też zobaczymy.

    Prawdopodobnie jak piszesz, jakaś kwestia w trafie, nawinięciu, bądź dziwnemu podłączeniu.

    W każdym razie nie widać u ciebie na drenach czasu martwego, może masz dość wolne przełączanie tranzystorów i się zastanawiam czy nie nachodza na siebie.

    0
  • #10 25 Wrz 2008 12:19
    lechoo
    Poziom 39  

    Zastanawiająca jest ta szpilka (przepięcie ograniczone zapewne napięciem przebicia Uds) na przebiegu napięcia na drenie - masz dużą indukcyjność rozproszenia o czym pisałem wcześniej, albo zapomniałeś o kondensatorze blokującym zasilanie po stronie pierwotnej.

    0
  • #11 25 Wrz 2008 15:49
    Kuczus
    Poziom 19  

    Kondensatorze blokującym zasilanie? nie za bardzo kojarze które to kondensatory? zamieszczam schemat:
    Przetwornica AVT-2732 -mała wydajność prądowa przetwornicy.
    co mógłbym jeszcze sprawdzić? zaraz idę sprawdzić to co kazała trol.six


    Edit:
    kurde, mój błąd...podaje nowe oscylogramy, na których widać ewidentnie że coś jest nie tak.Radiator który mam z zasilacza ATX jest na mosfetach jest gorący po 5 minutach pracy z obciążeniem przetwornicy, diody prostownicze nie zmieniają temperatury, są zimne, a dodanie kondensatora 4700uF na wyjście nie zmienia wyglądu oscylogramu:

    przebieg na drenie, podczas obciążenia wyjścia przetwornicy przez rezsytor 16ohm: (druga fotka to nie żadrna pomyłka aparatu, tylko rzeczywiście przebieg tak wygląda po innym ustawieniu oscyloskopu)
    20 V/DPrzetwornica AVT-2732 -mała wydajność prądowa przetwornicy.

    5V/DPrzetwornica AVT-2732 -mała wydajność prądowa przetwornicy.


    Wykonałem kolejne pomiary dla trol.six:
    napięcie zasilające 12V
    napięcie zasilające po podłączeniu obciążenia 11.7V
    napięcie na wyjściu przetwornicy w stanie jałowym 44V i najprawdopodobniej rosło minimalnie o mV w górę;/
    Obciążenie rezystancyjne 107 ohm
    napięcie wyjściowe spadło do 38.2V
    przebiegi są wręcz idealne:
    mniejszy to przebieg na pierwotnym uzwojeniu (czyli Dren mosfeta)
    większy to wtóre uzwojenie transformatora :
    Przetwornica AVT-2732 -mała wydajność prądowa przetwornicy.

    0
  • #12 25 Wrz 2008 19:20
    trol.six
    Poziom 30  

    Ja czegoś nie łapie, dajesz fotke pierwszą i opisujesz przebieg na drenie, potem ostatnie zdjęcie i dajesz tam też przebieg na drenie i się różni od tego poprzedniego.

    Więc jak to jest?

    Jeżeli ten pierwszy jest z opornikiem mniejszym, to wygląda na to że działa ci ograniczenie prądowe.

    Ja chciałem przebiegi na trafie wyjściowym, z obciążeniem i bez obciążenia, żeby porównać, ile nam spada napięcie, a dałeś tylko jedno z jakimś średnim.

    A w ogóle jak sytuacja jest niejasna, to trzeba wszystko po kolei sprawdzić.

    0
  • #13 18 Paź 2008 00:47
    michal.rogaczewski
    Poziom 28  

    A że się spytam, jaki masz prąd jałowy ??, bo jeżeli powyżej 300mA to coś sknociłeś w trafie (w swoich przetwornicach osiągam nawet 90mA :) ale to już wymaga troche pracy)

    0
  • #14 18 Paź 2008 01:07
    Qwet
    Poziom 33  

    To może być wina bardzo wielu rzeczy, nie tylko transformatora. Prąd spoczynkowy zależy od mocy przetwornicy, napięcia zasilania (10-15V) itp. Bywa bardzo różny, ale waha się między kilkadziesiąt a kilkaset miliamper.

    0
  • #15 08 Lis 2008 13:05
    Kuczus
    Poziom 19  

    Witam, po strasznie długiej przerwie( z powodów obowiązków w szkole) wracam do tego tematu.
    Podłączyłem do tej przetwornicy wzmacniacz mosfet projektu Irka Piworskiego i wszystko niby działa, lecz gdy zwiększę poziom sygnału na wejście wzmacniacza to przetwornica się wyłącza... Czyli tak jak ktoś wspomniał wyżej, układ zabezpieczenia prądowego działa, jak mam zwiększyć zakres prądowy ?

    0
  • #16 08 Lis 2008 13:38
    michal.rogaczewski
    Poziom 28  

    Ale chłopie, to zabezpieczenie to sie włącza przy ok 15A z akku, a wzmacniacz irka nie powinien pociągnąć więcej niż 7-10A (moze w impulsie trochę więcej ale przetwornica nie powinna się wyłączyć) chyba że nie ustawiłeś zabezpieczenia prądowego wogóle (potek 10k)

    0
  • #17 09 Lis 2008 15:07
    Kuczus
    Poziom 19  

    Drodzy koledzy, może zrobimy to wszystko od nowa w inny sposób... Powiedzcie mi co mam sprawdzić, co zmierzyć, jakie podać dane itp... bo jak na razie jest tutaj totalny chaos... A więc ?

    0
  • #18 09 Lis 2008 15:36
    Qwet
    Poziom 33  

    Najprawdopodobniej zasilasz przetwornicę ze słabego źródła prądowego takiego jak na przykład stary akumulator żelowy 5Ah. Kiedy napięcie zasilania spada poniżej 10V przetwornica przestaje pracować. Według mnie to najbardziej prawdopodobna przyczyna.

    Jeśli jednak zasilaniem jest gruby akumulator lub instalacja samochodowa, skręć P1=10k maksymalnie w stronę +5V zasilania i napisz czy nadal masz problem z wyłączaniem się przetwornicy.

    0
  • #19 09 Lis 2008 23:31
    Kuczus
    Poziom 19  

    Przetwornica zasilana jest z akumulatora 40Ah...
    Na nózce 2 TL'a (suwak potencjometru) - napięcie 4.92 V

    0
  • #20 10 Lis 2008 14:16
    Qwet
    Poziom 33  

    I nadal się wyłącza? A zapala sie czerwona dioda?

    0
  • #21 10 Lis 2008 17:42
    Kuczus
    Poziom 19  

    Cały czas jest zapalona Zielona Dioda,czerwona wyłączona.
    Najprawdopodobniej to wzmacniacz się wyłącza z powodu spadku napięcia zasilania. Dodam że za przetwornicą mam 6 kondensatorów 4.700uF (po 3 na szynę + te które są na płytce przetwornicy)

    0
  • Pomocny post
    #22 10 Lis 2008 18:35
    michal.rogaczewski
    Poziom 28  

    I tu cie mam :P prawie 15mF w przetwornicy impulsowej ????? góra 2200uF na stornę

    0
  • #23 11 Lis 2008 10:32
    Kuczus
    Poziom 19  

    hmm, acha... Ale czy spadki napięcia to wina tych kondensatorów?
    Edit:
    Usunąłem kondensatory, bez zmian, dodam że podałem na wzmacniacz sygnał sinus 100hZ i napięcie przysiadło z 80V na 60V przy czym prąd pobierany przez przetwornicę wynosił ok 6-7 amper i się wyłączał... (regulowałem sygnał podawany na wzmacniacz potencjometrem, stąd mogłem zauwarzyć granice wyłączania się wzmacniacza)

    0
  • #24 11 Lis 2008 11:11
    michal.rogaczewski
    Poziom 28  

    Spadki napięcia to na pewno nie ich wina, ale cała rzecz w tym, że przy takich kondensatorach i braku dławika tranzystory dostają ostro w dupe....

    Poza tym, czy tylko mi sie wydaje, że na ETD44 5zw na pierwotnym to ciut dużo ? 3-4zw góra bym zrobił (5zw robie na ETD34), zwiększysz moc, ale to nie załatwia sprawy wyłączania przetwornicy

    Dalej, mam nadzieje że nie zmieniałeś mosfetów ? bo jak zmieniłeś na takie z większym RDSon to się nie dziw że sie wyłącza przy małych prądach :P

    sinus 100hz przy około 60W RMS... jezu :P,

    P.S. mam nadzieje że prądu zwykłym miernikiem cyfrowym nie mierzysz, albo przekładnik prądowy, albo miernik analogowy

    0
  • #25 11 Lis 2008 12:18
    Kuczus
    Poziom 19  

    W weekend nawinę na nowo to trafo i zobaczę jak wtedy.
    Nadal zostawione są IRFZ44N.

    0
  • #26 11 Lis 2008 12:33
    Qwet
    Poziom 33  

    A czy coś w przetwornicy się grzeje? Jeśli nie to winny jest tylko transformator, za duże rozproszenie indukcji.

    0
  • #27 12 Lis 2008 12:08
    Kuczus
    Poziom 19  

    No właśnie najgorsze jest to że się nic nie grzeje...
    Właściwie, to może żeby sobie ułatwić nawijanie, zastosuje biały rdzeń którego zdjęcia zamieszam poniżej, tylko nie wiem do jakiej mocy on wystarczy, osoba od której go dostałem mówiła że pracował w wzmacniaczu samochodowym SANYO BPA 70, lecz nic więcej nie wiem na temat tego rdzenia, umiałby ktoś oszacować parametry tego rdzenia ?
    Przetwornica AVT-2732 -mała wydajność prądowa przetwornicy.

    0
  • #28 12 Lis 2008 12:49
    Qwet
    Poziom 33  

    Coś w rodzaju TN32. Jakieś 400W przy dobrym nawinięciu...

    0
  • #29 12 Lis 2008 13:13
    -RoMan-
    Poziom 42  

    Zależy z jakiego jest materiału...

    0
  • #30 12 Lis 2008 14:38
    Kuczus
    Poziom 19  

    O łał, a więc zostaje przy tym rdzeniu. Tylko teraz powiedz mi, ile nawinąć ? i jakim drutem (mm2) ?

    edit:
    nie wiem dlaczego pojawiła się moja odpowiedź tak późno, chyba miałem problemy z internetem, rdzeń waży ok 30g mierzone na wadze kuchennej, co mógłbym jeszcze sprawdzić by się upewnić?

    0
  Szukaj w 5mln produktów