Elektroda.pl
Elektroda.pl
X

Search our partners

Find the latest content on electronic components. Datasheets.com
Elektroda.pl
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

Zmywarka Whirlpool for Ikea DWF 405 - przerywa i dioda miga

rychaczu 07 Oct 2008 08:11 8062 2
IGE-XAO
  • #1
    rychaczu
    Level 2  
    Witam! Mam zmywarkę zakupioną w IKEA. Od jakiegoś czasu zachowuje się dziwnie:
    - włączam dowolny program i zmywarka zaczyna wypompowywać wodę, ale robi to w cyklach około sekundowych, tzn. sekundę pompka działa, potem sekundę przerwy, zaś działa i zaś przerwa. I tak jakąś minutę. Przez cały ten czas dioda miga w takt działania pompy.
    - następnie napuszcza wodę. I tu sytuacja się powtarza. Sekundę wodę napuszcza, sekundę odpoczywa, napuszcza, odpoczywa. I tak z kółko, aż uzna poziom wody za wystarczający do rozpoczęcia zmywania (zwykle 3-4 minuty). Tutaj także dioda miga w rytm napuszczania wody, czyli ok 1Hz
    - potem jak gdyby nic się nie działo zmywa sobie naczynka (dioda świeci ciągłym), aż trzeba kiedyś wodę wypompować. I zaś pompuje na raty i na raty dobiera sobie wody (dioda miga).
    - najlepsze jest to, że finalnie zmywanie się skończy, suszenie działa. Tylko ten niejednostajny hałas jest irytujący.
    Zmierzyłem wszystkie czujniki jakie znalazłem, ale bez schematu działam trochę po omacku.
    Wyczytałem gdzieś, że bywają kłopoty z wydajnością zasilacza. Więc sprawdziłem napięcia na stykach pompki: 70 i 230V na zmianę. Potem odłączyłem pompkę od sterownika i zmierzyłem co się dzieje na stykach sterownika: 70 i 230V. Skoro miga bez obciążenia, więc chyba nie jest to wina zasilacza. Procedurę powtórzyłem dla elektrozaworu i sytuacja się powtarza: 70 i 230V na zmianę co 1 sekundę.
    Nie dokładnie wiem jak, ale przy pewnej kombinacji naciśnięć i pokręceń, chyba włączyłem jakiś test, i dioda mrugnęła 2 razy, chwila przerwy, zaś 2 razy i tak w kółko. Na jakimś niemieckim forum ktoś opisywał ten sam problem z tą zmywarką. Jedyną sugestię jaką otrzymał to, że jest to kod:"Woda w tacy dolnej zmywarki", jeśli dobrze zrozumiałem, a to przyznaję, że po germańsku czytam trochę kulawo.
    Oczywiście sprawdziłem ten trop, ale pływak i jego czujnik działają prawidłowo.

    1. Czy ktoś to potrafi rozgryźć?
    2. W kategorii rozrywki umysłowej: cały czas nurtuje mnie, po co ten plastikowy zbiornik z boku zmywarki został tak kosmicznie powykręcany. Gapiłem się w niego z 40 minut i nic z tego nie zakminiłem. Jedyne skojarzenie jakie miałem, to labirynt w stylu "Zaprowadź jeżyka do jabłka" z książeczek 5-latka ;-)

    --
    2008.10.23- zmieniłem napięcia w opisie powyżej. Poprzednio podane były błędne (mierzyłem ustawieniem DC - wiem wstyd)
  • IGE-XAO
  • #2
    rychaczu
    Level 2  
    Znalazłem rozwiązanie:
    Wina leży po stronie kondensatora, który miał mieć 1,5 µF a w wyniku testu wyszło, że miał 0,5 µF. Wystarczyło go podmienić i wszystko gra.
    Objaw migającej diody nie był błędem programatora, uszkodzonego triaka czy termistora tylko słabej wydajności modułu zasilania. Przekaźniki załączające pompkę i elektrozawór nie dostawały wystarczającego napięcia (miało być 12 a było ok 6V) i klapały.


    Wielkie dzięki za pomoc dla jasxx, któremu oberwało się od moderatora, tylko dlatego że chciał pomóc i wykładał laikowi (czyli mnie) wszystko kawa na ławę (choć mylił się co do 1000% pewności, że to programator do wymiany) oraz dla mirofalcon, który podsunął genialną myśl.
    Dzięki dla Teodora, który odtworzył schemat płytki (niestety tylko w swojej głowie) i powiedział gdzie grzebać.

    Pozdrowienia dla moderatora skryn, który skutecznie zraził mnie do kadry zarządczej forum
  • #3
    User removed account
    Level 1