Elektroda.pl
Elektroda.pl
X

Wyszukiwarki naszych partnerów

Wyszukaj w ofercie 200 tys. produktów TME
Europejski lider sprzedaży techniki i elektroniki.
Proszę, dodaj wyjątek elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Kłopot z uruchomieniem Win XP po deinstalacji programu.

Sharky 07 Paź 2008 14:47 1499 9
  • #1 07 Paź 2008 14:47
    Sharky
    Poziom 13  

    Witam!

    Postanowiłem w domu zrobić porządek i odinstalowałem stare, często nieużywane programy.
    Zauważyłem, że mam starą wersję Spybot Search & Destroy i postanowiłem go również odinstalować.

    Po zakończeniu odinstalowywania pojawił się komunikat, że potrzebne jest ponowne uruchomienie komputera.
    Potwierdziłem tą operację i system się zamknął i zaczął uruchamiać na nowo.
    Niestety, coś poszło nie tak, bo podczas uruchamiania Windowsa XP pro pojawia się komunikat na niebieskim tle o wczytywaniu ustawień lokalnych (lub coś podobnego) i nic się nie dzieje. Po kilku minutach pojawia się napis ZAPRASZAMY, po czym następuje ponowny restart komputera.
    Proces ten się zapętla.

    Spróbowałem skorzystać z funkcji "F8" i postanowiłem wybrać opcję - Ostatnia znana dobra konfiguracja.
    Niestety to nic nie dało.
    Postanowiłem więc uruchomić system w trybie awaryjnym, jednak i tu nie odniosłem sukcesu.
    Po kilku próbach udało mi się jednak uruchomić system w trybie awaryjnym jako administrator. Utworzyłem nowego użytkownika i na nim mogę już uruchomić system, jednak jest on "goły" i muszę praktycznie wszystko instalować od nowa, choć na dysku są wszystkie dotychczasowe pliki. Próba przełączenia na dotychczasowego użytkownika kończy się podwieszeniem systemu na ok. 30 sekund, po czym następuje restart komputera.

    Czy ktoś miał może podobną sytuację i wie, co można zrobić, aby przywrócić normalne funkcjonowanie systemu.
    Kiedyś słyszałem, że ponoć jest gdzieś przechowywana kopia plików startowych i można ją podmienić i wszystko wróci do normy, jednak nigdy nie miałem z tym styczności i nie mam kompletnie wiedzy na ten temat.

    Będę wdzięczny za pomoc.

    PS.
    Dodam, że system Windows XP Pro funkcjonował bez najmniejszych problemów od ponad 3 lat.

  • #2 07 Paź 2008 15:06
    ahilles11
    Poziom 19  

    Może spróbuj włożyć płyte od windows i naprawic po przez naciśnięcie R.A jak nie to może czas na reinsall windows. Weź skopiuj dane przez live-cd np. z linux-a i wgraj od nowa.

  • #3 07 Paź 2008 15:17
    Sharky
    Poziom 13  

    > Może spróbuj włożyć płyte od windows i naprawic po przez naciśnięcie R.

    Już to robiłem - nic nie dało :(


    > A jak nie to może czas na reinsall windows. Weź skopiuj dane przez live-cd np. z linux-a i wgraj od nowa.

    Spróbowałem zainstalować Windowsa "na barana" też bez efektu :(

    Pomyślałem, że przed reinstalacją warto spróbować odratować system, szczególnie, że przez cały czas chodził bezproblemowo, a na dodatek mam zainstalowanych i skonfigurowanych sporo programów, których będzie problem ponownie odtworzyć.

  • #4 07 Paź 2008 15:30
    witoj
    Poziom 29  

    w Podglądzie zdarzeń zobacz jakie są błedy może znajdziesz przyczyne restartów.

  • #5 07 Paź 2008 19:01
    ahilles11
    Poziom 19  

    A nie jest to moze problem z sprzętem. Może usunięcie programu nie ma nic wspólnego zbieg okoliczności. Weź normalnie zrób reinstall systemu najlepiej zintegruj z płytką SP3.

  • #6 07 Paź 2008 20:17
    Sharky
    Poziom 13  

    > w Podglądzie zdarzeń zobacz jakie są błedy może znajdziesz przyczyne restartów.

    Spojrzałem tam ,ale nic specjalnego nie znalazłem :(


    > A nie jest to moze problem z sprzętem. Może usunięcie programu nie ma nic wspólnego zbieg okoliczności.
    > Weź normalnie zrób reinstall systemu najlepiej zintegruj z płytką SP3.

    Uważam, że odinstalowanie programu nie jest do końca winne, prawdopodobnie po odinstalowaniu i wymuszonym restarcie system nie zdążył zapisać wszystkie wymagane dane do plików konfiguracyjnych.

    Sama instalacja systemu nie jest problemem, więcej męczarni będzie z instalacją i konfiguracją programów, których od ostatniej instalacji systemu jest naprawdę sporo. Na dodatek nie pamiętam mnóstwa haseł, gdyż większość programów uruchamiała się automatycznie. Dodatkowo trzeba będzie namęczyć się z konfiguracjami itp. normalnie horror.

    Myślę, że sam system nie jest uszkodzony jedynie pliki konfiguracyjne.

  • #7 07 Paź 2008 21:05
    northx
    Poziom 17  

    Zanim zaczniesz reinstalować cokolwiek sprawdź czy wszystkie kabelki wewnątrz są odpowiednio dociśnięte - podobne objawy wywołał mi kiedyś niedokładnie dociśnięty kabelek sata od dysku (innym razem był to kabelek od zasilacza). Czy podczas odinstalowywania nie pojawił się komunikato współdzieleniu plików? Jeśli uda Ci się ponownie uruchomić windę to spróbuj polecenia "sfc /scannow" przy włożonej płycie instalacyjnej.

  • #8 08 Paź 2008 08:01
    Sharky
    Poziom 13  

    Zdjąłem obudowę, poprawiłem większość kabelków, w tym głównie idące do dysków twardych (3). Dodatkowo odpiąłem niewykorzystywane napędy np. DVD, stację dyskietek itp. i nadal nic się nie poprawiło.
    Jedyne co mogę, to uruchomić system na innym, nowo utworzonym koncie. Wszelkie próby uruchomienia systemu zarówno w trybie awaryjnym i normalnym na dotychczasowym koncie użytkownika kończy się zawieszeniem podczas wczytywania ustawień użytkownika :(

    Próbowałem skorzystać z przywracania systemu, jednak będąc na innym koncie użytkownika mam tylko jego punkty przywracania systemu.
    Również próba naprawy systemu z płyty instalacyjnej nic nie daje.'

  • #9 08 Paź 2008 11:05
    Piotras_C
    Poziom 20  

    Witam

    Proponuję przywrócenie kopii rejestru z przed awarii przy pomocy konsoli odzyskiwania. Procedura jest trochę zakręcona dlatego wykonaj koniecznie kopię ważnych danych prze podjęciem tych kroków.

    Po uruchomieniu konsoli będąc w katalogu WINDOWS utwórz katalog, który będzie później potrzebny np. tmp wydając komendę "md tmp" (nazwa może być inna).
    Następnie kasujemy aktualny rejestr systemowy wydając następujące komendy:
    C:\WINDOWS>del c:\windows\system32\config\system
    C:\WINDOWS>del c:\windows\system32\config\software
    C:\WINDOWS>del c:\windows\system32\config\sam
    C:\WINDOWS>del c:\windows\system32\config\security
    C:\WINDOWS>del c:\windows\system32\config\default

    Teraz kopiujemy pierwotną wersję rejestru, którą WINDOWS tworzy podczas instalacji.
    c:\WINDOWS>copy c:\windows\repair\system c:\windows\system32\config
    c:\WINDOWS>copy c:\windows\repair\software c:\windows\system32\config
    c:\WINDOWS>copy c:\windows\repair\sam c:\windows\system32\config
    c:\WINDOWS>copy c:\windows\repair\security c:\windows\system32\config
    c:\WINDOWS>copy c:\windows\repair\default c:\windows\system32\config

    Teraz wpisujemy exit i <enter> komputer się uruchamia ponownie (jak po świeżej instalacji).
    Teraz będziemy kopiować aktualniejszy rejestr.
    Uruchom komputer w trybie awaryjnym.
    Potrzebne nam kopie rejestru są ukryte w katalogu "System Volume Information". Dostęp do niego jest zabezpieczony nawet przed administratorem dlatego musimy dodać sobie uprawnienia.
    Dla XP Prof i partycją NTFS:
    Mój komputer -> dysk C: -> Narzędzia -> opcje folderów w zakładce Widok odznacz: Ukryj chronione pliki... oraz Ukryj rozszerzenia znanych typów plików oraz dodajemy zaznaczenie przy: Pokaż ukryte pliki i foldery.
    Teraz Dysk lokalny C: i klikamy prawym przyciskiem na katalog System Volume Information wybieramy Właściwości i zakładkę Zabezpieczenia (jeżeli jej nie ma to powinien być już dostęp), klikamy Dodaj i wpisujemy administrator i klikamy Sprawdź nazwy następnie OK i dodajemy zaznaczenia przy wszystkich pozycjach w kolumnie Zezwalaj.
    Dla XP Prof i Home i partycji FAT32 wystarczy zmiana w opcjach folderów.
    Dla XP Home i partycji NTFS uruchamiamy wiersz polecenia i wpisujemy:
    cacls "c:\System Volume Information" /E /G nazwauzytkownika:F

    Przechodzimy do katalogu System Volume Information i wyszukujemy katalog (_restore...) zawierający punkty przywracania z datą, która nas interesuje. Wchodzimy do niego i wybieramy najnowszą kopię (RPnr) wchodzimy do niego a następnie do snapshot. W folderze tym znajduje się potrzebna kopia rejestru. Kopiujemy pliki:
    _REGISTRY_MACHINE_SAM
    _REGISTRY_MACHINE_SECURITY
    _REGISTRY_MACHINE_SOFTWARE
    _REGISTRY_MACHINE_SYSTEM
    _REGISTRY_USER_.DEFAULT
    do katalogu, który utworzyłeś w konsoli odzyskiwania (C:\WINDOWS\tmp).
    Ponownie uruchamiasz konsolę odzyskiwania i kasujesz pliki rejestru:
    C:\WINDOWS>del c:\windows\system32\config\system
    C:\WINDOWS>del c:\windows\system32\config\software
    C:\WINDOWS>del c:\windows\system32\config\sam
    C:\WINDOWS>del c:\windows\system32\config\security
    C:\WINDOWS>del c:\windows\system32\config\default

    a następnie kopiujesz rejestr z katalogu tmp:
    C:\WINDOWS>copy c:\windows\tmp\_registry_machine_security c:\windows\system32\config\security
    C:\WINDOWS>copy c:\windows\tmp\_registry_user_.default c:\windows\system32\config\default
    C:\WINDOWS>copy c:\windows\tmp\_registry_machine_software c:\windows\system32\config\software
    C:\WINDOWS>copy c:\windows\tmp\_registry_machine_sam c:\windows\system32\config\sam
    C:\WINDOWS>copy c:\windows\tmp\_registry_machine_system c:\windows\system32\config\system

    teraz exit i powinien uruchomić się system z ustawieniami jak w dniu utworzenia kopii rejestru w punkcie przywracania.

    Powodzenia i pamiętaj o kopii bezpieczeństwa przed zabawą z rejestrem!

  • #10 08 Paź 2008 22:22
    Sharky
    Poziom 13  

    Dzięki za tak dokładny opis.
    Zacząłem robić, jak napisałeś, jednak okazało się, że po wcześniejszych próbach naprawy systemu z płyty instalacyjnej cała historia punktów przywracania systemu została skasowana i pozostała tylko najnowsza, dzisiejsza wersja :(

    Coś mi się wydaje, że chyba wcześniejsze próby uratowania systemu tak naprawdę przyczyniły się do jego unicestwienia :(

TME logo Szukaj w ofercie
Zamknij 
Wyszukaj w ofercie 200 tys. produktów TME
TME Logo