Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Nadajnik 36kHz na układzie 555

Radek 20 Paź 2002 21:23 5909 9
  • #1 20 Paź 2002 21:23
    Radek
    Poziom 13  

    Witam
    Otóz mam taki problem:
    Zbudowałem generator 36kHz na kostce 555 który docelowo ma się znaleźć w prostym pilocie, i chodzi o to, że nie mogę go zestroić na te 36kHz. Po prostu chodzi o to że odbiornik TFMS5360 nie reaguje na sygnał. nie wiem czy wina nie leży w tym iż nośna nie ma wypełnienia 50% (ok. 30 na oko). NIe posiadam miernika częstotliwości więc jest troche ciężko.
    Z góry dzięki za pomoc.
    Radek

    0 9
  • #2 20 Paź 2002 22:45
    uaz
    VIP Zasłużony dla elektroda

    Spróbuj odbiornik zdiagnozować zwykłym pilotem czy w ogóle coś łapie.
    Jak możesz podeślij schemat - policzymy czy wychodzi 36k.

    0
  • #3 20 Paź 2002 23:12
    Anonymous
    Użytkownik usunął konto  
  • #4 20 Paź 2002 23:36
    Radek
    Poziom 13  

    Odbiornik jest w 100% sprawny.
    Co do elementów to liczyłem i powinno byc dobrze.
    Do regulacji służy ten potencjometr 20k.

    0
  • #6 21 Paź 2002 15:21
    Radek
    Poziom 13  

    To ze one są na różne częstotliwości to wiem, sądze ze to moze miec jakis związek z wypełnieniem przebiegu lub tym o czym wspomniał Siwy %%

    0
  • #7 13 Gru 2002 23:36
    bolek
    Specjalista - oświetlenie sceniczne

    takie moje praktyczne spostzreżenia na temat tego postu:

    1) Nośna (36kHz) musi być (przynajmiej) modulowana przebiegiem prostokatnym o częstotliwosci kilkuset Hz.
    2) jesli TFSM-a "oświecimy" takim przebiegiem to na jego wyjsciu nie będzie cały czas panował stan niski, tylko będą sie pojawiac paczki impulsów (cos w rytmie impulsów modulujacych ).
    3) generator na 555 jest troszkę za mało stabilny jak do tego układu i na mój gust :wink:

    0
  • #8 08 Mar 2006 20:07
    żubr1768
    Poziom 10  

    Witam.Zgadzam się z bolkiem. Też robię teraz podobny projekt, sterowanie oświetleniem w pokoju. Strasznie się zdziwiłem, kiedy przy zmianie napięcia .. tejże kostki 555 , układ przestawał pracować. Sprawdziłem wszystko co było do sprawdzenia. Myślałem że pływa mi kondensator... a okazało się że układ zmienia czestotliwość generowanego przebiegu w zależnosci od zmian zasilania. (!!). lepiej poszukać czegość stabilniejszego. pozdrowienia.

    0
  • #9 09 Mar 2006 00:29
    ostrytomasz
    Poziom 22  

    żubr1768 napisał:
    Strasznie się zdziwiłem, kiedy przy zmianie napięcia .. tejże kostki 555 , układ przestawał pracować. Sprawdziłem wszystko co było do sprawdzenia. Myślałem że pływa mi kondensator... a okazało się że układ zmienia czestotliwość generowanego przebiegu w zależnosci od zmian zasilania. (!!). lepiej poszukać czegość stabilniejszego. pozdrowienia.


    Dosyć dziwne. Po pierwsze częstotliwość generacji 555 powinna być w dużym stopniu niezależna od napięcia zasilania (chyba, że wykraczasz poza nominalny zakres napięcia zasilania). Po drugie selektywność tego typu odbiorników jest raczej mizerna. TSOP1736 pracował u mnie poprawnie z nośną 27,7kHz (zupełnie przypadkowa wartość, wynikająca z tego, że akurat nie miałem za dużego wyboru kondensatorów styrofleksowych pod ręką, nie żebym celowo rozstrajał). Potwierdzają to też datasheet czy też np. opis Igorpluga. Czułość spada, ale np. dla krótkiej bariery optycznej jest to korzystne.

    0
  • #10 03 Kwi 2006 08:00
    zerpo
    Poziom 22  

    Chciałbym się też podzielić moimi ostatnimi doświadczeniami z TSOPem w roli czujnika przeszkód.
    Również dotknął mnie problem niestabilnej częstotliwości 555 - tki. Co jakiś czas muszę doregulowywać częstotliwość, jednak na razie się tym nie martwię, chociaż jest to niewygodne.
    Używam trzech TSOP1736, czyli teoretycznie na 36kHz, jednak mój oscyloskop podłączany do PC (niestety nie najlepszej jakości, więc nie wiem, czy to nie on się tutaj myli) pokazuje, że najlepszą pracę uzyskuję przy ok. 34-35kHz.
    Wypełnienie to ok. 30%, dioda podłączona jest do Vcc przez rezystor 22 omy, więc prąd chwilowy po uwzględnieni spadków napięć to ok 150-180mA. Prąd średni, ok. 50mA.
    Udaje mi się na tym wyciągnąć zasięg do ok. 0,5m, ale....
    Kombinowałem troszeczkę i okazuje się, że ważną rolę pełni filtr pasywny (taki jak w dokumentacji TSOP'ów) przed wejściem zasilania tegoż czujnika. Istnieje pewna graniczna wartość tych elementów, która pozwala ustawić TSOPa na granicy samo wzbudzenia się (tzn. stanu, gdy daje nam sygnał, mimo że my nic mu nie nadajemy, nie ma przeszkody itp). Przy tej granicznej wartości można właśnie uzyskać stosunkowo duży zasięg. Ale uwaga. Jeśli pojemność od strony układu jest zbyt duża, to wtedy sytuacja się pogarsza i Nawet przy braku tego filtra TSOP się sam nie wzbudzi. Oczywiście cały czas mówię o pracy jako czujnika dystansowego! Sygnału nie kluczuję w żaden sposób, jest tylko jeden generator niecałych 36kHz.
    Nie wiem z czego to wynika. Może na linii zasilającej powstają pewne harmoniczne od nadajnika, których obecność jakby "rozgrzewa" TSOPa (nie wiem, czy wyraziłęm się jasno) i jest mu "łatwiej" się później przełączyć.
    Wkrótce zabawię się w jakieś kluczowania jeszcze i można dodatkową filtrację, bo na pewno z tego można coś jeszcze wyciągnąć :D

    0