Elektroda.pl
Elektroda.pl
X
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

Przetwornica zaporowa na układzie UC3843

michal.rogaczewski 16 Oct 2008 17:18 7653 25
  • #1
    michal.rogaczewski
    Level 28  
    Witam
    Przetwornicami, jako takimi się już jakiś czas bawię, ale zawsze były to przetwornice P-P, nigdy Flyback (m.in. przez konieczność wykonania szczeliny powietrznej w rdzeniu...), I mam takie pytanie, Jak przy pomocy Tl494 zrobić przetwornicę flyback, czy są jakieś ograniczenia ? (np dot. max wypełnienia impulsów), Widziało mi sie to tak, Tl494 moge zasilić zasilaczem beztransformatorowym co w p-p jest niemożliwe/bezsensowne z powodu prądu pobieranego przy sterowaniu tranzystorami poprzez transformator sterujący. Ogólny wygląd takiego zasilacza znam. Ustalenie f, stabilizacja, ograniczenie prądowe, takie rzeczy nie są dla mnie problemem, Jest natomiast problem, w tym jak sterować tranzystorem mocy ? (IRF840)

    Przetwornica ma mieć moc około 50-80W, trafko mam na rdzeniu EE30/7, pierwotne 30zw licą złożoną z 6 drucików 0.2mm, wtórne to 2x5zw także licą ale tym razem z 12 drucików 0.3mm. I dodatkowe uzwojenie 3zw. licą taką jak do pierwotnego. Szczelina powietrzna, około 0.5mm (moge zwiększyć, zmniejszyć będzie trudniej :) )
  • Helpful post
    #2
    lechoo
    Level 39  
    Układ UC3843 dedykowany do flyback'ów kosztuje ~2zł, dlaczego więc chcesz sobie tak życie utrudniać?
  • #3
    michal.rogaczewski
    Level 28  
    No tak, ale jest 5% szans że go kupie u siebie, na razie przyjmijmy że mamy tylko tl494 do wyboru
  • Helpful post
    #4
    lechoo
    Level 39  
    Skoro tak, to mogę zaproponować/zasugerować:
    - kontroler TL494 na pewno musi pracować w trybie single-ended, 13 nóżka do masy,
    - wyjścia należy połączyć równolegle, czyli nóżki 8 i 11 (kolektory) do + zasilania, a emitery (n. 9 i 10) też razem do drivera wyjściowego
    - driver wyjściowy możesz zrobić w prostym układzie z diodą, tranzystorem pnp i rezystorem,
    - możesz mieć problem z prawidłowo działającym ograniczeniem prądowym - układ uc384x działa w trybie prądowym i wyłącza klucz gdy prąd chwilowy w wyniku zwarcia wyjścia lub nasycenia rdzenia przekroczy ustaloną wartość, a w tl494 nie da się tego zrealizować.
    To chyba wszystko co mam do powiedzenia na ten temat, poszukaj i przejrzyj dokument pt. Designing Switching Voltage Regulators With the TL494 - można z niego dowiedzieć się ciekawych rzeczy o TL494...
  • #5
    michal.rogaczewski
    Level 28  
    O rzeczach które wypisałeś wiem, a tą dokumentacje przeczytałem we wszystkie strony :P, ograniczenie prądowe też potrafię zrobić, (w wersji która zmniejszy wypełnienie imp. po przekroczeniu ustalonego prądu jak i w takiej która wyłączy/zblokuje tl-a, a odblokuje dopiero po ponownym włączeniu zasilania)


    p.s. jest nadzieja na tego UC :) (chociaż nota katalogowa na prostą nie wygląda) bo gdzieś go widziałem
  • Helpful post
    #7
    -RoMan-
    Level 42  
    To mi się podoba - kompensacja sprowadzona do jednego kondensatora 10 nF i wyłączenie zbędnego wzmacniacza błędu :)
  • #8
    michal.rogaczewski
    Level 28  
    Według tej stronki wyszło m coś takiego:
    Przetwornica zaporowa na układzie UC3843

    Chyba dobrze...., ale coś czuje że przewijanie mnie czeka :P
  • #9
    lechoo
    Level 39  
    Koniecznie zmniejsz przekładnię transformatora, bo przy maksymalnym napięciu wejściowym tranzystor na 600V już Ci nie wystarczy...
  • #10
    michal.rogaczewski
    Level 28  
    Aleluja i do przodu :P mam tego UC3843 (choć kosztował mnie 4zł a nie 2 :) ), tl494 idzie do szufladki, teraz trafo... przekładnię zmniejszyłem, ale trafo i tak nie za bardzo wiem jak obliczyć z tej stronki (zwoje itp.)
    Przetwornica zaporowa na układzie UC3843
  • #11
    lechoo
    Level 39  
    Ja tu bardziej widzę następujące parametry:
    N1/N2 = 12
    L1 = 1mH
    Częstotliwość raczej trzeba będzie zwiększyć do ~70kHz żeby wystarczył Ci rdzeń E30/15/7.
    AL=100 (szczelina 1mm), pierwotne 100zw., (2x50), wtórne 9zw. pomiędzy połówkami pierwotnego, pomocnicze 10zw. na samym wierzchu.
    Rezystor czujnika prądu - 0,5ohm bezindukcyjny.
    Rdzeń lepiej byłoby wziąć trochę większy, o większym przekroju, wtedy AL może być większe, szczelina na środkowej kolumnie mniejsza i zarazem mniejsza będzie indukcyjność rozproszenia.
    Jestem ciekaw, co na to powie Kolega RoMan..?
  • #12
    -RoMan-
    Level 42  
    ETD29 lub 34? Łatwiej nawijać.
  • #13
    michal.rogaczewski
    Level 28  
    Z tym że EE30/15/7 mam, a etd29 bym musiał zamówić (mam jeszcze ETD34 ale szkoda mi go na tak słabą przetworke, z niego dało by sie z 200W wycisnąć)

    p.s. IRF840 jest na 500V, z tej stronki wynika że będe go "katował" 450V, przeżyje ?? bo nie mam pewności, czy zmieniać tranzystor czy zmienić ciut transformator
    Przetwornica zaporowa na układzie UC3843
  • #14
    lechoo
    Level 39  
    Ech zapomniałem, że masz tranzystor na 500V... W takim razie najkorzystniejsza będzie przekładnia N1/N2=8. Wtórne 13zw., pomocnicze 15zw, reszta bez zmian chyba...
  • #15
    michal.rogaczewski
    Level 28  
    no to nawijam panowie :)

    Pierwotne 2x44zw drutem 0.45mm (więcej niz 44zw w 1 warstwie zmieścić nie mogę)

    Wtórne 13zw licą, 15 drucików 0.2mm ? Chyba wystarczy.

    A pomocnicze 15zw. 0.2mm

    Będzie ok :), z tą szczeliną powietrzną poczekam aż to nawinę
  • #16
    lechoo
    Level 39  
    Wtórne więc nawiń 12zw., a szczelinę wykonasz mierząc co jakiś czas indukcyjność uzwojenia pierwotnego.
    Ta lica na wtórnym to zdecydowanie za mało, wychodzi gęstość prądu prawie 15A/mm2. Ja wykonałbym wtórne z licy 7x0,45 (7 drutów bardzo ładnie skręca się ze sobą).
  • #17
    michal.rogaczewski
    Level 28  
    Zapomniałem napisać że obciążenie jest impulsowe więc ta lica wystarczy (wzmacniacz 2x22W :P) ten zasilacz to takie "sprawdzenie" jak wygląda sprawa zasilania wzmacniaczy mocy zasilaczami impulsowymi :)

    p.s. jakieś dobre sposoby na techniczny pomiar indukcyjności ??, bo miernik który posiadam jest giiiiga niedokładny :P, chyba że lepiej zrobię jeśli złożę to: https://www.elektroda.pl/rtvforum/topic421759.html
  • #18
    lechoo
    Level 39  
    Śmiało możesz użyć tego układu do pomiaru indukcyjności. Tylko nie używaj kondensatora ceramicznego jako C1 bo dokładność pomiaru będzie tragiczna.

    BTW: Myślałem, że będzie to jakieś ciekawsze zastosowanie dla tego zasilacza...
  • #19
    michal.rogaczewski
    Level 28  
    Dziękuje wam panowie zasilacz działa prawie dobrze :) (prawie, bo musze zrobić zasilacz beztransformatorowy do UC bo juz mi 1 wybuchł jak go zgodnie ze schematem podłączyłem :/)
  • #20
    -RoMan-
    Level 42  
    Zmieniam temat wątku na odpowiadający rzeczywistości.
  • #21
    lechoo
    Level 39  
    Pokaż swój schemat - coś musiałeś sknocić skoro UC się spalił.
  • #22
    michal.rogaczewski
    Level 28  
    Mój schemat = twój schemat, może źle to pomocnicze uzwojenie podłączyłem albo cuś.... bo spaliło jeszcze ten rezystor 0.4ohm i chyba tranzystor

    no nic w pon. od nowa zabawa, a te UC znalazłem za 2.50 :)

    p.s. Stabilizacja działa, dałem tam zamiast PC123 jakiś COSMO 1010-817 wytargany z UPS-a (ale zenerke musze zmienić bo mam na 11V a na wyjściu mam 11.67V, dam na 12V)
  • #23
    lechoo
    Level 39  
    Rezystor 1k zmień na trochę mniejszy, bo teraz dioda Zenera 11V pracuje na "kolanie", proponuję 220ohm. Napięcie wyjściowe powinno się wtedy nieznacznie podnieść. Ten transoptor może być.
    Sprawdzałeś napięcie zasilające UC (na kondensatorze C2)? Na zasilaniu układu jest wewnętrzna dioda Zenera 34V, a napięcie zasilające nie powinno przekraczać 30V, optymalnie 12..20V.
    Na moim schemacie jest układ UC3845 - po zmianie na UC3843 (ten jest zalecany do flyback'a) częstotliwość pracy przetwornicy wzrośnie 2x - trzeba odpowiednio dobrać elementy RC oscylatora, mam nadzieję, że o tym pamiętałeś...
  • #24
    michal.rogaczewski
    Level 28  
    Tak, tak zmieniłem części od częstotliwości na 4.7nf i 10k (na oscyloskopie wychodzi mi 60kHz) nie zdążyłem sprawdzić napięcia bo to eksplodowalo dosłownie w 1sek od podłączenia. A rezystor rzeczywiście trza zmienić :P

    Aha i ten rezystor zasilający UC przy starcie mam 180K a nie 150K, chyba za wiele to nie zmieni
  • #25
    lechoo
    Level 39  
    Jeśli pomyłkowo odwrotnie podłączyłeś uzwojenie pomocnicze to faktycznie UC mógł otrzymywać sporo ponad 30V. Wartość rezystora rozruchowego nie jest krytyczna, równie dobrze może być 300k - wtedy start zasilacza będzie trwał trochę dłużej.
    Nie ma co się przejmować rozlanym mlekiem - mi też zdarzyło się spalić 2 szt. UC gdy robiłem próbne pomiary na "pająku", wtedy bardzo łatwo o zwarcie...
  • #26
    michal.rogaczewski
    Level 28  
    W tej chwili jestem na etapie robienia płytki :), wyjdzie b.mała, Ale musze powiedzieć że bum było baaardzo efektowne , słup ognia i dymu na około metr od scalaka :D