Elektroda.pl
Elektroda.pl
X
Banner Multimetr Fluke 87VBanner Multimetr Fluke 87V
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Medion MD5530VT na PCA84C641P/524S1 ciągle czuwa

22 Paź 2002 02:47 2970 12
  • Poziom 28  
    TV Medion MD5530VT 21cali
    Ważniejsze układy: OM8361, SAA5254, TDA4665, CTV322S V1.2
    Telewizor po włączeniu włącznikiem sieciowym startuje na około jedną sekundę. Przy przytrzymaniu włącznika sieciowego TV działa nieustannie jednakże mikrokontroler jest wówczas nadal wyłączony. Wyłącznik sieciowy posiada dodatkowy zestyk startowy jego krótkotrwałe zwarcie powinno włączać TV. Nie mam do tego TV oryginalnego pilota. Ujrzawszy mikrokontroler firmy Philips CTV322S V1.2 doszedłem do wniosku iż powinien tu pasować popularny pilot RC5 np. obsługujący bardzo popularny mikrokontroler PCA84C640/030. Niestety brak reakcji. Telewizora nie mogę uruchomić ani z klawiatury lokalnej ani owym pilotem. W związku z powyższym wymieniłem mikrokontroler. W sklepie zaoferowano mi zamiennik o oznaczeniu PCA84641P/524S1 na nowym procesorze również widniał napis zgodny z oryginałem CTV322S V1.2 co utwierdza mnie w przekonaniu iż jest właściwy odpowiednik. Po zamontowaniu do TV nowego mikrokontrolera sytuacja się w ogóle nie zmieniła. Wymieniłem rezonator kwarcowy 10MHz. Szyna danych SDA/SCL ma wysoki stan, nic jej nie przywiera. Do proca dochodzą impulsy z czujki pilota na 35 nogę o czym świadczy zmiana napięcia z 4,74 na 4,2 wolta przy wysyłaniu rozkazu z pilota. Zwarcie nogi 41 mikrokontrolera do masy załącza odbiornik na obrazie obserwuję prawidłowe śnieżenie jednakże takie wymuszenie nie załączy mikroprocesora nawet i w sprawnym TV. Telewizor naprawiam od czerwca br. Spędza on mi sen z powiek. Dodam jeszcze, że ktoś przede mną wymontował układ TXT z TV. Na podstawie aplikacji wywnioskowałem iż znajdował się w nim SAA5254P/E. W okolicy mikrokontrolera zlokalizowałem zwarty tranzystorek małej mocy oraz przy tranzystorze linii przywartą diodę T4148 w układzie powrotu impulsów H na 38 nogę OM8361.
    Czy popularne piloty Philips obsługują PCA84C641P/524S1=CTV322S V1.2? Jakie muszą zaistnieć warunki aby owy mikrokontroler dał się załączyć włącznikiem sieciowym lub pilotem?
    Jedyne co mi pozostało to podanie na zakończenie napięć mierzonych względem masy na mikrokontrolerze, który cały czas jest w stanie spoczynku - STBY.
    1(4,95);2(4,97);3(4,97);4(4,97);5(4,98);6(4,98);7(4,55);8(4,55);9(4,04);10(4,98);11(0);od 12 nogi do 20 (4,98); od 21 do 26(0V); 27(0,2); 28(4,98);29(4,98); 30(0);31(2,23); 32(2,09); 33(0); 34(0); 35(4,74 przy rozkazach z pilota 4,2V); 36(0); 37(4,98); 38(0); 39(4,98); 40(4,98); 41(4,17); 42(4,98).
  • Banner Multimetr Fluke 87VBanner Multimetr Fluke 87V
  • Poziom 12  
    A co się dzieje z nogą RESET na procesorze? Przy normalnych warunkach dla PCA do uruchomienia wystarczą : sprawny generator na kwarcu, reset szyna I2C z pamięcią i procek powinien załączyć TV. Oczywiście jeszcze zasilaie 5 V na procek i pamięć
  • Poziom 28  
    A jak sprawdzić działanie układu reset
  • Poziom 12  
    W procesorach PCA yły dwie metody wykonaia resetu: układ scalony 3 nóżkowy lub 2 oporniki i 2 kondensatory. W momencie włączenia zasilaia ładuje się elektrolit i po chwili na nodze resetu jest c.a. 5V. Miałem kiedyś podobną sytuację i uskodzony miałem kondensator 10nF w resecie ( było ok. 2 V)
  • Banner Multimetr Fluke 87VBanner Multimetr Fluke 87V
  • Użytkownik usunął konto  
  • Poziom 12  
    Generator musi ci pracować cały czas inaczej procek nie jest taktowany i martwy.
  • Poziom 26  
    Przejrzyjcie sie zasilaniu +5V idacemu na mikrokontroler i do pamieci EEprom. Cudow nie ma, generator pracowac musi.
  • Poziom 11  
    Witam .
    Mam identyczny problem z odbiornikiem Tesla Ck 3376 XT.Brak oscylacji na kwarcu.Wstawiłem nowy procesor,nowy kwarc,nową pamięć,wywaliłem układ teletekstu ,żeby nie mieszał.Zasilanie jest 5,1 V,na magistrali panują stany wysokie i procesor nie żyje.Koledzy,błagam ,pomóżcie.
  • Poziom 12  
    panowie oscylacje na kwarcu NIE SĄ PRZERYWANE przez RESET !!! jest napięcie +5V procka to muszą być oscylacje !!!! :roll:
    Jedyne co że tam jest tylko 22..33pF i uważajcie czym dotykacie podczas mierzenia... jeśli wasze sondy mają więcej niż 10pF to kicha oscylacje znikną.... i TYLE możecie mierzyć do bólu i NIC...
  • Poziom 11  
    Jak mierzę oscylacje w innym odbiorniku z PCA i one są ,to chyba moja sonda nie jest sprawcą zamieszania.W moim przypadku zasilanie jest ,a oscylacji nie ma,DLACZEGO????
  • Poziom 31  
    robcio61 napisał:
    Jak mierzę oscylacje w innym odbiorniku z PCA i one są ,to chyba moja sonda nie jest sprawcą zamieszania.W moim przypadku zasilanie jest ,a oscylacji nie ma,DLACZEGO????

    Tak jak powyżej kolega napisał. A może to byc uzależnione od egzemplarza procka, i niestety przy podłączeniu sondy zanikają.
    Bardziej wiarygodny jest pomiar impulsów na magistrali (oscyloskopem), nie napięcia stałego!
  • Poziom 11  
    Na magistrali nie ma żadnych impulsów ,procesor nie żyje.Podstawiłem dwa procesory i nic.Te procesory w innym odbiorniku pracują zupełnie poprawnie.
  • Poziom 26  
    Daj procesor na podstawke i przy wyjetym obmierz okolice procesora, szczegolnie ceramiki-moze z ktoregos zrobil sie polprzewodnik.
    Mam nadzieje ze +5V ogladales na oscyloskopie ? Pomiar wartosci skutecznej woltomierzem nie zawsze bywa miarodajny....