Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Excel funkcja automatyczna

mcmaro 20 Paź 2008 09:08 2358 4
  • #1 20 Paź 2008 09:08
    mcmaro
    Poziom 9  

    Witam. Kolejny raz zgłaszam sie o pomoc w sprawie excela. Potrzebuje stworzyc funkcje ktora automatycznie, zaleznie od pozostalych komorek bedzie wypelniala kolejne komorki. Baza wyglada tak:

    ADSL (IPVPN) ________128
    ADSL (IPVPN) ________512
    FR/ATM+IPVPN________155000
    ADSL (IPVPN) ________2048
    ADSL (IPVPN) ________1024
    FR/ATM+IPVPN _______2048

    Potrzebuje uzupelnic trzecia kolumne, ktora w przypadku jesli to jest ADSL (IPVPN) bedzie wpisywala E-1 a jesli FR/ATM+IPVPN wpisze OC-3. Malo tego jesli ADSL (IPVPN) powyzej 1024 bedzie wpisywala liczbe kart E-1 (jesli 1024= 1xE-1, 2048= 2xE-1, 4096= 3xE-1 ...and so on :). Macie jakies pomysly...

    0 4
  • #2 20 Paź 2008 14:56
    marek003
    Poziom 40  

    Chcesz żeby ktoś odrobił zadanie domowe za ciebie?

    Przecież to nie jest takie trudne. W czym masz kłopot?
    Napisz to pomogę ale nie oczekuj gotowego rozwiązania bo naprawdę nie jest to ciężkie.

    Nie za bardzo rozumiem że wynik ma być w 3 kolumnie.
    Czyli w jednej kolumnie są nazwy (ADSL ...) a w drugiej kolumnie liczby (1024)???
    Jeżeli tak to bardzo uprości sprawę i wtedy całkiem nie wiem gdzie masz kłopot. Wykorzystujesz funkcję "jeżeli" i parę podstawowych zasad matematyki.

    Ale jeżeli ten tekst masz w jednej kolumnie (co też nie jest trudne) to oprócz funkcji "jeżeli" musisz użyć funkcje tekstowe (dł, prawy, lewy, fragment.tekstu, wartość)

    Tu podpowiem więcej (choć nie wiem czy powinienem) bo nauczycielowi zapewne i o to chodziło.
    Aby wprowadzić odpowiedni "licznik" możesz wykorzystać logarytm (do wyliczenia wielokrotności 1024) [ale to tylko jeden ze sposobów]

    Powodzenia
    i ucz sie pilnie :)

    0
  • #3 20 Paź 2008 15:13
    mcmaro
    Poziom 9  

    Nie trafiles kolego z ta praca domowa. Studia juz zakonczone i excela nie uczyli, zatem szukam pomocy po ku temu sluzacych forach. Mimo to dzieki za odpowiedz... jutro poczytam jak wroce do pracy...

    Pozdrawiam
    Pilny Uczeń :)

    0
  • Pomocny post
    #4 20 Paź 2008 16:57
    marek003
    Poziom 40  

    Mimo wszystko jeżeli oczekujesz na gotowe rozwiązania to się nie nauczysz. A szkoda by było bo excel potrafi prawie wszystko :)
    A z drugiej strony jak zobaczysz wynik (formułę) to się możesz zniechęcić a to dość proste.


    Poniżej masz załącznik z dwoma rozwiązaniami (bo dalej nie wiem dokładnie jak masz ułożone dane).
    Funkcje w excelu najlepiej czytać.

    Do pierwszego przypadku:
    =JEŻELI(A1="FR/ATM+IPVPN";"OC-3";JEŻELI(B1<1024;"E-1";LOG(B1/1024;2)+1&"xE-1"))

    Jeżeli [nawias] w komórce A1 tekst jest równy (taki sam jak) FR/ATM+IPVPN to [średnik] wstaw OC-3 w przeciwnym wypadku [średnik] jeżeli [nawias] w komórce B1 jest mniejsza liczba od 1024 to [średnik] wstaw E-1 w przeciwnym wypadku [średnik] policz logarytm [nawias] z liczby z komórki b1 podzielonej przez 1024 [średnik] (logarytm) o podstawie 2 [zamknij nawias] dodaj do tego 1 i dodaj tekst [&] xE-1 [zamknij nawias] [zamknij nawias]

    W drugim przypadku zasada jest ta sama z tytm że najpierw trzeba wydobyć liczbę z tekstu do tego służą wszystkie te zabawy z funkcjami tekstowymi.

    =JEŻELI(LEWY(F1;1)="F";"OC-3";JEŻELI(DŁ(F1)<25;"E-1";LOG(WARTOŚĆ(PRAWY(F1;DŁ(F1)-21))/1024;2)+1&"xE-1"))

    Żeby to lepiej zrozumieć zobacz jak działą każda funkcja oddzielnie np LEWY(F1;1)

    Co do wykorzystania logarytmu to kwestia twojej kolejności.
    Owszem można dalej ciągnąć zapętlanie funkcji jeżeli 1024 to 1xE-1 w przeciwnym wypadku jeżeli 2048 to 2xE-1 w przeciwnym wypadku jeżeli ... itd
    ale trzeba pamiętać że tych jeżeli w jeżeli może być tylko 7 więc może zabraknąć na wszystkie możliwe przypadki. Więc jeżeli jest jakiś ciąg liczb to można na niego wyprowadzić wzór.
    Jeżeli chcesz wiedzieć skąd się wziął ten wzót to ci wytłumacze (a może sam do tego dojdziesz).

    0
  • #5 21 Paź 2008 17:12
    mcmaro
    Poziom 9  

    Dzięki, troche poprawiłem, dostosowalem do swoich warunkow i smiga. Jak bedziesz potrzebowal pomocy z sieci komputerowych, jesli tylko dam rade... polecam sie... pzdr

    0