Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

[Aduc 842]Separacja galwaniczna - transoptor

02 Lis 2008 19:33 1714 1
  • Poziom 9  
    Witam chcę separować dwa układy:
    1: odbiornik radiowy przekazujący odebrany sygnał do uC - sygnałem odbieranym jest sygnał prostokątny o wypełnieniu 50% i napięciach "0" - 0V , natomiast "1" - 3,2V
    2: uC na który ma trafiać sygnał z odbiornika radiowego - "0" - 0V , "1" - 5V .

    Próbowałem bez separacji lecz układ odbiornika radiowego po podłączeniu do AduC 842 pin 3.3 oraz masy do DGND psuje sygnał. W załączeniu umieszczam dwa zdjęcia przed podłączeniem do uC i po podłączeniu do ww. pinów. Wiem, że pin 3.3 jest pinem z rezystorami podciągającymi - może w tym tkwi problem ?
    Pytanie:

    Jaki transoptor wykorzystać ( jakiś symbol ) ?
    [Aduc 842]Separacja galwaniczna - transoptor
    [Aduc 842]Separacja galwaniczna - transoptor
  • Pomocny post
    Poziom 38  
    Żeby dodać transoptor musiał byś zrobić wzmacniacz, który wysteruje diodę transoptora. Może wiec lepiej dać wzmacniacz, który wzmocni sygnał na wejście µC. Podejrzewam że sygnał psuje za mała oporność wejściowa wejścia µC, lub moc wyjścia odbiornika radiowego jest za mała i po podłączeniu wejścia µC napięcie siada. Tak czy inaczej radził bym dać wzmacniacz. Z tego co widać z ustawień 1ms/DIV, częstotliwość sygnału nie jest zbyt wielka, jako wzmacniacz można zastosować oamp np. TL072 zasilany z Vcc µC. Przyczyną może też być słaby sygnał w antenie odbiornika zauważ że wierzchołki i zbocza sygnału na drugim oscylogramie są zaszumione, więc może antena o większym zysku załatwi sprawę.