Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Wolny odczyt z kart SD

wachcio 04 Lis 2008 12:52 7534 16
  • #1 04 Lis 2008 12:52
    wachcio
    Poziom 24  

    Witam

    Mam problem z wolnym odczytem z kart SD. Mam laptopa z Vistą Home Premium 32-bit PL w nim czytnik kart SD oraz lustrzankę cyfrową Canona 450D. Do tego karty Kingston 2 i 4 GB oraz SanDisc Extreme III 2 GB oraz dodatkowy czytnik kart firmy Trust.
    Mianowicie transfer nie przekracza ok 4Mb/sek a przeważnie jest w okolicach 2 albo niżej. Nieraz to tylko kilkaset KB/ sek! Kombinacja czytników (nawet pożyczałem jeszcze jeden na którym CF na moim laptopie miało 18 MB/sek) i kart nie daje wzrostu wydajności. Największą szybkość osiągam jak podłączę aparat przez USB i korzystam z jego czytnika. Wtedy prędkoś waha się ok 8 Mb/sek z kartą SandDisc (na Kingstonach gorzej). Niestety wszystkie te rezultaty są grubo poniżej oczekiwań gdyż specjalnie kupowałem drogiego SanDisca żeby zbiliżyć się chociaż do tych 20 MB/sek które oferuje producent karty.

    Nie wiem w czym leży problem. Kupić jeszcze jakiś specjalny model czytnika?

    0 16
  • #2 04 Lis 2008 13:53
    Platon
    Spec od komputerów

    A jaki masz czytnik? Taki za 5zł? To wlasnie ma taka predkosc <4MB/s

    0
  • #3 04 Lis 2008 14:28
    wachcio
    Poziom 24  

    Wbudowany w laptopa, jakiś model czytnika Trust i korzystałem z kolegi MSI Star Reader 52 in 1. Na czytniku MSI na moim laptopie SD ok 4MB/sek a CF 18 MB/sek

    A co byś polecił z dobrych czytników? Myślisz, że w nim leży wina? Może to znów jakaś niedoskonałość Visty?

    0
  • #4 04 Lis 2008 14:44
    PH0ENIX
    Poziom 14  

    Spróbuj zainstalować pakiety KB938979 oraz KB938194. Rozwiązują część problemów związanych z kopiowaniem.

    Mam taki sam aparat oraz kartę 4GB Sandisc Extreme III, w komplecie z kartą był czytnik. Co prawda nie osiąga max prędkości, ale 21 - 25 mb/s jest raczej normą.

    0
  • #5 04 Lis 2008 18:10
    wachcio
    Poziom 24  

    PHOENIX niestety wyświetla mi, że ta aktualizacja nie ma zastosowania dla mojego systemu... Poza tym karty SD sanDisca Extreme III mają chyba prędkość do 20 MB. Może mówisz o CF...

    0
  • #6 05 Lis 2008 08:48
    PH0ENIX
    Poziom 14  

    Prawdopodobnie aktualizacje masz już pobrane przez Windows Update.

    Co do prękości odczytu faktycznie masz rację, sprawdzilem. Pomylka wziela sie z tego, ze na codzien uzywam OCZ Rally ktory wlasnie ma w odczycie kolo 30mb/s

    0
  • #7 05 Lis 2008 09:30
    wachcio
    Poziom 24  

    Masz jakieś jeszcze pomysły? Może jeszcze zaryzykować kupno innego czytnika tylko jakigo? Łudząc oczywiście się, że to nie wine Visty...

    0
  • #8 05 Lis 2008 11:42
    PH0ENIX
    Poziom 14  

    Trochę dziwne, że wbudowany w laptopa czytnik tak powoli działa. W moim firmowym 5220Z Acera czytnik chodzi całkiem przyzwoicie.

    Zanim kupisz nowy czytnik, sprawdź dostępność nowszych sterowników płyty gł. i czytnika. Zobacze też jak się zachowują te czytniki pod jakimś linuxem live.

    0
  • #9 05 Lis 2008 12:59
    pejotpc
    Poziom 11  

    U mnie laptop Toshiby Tecra wbudowany czytnik SD, sterwoniki uniwersalne 'zgodne z standartem SDA' z czerwca 2006, ten sam OS co u Ciebie. Karta Sandisc extreme III -wszystko smiga tak jak powinno..

    0
  • #10 05 Lis 2008 17:39
    wachcio
    Poziom 24  

    Uruchomiłem komputer z SUSE Live CD i prędkość na wbudowanym czytniku na wszystkich kartach była podobna i wahała się około 16-19MB/sek. Czytnik więc jest szybki. Nie wiem tylko gdzie kopiowałem pliki bo nie znam się za bardzo na Linuksie i nie wiem gdzie on miał swoje foldery - w pamięci czy gdzieś na dysku. Zwykłe katalogi na dysku mogłem tylko odczytywać nie modyfikować.

    Wniosek z tego jeden to Vista lub jakieś stery w niej są winne. Drugi to taki, że nie opłacało mi się kupować "szybkiej" karty bo czy kingston 4GB za 50 zł czy sandisc 2GB za ponad 100 majątaką samą szybkość...

    Ktoś ma jeszcze jakieś pomysły?

    0
  • #11 06 Lis 2008 08:33
    PH0ENIX
    Poziom 14  

    Kopiowales zapewne do jakiegos ram-dysku.
    Co do samego sandisca to wg mnie sie oplacalo, sprawdzilem na sobie. Przed zakupem sprawdzilem jak chodzi w aparacie zarowno kingston jak sandisk, na tej drugiej zapis odbywał sie szybciej, bylo to szczegolnie widoczne przy wykonywaniu serii okolo 15 zdjec w RAW-ach (o samej jakosci tych kart nie wspominajac) ale to juz tak poza tematem.

    Na ostatnie pytanie w sumie sam sobie odpowiedziales i jak pisalem wczesniej sprawdz sterowniki, mozna tez postawic windows na nowo. A tak na marginesie przyszla mi do glowy jedna mysl, wydaje mi sie raczej malo prawdopodobna ale mozna sprawdzic - sprawdz wydajnosc dysku, byc moze nie nadaza tak "szybko" zapisywac. Moze masz jakies urzadzenie na USB ktore zajmuje wiekszosc pasma.

    0
  • #12 06 Lis 2008 10:07
    wachcio
    Poziom 24  

    PH0ENIX napisał:
    Kopiowales zapewne do jakiegos ram-dysku.

    Jak już pisałem nie wiem gdzie...

    PH0ENIX napisał:
    Na ostatnie pytanie w sumie sam sobie odpowiedziales i jak pisalem wczesniej sprawdz sterowniki, mozna tez postawic windows na nowo.

    Strowniki niby aktualne. Przynajmniej tak podaje mi Vista i sam nowszych nie znalazłem. System stawiany tydzień temu gdyż w poprzednim po roku coś padło na dobre. Wszystkie uaktualnienia które chciała Vista oczywiście zainstalowane

    PH0ENIX napisał:
    A tak na marginesie przyszla mi do glowy jedna mysl, wydaje mi sie raczej malo prawdopodobna ale mozna sprawdzic - sprawdz wydajnosc dysku, byc moze nie nadaza tak "szybko" zapisywac. Moze masz jakies urzadzenie na USB ktore zajmuje wiekszosc pasma.


    Mam podpięty dodatkowy dysk 2,5''. Z dysku w kompie na niego dane kopiują się te same zdjęcia (na tym samym usb gdzie podłączałem czytniki) z prędkością 17-25 mb/sek odczyt 17-25MB/sek (raz nawet 55MB/sek). Na porcie gdzie zawsze jest podłączony prędkości podobne.

    Więc po stronie sterów USB też chyba nie leży wina skoro dysk kopiuje z takimi prędkościami.

    Już po mału mi brak pomysłów...

    0
  • #13 06 Lis 2008 10:23
    PH0ENIX
    Poziom 14  

    Sprawdz na jakiejs starszej wersji sterownikow bo nowsze nie zawsze znaczy lepsze (przynajmniej na mojej plycie z G35). Jesli na innym systemie jest dobrze to nie pozostaje nic innego jak sterowniki albo sam system innych pomyslow mi brakuje.

    Pozdrawiam

    0
  • #14 06 Lis 2008 10:52
    653388
    Użytkownik usunął konto  
  • Pomocny post
    #15 06 Lis 2008 11:11
    PH0ENIX
    Poziom 14  

    janko_wodnik - jaką wydajnośc ma mechanizm DRM ?
    wachcio - jaki masz procesor ?

    Pytam bo jeśli ten mechanizm jest takim hamulcem to wydajność jego musi być bardzo uzależniona od wydajności procesora. U siebie nie zauważyłem żadnych problemów tego typu (procesor jedynie Dual Core E2200).

    Cytat:
    Żaden czytnik kart tutaj nie pomoże:D

    Dlaczego więc czasami jednak pomaga ?
    Cytat:
    pożyczałem jeszcze jeden na którym CF na moim laptopie miało 18 MB/sek

    0
  • #16 06 Lis 2008 11:57
    wachcio
    Poziom 24  

    Po zainstalowaniu jeszcze raz pobranych ze strony asusa (wczoraj nie działał dział download) sterowników sytuacja wróciła do jakiej takiej normy... Transfery wahają się bardzo ale w granicach rozsądku czyli od 5 do 19 MB/sek. Raz nawet miałem 45 MB/sek. Przeważnie szybsza jest karta SanDisca.
    janko_wodnik wiem, że Vista ma szereg wad i właśnie głównie ją obarczałem od początku za ten stan rzeczy. Niestety jest duży problem ze sterownikami do XP. Na stronie Asusa cisza może jak bym napisał do nich coś by pomogło. Komputer kupiłem w Norwegii ze skandynawską (języki norweski, duński, fiński i angielski) więc kupiłem polską właśnie ze względu na brak sterów do XP. Duuuże problemy i kombinacje są w tym modelu na XP z dźwiękiem, grafiką a o karcie TV (również program do jej oglądania), odbiorniku podczerwieni do pilota i kilku innych rzeczach można w ogóle zapomnieć.

    Dodano po 24 [minuty]:

    To mój komputer

    Processor
    Model : AMD Turion(tm) 64 X2 Mobile Technology TL-60
    Speed : 2GHz
    Model Number : 3600
    Cores per Processor : 2 Unit(s)
    Threads per Core : 1 Unit(s)
    Type : Mobile, Low Power, Dual-Core
    Internal Data Cache : 2x 64kB, Synchronous, Write-Back, 2-way, Exclusive, 64 byte line size
    L2 On-board Cache : 2x 512kB, ECC, Synchronous, Write-Back, 16-way, Exclusive, 64 byte line size

    System
    System : ASUSTeK Computer Inc. A7K
    Mainboard : ASUSTeK Computer Inc. A7K
    Bus(es) : ISA PCI PCIe IMB USB i2c/SMBus
    Multi-Processor (MP) Support : No
    Multi-Processor Advanced PIC (APIC) : Yes
    System BIOS : American Megatrends Inc. A7KAS.2
    Total Memory : 2GB DDR2 SO-DIMM

    Chipset
    Model : AMD (ATI) RS690 Host Bridge
    Front Side Bus Speed : 1x 200MHz (200MHz)

    Chipset
    Model : AMD Athlon 64 / Opteron HyperTransport Technology Configuration
    Front Side Bus Speed : 2x 800MHz (1.60GHz)
    Total Memory : 2GB DDR2 SO-DIMM
    Memory Bus Speed : 2x 333MHz (666MHz)

    Video System
    Adapter : ATI Mobility Radeon HD 2600 (256MB, PCIe 1.00 x16, SM4.0)

    Graphics Processor
    Adapter : ATI Radeon HD 26XX (RV630) (1.02, 256MB, 500MHz/400MHz)

    Storage Devices
    Hitachi HTS542525K9SA00 250GB (SATA150, 2.5", 5400rpm, NCQ, 7MB Cache) : 233GB
    TOSHIBA 57APT08YT 160GB (USB) : 149GB
    HL-DT-ST DVDRAM GSA-T20L (ATA33, DVD+-RW, CD-RW, 2MB Cache)


    Operating System(s)
    Windows System : Microsoft Windows Vista Home 6.00.6001 (Service Pack 1)
    Platform Compliance : x86

    Windows Experience Index
    Current System : 4.8

    0
  • #17 06 Lis 2008 18:55
    653388
    Użytkownik usunął konto  
  Szukaj w 5mln produktów