Elektroda.pl
Elektroda.pl
X
Relpol przekaźniki
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Problem z uruchomieniem sterownika CNC

03 Gru 2008 19:02 4467 8
  • Poziom 13  
    Podłączyłem sterownik jednej osi pod Macha2 i nawet zadziałało lecz nie wiem co się dzieje bo silnik obraca się tylko w jedną stronę próbowałem ustawić Macha według opisu na stronie CNC ale bez zmian wyczytałem gdzieś że niestety to mogą być objawy padniętego układu w innym miejscu zaś braku zasilania 12V na płycie głównej SSK-MB2 ja podłączyłem bezpośrednio 5V , kolejna rzecz to że mam podłączone w miejscu osi X na płycie głównej a wszystkie zmiany (prędkość silnika ) w machu odpowiadają osi Y
    Dorobiłem kolejny sterownik na układzie TA 8435H oczywiście na nowych częściach i niestety tak samo a nawet jeszcze więcej problemów silnik prawie wcale nie reaguje wczytałem jakieś G-Kody koło czy coś i w całym procesie pracy silnik tylko wykonał kilka kroczków w zakładce diagnostyki Macha wciskając kursory dla tej osi zapala mi się dioda przekaźnika PK1
    niestety nie mogę sobie z tym problemem poradzić sprawdziłem poprawność złożenia płyty głównej znalazłem zamieniony rezystor ale to nie zmieniło nic reszta wydaje się być ok
    Pobrałem STEP2CNC 1.2 wersję demo i zachowanie jest takie samo strzałki w górę /dół silnik (powinien być osi X )obraca się tylko w jedną stronę strzałki prawo/lewo załącza PK i tyle nie wiem może to kabel ale 2 i ten sam problem

    Panowie pomocy bo nie wiem co robić

    Robert
  • Relpol przekaźniki
  • Poziom 20  
    Nie pamiętam dokładnie ale na wyjściach sterownika jest sygnał zmiany kierunku obrotów silnika(DIR), możesz sprawdzić miernikiem, czy podając obroty lewe, później prawe czy ten sygnał zmienia swoja wartość.
    Piny w gnieździe LPT są połączone ze sterownikami, gniazdem krańcówek i przekaźnikami następująco:
    1 - przekaźnik PK1
    2 - CLK X
    3 - DIR X
    4 - CLK Y
    5 - DIR Y
    6 - CLK Z
    7 - DIR Z
    8 - AUX 6
    9 - AUX 7
    10 - E-STOP
    11 - Home X
    12 - Home Y
    13 - Home Z
    14 - AUX 1
    15 - AUX 2
    16 - przekaźnik PK2
    17 - Enable
    18-25 - Masa
    Jeśli posiadasz taki sterownik jak w linku poniżej to ten sygnał dostępny jest również na jego wyjściach do sterowników silników krokowych.
    http://www.akcesoria.cnc.info.pl/pliki/sterowniki/podlaczenie.jpg
    Jeśli posiadasz inny to sprawdź w dokumentacji gdzie jest wyjście zmiany obrotów i jeśli możesz ja udostępnić to zamieść może być pomocna bardzo.

    Jeśli pomogłem to wciśnij pomógł proszę.

    Dodano po 11 [minuty]:

    Jeśli sygnał Dir się nie zmienia z 5V na 0V przy zmianie kierunków na złączu LPT to możesz nie mieć zainstalowanego sterownika odblokowującego porty pod XP lub źle ustawiony tryb pracy portu w biosie.
    Znalazłem opis sterownika:) http://www.akcesoria.cnc.info.pl/sterownik_silnika_krokowego_sskmb2.htm
    Jeśli niema zmiany tego sygnały(DIR) na wyjściu sterownika to uszkodzony jest sterownik. Potem zostaje już tylko sterownik silnika i sam silnik.
  • Relpol przekaźniki
  • Poziom 13  
    Witam dzięki za odpowiedz czyli jak zrozumiałem kabel DB25 powinien być na wprost a nie sygnałowy a ja mam prawdopodobnie sygnałowy a one są przeparowane wieczorem to sprawdzę bo na płycie SSK-MB2 to sprawdziłem wszystko 2 razy


    Kupiłem kabelek, 1do 1 i lipa teraz to już nie ma żadnej reakcji świeci tylko dioda PK1 i nic poza tym się nie dzieje a na poprzednim to chociaż cokolwiek się działo :cry::cry:
  • Poziom 20  
    1. Sprawdź czy bezpośrednio na złączu LPT wyprowadzenia o numerach 3, 5, 7 (DIR) odpowiedzialne za zmianę kierunku ruchu silnika zmieniają swój stan z 5V na 0V lub z 0V na 5V kiedy zmieniasz kierunek jeśli tak to punkt następny.
    2. Sprawdzasz czy na wyjściach DIR XYZ płytki sterownika SSK-MB2 następuje taka sama zmiana napięcia jeśli tak to płytka działa ok.
    3. To problem w samym sterowniku silnika krokowego lub podłączeniu silnika.

    Jeśli masz zły przewód to możesz to wykryć sprawdzając, czy kolejne piny z portu LPT mają swoje odpowiedniki na złączu sterownika.

    Jeśli możesz to sprawdź jak to działa gdy podłączysz zasilacz 12V jak to jest w instrukcji do płytek, czyli tak jak to przewidział producent.
  • Poziom 13  
    Sprawdziłem na sucho 3-4,5v,5-0v,7-4,5v ale po uruchomieniu SETUP2CNC na tych pinach po wciśnięciu strzałek jest zmiana napięć
    ale na wyjściach DIR niestety już nie tylko na osi Z się zmienia

    dziwne jest że zaraz po podłączeniu kabla DB uruchamia się pk1
  • Pomocny post
    Poziom 20  
    Sprawdź konfiguracje programu Mach2, tam można ustawiać różne parametry nawet stany aktywne pinów np. DIR. zobacz http://www.akcesoria.cnc.info.pl/sterownik_silnika_krokowego_sskmb2.htm

    Ze schematu wynika że sygnały z wyjścia portu LPT zmiany kierunku DIR idą bezpośrednio do wyjść DIR płytki. Jeśli nie masz zmian na osiach X i Y to sprawdź ścieżki na płytce, czy gdzieś niema zwarć do 5V lub masy lub przerwy. Możesz sprawdzić też drabinkę rezystorów DR1 czy coś tam nie jest źle.
    PK1 możne się załączyć jeśli w konfiguracji jest ustawiony.
  • Poziom 13  
    Zauważyłem jeszcze jedną rzecz a mianowicie na płycie zamontowałem takie gniazdo db25 http://www.lpt.strona.pl/ pin 1 jest z prawej na górze i tak przychodzi z kompa lecz jak patrzę na schemat montażowy płyty zastanawia mnie opis portu pin 1 jest z lewej sam nie wiem jak to interpretować czy są jakieś inne gniazda ?

    Co do drabinki to była ok ale je wymieniłem


    Witam ponownie myślę że problem rozwiązany ustaliłem że powinienem zastosować gniazdo DB25 męskie a nie żeńskie i tu był w zasadzie cały problem żaden kabel nie miał szans przekazać danych w odpowiedni sposób zrobiłem kabel z odpowiednim układem pinów i układ działa XiY zostało złożyć sterowanie Z

    Dzięki serdeczne shadoweyes Twoje podpowiedzi nakierowały mnie na właściwy tor gdyby nie to to pewnie bym się jeszcze gapił na płytki i wymieniał niepotrzebnie dobre elementy jeszcze raz dzięki

    Pozdrawiam Robert557
  • Poziom 10  
    He he zrobiłeś jak ja kiedyś :) Masz pozamieniane wszystkie piny,płytka jest pod db25 męskie nie żeńskie ....
  • Poziom 13  
    Miałem ten sam problem z płytą SSK-MB2. Doszedłem po 5-ciu dniach poszukiwań do tego co ty.
    Winę za to ponosi producent, nie informuje o takich lustrzanych odbiciach gniazda na płytce. Interweniowałem w tej sprawie na CNC info, ale prosili o przysłanie zdjęć płytki. ŚMIESZNE, prawda ?