Elektroda.pl
Elektroda.pl
X
Elektroda.pl
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Konfiguracja Windowsowego Firewalla do dzielenia Internetu

04 Gru 2008 20:02 1911 10
  • Poziom 23  
    Witam.

    Posiadam dwa komputery, przy czym jeden z nich ma dostęp do internetu po kablu. Aby móc surfować z drugiego komputera korzystam z windowsowej opcji dzielenia internetu. Internet do drugiego komputera przekazywany jest drogą radiową (wbudowane karty WLAN). Zastosowałem typową konfigurację:
    Komputer 1:
    XP Home SP3 + wszystkie update'y, łącznie z patchem, o którym pisze wikipedia
    Dostęp do internetu przez LAN
    WLAN utworzone połączenie Peer-to-Peer z komputerem 2

    Komputer 2:
    XP Home SP3 + wszystkie update'y, łącznie z patchem, o którym pisze wikipedia
    LAN nieaktywny
    WLAN utworzone połączenie Peer-to-Peer z komputerem 1

    Od jakiegoś czasu (możliwe, że to po instalacji SP3 do XP) pojawił się problem -> brak internetu w drugim komputerze. Komputery widzą się nawzajem (pingowanie 192.168.0.1 oraz 192.168.0.2 działa), lecz drugi komputer nie widzi świata. Zrezygnowany wyłączyłem zupełnie oba firewalle (standartowe XP, innych nie instalowałem) i internet ruszył. Potem po testach okazało się, że tak na prawdę istotny jest stan firewalla pierwszego=udostępniającego internet komputera - jeśli jest on aktywny, nie mam internetu na drugim komputerze, jeśli go wyłączę, to wtedy wszystko działa.
    A teraz najlepsze:
    1. Pingowanie stron www z drugiego komputera przy załączonych firewallach działa, przy czym czasami 1 z 4 pakietów jest tracony. Mimo działania pingów, strony nie ładują się do przeglądarki (testowane na IE, Opera).
    2. Zdarza się, że przy włączonych firewallach mogę przeglądać stronę elektroda.pl na drugim komputerze, ale inne typu wp.pl, już nie działają! Zupełnie się w tym pogubiłem. Jest jakaś porada?

    No i przede wszystkim: jak skonfigurować firewalla na pierwszym komputerze, by nie blokował udostępniania internetu?
  • Poziom 11  
    Cytat:
    Pingowanie stron www z drugiego komputera przy załączonych firewallach działa, przy czym czasami 1 z 4 pakietów jest tracony. Mimo działania pingów, strony nie ładują się do przeglądarki (testowane na IE, Opera).

    Na moje oko jest to wina DNS-ów.
    W DNS-ach przy ustawieniach kart sieciowych na komputerze 2 wpisz 192.168.0.1 a jesli to nie pomoze to daj 194.204.152.34 194.204.159.1

    Co do firewalla to mozesz dodac wyjatek twojej sieci:
    Foto 1
    A takze pokombinowac tutaj:
    Foto 2
  • Poziom 23  
    Dzięki za ładne obrazki, ale zmiana DNSów nie pomogła. Co gorsza, bo wpisaniu stałych adresów, nawet wyłączenie firewalla nie pomaga w dostępie do netu na drugim kompie...
    Co do wpisania adresów IP do odblokowania - fajny pomysł, tylko należy jeszcze podać numer portu (pozostawiając to pole puste przycisk OK jest nieaktywny); jakaś propozycja co do tego numeru?
  • Poziom 11  
    Hmm w innych firewall-ach takie wylaczenie lokalu pomaga.
    Tutaj jednak jest to port, nie dopatrzylem sie.
    Moze sprobuj podac port 80 ( www ).

    Sprawdz jeszcze ping do wp.pl
    Jesli pojdzie to wejdz w przegladarke i wpisz:
    http://212.77.100.101 ( wp w postaci IP ) wtedy wyeliminujemy badz potwierdzimy awarie DNS
  • Poziom 26  
    Na drugim screenie kolegi <<giecik>> masz ustawienia zaawansowane połączenia. Spróbuj włączyć na obu kompach wszystkie opcje z zakładki Usługi.
    Do tego w kompie 2:
    Adres IP 192.168.0.2
    Maska 255.255.255.0
    Brama - adres IP kompa 1 (tego który udostępnia)
    DNSy np 212.2.96.51
    153.19.250.100
    mozesz jeszcze dodac adres IP kompa 1 do DNSow
  • Poziom 11  
    hmm moze sprobuj poprostu kupic druga karte sieciowa na lan. koszt raptem z 10 zl a duzo mniej ustawienia. Ja tak dziele u siebie. Przyczym blaszak dzieli neta a laptop jedzie na kablu z blaszaka.
    Wszystko zalatwiam konfiguracja windosowska.
    "Konfiguruj polaczenie sieciowe->ten komputer jest podlaczony do internetu, inne komputery lacza sie przez niego" o ile pamietam. Potem powlaczac udostepnianie plikow i drukarek i finito. Na lapie chyba standardowe ustawienie z tego co mi sie wydaje.. Mimo to moze sprobuj i tego tylko ze na radiowce?
  • Poziom 23  
    giecik napisał:
    Hmm w innych firewall-ach takie wylaczenie lokalu pomaga.
    Tutaj jednak jest to port, nie dopatrzylem sie.
    Moze sprobuj podac port 80 ( www ).

    Niestety nie pomogło.
    giecik napisał:
    Sprawdz jeszcze ping do wp.pl

    Jak zawsze - to działa.
    giecik napisał:
    Jesli pojdzie to wejdz w przegladarke i wpisz:
    http://212.77.100.101 ( wp w postaci IP ) wtedy wyeliminujemy badz potwierdzimy awarie DNS

    Strona się nie otwiera.
    ozzman napisał:
    Na drugim screenie kolegi <<giecik>> masz ustawienia zaawansowane połączenia. Spróbuj włączyć na obu kompach wszystkie opcje z zakładki Usługi.

    Niestety nie pomogło.
    ozzman napisał:

    Do tego w kompie 2:
    Adres IP 192.168.0.2
    Maska 255.255.255.0
    Brama - adres IP kompa 1 (tego który udostępnia)
    DNSy np 212.2.96.51
    153.19.250.100
    mozesz jeszcze dodac adres IP kompa 1 do DNSow

    Niestety nie pomogło. Działa jedynie jeśli wyłączę firewalla na komputerze 1. Wówczas działają wszystkie kombinacje DNSów, jakie tu podałeś.
    DeVaK napisał:
    moze sprobuj poprostu kupic druga karte sieciowa

    To ostateczność, bo pamiętam, że mi to połączenie już działało kilka miesięcy temu. No i jeśli już to raczej bezprzewodówkę, bo te 2 komputery, o których piszę to laptopy. Opcja zabawy z kablami nie wchodzi w grę (karta LAN na PCMCIA).
    DeVaK napisał:
    "Konfiguruj polaczenie sieciowe->ten komputer jest podlaczony do internetu, inne komputery lacza sie przez niego"

    Próbowałem automatycznej konfiguracji na obu komputerach - nie pomaga niestety.
    Alana napisał:
    A moze sprobowac wylaczyc firewala dla sieciowki wifi

    Chyba by mnie Windows zamęczył swoimi komunikatami o wyłączonym firewallu dla bezprzewodówki.
    No ale dla testów:
    1. Wyłączenie Firewalla dla bezprzewodówki (komp 1)- nie pomogło (komp 2 Firewall włączony)
    2. wyłączenie Firewalla dla LANu (komp 1)- pomogło (komp 2 Firewall włączony)

    Więc teoretycznie jest okej, gdyby nie to, że musiałbym deaktywować LANa na pierwszym kompie, co jest raczej niedobrym rozwiązaniem. Poza tym nic z tego nie rozumiem: Firewall na LANie (komp 1) nie blokuje przeglądania www na kompie 1, ale uniemożliwia przeglądanie na kompie 2.


    Czy są jakieś inne sugestie/wytłumaczenia tej zagadki?
  • Poziom 37  
    Wylacz usluge "centrum zabezpieczen" albo w centrum zabezpieczen wylacz powiadamianie o nieprawidlowosciach. Moj windows tej uslugi wogule nie ma [wywalilam przy okazji dogrywania sterownikow do sata za pomoca nlite]. Niebiezpieczenstwa nie ma bo wylaczasz firewala od strony sieci bezpiecznej, prywatnej.
  • Poziom 23  
    Alana napisał:
    Niebiezpieczenstwa nie ma bo wylaczasz firewala od strony sieci bezpiecznej, prywatnej.

    Chyba nie do końca. Tak jak pisałem, by mieć dostęp do sieci na drugim komputerze, muszę deaktywować firewalla sieci przewodowej (LAN), dzięki której łączę się z internetem na pierwszym komputerze. To chyba ryzykowne. Może mi to w ogóle jakiś spec wytłumaczyć, dlaczego się tak dzieje? Rozumiałbym, jeśli trzebaby było wyłączać firewalla do bezprzewodówki, ale co przewodówka ma do tego!? I dlaczego mimo aktywnego firewalla, mam neta na pierwszym kompie...
  • Poziom 11  
    fw na 1 kompie traktuje pakiety przychodzace z wifi
    jako zagrozenie
    nalezy odblokowac ZALKOWICIE KOMUNIKACJE NA karcie wifi, WSZYSTKO NA ZEZWALAJ
    na 2 kompie nic nie zmieniasz
    zostawiasz zapore tak jak jest....