Elektroda.pl
Elektroda.pl
X

Search our partners

Find the latest content on electronic components. Datasheets.com
Elektroda.pl
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

OKI 321 drukuje "głupoty"

chief 23 Mar 2004 22:15 3216 17
  • #1
    chief
    Level 22  
    Drukarka drukuje różne znaczki "głupoty" z windowsa, notatnika, worda jak równiez z dosa. Tylko swoje ustawienia bezpośrednio z panelu sterującego drukuje ok. Początkowo pomagało jak drukarka przez kilka dni była wyłączona z sieci to później przez pewien okres czasu działała poprawnie, nie działo się to systematycznie. Port LPT kompa jest ok, sprawdzone na kilku jak również z różnymi ustawieniami portu: SPP, EPP i ECP.

    chief
  • #2
    Kazik
    Printers specialist
    Ostatnio miałem podobny problem - okazało się że to niekontakty na płycie zasilacza. Może Kosmita coś konkretnego podpowie - spróbuj trybu hex dump - to będzie wiadomo czy prawidłowo interpretuje to co dostaje z kompa.
  • #3
    Keszel3
    Level 14  
    Spróbuj zainstalować ją w Windowsie jako np. EPSON 1170 i sprawdź wydruk.
  • #4
    kosmita
    VIP Meritorious for electroda.pl
    Kazik wrote:
    spróbuj trybu hex dump - to będzie wiadomo czy prawidłowo interpretuje to co dostaje z kompa.


    dokladnie zrob tak jak radzi kazik wyslij kilka literek z pliku tekstowego kopiujac go na lpt potem wez tablice kodow aski i znajdz znaczek ktory wyslales i ktory wydrukowalo (w hex) pozniej wszystko zamien na system dwojkowy i sprawdz czy na stale nie jest wyzerowany albo ustawiony ktorys bit... druga sprawa to bufor na liniach sterujacych drukarki (chyba 7406) byc moze jest trzasniety i wtedy drukarka zachowuje sie dziwnie... poza tym przejzyj dokladnie elektronike i poszukaj zimnych lutow.. to co powiedziales o odstawieniu drukarki wskazuje jednak na ktorys z kondensatorkow ale i zimny lut na zimno moze zachowywac sie inaczej.. poza tym sprawdz czy z bateryjki nie wylal sie elektrolit (bateria powinna miec 3,3 V)

    pozdrawiam

    ps pisz co wykryles byc moze na odleglosc da sie pomoc.. jesli nie to zostanie oddac ci drukarke komus kto ma doswiadczenie w naprawianiu elektronik OKI
  • #5
    chief
    Level 22  
    Sprawdziłem dokładnie elektronikę i poprawiłem wszystkie luty które wyglądały podejrzanie, zrobiłem to juz wcześniej, żaden z kondensatorów nie wyglada podejrzanie lecz dla pewności wymienię elki w zasilaczu, co do druku to sprawdzę i dam znać. Instalowałem ja jako IBM 9 igłowy lecz to nie pomogło jako Epson nie sprawdzałem

    chief
  • #6
    kosmita
    VIP Meritorious for electroda.pl
    a kopiowanie prostego pliku textowego na port lpt np autoexeca??
  • #7
    chief
    Level 22  
    Jak bym nie ustawił druku to nic nie daje, jak drukuje zwykły plik tekstowy np.autoexec to karetka jeździ po całej długości wałka i poźniej zatrzymuje się na początku i w jednym miejcu drukuje poruszając się tylko kilka mm, później po wydruku przewija papier aż do momentu wyłączenia drukarki.

    chief
  • #8
    kosmita
    VIP Meritorious for electroda.pl
    a sprawdzales tego 74ls06 na wejsciu??? (buforuje stan lini sterujacych??? jak to nie to tozostaje tylko sisasc z schematem i badac co dzieje sie w elektronice a co powinno sie dziac... moze to byc procesor ale na odleglosc to mozna sobie gdybac bo moze tez byc jakis rezystorek... jak to zwykle w elektronice.. dobrze by bylo z innej drukakrki podmienic elektronike zeby miec 100% ze to na pewno drukarka

    pozdrawiam
  • #9
    chief
    Level 22  
    74ls06 jeszcze nie sprawdzalem, spróbuję z podmianą elektroniki, jednak wykluczam winę kompa na 100% . Wiesz może skąd mogę ściągnąć schemat do niej.

    chief
  • #10
    kosmita
    VIP Meritorious for electroda.pl
    powinien byc w serwisowce ktora jest na elektrodzie
  • #11
    chomiq
    Level 12  
    Keszel3 wrote:
    Spróbuj zainstalować ją w Windowsie jako np. EPSON 1170 i sprawdź wydruk.

    Witam!
    Moja OKI 321 Microline zachowuje sie tak jak opisuje chif, z windowsa drukuje krzaczki po całym wałku.
    Zainstalowałęm ją jako EPSON 1170 i drukuje prawie dobrze.
    Przed każdą linią pojawia sie jeden dziwny znaczek ( najczęściej małe a z daszkem ).
    Co to oznacza? Jak mozna to naprawic?
  • #12
    pawelzet
    Level 21  
    chomiq a jak masz ją ustawiona w setup-ie samej drukarki. Jako IBM Proprinter ,czy EPSON, czy jakoś tam jeszcze, chyba GRAPHICS?
  • #13
    kosmita
    VIP Meritorious for electroda.pl
    chomiq wrote:

    Zainstalowałęm ją jako EPSON 1170 i drukuje prawie dobrze.
    Przed każdą linią pojawia się jeden dziwny znaczek ( najczęściej małe a z daszkem ).
    Co to oznacza? Jak mozna to naprawic?

    a jaki masz system operacyjny?? jakie sterowniki?? jaki rodzaj wydruku (graficzny czy tekstowy, tekst z worda to wydruk grafiki :!: )?? z jakiego programu drukujesz?? jest tu pare dobrych osób od napraw no ale nie aż tak żeby jasnowidzieć.. podaj więcej szczegółów to pewnie Ci pomożemy
  • #14
    pawelzet
    Level 21  
    Ważne, żeby w PC-cie drukarka była zainstalowana jako ta, która jest ustawiona w setup-ie samej drukarki. Jak zrobisz wydruk setup-u drukarki, to będziesz miał np. EPSON, i jako EPSON, w tym przypadku może być 1170, musisz mieć zainstalowanego w PC. Jeśli masz inaczej to skoryguj to.
  • #15
    chomiq
    Level 12  
    Dzieki za zainteresowanie:)

    Sprawa wygląda tak:

    Czsem, w róznych momentach drukarka przestaje drukowac i zaczynać migać kontrolka MENU ( wg. instrukcji przegrzanie głowicy )
    pomimo, że głowica jest zimna.
    Jak się opuka, dociśnie na obudowe lub karetkę to na chwile się uspokaja i drukuje poprawnie.
    Drukarka jest wstępnie przeczyszczona.
    Stan baterii w drukarce 3,29 V.
    Jakie są najbardziej prawdopodobne miejsca usterki ???
    Gdzie szukać newralgicznych punktów ???
    Które styki, złączam, płytki ???
    Czy może być uszkodzony czujnik temperatury w głowicy ???

    W setupie drukarki ustawiona jest jako Graphics Printer i działa zainstalowana jako OKI 321 IBM albo jako Epson( ze znaczkami przed linią).
    Z tym sie już chyba z waszą pomocą uporałem.
    Testowana na p133 i duronie1,0 pod Win98se i Win2k, z notatnika, acrobata i painta.

    Pozdrawiam.
  • #16
    Kazik
    Printers specialist
    chomiq wrote:
    Dzieki za zainteresowanie:)

    Sprawa wygląda tak:

    Czsem, w róznych momentach drukarka przestaje drukowac i zaczynać migać kontrolka MENU ( wg. instrukcji przegrzanie głowicy )
    pomimo, że głowica jest zimna.
    Jak się opuka, dociśnie na obudowe lub karetkę to na chwile się uspokaja i drukuje poprawnie


    Jest duże prawdopodobieństwo że masz niekontakt na termistorze w głowicy - trzeba delikatnie go przelutować. Poza tym obejrzyj całą elektronikę czy gdzieś "gołym okiem" nie widać popękanych lutów. Powyjmuj i powkładaj wszystkie taśmy, złącza itp. To na razie tyle. Napisz czy to coś pomogło.
  • #17
    szauek
    Level 12  
    W windowsie są zawsze dwa rodzaje sterowników. Jeśli zainstalowałeś sterowniki które w nawiasie maja (microline) a nie (IBM) to mogą się drukować krzaki. Spróbuj zmienić na IBM bez względu na to co masz ustawione w setup-ie samej drukarki
  • #18
    chomiq
    Level 12  
    Pomogło przelutowanie czujnika temperatury.
    Teraz trwają testy ;) Dzięki za pomoc.
    Pozdrawiam.