Elektroda.pl
Elektroda.pl
X

Search our partners

Find the latest content on electronic components. Datasheets.com
Elektroda.pl
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

www.YouTube.com i pogarszanie jakości plików wideo...

Kubbaz 12 Jan 2009 22:44 3013 2
  • #1
    Kubbaz
    Level 26  
    Witam,

    Po nagraniu aparatem cyfrowym filmu (plik AVI) w standardowej rozdzielczości VGA 640 pikseli x 480 pikseli skopiowałem go na dysk twardy komputera i postanowiłem udostępnić w Internecie na serwisie www.YouTube.com. Jednocześnie chciałem nieco skompresować plik filmowy przed wysłaniem na serwis www.YouTube.com i dodać w jego kadrze jakiś napis tzw. znak wodny (cokolwiek, nieważne...). Po utworzeniu skompresowanych plików (skompresowanego i z dodanym napisem / logo oraz tylko skompresowanego – bez napisu / logo ) odtwarzanych z dysku komputera przez np. Winamp 2.95 (x86) jest bardzo dobrej jakości.

    Po wysłaniu skompresowanego bez napisu filmu na serwis www.YouTube.com film można było kiedyś oglądać w wysokiej rozdzielczości i wszystko było ok., wszystko dobrze widać, było ostre nie pikselowało. Teraz coś się popsuło... nie ma opcji oglądaj film w wysokiej rozdzielczości, co się stało ?

    Ten sam plik kiedyś: http://www.youtube.com/watch?v=7wq-LjfcHJI&feature=channel_page
    (co prawda skompresowany w nie pamiętam jakich ustawieniach ale na pewno w Target bitrate: 1200 kbps, a zatem mniejszym niż teraz – 1500 kbps)



    Pliki filmowe teraz po wysłaniu na serwis www.YouTube.com wyglądają tak:
    - skompresowany bez napisu: Link
    - skompresowany z napisem / logo: Link

    Do kompresji filmów używam programu VirtualDub 1.8.5 z kodekiem XviD MPEG-4 Codec z poniższymi ustawieniami:
    Profile@Level: Advanced Simple@L4
    Encoding type: Single Pass
    Target bitrate: 1500 kbps
    Audio: Direct Stream

    Do nakładania napisów na film używam programu VirtualDub 1.8.5 z wtyczką logo (17b2) (plik logo17b2.zip do pobrania w załącznikach) Donald Graft z poniższymi ustawieniami:
    Transparent Color:
    Red: 255
    Green: 255
    Blue: 255
    Tolerance: 254
    Alpha: 255

    Oryginalne pliki (przed wysłaniem na serwis www.YouTube.com):
    - plik skompresowany (23,3 MB) (z ustawieniami jak powyżej) do pobrania pod adresem Link,
    - plik skompresowany (23,3 MB) (z ustawieniami jak powyżej) i z dodanym napisem (z ustawieniamii wtyczki logo 17b2 jak powyżej) do pobrania pod adresem Link,

    Plik graficzny jakiego użyłem do utworzenia logo / napis to bitmapa (BMP) utworzona w np. MS Paint (plik logo.rar w załącznikach)
    System operacyjny jaki posiadam do MS Windows 2000 SP4.
    Przeglądarka internetowa, której używam to Mozilla FireFox 3.0.5.

    Co się dzieje podczas przesyłania pliku AVI na serwis www.YouTube.com że film traci jakość?
    Jak temu zaradzić, aby film skompresowany był dobrej jakości takiej jak ten wysyłany wcześniej?
  • #2
    xamrex
    Level 28  
    Na pewno Youtube kompresuje jeszcze filmy które ty wysyłasz. Gdzieś kiedyś widziałem w jakiej rozdzielczości i jakim kodekiem najlepiej wysyłać na Youtuba, ale nie potrafię tego teraz znaleźć.

    A co do tego, że kiedyś film można było oglądać w wysokiej rozdzielczości, a teraz nie to naprawdę dziwne.. Nie wiem czemu tak się stało.
  • #3
    pipinet

    Level 18  
    Oczywiście żę pliki są kompresowane. Czytałem że obraz w dobrej jakości jest dostępny przy korzystaniu z angielskiej wersji youtube, ale nie sprawdzałem czy to prawda.