Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

WD Caviar 22500 i "błąd dostępu"

Krystian14 15 Kwi 2004 20:26 4271 12
  • #1 15 Kwi 2004 20:26
    Krystian14
    Poziom 17  

    WD Caviar 22500 przy partycji NTFS, płyta Shuttle HOT-555A Pentium I 166 Mhz

    Dysk działa sprawnie bez bad sectorów. Serwisowałem na nim nagrywarkę SCSI i wszystko działało bez problemów. Dysk leżał cały czas w obudowie komputera, gdy go z powrotem podłączyłem, Windowsa 2000 wogóle nie mogłem uruchomić. Po pewnym czasie w końcu ruszył, jednak ScanDisk wogóle nie działał. Po resecie nigdy nie wstał. Usunołem partycję fdiskiem, utworzyłem na maxa FAT32, jednak podczas formatowania zawsze zgłaszał błąd - "Brak dostępu" i dalej nie szedł. W końcu doszedłem do wniosku po paru formatach, że błąd ten występuje w pewnym sektorze. Zawsze w jednym miejscu format kończył

    W tej płycie głównej mam dostępu low-fomat po włączeniu bios-modem max 65 GB. Bada on jakby dysk od końca i pełno ad sectorów, jednak nie pozwoliłem mu skończyć

    Dysk stuka jak nie jest ustawiony na Cable Select. Po sformatowaniu 32 MB znalazłem tylko 1 bad sector

    Czego to jest wina, chciałbym mieć dostępny cały dysk i wtedy był sformatował low-formatem, aby usunąć bad-sectory

    Nie pamiętam, co sie działo z tym dyskiem podczas ostatniej sesji w Windowsie 2000:( Nigdy nie miałem z nim problemów.
    Wykrywany jest poprawnie

    Mogę go spokojnie używać jako 32 MB, ale pojemność jego była 2 GB, szkoda mi go na 386 sadzić

    PS. Obliczenie spójności tego dysku nie trwało krótko, nawet robił to parę razy. Na allegro jest taki sam dysk, który zgłasza taki błąd

    0 12
  • #2 16 Kwi 2004 00:17
    -KrZySieK-
    Poziom 15  

    No to chyba po twardym. Sprawa podobna co u mojego kumpla trochę czasu temu, tylko on miał 1,2 GB Cawiara. Chodzil super chyba przez cale 2 lata ! Przy którymś uruchomieniu kompa po prostu zaczęly się dziać z nim cuda iewidy ! Ale gównie pojawiały się BAD-y czyli te bad sectory ! Nic nie pomagało, formaty, repartycjonowanie, low format nawet calonocny, nic, nawet zmienaliśmy chyba firmware tego twardego i nic ! Padł i szlag go trafił chyba z niczego, niewiem ae chyba w tym przypadku jest podobnie, od kiedy pamiętam i od kiedy miałem do czynienia z tego typu twardymi to po prostu one tak chodziły. Niewiem jak jest z nowymi 40 stkami i 80 tkami i wyzej bo nie używalem ! Według mnie twardy pada bezpowrotnie i nieuchronnie nadchodzi jego koniec. Jako dobre firmy twradych proponuję samsunga który obecnie daje 3 lata gwarancji na swoje twardziele i jako jedyny albo np. IBM-y - też są dobre, szybkie i z pewną gwarancją , a z tych mniejszych i słabszych to mogą być np. Fujitsu albo seagate do 6.4 GB albo 8 GB !
    Pozdrowionka i powodzenia !

    0
  • #3 16 Kwi 2004 00:56
    Krystian14
    Poziom 17  

    To prawda sprawa podobna, ale nie identyczna
    U mnie za jednym razem pojaiwły się te bad sectory, wcześnisje nic nie miałem. Dysk był używany ponad 4 lata, a sam miałbym dzisiaj 14 latniego Quantuma, gdybym przez nieuwagę skopał elektroniki:( Ale o co chodzi z tym "Błąd dostępu", możę jak pozbęde się jakoś tego problemu wtedy naprawie low-formatem te bad-sectory. Może to jakieś uszkodzenie mechaniczne, dysk nagle zaczoł stukać.
    Nie było nigdy żadnych objawów awarii.

    Mam 2 dyski Seagata i jeden spisuje się nieźle, z dysków IBM nigdy nie korzystałem.

    0
  • #4 16 Kwi 2004 10:40
    BIGOLSEN
    Specjalista - HDD i odzyskiwanie danych

    Na początek odpuść sobie fdisk-a , ( widzi tylko partycję na FAT ) . Załaduj program do obsługi dysków WD Caviar - WDCLEAR.EXE do ustawiania partycji . Możesz też użyć programu do dysków firmy Maxtor o nazwie Maxblast 2
    ( musi być o tej nazwie - inne nie będą działać z dyskiem innej firmy ) , powinien działać i z twoim dyskiem . W nim tworzysz dyskietkę startową i restartujesz kompa z tej dyskietki . W programie już , ustawiasz dysk który chcesz obsłużyć . Ustawiasz system plików , na który chcesz sformatować dysk i wielkość partycji -
    ( program widzi wszystkie partycje ) .
    W twoim wypadku prawdopodobnie fdisk nie usunął partycji NTFS , bo jej nie widział i sformatowałeś tylko dane dysku , czyli te dane , które dysk zapisuje : sektor MBR i dane odnośnie powierzchni , czyli na własne potrzeby , a nie systemu plików . Mniemam iż dysk jest dobry , tylko musisz go jeszcze raz ustawić od nowa . Można by to zrobić przy pomocy płyty CD z systemem XP , lub 2000 ( widzą system plików NTFS , natomiast FAT32 , go nigdy nie zobaczy sam ) . Ale uruchamiając instalację z płyty musisz ustawić od nowa partycję na 100% powierzchni dysku i sformatować na pełne FAT .
    Jeżeli się mylę , to trudno , ale wydaje mi się , że taka opcja powinna pomóc . Z innych przychodzi mi do głowy tylko uszkodzona taśma E-IDE .
    Pozdrawiam .

    0
  • #5 16 Kwi 2004 18:29
    gregorianin
    Poziom 27  

    ->BIGOLSEN
    Fdiskiem mozna usunac partycje NTFS, jest "rozpoznawana" jako nieznany system plikow.

    Co to znaczy? ...sformatowałeś tylko dane dysku , czyli te dane , które dysk zapisuje : sektor MBR i dane odnośnie powierzchni , czyli na własne potrzeby.

    MBR sie nie formatuje tylko aktualizuje (ew. czysci)
    dane odnoscie powierzchni... zapewne chodzi Tobie o obszar zarezerwowany na wypadek bledu zapisu w danym sketorze (CRC), no wiec do tego obszaru nie ma zaden program dostepu tylko sam HDD, ktory decyduje co i kiedy sie tam znajdzie.

    ...( widzą system plików NTFS , natomiast FAT32 , go nigdy nie zobaczy sam )... przyznam sie nie rozumiem.

    Uszkodzenie tasmy IDE mozliwe, warto sprawdzic
    Koniecznie polecam zrobienie pełnego testu HDD przy pomocy programu PCCHECK z 98 roku, tam wiele prawdy wyjdzie.
    Bardzo mozliwa bledna konfiguracja w BIOS-ie, dostepu do HDD, CHS, LBA, LARGE jesli sie ustawi zamiast powiedzmy LBA - CHS i jakims cudem sformatuje (jest to wysoce prawdopodobne ze wystapia wlasnie takie bledy) nalezy powrocic do prawidlowego ustawienia i przepartycjonowac dysk !!!
    Najprosciej jak wezmiesz sobie dysk do reki i odpiszesz jego dokladne dane, potem porownaj z tymi wykrytymi przez plyte.

    pozdrawiam

    0
  • #6 16 Kwi 2004 19:33
    0__0
    Poziom 30  

    sprawdz w biosie czy masz dobrze wpisane parametry - dokladnie tak jak napisane na dysku:
    4960cyl 16heads 63sec - ja mialem podobny problem z tym dyskiem i okazalo sie ze nie pracuje on prawidlowo z wlaczonym LBA

    0
  • #7 18 Kwi 2004 23:56
    Krystian14
    Poziom 17  

    Dzięki za zainteresowanie tematem!
    Dysk sprawdziłem, użyłem narzędzie WDCLEAR
    Zgłaszał błędy:

    ECC Error
    Servo Error
    Bsy TimeOut
    DRQ Error

    Na Stornie Wester Digitala opisywali je jako błąd sektórów, dostępu. Częste podawali jako rozwiązanie wymiane dysku. Po 101 błędach program zakończył działanie. Nie pomógł ani low-format z tego programu, ani test odczytu

    Komputer jest "wymienny", pracuje także na innych dyskach, a z nimi nie mam problemów, więc to nie jest wina taśmy. Parametry są podane dobrze, dysk pracuje w trybie LBA.
    Wydaje mi się, że już nic z niego nie będzie, pozostaje pytanie.
    Jak to się mogło stać?

    0
  • #8 19 Kwi 2004 08:50
    0__0
    Poziom 30  

    Przeciez napisalem ze MUSI byc wylaczone LBA -mam taki sam dysk a te parametry ktore podalem byly z niego spisane - z wlaczonym lba fdisk u mnie sie zapetlal przy sprawdzaniu spojnosci - dochodzil do 90% i zaczynal od nowa.

    0
  • #9 19 Kwi 2004 21:35
    roodzeek
    Poziom 23  

    Jak WDCLEAR zgłasza takie błędy to dysk na 99% jest już martwy. Sprawdź czy podczas jak leżał w szafie to np młodsze rodzeństwo nie użyło go do zabawy lub po prostu nie upadł. Błędy servo i DRQ pojawiają się wtedy w dużych liczbach. Czy dysk nie chodzi głośniej niż powinien?

    0
  • #10 19 Kwi 2004 22:41
    Krystian14
    Poziom 17  

    :arrow: 0__0 Niestety to nic nie pomogło, z wyłączonym LBA i w trybie normal z dyskiem nic sie nie zmieniło

    :arrow: roodzeek Dysk leżał cały czas w obudowie pod innymi, brat mi go napewno by nie uszkodził, bo wtedy ja bym go uszkodził :D

    Dysk wogóle juz chyba nie działa, stuka, test spójności cały czas przy 0%, trafił się 1%, ale potem znów 0. Partycja podstawowa znikneła. Dyskiem nie rzucałem o ściane. Quantum 50MB lezał pod łużkiem cały zakużony i nic, a ten tak nagle padł:-(

    0
  • #11 19 Kwi 2004 22:56
    roodzeek
    Poziom 23  

    Jedyne co mogło mu się stać to pole magnetyczne (pytanie skąd?) albo jakiś dziwny błąd jak go uruchamiałeś. Jak stuka to ma problem z initializacją (musi odczytać część danych potrzebnych do pracy z talerzy i tego nie potrafi) i raczej możesz go sobie powiesić nad biurkiem.
    Miałem sytuacje z WDkami że elektroniki padały ale na to trzeba było sobie naprawdę zapracować.
    Znajdź program WDDIAG ver 2.20 (ta, nie inna) i spróbuj przetestować. Ale stukania to mi się jeszcze nie udało naprawić...

    0
  • #12 21 Kwi 2004 22:26
    Krystian14
    Poziom 17  

    :arrow: roodzeek
    Niestety nie znalazłem WDDIAG w wersji 2.20, jest tylko 2.90. O ile to możliwe mógłbyś podać mi link, ew. wysłać na maila

    Elektronika nie wygląda na niesprawną, jednak dysk jest bezproblemowo wykrywany tylko przy Cable Select, w innych ustawieniach Master\Slave bios się męczy i podaje cząstkowe dane abo wogóle. Czy elektronika od modelu 21000 mogła by pasować?

    0
  • #13 22 Kwi 2004 19:38
    roodzeek
    Poziom 23  

    Nie pamiętam czy v2.90 pisze o tym że jest możliwa naprawa (2.20 to wypisuje więc wiem że próbuje naprawiać) ale spróbować nie zaszkodzi 2.90.

    Jak masz takie cyrki ze zworkami to poderzewałbym elektronikę (nie wykluczając mechaniki). Elektronika z WDAC21000 raczej nie będzie pasować - sprawdź numery (na takiej białej nalepce na dole oraz powinny być też wytrawione tak jak ścieżki) jak będą w obu HDD takie same (wątpię) to mógłbyś próbować pod warunkiem że wgrasz firmware lub przelutujesz flasha (odradzam) także raczej na 99% nie będzie pasować.
    WDki z tego co pamiętam były wrażliwe, nawet mając ten sam model (np WDAC34300) to trzeba się patrzeć na to co jest dalej (np 32LB czy 00F). Zamieniając między nimi elektroniki raczej oba zaczną klupać, ale nie powinny się uszkodzić, także po ponownej zamianie na oryginalne powinieneś mieć status quo.

    WDDIAG 2.20 http://roodzeek.w.interia.pl/wddiag.zip

    0