Elektroda.pl
Elektroda.pl
X

Search our partners

Find the latest content on electronic components. Datasheets.com
Elektroda.pl
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

Excel - format daty + godziny

kacper607 22 Mar 2009 08:04 10737 8
  • #1
    kacper607
    Level 11  
    Mam problem z formatem daty i godziny .
    Problem z obliczaniem czasu postoju maszyn.
    Te dane są zrzucane w postaci ciągu liczb.
    Szukam pomocy.
  • #2
    adamas_nt
    Moderator of Programming
    Nie jestem pewien czy chodzi Ci o zmianę na format daty i czasu w kolumnach E,F,G,H w arkuszu "przykład"?
    Jeżeli tak, to z datą nie ma problemu ale czas zapisywany jest w różny sposób (liczby 4, 5 i 6-cio cyfrowe).

    Pytanie:
    1. Godzina 2023 to: 20:23:00 a może 00:20:23
    2. Godzina 23233 to: 02:32:33, 23:23:30

    Przykład:
    wiersz 16: 20090320 2023 do 20090320 90717
    wygląda na: 2009-03-20 00:23:23 do 2009-03-20 09:07:17

    Myślę o czymś takim (dla E2+F2 czas 6-cio cyfrowy) umieszczone w osobnym arkuszu:
    =DATA(LEWY(przykład!E2;4);FRAGMENT.TEKSTU(przykład!E2;5;2);PRAWY(przykład!E2;2))+CZAS(LEWY(przykład!F2;2);FRAGMENT.TEKSTU(przykład!F2;3;2);PRAWY(przykład!F2;2))
    I to samo dla G2 i H2 i po odjęciu obu wyników mamy przestój

    Format komórki wynikowej: rr-mm-dd g:mm:ss
  • #3
    kacper607
    Level 11  
    Witam
    1.Uwaga 2023 to błąd , godziny są podawane 203315 to 20:33:15 , a np: 52425 to 5:24:25
    2.Daty są zrzucane jako 20090320 to 2009-03-20
    3.Często czas zakończenia naprawy jest w dniu kolejnym lub dalszym .

    Muszę zrobić wykresy dla postoju poszczególnych informacji :
    - konkretny wydział
    - lkonkretna linia
    - konkretna maszyna

    Dziękuję .
  • #4
    adamas_nt
    Moderator of Programming
    W wykresach jestem słabiutki, więc w tym Ci nie pomogę. Sumowania czasów przestoju dla poszczególnych działów, linii i maszyn można przedstawić używając (po posortowaniu): raport tabeli przestawnej, sum częściowych lub (bez sortowania) filtrowania.
    Czas przestoju w arkuszu "przykład" można wyliczyć taka formułą wklejoną w komórkę L2 i skopiowaną (przeciągniętą) w dół:

    =JEŻELI(LUB(DŁ(F2)=4;DŁ(H2)=4);"Popraw błąd";(DATA(LEWY(G2;4);FRAGMENT.TEKSTU(G2;5;2);PRAWY(G2;2))+JEŻELI(DŁ(H2)=6;CZAS(LEWY(H2;2);FRAGMENT.TEKSTU(H2;3;2);PRAWY(H2;2));JEŻELI(DŁ(H2)=5;CZAS(LEWY(H2;1);FRAGMENT.TEKSTU(H2;2;2);PRAWY(H2;2)))))-(DATA(LEWY(E2;4);FRAGMENT.TEKSTU(E2;5;2);PRAWY(E2;2))+JEŻELI(DŁ(F2)=6;CZAS(LEWY(F2;2);FRAGMENT.TEKSTU(F2;3;2);PRAWY(F2;2));JEŻELI(DŁ(F2)=5;CZAS(LEWY(F2;1);FRAGMENT.TEKSTU(F2;2;2);PRAWY(F2;2))))))

    Przy czym niestandardowy format komórek w kolumnie L: d gg:mm:ss
  • #5
    kacper607
    Level 11  
    Dzięki . mam już wyliczony czas postoju .
    Proszę jescze o chwilę Twojego czasu.
    Możesz mi pomóc w automatycznym przerzucaniu danych do Arkusza2(wykres).
    Z góry dzięki.
  • Helpful post
    #6
    adamas_nt
    Moderator of Programming
    Najprościej będzie zastosować SUMA.JEŻELI i jako kryteria Nr wydziału/linii/maszyny.
    Spróbuj w B3 lub w C3 w arkuszu "wykres" wkleić formułę:
    =SUMA.JEŻELI(przykład!B$2:B$45;A3;przykład!L$2:L$45)
    i przeciągnij w dół. Pamiętaj: format niestandardowy komórek d gg:mm:ss lub d gg:mm bez sekund.

    Jeżeli nie chcesz wartości zerowych można przez poprawność danych z listy:
    i/lub formuła:
    =JEŻELI(SUMA.JEŻELI(przykład!B$2:B$45;A3;przykład!L$2:L$45)=0;"";SUMA.JEŻELI(przykład!B$2:B$45;A3;przykład!L$2:L$45))

    Excel - format daty + godziny
  • #7
    marek003
    Level 40  
    Ja tylko słówko.

    Sorki że się wtrącę ale (pomimo tego że autor powinien wiedzieć lepiej) uważam że 2023 to nie błąd tylko godzina 00:20:23 (chwila po północy).Wskazuje na to kolejny zapis godzin (wcześniej do 22 godziny a potem 1 godzina rano).

    Nie wiem skąd autor przerzuca dane do excela do arkusza "przykład". Z pliku txt lub podobnego? Jeżeli tak to lepiej zaznaczyć przy konwersji że dane w kolumnach to tekst wtedy zapewne pojawi się 00 przed 2223 i 0 przez 11100. Będzie można wtedy wykorzystać pierwszą z formułę podaną przez kolegę adamas_nt (wszystkie czasy będą 6 cyfrowe)
  • #8
    kacper607
    Level 11  
    Wielkie dzięki za Twój czas i pomoc.
    Pozdrawiam.
  • #9
    kacper607
    Level 11  
    Panowie
    Mam prośbę o wprowadzenie mnie w tworzenie MAKRA na prostych przykładach.

    Pozdrawiam.