Elektroda.pl
Elektroda.pl
X
PCBway
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Naprawa ST3500320AS - nietypowy problem

10 Kwi 2009 15:45 7840 6
  • Poziom 9  
    Podpinam pod terminal, odpalam hyper terminal, podpinam napięcie daje CTRL+Z i:

    F3 T>/2

    F3 2>Z

    Spin Down Complete
    Elapsed Time 0.146 msecs
    F3 2>U

    Error 1009 DETSEC 00006008
    Spin Error
    Elapsed Time 26.432 secs
    R/W Status 2 R/W Error 84150180


    jak to dalej ugryźć ?

    Pozdrawiam i zgóry dziękuje za pomoc
  • PCBway
  • Użytkownik usunął konto  
  • PCBway
  • Poziom 9  
    Nirvanowiec napisał:

    Lepiej nie zabierać sie za coś czego się nie rozumie.
    Kolega nie przykręcił PCB przed komenda U.


    PCB było przykręcone, to nie pierwszy dysk seagate którego "ratuje", Wszystko wg tego samego schematu stąd moje zdziwienie.

    Dysk wykazuje standardową usterke i wisi.
    Na początku z zailozowanym pcb kręci, przestaje pracować, po wyadnmiu komendy U zaczyna chodzić. i error
  • Użytkownik usunął konto  
  • Poziom 10  
    Witam szanowne grono. Natknąłem się na identyczny problem jak kolega _Vomit_. Trochę mnie to zaskoczyło gdyż we wcześniejszych dwóch takich samych dyskach problem tak zwanego BSY udało mi się rozwiązać bez najmniejszego kłopotu.
    Tak więc problem objawia się tymże samym komunikatem jak kolegi przy próbie "rozpędzenia" napędu z tym, że ( kolega _Vomit_ nic nie napisał więc nie wiadomo jak u niego ) silnik ewidentnie zostaje uruchomiony i wydaje się działać normalnie lecz coś jest nie tak z głowicą - podczas rozruchu przez około 7sec. słychać jakby klikanie, jakby utknęła.
    Przy podłączeniu zasilania ( po wcześniejszym rozłączeniu ma się rozumieć ) występuje ten sam objaw z tym że na koniec również i silnik zostaje zastopowany.
    Na obecnym etapie dysk jest już wykrywany przez BIOS - wygląda jakby tym razem był problem 0 LBA. Próba podania komendy formatu partycji "m" kończy się następującym komunikatem:
    Cytat:
    LED:000000CC FAddr:0025BF67
    LED:000000CC FAddr:0025BF67

    i terminal zostaje zablokowany.
    Skończyły mi się już pomysły. Cały czas szukam informacji nie mniej znajduje jedynie pytania bez odpowiedzi. Z całym szacunkiem zwracam się do grona o pomoc jeśli to możliwe.
    Pozdrawiam serdecznie
    Radosław K.

    Ps. Firmware nie był aktualizowany i od początku jest SD15.
  • Poziom 10  
    Panowie, mam problem mianowicie zbudowałem terminal zrobiłem wszystko wg. procedur w internecie i przywróciłem swój dysk (ST3500320AS) do życia, wcześniej jak większość w pewnym momencie przestał być wykrywany przez bios. od razu po naprawie zacząłem kopiować dane, lecz po mniej więcej godzinie przenoszenia plików dysk ponownie przestał być widoczny w windows-ie lecz w biosie pojawiał się, postanowiłem zrobić upgrade firmware-u do wersji SD1A lecz po zainstalowaniu jej i resecie komputera dysk ukazywał się jako ST3500320AS SD1A posiadał wielkość 500GB lecz dane były widoczne ale nie można było ani ich otworzyć ani skopiować ani usunąć. w tej sytuacji powtórzyłem procedurę z terminalem, dysk ponownie wrócił do życia na parę godzin lecz pod koniec kopiowania ostatnich plików znów padł. Większość plików udało się przenieść ale trochę zostało dlatego mam pytanie czy wiecie czym może być spowodowany problem? tutaj nadmienię że podczas kopiowania sporo pilików było widocznych ale niedostępnych do otworzenia.
  • Poziom 10  
    Witam ponownie.
    Piszę praktycznie post pod postem gdyż udało mi się rozwiązać problem i dysk odżył - teraz tylko archiwizacja na drugi dysk (tym razem na WD) i aktualizacja softu/firmware.
    Podejrzewam że problem mógł tkwić w tym o czym napisał kolega Nirvanowiec i mimo dokręcenia PCB, na którymś ze styków mogło tego połączenia nie być z głowicą (w co wierzyć mi się chce gdyż kilkukrotnie podejmowałem i dokręcałem elektronikę).
    Działa w każdym razie i to co zrobiłem:
    - z samego rana (11 to nie rano, ale dopiero wstałem) start dysku by się upewnić, że nic się nie zmieniło - a cóż się mogło zmienić, ale człowiek ma zawsze nadzieję na zdarzenie rzeczy niewyjaśnionych;)
    - następnie power down i podważyłem PCB od strony styków głowicy, pozostawiając połączenie z silnikiem
    - start, rozruch silnika i gdy ten się zatrzymał, ustanowiłem połączenie terminalowe
    - następnie postanowiłem dokończyć procedurę dla BSY czyli poziom pierwszy i czyszczenie S.M.A.R.T.
    - następnie restart zasilania i czyszczenie G-LIST
    - kolejny restart zasilania i formatowanie partycji ( m ) po czym shutdown zasilania.

    Wszystko gra i działa od chwili, głowica nie tyka/klika/stuka czy co to tam był za dźwięk - już po dokręceniu PCB i restarcie zasilania dysk zaczął wydawać normalne dźwięki.

    Tak więc, ogromne podziękowania dla kolegów Okzo, Nirvanowiec, migol21, gradius2 i gsustek z for zagranicznych i wielu innych, którzy podzielili się wiedzą na temat problemu i to dzięki nim możliwe było rozwiązanie.
    Pozdrawiam serdecznie i życzę powodzenia.

    Na koniec jeszcze log z dzisiejszej operacji:
    Cytat:
    F3 T>/2

    F3 2>

    F3 2>Z

    Spin Down Complete
    Elapsed Time 10.033 secs
    F3 2>

    F3 2>U

    Spin Up Complete
    Elapsed Time 6.245 secs
    F3 2>/T

    F3 T>/1

    F3 1>N1

    F3 1>
    Blks 000E24-000E24 (000001), BufAddr 001C4800-001C49FF, DBA 061C4800, BytesPerBl
    k 200 Online Cmd SDBP DFB
    Blks 000E25-000E25 (000001), BufAddr 001C4A00-001C4BFF, DBA 061C4A00, BytesPerBl
    k 200 Cmd Input Buf
    Blks 000E26-000E26 (000001), BufAddr 001C4C00-001C4DFF, DBA 061C4C00, BytesPerBl
    k 200 Diag Batch File
    Blks 000E27-000E27 (000001), BufAddr 001C4E00-001C4FFF, DBA 061C4E00, BytesPerBl
    k 200
    Blks 000E28-000E28 (000001), BufAddr 001C5000-001C51FF, DBA 061C5000, BytesPerBl
    k 200
    Blks 000E29-000E29 (000001), BufAddr 001C5200-001C53FF, DBA 061C5200, BytesPerBl
    k 200
    Blks 000E2A-000E2A (000001), BufAddr 001C5400-001C55FF, DBA 061C5400, BytesPerBl
    k 200
    Blks 000E2B-000E2B (000001), BufAddr 001C5600-001C57FF, DBA 061C5600, BytesPerBl
    k 200
    Blks 000E2C-000E2F (000004), BufAddr 001C5800-001C5FFF, DBA 061C5800, BytesPerBl
    k 200
    Blks 000E30-000E33 (000004), BufAddr 001C6000-001C67FF, DBA 061C6000, BytesPerBl
    k 200
    Blks 000E34-000E37 (000004), BufAddr 001C6800-001C6FFF, DBA 061C6800, BytesPerBl
    k 200
    Blks 000E38-000E3B (000004), BufAddr 001C7000-001C77FF, DBA 061C7000, BytesPerBl
    k 200
    Blks 000E3C-000E5B (000020), BufAddr 001C7800-001CB7FF, DBA 061C7800, BytesPerBl
    k 200 Diag Mode Cmd SDBP DFB
    Blks 000E5C-000E7B (000020), BufAddr 001CB800-001CF7FF, DBA 061CB800, BytesPerBl
    k 200 Drive Geometry SDBP DSB
    Blks 000E7C-000E9B (000020), BufAddr 001CF800-001D37FF, DBA 061CF800, BytesPerBl
    k 200 Ext Test Service SDBP DSB
    Blks 000E9C-000EBB (000020), BufAddr 001D3800-001D77FF, DBA 061D3800, BytesPerBl
    k 200
    Blks 000EBC-000F15 (00005A), BufAddr 001D7800-001E2BFF, DBA 061D7800, BytesPerBl
    k 200
    Blks 000F16-000F6F (00005A), BufAddr 001E2C00-001EDFFF, DBA 061E2C00, BytesPerBl
    k 200
    Blks 001769-001AFA (000392), BufAddr 002ED200-0036128F, DBA 062ED200, BytesPerBl
    k 208 Default Diag Rd Buf
    Blks 001B0C-001E9D (000392), BufAddr 00361800-003D588F, DBA 06361800, BytesPerBl
    k 208 Default Diag Wrt Buf
    /T

    F3 T>i4,1,22

    F3 T>
    F3 T>m0,2,2,0,0,0,0,22
    Max Wr Retries = 00, Max Rd Retries = 00, Max ECC T-Level = 00, Max Certify Rewr
    ite Retries = 0000

    User Partition Format Successful - Elapsed Time 0 mins 00 secs

    F3 T>