Elektroda.pl
Elektroda.pl
X
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

Zasilacz impulsowy do zastosowań audio 250W - projekt

Qwet 03 May 2013 11:13 457420 1147
Computer Controls
  • #991
    kaka0204
    Level 28  
    elektryku5 wrote:
    Co do IR to nie wiem czy u mnie zostanie użyty, ze względu na dostępność i cenę,

    W TME bez problemu można dostać za ok. 4zł/szt. Nie jest to chyba jakaś ogromna suma a jaka prostota. W dodatku odpada trafko sterujące.
  • Computer Controls
  • #992
    Chrusta
    Level 22  
    A ja może odświeżę troszkę temat. Dziś podczas porządków odkopałem swój zasilacz, o którym pisałem kilka stron wcześniej. Jako że ostatnio, kiedy coś robiłem przy tym zasilaczu - obciążałem go tylko grzałką, więc właściwie w pełni go nie przetestowałem. Dziś miałem pod ręką spiralę z drutu oporowego (jakaś stara grzałka), odmierzyłem odcinek 10 Ohm, podłączyłem i o to jakie efekty uzyskałem na dwóch D13009K (prawie to samo co MJE13009) i trafie prawie identycznym jak ETD34 (tylko kilka mm wyższe, zdjęcia trafa mniej więcej w połowie strony 27 tego tematu):
    prąd 4,84A
    napięcie 68,4V
    co daje wydzielaną moc około 330W.

    Przekładnia transformatora była na 99,9% dobrana na 2x35V. Wodę w szklance gotowało bardzo szybko, jednak testy nie trwały dłużej niż kilkanaście sekund, po tym czasie odłączałem na chwilę zasilacz żeby skontrolować temperatury i ponownie włączałem. W sumie jednak zasilacz parę minut pracował. Trafo i diody prostownicze nie zagrzały się w ogóle, radiator od tranzystorów baardzo delikatnie, ledwo się dało wyczuć.

    Bałem się obciążać zasilacz przez dłuższy czas (i próbować dać jeszcze mniejsze obciążenie), gdyż obawiałem się czy nie strzeli mi któryś z tranzystorów kluczujących. Całość leżała także "luzem" na biurku. Dość mocno grzał się też czarny element wpięty szeregowo za mostkiem prostowniczym, coś jak warystor (ale nie warystor), lecz zapomniałem jego nazwy termistor :). Wstawię większy. Oryginalnie, ten zasilacz gdy pracował jako zasilacz AT, miał pewnie ze 150W max.

    Co sądzicie o wynikach? Ile mogę jeszcze spróbować "wycisnąć" mocy, by nie wystrzeliły mi tranzystory kluczujące? W razie coś to mam jeszcze dwie pary w zapasie, więc mogę dołożyć.

    Zachęcam do eksperymentów, szczególnie do przerabiania starych zasilaczy AT. Ja właściwie za darmo mam bardzo lekki zasilacz 300W. Jeszcze drugie takie trafo i dodatkowa para kluczujących i można złożyć wzmacniacz 500W ważący grosze :D.

    Pozdrawiam.

    PS. Jeszcze jak ktoś mógłby mi powiedzieć, jak jest z pojemnością kondensatorów filtrujących we wzmacniaczu z zasilaczem impulsowym, to byłbym bardzo wdzięczny.

    PS2. I nie mam w zasilaczu dławika, jak pisałem wyżej - o dziwno nic się specjalnie nie grzeje.

    Aktualizacja posta ----------------
    Kolejny test. 5,96A, 66,2V ==> 395 W. Dołożyłem drugą parę D13009K. Test trwał kilkanaście sekund i nic nie wybuchło ani zbytnio się nie nagrzało (oprócz wody w szklance). Czasami włącza się tylko zabezpieczenie (zasilacz zaczyna brzęczeć i przestaje pracować. Zastanawia mnie tylko co to za zabezpieczenie, skoro oryginalne odłączyłem (układ z przekładnikiem prądowym, idący do 4 nóżki układu TL494).
  • #993
    pinkin
    Level 18  
    Termistor we z tego co pamiętam miał być przed mostkiem.
    Ja na testach uruchamiałem na krótko zasilacz kombinując z obciążeniem. Pierwszy test trwał 45min(godzina bez, a potem z obciążeniem) i dopiero wtedy byłem w stanie stwierdzić co się grzeje, a co nie.

    ad. PS. nie wiem o jakie kondensatory ci chodzi. Jeśli o kondensatory na wyjściu zasilacza, to było o tym w temacie.
    ad. ps2. ok, to Twój zasilacz. Po prostu jeżeli chodzi Ci o dławiki wyjściowe, to radze Ci je jednak założyć.
    Chrusta wrote:
    Czasami włącza się tylko zabezpieczenie (zasilacz zaczyna brzęczeć i przestaje pracować. Zastanawia mnie tylko co to za zabezpieczenie, skoro oryginalne odłączyłem (układ z przekładnikiem prądowym, idący do 4 nóżki układu TL494).

    Może to właśnie kwestia dławików. Coś jest nie tak skoro zabezpieczenie działa, choć nie powinno. Zamiast kombinować z mocą "w górę", pokombinuj z kwestią zabezpieczenia. (pomierz napięcia itp)

    Dodano po 3 [minuty]:

    PS. Nie wiem jak podłączyłeś druga parę tranzystorów. Nie było o tym mowy. Nie wiem czy wiesz, ale ze względu na polaryzację złącza nie można z nimi dowolnie kombinować, jak np z rezystorami.
  • #994
    Chrusta
    Level 22  
    pinkin wrote:
    PS. Nie wiem jak podłączyłeś druga parę tranzystorów. Nie było o tym mowy. Nie wiem czy wiesz, ale ze względu na polaryzację złącza nie można z nimi dowolnie kombinować, jak np z rezystorami.


    Równolegle z tymi co już były + rezystory 3R3 do baz (oryginalnie też były takie rezystory przy bazach). Z tym może coś pogmatwałem, po jednym teście i tak odłączyłem dodatkowe tranzystory.

    Z zabezpieczeniami to się pogubiłem trochę, bo na płytce było sporo "niepotrzebnych" elementów, np. od przewodu P.G. (podaje na płytę główną 5V gdy napięcia się ustabilizują), a nie zrysowałem sobie całego schematu.

    pinkin wrote:
    ad. PS. nie wiem o jakie kondensatory ci chodzi. Jeśli o kondensatory na wyjściu zasilacza, to było o tym w temacie.

    O te na wejściu wzmacniacza (jeśli z takowym współpracuje zasilacz impulsowy), chociaż to to samo :). Z tego co pamiętam, to miały one nie być zbyt dużej pojemności, by nie powodować przeciążania przetwornicy spowodowanego wysokim prądem ładowania kondensatorów (przy włączaniu, przy uderzeniach basu, gdy zużywane jest dużo energii zgromadzonej w kondensatorach). Chociaż sam nie wiem jak to jest, duża czy mała pojemność, ostatecznie nie wychodzi na to samo? Poszukam jeszcze w tym temacie, choć nie przypominam sobie by było napisane coś konkretniejszego.

    Chciałem przerobić zasilacz AT żeby zbytnio się nie męczyć, a summa summarum i tak pewnie wykonam swoją płytkę albo tą zaprojektowaną przez kolegę Qwet.

    Czy jeśli na pin 2 układu TL494 podam połowę Vref (a nie pełne Vref), a nóżkę 1 połączę z masą, to czy wzmacniacz błędu będzie "wyłączony"?

    W moim zasilaczu zabezpieczenie nadprądowe było zrealizowane na 4 pinie (plus oczywiście przekładnik prądowy, itp) - po podaniu na ten pin napięcia >4V, układ się wyłączał.

    W jakim celu na poniższym schemacie między nóżką 2 i 3 znajduje się kondensator i rezystor? Na schemacie autora tego tematu nie ma tych elementów.
    Zasilacz impulsowy do zastosowań audio 250W - projekt
    Tyczy się to też chyba większości zasilaczy komputerowych, praktycznie wszędzie widziałem te elementy między 2 i 3 nóżką. Przykładowo na 9 schematów zasilaczy AT które posiadam - na 8 z nich między nóżką 2 i 3 znajduje się rezystor i kondensator.

    PS. Oryginalne dławiki były na napięcia 12V, 5V, więc je wywaliłem. Przeprowadzałem próby z nawiniętym dławikiem, różnicy nie zauważyłem, chociaż finalnie i tak dławiki pewnie zrobię.
  • #996
    elektryku5
    Level 39  
    Wcześniejsze eksperymenty przeprowadzałem na gotowych trafach i było ok, natomiast ostatnio nawinąłem swoje i jest problem... Zasilacz to TL494 bez stabilizacji, transformator 2x20zw. pierwotne, 2x12zw. wtórne, napięcie powinno wynosić około 44V, no i tyle wynosi, problem polega na tym, że trafo piszczy, po pominięciu żarówki szeregowo z zasilaniem napięcie po chwili leci na 70V i zaczyna piszczeć może nawet mocniej, kiedy trafo nie było sklejone działo się tak nawet z szeregową żarówką, dość mocno grzeje się duodioda na wyjściu. Obciążenie nie działa, bez duodiody piszczenie też występuje.

    Nie wiem, muszę transformator "zalać", żeby był cały sklejony, czy co?
  • #997
    kaka0204
    Level 28  
    Z jaką częstotliwością pracuje generator? Wygląda na to, ze częstotliwośc spada do słyszalnej przez człowieka.
  • #998
    elektryku5
    Level 39  
    Dokładnie nie sprawdzałem, ale był to zasilacz komputerowy i z oryginalnym trafem działał, więc albo coś to moje trafo felerne, albo zasilacz wariuje.

    A na tym zasilaczu tylko testowałem to trafo, bo IR2153 czeka, tylko mosfetów oraz PCB jeszcze nie mam.
  • Computer Controls
  • #1000
    elektryku5
    Level 39  
    Swojego nie, ale pożyczyć mogę, choć obawiam się, że coś nie tak z źle sklejonym trafem. Możliwe, czy to raczej fabryczny zasilacz szwankuje?

    Zobaczymy jak będzie to chodzić z IR2153.
  • #1001
    kaka0204
    Level 28  
    Jeszcze jedna dość istotna informacja. Jest to transformator bez szczeliny, czy ze szczeliną?
  • #1002
    elektryku5
    Level 39  
    Oczywiście bez szczeliny, identyczny rdzeń jak był w oryginale.
    Miał ktoś z Was podobne problemy z własnym trafem?
  • #1003
    unnamed
    Level 13  
    Witam
    Wykonalem przetwornice bazujac na schemacie kolegi Qwet z niewielkimi przeróbkami
    Oto schemat
    Zasilacz impulsowy do zastosowań audio 250W - projekt
    Uruchamianie ukladu zaczalem od wylutowania dlawika LC4 i za nim podlaczylem zasilacz 20V oraz oczywiscie zasilanie sieciowe do w celu zasilania sterownika przetwornicy. Wówczas wszystko wygladalo dobrze , na wyjsciu przetwornicy pojawily mi sie napiecia 1V 1,4V oraz 2,2V ,takwiec przyszla pora na podlaczenie calosci ukladu do sieci , wlutowalem dlawik LC4 .
    Po podlaczeniu do sieci i uplywie ok 1,5sec wybuch MOSFET-ow. Zrobilem ogolny przegląd w poszukiwaniu ewentualnych bledow , zimnych lutow i zwarc ale niestety nic nieznalazlem.
    Jedyne co mi przychodzi do glowy to zle nawiniety glowny transformator.
    Nawinalem go drutem 0.8mm , uzwojenie pierwotne 2x21zw
    Wtórne podwójnym drutem tej samej srednicy kolejno 4zw dla 12V 7zw dla 24V
    10zw dla 35V
    Rdzen ETD39 o srednicy kolumny glownej 12.5mm czyli przekroj rdzenia 1.22cm^2
    A tu przebiegi i wyglad plytki
    Zasilacz impulsowy do zastosowań audio 250W - projekt Zasilacz impulsowy do zastosowań audio 250W - projekt
    Co moze byc jeszcze nietak ? juz brak mi pomyslow
  • #1004
    Kamis47
    Level 13  
    elektryku5 wrote:
    Oczywiście bez szczeliny, identyczny rdzeń jak był w oryginale.
    Miał ktoś z Was podobne problemy z własnym trafem?

    Mi się wydaje, że przez nieco inne parametry twojego trafa zmieniła się częstotliwość pracy tej przetwornicy. Zobacz jakie elementy za nią odpowiadają i spróbuj coś pozmieniać.
  • #1005
    kaka0204
    Level 28  
    elektryku5 wrote:
    Oczywiście bez szczeliny, identyczny rdzeń jak był w oryginale.
    Miał ktoś z Was podobne problemy z własnym trafem?


    Może masz jakiś brud pomiędzy pomiędzy polówkami rdzenia i zwiększa się indukcyjność trafa.
  • #1006
    Chrusta
    Level 22  
    unnamed wrote:
    Po podlaczeniu do sieci i uplywie ok 1,5sec wybuch MOSFET-ow. Zrobilem ogolny przegląd w poszukiwaniu ewentualnych bledow , zimnych lutow i zwarc ale niestety nic nieznalazlem.


    Na zdjęciu widać żarówkę, zawsze dopóki się nie upewnisz że wszystko ok - włączaj zasilacz z szeregowo wpiętą żarówką. Ja odkąd tak robię, nic nie upaliłem.

    Odłącz trafo główne i się dowiesz czy to jego wina.
  • #1007
    unnamed
    Level 13  
    Ta zarowka ma 45W i wlasnie z wpieta zarowka wyparowywuja IRF-y. Ona na poczatku sie zapala i po chwili przygasa (zazy sie) i wybuch. Szkoda ze tak szybko to nastepuje bo niezdaze nawet zrobic pomiaru na bramkach oscyloskopem.
  • #1008
    kaka0204
    Level 28  
    unnamed wrote:
    Szkoda ze tak szybko to nastepuje bo niezdaze nawet zrobic pomiaru na bramkach oscyloskopem.

    To odłącz trafo główne i zamiast jego podłącz żarówkę. Powinna się świecić troszkę słabiej jak z sieci. Jeżeli mosfety wybuchają, to uszkodzenie szukałbym po stronie generatora. Najlepiej byłoby jakbyś wylutował MOSFETY i sterownik zasilił z niższego napięcia i zobaczył czy impulsy na bramce są.
    Pozdrawiam.
  • #1009
    huhs
    Level 10  
    Witam znalazłem taki rdzeń w szufladzie jest on z atx-a ale nie wiem jaką funkcję pełnił, jego średnica 23mm/wewnętrzna 19mm, czy nadaje się on na rdzeń transformatora sterującego? Zasilacz impulsowy do zastosowań audio 250W - projekt
  • #1010
    _JF_
    Level 23  
    Tylko na dławik, przerabiałem temat szkoda czasu i pieniędzy.
  • #1011
    huhs
    Level 10  
    Ktoś kiedyś napisał że zielone rdzenie z filtra EMI nadają się na transformatory i przekładniki, a ja nie spotkałem się jeszcze z filtrem EMI na rdzeniu pierścieniowym.Mam jeszcze inny zielony rdzeń (trochę mniejszy) ale na nim nawinięty jest już przekładnik który działa poprawnie. Muszę szukać dalej..
  • #1013
    kaka0204
    Level 28  
    huhs wrote:
    Ktoś kiedyś napisał że zielone rdzenie z filtra EMI nadają się na transformatory i przekładniki

    To prawda. Nadają się. U mnie transformator sterujący na zielonym rdzeniu działa bardzo dobrze.
    huhs wrote:
    a ja nie spotkałem się jeszcze z filtrem EMI na rdzeniu pierścieniowym.

    Dość rzadko się zdarzają. Ja na już dość dużo rozkręconych ATX-ów i innych przetwornic znalazłem tylko trzy takie rdzenie.
  • #1014
    Doctore.
    Level 18  
    Najlepszy opis jaki widziałem, fajny projekt, można się wiele nauczyć.
    Niestety nie opłacalne, bo za te pieniądze co ty wydałeś na 250W można łatwo sobie przerobić zasilacz serwerowy i otrzymać 1000W, nawet nie porównuje czasu roboty...
    Ale i tak gratulacje!
  • #1015
    huhs
    Level 10  
    Witam.
    Czy tak powinny wyglądać przebiegi na uzwojeniach wtórnych transformatora sterującego bez obciążenia (wyprowadzenia wiszące nie podłączone)?
    Zasilacz impulsowy do zastosowań audio 250W - projekt
  • #1016
    Chrusta
    Level 22  
    Doctore. wrote:
    Niestety nie opłacalne, bo za te pieniądze co ty wydałeś na 250W można łatwo sobie przerobić zasilacz serwerowy i otrzymać 1000W, nawet nie porównuje czasu roboty...


    A może kolega jakoś rozwinie tą myśl? Bo zaciekawiło mnie to, taki zasilacz to już coś :).
  • #1017
    elektryku5
    Level 39  
    Mnie w tej myśli zastanawia jakie uzyskane zostanie napięcie z takiego serwerowego, w tradycyjnym zasilaczu ATX po wywaleniu kontroli można dostać jakieś 25V (dlatego też myślałem nad użyciem 2 identycznych traf, niestety mam tylko jakieś małe badziewie i nie wiem czy zaprzątać sobie głowę).
  • #1019
    markovip
    Level 34  
    Program wyłącza się po wpisaniu pierwszego waloru...
  • #1020
    arek1234321
    Level 12  
    Aaa zapomniałem dodać że moc podajemy w Watach ale wpisujemy tylko cyfry np. 500. Wpisujemy samą cyfre, potem pole rdzenia w cm2 np. 1.25 i ostatnia rzecz czyli napięcie na uzwojeniu wtórnym w voltach np. 32.