Elektroda.pl
Elektroda.pl
X
SterControl
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

s7-200 podstawowy program - brak reakcji na wyjściu

06 Maj 2009 10:34 1638 8
  • Poziom 20  
    Witam!

    Dopiero zacząłem zabawę z PLC i mam mały problem. Ogólnie do wszystkiego dochodzę sam ewentualnie korzystam z jakichś artykułów z EDW. Zakupiłem z Alle*ro s7-200 CPU 224, programator(konwerter rs232-rs485) złożyłem sam i działa bez problemu (wykrywa, z poziomu MicroWin zatrzymuje i wznawia pracę sterownika itp.) Podłączyłem do I0.0 przycisk. Na wejściach 1M i 2M zwarłem z M (tak jak pokazane w kursie s7 w EDW, ale niestety nie pamiętam w tej chwili numeru czasoposma), jedną stronę przycisku do L a drugą do I0.0. Na wyjściu żarówka(dioda?) na 24V (działa - sprawdzałem na zasilaczu) jedna noga do Q0.0 a druga do M. Program to -||--() Pierwsze wpisuję I0.0 a do drugiego Q0.0 i naciskam PLAY, MicroWin pyta czy zrobić RUN na sterowniku -> OK. Sterownik przechodzi w tryb pracy i jak nacisnę przycisk zapala się kontrolka na sterowniku że wejście jest aktywne ale żarówka się nie świeci. Według kursu z EDW powinienem w Network2 dać --(MEND) niestety w MicroWin nic takiego nie mogę znaleźć a --(END) generuje błąd. Może brak końca programu nie pozwala się żarówce zapalić? Jak to rozwiązać? Może jest jakiś sposób na sprawdzenie samego sterownika czy w pełni funkcjonuje? A może źle odpalam/wgrywam program?
  • SterControl
  • Pomocny post
    Poziom 14  
    Czy zrobiłeś download programu do sterownika?
  • SterControl
  • Poziom 28  
    Program jak na rysunku?
    Wrzuciłeś program do sterownika?
    Możesz zrobić podgląd działania programu, program status?

    s7-200 podstawowy program - brak reakcji na wyjściu

    Na sterowniku na listwie wyjść są punkty 1L+, 2L+, musi tam być podane zasilanie
  • Poziom 20  
    Program jak na rysunku, zapewne nie zrobiłem downloadu programu do sterownika, tak jak pisałem jestem nowy w tej dziedzinie i dochodzę do wszystkiego po omacku. A czy tam nie musi być jakiegoś END'a? Jak zrobić download? 1L+ i 2L+ na wyjściu też nie mam podłączonego do zasilania (czy to może chodzi o wejścia? bo tam mam) Nie wiem też jak się robi podgląd działania programu. Ogólnie dzisiaj wieczorem jak wrócę do domu zastosuję się do uwag i jutro dam znać.
  • Pomocny post
    Poziom 20  
    Witam.
    Wgrales program do PLC??Wszystkie moduly I/O wymagaja zasilania - rozrysowane jest to na module. Sprawdz w programie jakie adresy we/wy sa na tej jednostce, mozliwe ze adresujesz cos czego nie ma.
  • Pomocny post
    Poziom 28  
    Ósma ikonka od lewej (aktywna) to download programu do sterownika.
    Dwunasta to podgląd działania programu.

    "Enda" programu nie musisz mieć, jest dopisywany domyślnie.

    L+ na WYJSCIU masz mieć zasilone.

    s7-200 podstawowy program - brak reakcji na wyjściu
  • Poziom 14  
    L+ na listwie z wyjściami to jest +24V do zasilania np. czujników. Nic tam nie trzeba podłączać!!!
  • Poziom 28  
    pimo17 napisał:
    L+ na listwie z wyjściami to jest +24V do zasilania np. czujników. Nic tam nie trzeba podłączać!!!


    Masz chyba na myśli listwę wejść.

    Z tego co pamiętam, to obwody wyjść są odseparowane galwanicznie od zasilania, zresztą podobnie jak wejścia. Robi się mostki na wszystkie masy i wszystkie kostki zasilania.
  • Poziom 20  
    Maly ma racje, dzieki za podpowiedz, zmostkowalem na wejsciach i wyjsciach M i L+ i program dziala. Dusze na przycisk zarowka swieci. Jeszcze raz dzieki za wytlumaczenie ksiazkowych krokow ;) Temat zamykam.