Elektroda.pl
Elektroda.pl
X

Search our partners

Find the latest content on electronic components. Datasheets.com
Elektroda.pl
HeluKabel Akademia WiedzyHeluKabel Akademia Wiedzy
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

Własny serwer pocztowy

07 May 2009 15:31 6476 7
  • Level 12  
    Proszę o pomoc .

    Na początek powiem czym dysponuję.

    1. Internet (DSL) z TPSA ze stałym adresem IP (XX.XX.XX.XX) któremu odpowiada nazwa hocXX(tu numer zamiast XX).internetdsl.tpnet.pl - mam nadzieje że dobrze rozumię ze w DNS tpsa jest po prostu ten IP powiązany z taką nazwą DNS ??

    2. Kompa na którym chciałbym postawić serwer pocztowy

    3. Mandrive (mam sporo materiałów jak to na niej zrobić - sporo nazbierałem i nie chce zmieniać systemu - może później jak naucze sie na tym.)

    zatrzymałem sie na oknie z wyborem instalacji KDE, GNOME i inna (wybrałem inna) wtedy mi sie spytał co chce instalować (wybralem wszystko co dotyczyło) serwera i inne narzedzia (wg tego co znalazłem w necie ze wymagane) oprócz środowisk graficznych instalacja poszła dalej.

    i teraz tak doszedłem do momentu instalacji - konfiguracja między innym łącza ethernet - ustawiłem ręczną konfiguracje adresu i tu wpisałem tak:

    adres IP - adres kktóry został mi przydzielony (ten o którym pisałem w ponkcie 1)

    maskę (zgodnie z tym co mi nadano)

    brame (jak wyżej)

    adres DNS1 i 2 (standardowe TPSA)

    oraz nazwę hosta wpisałem: hocXX(tu numer zamiast XX).internetdsl.tpnet.pl (i tu nie jestem pewien czy dobrze zrobiłem proszę o weryfikację)

    instalacja przebrnała do końca

    i teraz tak (dalej co zrobiłem)

    1. zaktualizowałem źródła urpmi (wg instrukcji znalezionej na stronie - przeszło bez błędów)

    2. zainstalowalem dodatkowe pakiety (to znalazłem w necie ze powinno być ( urpmi fetchmail wget bzip2 unzip zip nmap openssl lynx fileutils ncftp flex libxorg-x11-devel gcc gcc-c++)

    3. instalacja serwera DNS poleceniem urpmi bind
    i wystartowanie serwera

    4. instalacja mysql (urpmi MySQL MySQL-client libmysql15-devel)

    5. instalacja postfixa (urpmi cyrus-sasl libsasl2 libsasl2-devel libsasl2-plug-plain libsasl2-plug-anonymous libsasl2-plug-crammd5 libsasl2-plug-digestmd5 libsasl2-plug-gssapi libsasl2-plug-login postfix imap)

    i konfiguracja

    postconf -e 'mydomain = internetdsl.tpnet.pl' (moje watpliwosci czy prawidlowo)
    postconf -e 'myhostname = hocXX.$mydomain' (znowu wątpliwości - oczywiście za XX cyferki prawidłowe)
    postconf -e 'mydestination = /etc/postfix/local-host-names, localhost.internetdsl.tpnet.pl' (znowu wątpliwości) postconf -e 'smtpd_sasl_local_domain ='
    postconf -e 'smtpd_sasl_auth_enable = yes'
    postconf -e 'smtpd_sasl_security_options = noanonymous'
    postconf -e 'broken_sasl_auth_clients = yes'
    postconf -e 'smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination'
    postconf -e 'inet_interfaces = all' postconf -e 'mynetworks = 127.0.0.0/8'
    touch /etc/postfix/local-host-names
    touch /var/lib/mailman/data/aliases

    6. edycja pliku /etc/sasl2/smtpd.conf i tu wpis jak poniżej

    # SASL library configuration file for postfix
    # all parameters are documented into:
    # /usr/share/doc/cyrus-sasl/options.html
    # The mech_list parameters list the sasl mechanisms to use,
    # default being all mechs found.
    mech_list: plain login
    # To authenticate using the separate saslauthd daemon, (e.g. for
    # system or ldap users). Also see /etc/sysconfig/saslauthd.
    pwcheck_method: saslauthd
    saslauthd_path: /var/lib/sasl2/mux
    # To authenticate against users stored in sasldb. #pwcheck_method: auxprop
    #auxprop_plugin: sasldb #sasldb_path: /var/lib/sasl2/sasl.db

    7. zrobienie certyfikatu SSL (wg instrukcji przeszło pomyślnie)

    8. sprawdzenie telnet localhost 25, ehlo localhost (ok wg opisu z internetu odpowiedzi ok)

    i teraz tak

    zalogowany jako root dodałem użytkownika z konsoli useradd użytkownik haslo - zrobił

    przełączyłem sie na użytkownika poleceniem su

    wysłałem maila (z konsoli) na adres zewnętrzny XXXX(małpa)wp.pl - doszedł

    próbowałem odpowiedzieć i od razu dostałem zwrotkę jak poniżej:

    Hi. This is the qmail-send program at (nazwa serwera).
    I'm afraid I wasn't able to deliver your message to the following addresses.
    This is a permanent error; I've given up. Sorry it didn't work out.

    <uzytkownik(małpa)hcoXX.internetdsl.tpnet.pl>:
    User and password not set, continuing without authentication.
    XX.XX.XX.XX does not like recipient.
    Remote host said: 554 5.7.1 <uzytkownik(małpa)hcoXX.internetdsl.tpnet.pl>: Relay access denied Giving up on XX.XX.XX.XX.

    --- Below this line is a copy of the message.

    Proszę o pomoc co jest nie tak.
  • HeluKabel Akademia WiedzyHeluKabel Akademia Wiedzy
  • Level 31  
    Weź sobie google translate i przetłumacz. Z tego co widzę co tam pisze to, problemy z użytkownikiem, hasłem oraz autoryzacją.
  • HeluKabel Akademia WiedzyHeluKabel Akademia Wiedzy
  • User removed account  
  • Level 12  
    zmieniono - wypowiedz nie ma sensu po zmianie pierwszej
  • User removed account  
  • Level 12  
    Domena jest już od dawna.