Elektroda.pl
Elektroda.pl
X
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

Willem PRO 4 ISP Problem z zaprogramowaniem 27C512

wojtek1984 12 May 2009 20:18 6916 14
  • #1
    wojtek1984
    Level 12  
    Zapupiłem programator willem pro 4 i mam problem z zaprogramowaniem pamięci eprom 27c512 ( specjalnie do tych kosci go kupiłem). Na początku kupiłem pamięc OTP (jednokrotnego zapisu) i w zakładce Buffer miałem wyswietlone w całej zawartości "FF" i po sprawdzeniu kości Blank Check pokazywały że są puste, ale po programowaniu pasek dochodzi do 100% i wyskakuje błąd " Error at 0x000000 Chip = 0x00 buffer = 0x02" kupiłem kolejne 2 kości jednokrotnego zapisu bo myślałem ze są uwalone i na tych juz w zakładce Buffer wyswietlało całą zawartośc jako "00" i programator nie chciał je zapiasać bo wyskakiwał komunikat " Device is NOT Empty ($000000) " no i znowu zonk. Kupiłem kolejne kości tym razem kasowane UV i na nich wyskakuje to samo co na tych pierwszych zę kości są puste ale się nie programują. Poustawiałem ZWORKI zgodnie z instrukcją napięcie programowania ustawiłem nawet na 15V i przełacznik napięci 5 5/6 ustawiłem w środkowej pozycji i nic. Programator jest zasilany z zewnetrznego zrudła zasilaczem 12V i przy teście Hardware wyswietla "Hardware present" zczytuje zawartośc kości ale ikona Elektronic ID sie nie świeci. Czy to jest wina programatora? Przebadałem z 8 kosci 4 jednokrotnego zapisu i 4 UVki i nic to samo, juz nie mam zadnych pomysłów... Czekam na wasza pomoc bo jak nie to chyba kupie inny programator(prosze o opinie na jakim można te kości zaprogramować) a ten szmelc bede chyba reklamował jak nie bedzie działał.
  • #2
    Robewit
    Level 26  
    Czy zasilacz był dostarczony razem z programatorem? Jeśli nie to spróbuj podłączyć inny 12V DC stabilizowany z plusem w środku o wydajności przynajmniej 0,5A. Możesz sprawdzić napięcie na nóżce VPP, dla pewności z rezystorem obciążającym (270 Ohm od VPP do minusa) dla tego układu powinno być 12,5V. Można je załączyć w zakładce Test HW.
  • #3
    wojtek1984
    Level 12  
    niestety zasilacz nie było w komplecie. Użyłem do tego zasilacza od dysku zewnetrznego 12V DC 1500mA z plusem w środku. Zworki na programatorze ustawiłem zamiast na 12,5V na 15v i nic. Później sprawdze jakie jest napiecie na nóżce Vpp bo teraz nie mam takiej mozliwości.
  • #4
    User removed account
    User removed account  
  • #5
    wojtek1984
    Level 12  
    A jaki programator kolega proponuje? Skoro ten tylko up***sza kości. Byłem przekonany że nie będzie problemu z zaprogramowaniem tej kości skoro jest w spisie obsługiwanych układów?
  • #6
    wojtek1984
    Level 12  
    Sprawdziłem napięcie na nóżce Vpp (nr 22) do minusa zasilacza ma tylko 4,26V. Zmieniłem program na 0,97h w wersji polskiej i mi pokazuje że kość jest zapisana. czy to możliwe żeby nowa kość UV nie była czysta?
  • #7
    User removed account
    User removed account  
  • #8
    wojtek1984
    Level 12  
    Robiłem "blank check" na każdej kości i pokazuje że kość jest zapisana (Device is NOT Empty ($000000) ) w wersji 0,97ja i to samo pokazuje wersja 0,97h pl. Sprawdziłem jeszcze na różnych ustawieniach kość i tu są zbierzności.
    W załączniku są zgrane programatorem wsady:
    Nowa- nowa zakupiona kość UV nie zapisywana jeszcze, podłączona przez kabla 1-1 LPT napięcie 12,5V i 5V
    A- ta sama kość podłączona bezpośrednio pod wyjście w komputerze napięcie 12,5V i 5V
    B- ta sama kość podłączona bezpośrednio pod wyjście w komputerze napięcie 15V i 5V
    C- ta sama kość podłączona bezpośrednio pod wyjście w komputerze napięcie 15V i 5,6V
  • #9
    wojtek1984
    Level 12  
    Problem został rozwiązany. Okazało sie, że elektrit miał 100% racje ze to jest up*** kości. Programator został wysłany do serwisu i okazał się WADLIWY. Odradzam zakupu tego g****, kupiłem Wellona VP-590 i śmiga aż miło...:)
  • #11
    Godziks
    Level 14  
    Potwierdzam stwierdzenie darko12.

    W sumie to także gratuluję pomysłowości użytkownikowi wojtek1984 w rozwiązaniu problemu tzn. zakupu w firmie programatora uszkodzonego i dać się naciągnąć na zakup programatora prawie 8x droższego.

    Ja przynajmniej przed wysyłką testuje programatory.

    Pozdrawiam
    Piotr
    GOTRONIK
  • #12
    Neoklaus01
    Level 2  
    czemu mówicie o głupocie operatora widocznie te programatory mają jakiś błąd bo w moim nowym pro4 również wyskakuje bład przy zaprogramowaniu jakiejkolwiek kości a miedzy innymi tej chol....y 27C512

    jeżeli ma ktoś dobry pomysł na rozwiązanie tego problemu proszę o odpowiedź.
  • #13
    Godziks
    Level 14  
    Po pierwsze proponuję skontaktować się ze sprzedawcą.

    Ja sprzedałem wiele egzemplarzy programatora Willem 7.1 dla klientów którzy potrzebowali zaprogramować układ 27C512. I nikt nie miał problemów z zaprogramowanie tej podstawowej pamięci Eprom.

    Ten układ 27C512 to w jakiej jest obudowie?
    Ponieważ najczęstsze problememy to:
    - w przypadku obudów PLCC32 wsadzenie do nieodpowiedniej podstawki
    - układ nie jest skasowany (opcja Blank Check sprawdza czy układ jest skasowany)
    - w programie obsługującym można zmienić czasy tWP i tWC dla wolniejszych kości EPROM
    - przełącznik DIP-SW-12 nie jest ustawiony jak podpowiada program

    Pozdrawiam
    Piotr Godzik
    GOTRONIK PPHU
  • #14
    Neoklaus01
    Level 2  
    Układ skasowany w kasowarce UV i czysty i sprawdzony.

    Ze sprzedawcą to się kontaktowałem ale po jego wywodach wychodzi że sprzedaja sprawdzone programatory, a jeszcze jedno wczoraj próbowałem zaprogramować pamięć biosu PMC Flash Pm49FL002T i to samo Błąd 0x000000 układu 0x25 i co może być, może jednak jest uwalony ten programator? Mam pytanko może ktoś taki programator w jakiś sposób sobie znany poprawiał żeby programował poprawnie?
  • #15
    Godziks
    Level 14  
    Nie wykluczone że programator mógł ulec uszkodzeniu w trakcie transportu.

    Jeszcze jest taka ewentualność że może układ 27C512 jest uszkodzony.

    Proponuję wyjaśnić do końca sytuację ze sprzedawcą. Najlepiej jest to wyjaśnić bezpośrednio ze sprzedającym i jasno określić rozwiązanie problemu. Bo chociaż jest to konkurencyjna firma to nie chwiałbym na ogólnym forum wypowiadać się o problemach ze sprzętem itp. Także zdarza się czasami że moi klienci zamiast o problemie powiadomić mnie bezpośrednio piszą na forum, a później okazuje się użytkownik popełnia jakiś mały błąd. Ale niesmak pozostaje i zła niezasłużona opinia o firmie.


    W przypadku braku rozwiązania proponowałbym zwrot programatora i zakupienie pewnego sprzętu w mojej firmie:
    http://www.programatory.com.pl/sklep/index.php?p1,programator-willem-7-1-wersja-zif-32

    Można do nas przyjechać z danym układem i przetestować programator przez zakupem.

    Pozdrawiam
    Piotr Godzik
    Gotronik PPHU