Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

PSPICE - dodawanie modeli (CIR), pliki SPI

16 Maj 2009 16:33 2787 1
  • Poziom 14  
    Witam!

    Właśnie tworzę prosty obwód w PSPICE. Tworze go tekstowo, jako plik CIR.
    Ściągnąłem ze strony producentów części, model tranzystora, który chce użyć w układzie.

    Mam pytanie, w jaki sposób dodać go prawidłowo do pliku CIR. Próbowałem w następujący sposób:

    Code:

    ;tranzystor PMOS

    M_T1 we1 wy_1 wy_2 IXTH11P50


    *DEVICE=IXTH11P50,PMOS

    * IXTH11P50 PMOS model
    * updated using Model Editor release 9.2.1 on 10/24/03 at 17:48
    * The Model Editor is a PSpice product.
    .MODEL IXTH11P50 PMOS
    + LEVEL=3
    + L=2.0000E-6
    + W=35
    + KP=522.45E-9
    + RS=10.000E-3
    + RD=.73276
    + VTO=-5.1807
    + RDS=2.0000E6
    + TOX=2.0000E-6
    + CGSO=285.71E-18
    + CGDO=5.0325E-12
    + CBD=3.6162E-9
    + MJ=.62779
    + PB=.59821
    + RG=10.000E-3
    + IS=170.28E-9
    + N=5
    + RB=1.0000E-9
    + GAMMA=0
    + KAPPA=0
    + UO=300

     ; dalsze symulacje .op itp



    lub taki sposób:

    Code:

    M_T1 we wy_kolektor wy_klucz IXTH11P50
    .lib IXTH11P50.lib


    W obu przypadkach mam komunikat podczas symulacji obwodu:

    ERROR -- Missing model

    W jaki sposób dodać ten układ prawidłowo?

    I jeszcze jedno pytanie. Ściągnąłem też modele z rozszerzeniem SPI. W jaki sposób można je dodać do CIRa (w środku jest model typu .subckt nazwa, ale gdy wpisuje po prostu M_T1 we wy wy2 nazwa_subckt, tez mam missing model)?

    Dzięki
    Pozdrawiam
    Darmowe szkolenie: Ethernet w przemyśle dziś i jutro. Zarejestruj się za darmo.
  • Poziom 2  
    CIR:
    ^^^

    .INCLUDE scn05mos_tm.lib
    M1 2 1 3 0 CMOSN W=19.8u L=2.1u
    ------------------------------------------------------------------

    LIB:
    ^^^
    .MODEL CMOSN NMOS ( LEVEL=7
    + [params]
    )