Elektroda.pl
Elektroda.pl
X
Proszę, dodaj wyjątek dla www.elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Astra G - Check Engine (P0130) - nie lambda

28 Maj 2009 10:24 16714 15
  • Poziom 9  
    Witam,

    Na początek info samochodu:
    Astra G 1.6 benzyna, 8V, silnik X16SZR.

    Objawy:
    - kontrolka check engine zapalająca się po przejechaniu kilku km lub kilkunastu minutach
    - jedyny błąd to P0130 (O2 sensor)

    Dodatkowe info:
    - problem pojawia się od momentu wymiany tłumika środkowego
    - początkowo kontrolka zapalała się na chwilę i samoistnie gasła po kilku sekundach
    - w przeciągu kilku dni świeciła się coraz dłużej a aktualnie jak się zapali to już nie gaśnie
    - wymieniłem sondę lambda, ale problem nadal istnieje
    - do tego "dziwnego" momentu (w którym zapala się kontrolka) wskazania z sondy (sprawdzam przez kompa podpiętego do ECU) są poprawne tzn. napięcie się zmienia a mieszanka przeskakuje pomiędzy rich a lean
    - po wystąpieniu błędu sonda się "zawiesza", prawdopodobnie ECU po prostu przestaje ją czytac
    - po wyłączeniu i ponownym odpaleniu silnika znowu wszystko jest ok i trzeba trochę poczekac
    - rano przy temperaturze 15 stopni C, silnik zapala sie poprawnie ale wchodzi na wysokie obroty na biegu jalowym (wczesniej tak nie bylo), jak silnik sie rozgrzeje to jest ok
    - przytkałem dolot powietrza na kilka sekund (okolo 20) ale reakcja byla tylko taka ze wlaczyla sie chlodnica (dodam ze w tym silniku jest dodatkowy dolot chyba CO2 z kolektora wydechowego czy jakoś tak)
    - na 99% to nie EGR bo reaguje poprawnie na testy wykonywane za pomocą prograu auto scanner


    Zakładam że mam jakąś nieszczelnośc w dolocie powietrza ale nie wiem jak to sprawdzic. Moze macie jakies inne pomysly?
    Darmowe szkolenie: Ethernet w przemyśle dziś i jutro. Zarejestruj się za darmo.
  • Poziom 14  
    Nieszczelność tak, ale nie w dolocie tylko w układzie wydechowym. Aby czuujnik tlenu(sonda lambda) pracował poprawnie układ wydechowy musi być szczelny. Przmawia za tym też to co sam napisałeś że problem powstał po wymianie środkowego tłumika.
  • Poziom 9  
    Sugerowałem to mechanikowi podczas wymiany sondy, i przy odbiorze samochodu zapewnił mnie że nieszczelności nie ma. Wszystko posprawdzali, połączyli ponownie i dodatkowo nasmarowali łączenia jakimś środkiem (niestety muszę im wierzyc na słowo). Nieszczelnosc na pewno byla pomiedzy tlumikiem srodkowym a koncowym (kapala woda na laczeniu), ale juz jest ok a blad nadal wystepuje.
    Mechanik twierdzi ze jezeli problem bedzie wystepowal to trzeba wymienic katalizator, czy rzeczywiscie to pomoze?
  • Pomocny post
    Poziom 14  
    Zdecydowanie nie pomoże.

    Twój samochód ma jedną sondę lambda przed katalizatorem i żadną miarą stam katalizatora nie może wpływać na pracę sondy. Jego stan ma wpływ na czystość spalin jakie wydostają się z rury wydechowej ale nie na pracę sondy.
    Wymiana katalizatora miała by sens gdyby samochód miał je dwie. Jedną przed a drugą za. Taki układ pozawala diagnozować za pomoca OBD stan katalizatora. Ale taki układ w Twoim samochodzie nie występuje więc nie ma co o nim pisać.

    Mam jednak pytanie, skąd pewność, że to własnie nie lambda?
    Drugą sondę zakładałeś nową czy używaną?
  • Poziom 9  
    Dzieki za odpowiedz.

    Wymienilem teoretycznie na nowa. Teoretycznie bo sonde zalatwil i zakladal mechanik, wiec 100% nie mam. Wyglada na nowa, ale o dziwo wystaje (z kolektora) bardziej niz orginalna. Sonda jest ponoc jakiejs marki na V, ale nigdzie w internecie takiej nie znalazlem.
    Dlaczego uwazam ze jest sprawna, a no dlatego ze po odpaleniu silnika patrze sobie na wskazania dostepne przez program autoscan (wlanie ODB) i z tego co widze to wskazania mieszanki zmieniają sie z rich na lean dosyc czesto, dodatkowo widze tam rowniez jakies napiecie z sondy wachajace sie pomiedzy 400mV a 500mV.
    Czy mam rozumiec ze wskazania wcale nie swiadcza ze sonda jest sprawna?
  • Poziom 14  
    dzień dobry
    npisałeś sporo infomacji na temat usterki lecz nie napisałeś nic o tym jak zachowuje się samochód w monecie palenia się kontrolki wtrysku i w trakcie normalnej jazdy i czy wrosło ci zużycie lub zmalało
  • Poziom 9  
    Zachowanie samochodu o dziwo sie za bardzo nie zmienilo tzn. gdy kontrolka pojawiala sie po raz pierwszy (na moment) wowczas rwało przez chwile, aktualnie zuzycie jest moze troche wieksze ale niewiele.
  • Poziom 13  
    P0130 Obwod sondy lambda -wadliwe dzialanie,
    ja bym stawial na sonde ,ostatnio mialem taki przypadek ze po wymianie na nowa ze sklepu ,auto zwariowalo,byl to zamiennik i poprostu niepracowal tak jak powinien,
  • Poziom 14  
    dzień dobry
    zapomniałem dodać ze napięcie pracy sondy które podałes jes niezby parawidłowe w zależności od typu sondy powinno się wahać w zakresie
    0,1v do 0,9v lub
    1v do 5v należałoby sprawidzć jakie jki jest prąd na wyjściu ze sterownika po odpięcie kostki sondy na tym samym co sygnał, wążne też czy masz instalację gazową
  • Użytkownik usunął konto  
  • Poziom 9  
    Dzis przeprowadzilem dodatkowe testy.

    1. Wypiolem sonde i sprawdzilem napiecie (na progamie autoscann) i okazuje sie czy sonda jest podlaczona czy nie napiecie wacha sie pomiedzy 446 a 451 czy cos kolo tego.
    2. Podpiolem moja sonde (przedluzonym przewodem) do Astry F i ku mojemu zaskoczeniu okazala sie sprawna tzn. wskazywala napiecia w zakresie od 100 do 900 mV.
    3. Zrobilem tym samym test w druga strone, mianowicie lambda z Astry F,
    przewodem do mojej wtyczki. Niestety tutaj wskazania ani drgnely (czekalem nawet az temperatura silnika u mnie bedzie odpowiednia).

    Wyglada wiec na to ze sterownik silnika jest uszkodzony albo kabel doprowadzojący sygnał z lambdy do sterownika jest gdzieś uszkodzony.
    Aby sprawdzić kabel muszę sprawdzic sygnal przy sterowniku ale nie wiem gdzie go szukac.
    Mozecie potwierdzic moja teze (lub zaprzeczyc:)) i wskazac mi gdzie znajduje sie sterownik?

    Zapomniałe dodać (w odpowiedzi na zadane pytanie) ze nie mam gazu, tylko benzyna.
  • Pomocny post
    Moderator Samochody
    Sterownik masz za akumulatorem, sonda na pinie 27B(niebieska wtyka).
  • Poziom 9  
    Podstawowe pytanie, co sie stanie jak wypne komputer?
    Czy moge to zrobic bez obawy ze nie odpale pozniej samochodu?
    Czy powinienem na cos zwrocic uwage, o czyms pamietac?
  • Poziom 11  
    Możesz wypiąć kompa. Jednak zanim postawisz tak daleko idącą diagnozę może lepiej przed tym wymienić lambde na oryginał? Czasami warto się cofnąć jeden krok niż zrobić cztery za daleko :D
  • Poziom 9  
    Problem rozwiązany.
    Tak jak podejrzewałem przyczyną zaistniałej sytuacji był uszkodzony komputer. Naprawa kosztowała mnie 1000 zł (w tym wymiana EGR na regenerowany), ale warto było bo z czasem samochód coraz dziwniej się zachowywał.
    Zgodnie z informacją z serwisu, uszkodzonych było 10 podzespołów kompa.