Elektroda.pl
Elektroda.pl
X

Wyszukiwarki naszych partnerów

Wyszukaj w ofercie 200 tys. produktów TME
Europejski lider sprzedaży techniki i elektroniki.
Proszę, dodaj wyjątek elektroda.pl do Adblock.
Dzięki temu, że oglądasz reklamy, wspierasz portal i użytkowników.

Stabilizator impulsowy LM2576 -problemy

Guma1975 17 Maj 2004 10:06 7432 9
  • #1 17 Maj 2004 10:06
    Guma1975
    Poziom 13  

    Witam serdecznie!
    Problem polega na tym, że po złożeniu tego LM2576T-5.0 na pająku układ nie działa prawidłowo.
    Zlutowałem najkrótszą drogą jak to tylko możliwe, kondensatory w/g datasheet-a LOW EMR, masa w jednym punkcie.
    Co do dławika wykonałem go nawijając drutem miedzianym emaliowanym 0.8mm na pierścieniu zbliżonym do wymiarów w/g zaleceń producenta układu.
    Kombinowałem z różnymi materiałami na rdzeń zawsze zachowując tą samą indukcyjność L=100uH (też zalecaną).
    Dioda shottkyego 5A wyciągnięta z jakiegoś starego LAPA.

    Po obciążeniu układu (0.38A żarówkami 13.5V) przetwornica generuje impulsy na nodze nr2 paczkami , a na wyjściu zamiast "czystych" 5V są zauważalne tętnienia około 0.8V a na wejście stabilizatora podaje 12V.

    Po obniżeniu napięcia zasilania z 12 do 10V tętnienia ustają (czyste 5V) a generowane przebiegi na wyprowadzeniu nr 2 są ciągłe.

    Natomiast po zasileniu układu napięciem 15V praktycznie przestaje działać na wyjściu jest wtedy około 2V "poszarpanych ząbkami"

    Reasumując przy zasilaniu 8.5 do 10 działa dobrze.

    Prosiłbym o pomoc w rozwiązaniu problemu a może ktoś już składał coś na LM2576T-5.0 ?
    Już nie wiem co robić, przeczytałem datasheet-a setki razy i już mnie szlaczek goni.

    Pozdrawiam!

  • #2 17 Maj 2004 11:47
    SP1AQU
    Poziom 21  

    Miałem okazję projektować kilka przetwornic impulsowych, na różnych układach. Podejrzewam, bo niewiele konkretów na ten temat napisałeś, że przyczyną problemów może być cewka. Rzecz w tym, że jej indukcyjność to jedna sprawa, ale są jeszcze inne parametry istotne w przypadku indukcyjności magazynującej energię w przetwornicy. Otóż, w zakresie napięć i prądów występujących podczas pracy przetwornicy, rdzeń cewki nie może wchodzić w nasycenie. To z kolei zależy od materiału i wymiarów. Do takich przetwornic doskonale się nadają rdzenie proszkowe, natomiast eksperymenty z rdzeniami o nieznanych parametrach są obarczone dużym ryzykiem niepowodzenia. Niektóre rdzenie np. doskonale się nadają do tłumienia zakłóceń, ale do zastosowania w przetwornicy już nie.
    Dla sprawdzenia, możesz dać cewkę na rdzeniu np. 2-3 razy większym. Jeśli układ będzie działał poprawnie, to będziesz wiedział, że to wina cewki.

  • #3 19 Maj 2004 08:15
    Guma1975
    Poziom 13  

    Niestety nic to nie dało. Rdzeń proszkowy średnicy 30mm i dalej to samo.
    Chyba pobiegne do sklepu po drugą sztukę LM-a. A może jest jakiś sposób na sprawdzenie właściwości użytego rdzenia doświadczalnie?
    Widzę to tak: parę zwoi na badanym rdzeniu + generator + oscyloskop i co dalej?

  • #4 19 Maj 2004 14:01
    _jta_
    Specjalista elektronik

    Jeśli chodzi o badanie rdzenia, to wypadałoby zmierzyć indukcyjność (np.
    w rezonansie), oraz jej zależność od prądu stałego płynącego przez cewkę
    - zobacz, czy np. początkowo rośnie, i jaki prąd jest potrzebny, by zmalała
    np. do połowy maksymalnej indukcyjności. Źródło prądu polaryzacji powinno
    mieć dużą impedancję - np. z kolektora tranzystora - by nie zakłócało pomiaru.

    Typowy ferryt ma przenikalność około 1000 (są od 10 do 20000), i indukcję
    nasycenia 200-400mT - czyli do nasycenia potrzebuje za 300A/m, więc przy
    średnicy pierścienia ferrytowego 30mm jakieś 25-30A wystarczy (jak masz
    10 zwojów, to 2.5-3A) - a w nasyceniu indukcyjność maleje wielokrotnie.

  • #5 19 Maj 2004 22:25
    Guma1975
    Poziom 13  

    No właśnie a mam na tym rdzeniu 32 zwoje DNE fi 0.8mm
    Sprawdzałem w notach katalogowych LM-a oraz wymiary cewki orginalnej do tej aplikacji. Jest z tego samego materiału, który właśnie posiadam.
    Najdziwniejsze jest to, że przy napięciu zasilania równym dwukrotnej wartości napięcia stabilizacji jest OK! :?
    A zwiększając je do wartości 15V jest coraz gorzej (2V poszarpane).

    Głównie chodzi o to czy ktoś miał do czynienia z tymi LM 2576T 5.0
    Wtedy można coś wydedukować. Robiłem przetwornice głównie na tranzystorach i jakoś sprawność ich wypadała koło 90%
    Tu mam do czynienia z czymś nowym (brak ingerencji w parametry układu-kostka 5pin). Ma to być do uwalonego laptopa, gdyż jego zasilacz wewnętrzny LTC1142CG (nieosiągalny) padł w połowie i jest 3.3V a 5V brak.
    Całość musi się zmieścić do niego, dlatego zdecydowałem się na "nowość"
    Dlatego zanim zakupię drugą sztukę, chciałbym zasięgnąć porad tych, którzy mieli do czynienia konkretnie z tym układem.

  • #6 20 Maj 2004 00:20
    ul1111
    Poziom 22  

    Co do ltc1142 czy sprawdzałeś poziom napiecia na nóżce 16 i ew 2?

  • #7 20 Maj 2004 21:44
    Guma1975
    Poziom 13  

    Sprawdzałem i są na poziomie 0.04V czyli przetwornica włączona 3.3V jest a 5V brak. Sprawdziłem tranzystory kluczujące (zamieniłem parami -są bliźniacze) i nic. Jako że nie ma zbyt dużo części sprawdziłem również kondensatory smd i resztę. Pozostał tylko LTC1142
    Szkoda tylko, że są takie problemy z jego zdobyciem.

  • #8 21 Maj 2004 19:57
    olekewaagata
    Poziom 25  

    Ja od dwóch lat używam tylko LM-a jeśli muszę mieć troche wiecej
    prądu i nie mam do niego żadnych zastrzeżeń.
    Na twoim miejscu dokładnie sprawdziłbym napięcie zasilania, czy
    czasami nie siada kiedy zwiekszasz napięcie.

  • #9 22 Maj 2004 15:14
    Guma1975
    Poziom 13  

    Nie nic nie siada!
    Sprawdzam to zasilaczem serwisowym lecz nic to nie daje.
    Jeśli możesz wyślij mi na priva lub na forum zdjęcia lub ewentualnie wymiary cewek jakie stosujesz.
    Będę wdzięczny z góry.

  • #10 07 Cze 2004 21:54
    Guma1975
    Poziom 13  

    No cóż. Nic nie wykombinowałem z LM2576, lecz dostałem paczkę z TI
    Może kogoś zainteresuje a działa znakomicie, mając niewielkie wymiary i bez radiatora pogania mi to starego laptopa!
    Gorąco polecam PT6302A 5V i inne (na inne napięcia) dostępne jako sample w TI wraz z Datasheet-em
    Pozdrawiam!

 Szukaj w ofercie
Zamknij 
Wyszukaj w ofercie 200 tys. produktów TME