Elektroda.pl
Elektroda.pl
X

Search our partners

Find the latest content on electronic components. Datasheets.com
Elektroda.pl
Please add exception to AdBlock for elektroda.pl.
If you watch the ads, you support portal and users.

Mikroprocesorowy zasilacz laboratoryjny AVT-5083.

BigPablo 15 Jun 2009 09:16 8748 16
Altium Designer Computer Controls
  • #1
    BigPablo
    Level 21  
    Witam! Buduje Mikroprocesorowy zasilacz laboratoryjny jest to kit AVT-5083 oto link do opisu http://sklep.avt.com.pl/photo/_pdf/AVT5083.pdf
    Gdy podłączę do prądu zasilacz na wyświetlaczu nic się nie świeci ani diody. Na wyjściu zasilacza zawsze miałem gdy próbowałem ok. 2V gdy dziś rano włączyłem wyskoczyło mi 40V. Mam transformatory: do zasilania głównego układu TST100/15 który daje 28V - 3,75A , a do zasilania częsci sterującej TS 5/002 który na uzwojeniu wtórnym ma 6V - 0,8A. Naciskanie klawiszy nic nie daje nie zwiększa ani nie zmniejsza napięcia.Próbowałem już wymienić taśmę która łączy obie płytki. Pomocy szukałem na forum lecz niema podobnego problemu do mojego.
    Z góry dziękuję.
    Mikroprocesorowy zasilacz laboratoryjny AVT-5083. Mikroprocesorowy zasilacz laboratoryjny AVT-5083. Mikroprocesorowy zasilacz laboratoryjny AVT-5083.
  • Altium Designer Computer Controls
  • #3
    BigPablo
    Level 21  
    Do styków taśmy, która idzie do części sterującej, w ogóle nie dochodzi napięcie.
  • #4
    music
    Level 28  
    No to problem masz już właściwie rozwiązany. Znajdź przyczyne braku zasilania części sterującej i wszystko powinno wrócić do normy.

    Pozdrawiam

    Dodano po 2 [godziny]:

    Za zasilanie części sterującej odpowiada stabilizator 7805. Oznaczony na schemacie jako U3. Miernik do rączki i sprawdzić co jest na wejściu i na wyjściu. Po nitce do kłębka.

    Pozdrawiam
  • #5
    BigPablo
    Level 21  
    Prubowałem sprawdzic ale odpadł mi od płytki złamały się nóżki pojade na miasto to kupie i sprawdze ale to nie powiino długo trwać
  • Altium Designer Computer Controls
  • #6
    BigPablo
    Level 21  
    Kupiłem nowy stabilizator ale na wejściu nic sie nie pojawia żadne napięcie na wyjściu też nie. Ale zdziwiło mnie gdy wyjąłem LM358 i sprawdziłem co jest na końcówkach może pomoże to w znalezieniu problemu.
    Ponumerowane według zdjęcia na dole.
    między
    1 i 2- 41.1 V 2 i 3- 0 V
    1 i 3- 41 V 2 i 4- 0 V
    1 i 4- 41.2 V 2 i 5- 32.3 V
    1 i 5- 0 V 2 i 6- 21.1 V ale gdy mierzyłem 2 raz wyszło 18.8 V
    1 i 6- 21.2 V 2 i 7- 0V
    1 i 7- 39.9 V 2 i 8- 0V
    1 i 8- 41.2 V

    3 i 4- 0V 4 i 5- 32.5V
    3 i 5- 32.2 V 4 i 6- 18.0V
    3 i 6- 18.6V 4 i 7- 0V
    3 i 7- 0V 4 i 8- 0V
    3 i 8- 0V

    5 i 6- 12.6V 6 i 7- 17.9V
    5 i 7- 31.2V 6 i 9- 18.8V
    5 i 8- 32.4V 7 i 8- 0V

    Takie różnice napięcie są chyba trochę dziwne i mierzyłem to miernikiem uniwersalnym ustawionym na napięcie stałe w zmiennym na niektórych końcówkach pojawiało się nawet 80 V
    Mikroprocesorowy zasilacz laboratoryjny AVT-5083.
  • #7
    music
    Level 28  
    Strasznie masz tam nasmarkane w górnym prawym rogu zdjęcia. Weź no to oczyść. Sprawdź czemu nie masz napięcia na wejściu stabilizatora. Pewnie narobiłes zwarć i zająłeś się pomiarami napięć zupełnie gdzie indziej.
  • #8
    BigPablo
    Level 21  
    dobra a te nasmarkane:) to kalafonia czym to zmyc denaturatem? Wylutuje wszystkie częsci oczyszcze łytke i zrobie jeszcze raz hyba ze będę cos zamawiac to wezme i nowe plytki.
  • #9
    PC_maniak
    Level 13  
    Chcę sobie złożyć ten zasilacz. W związku z tym mam pytanie odnośnie transformatorów.
    Akurat mam pod ręką TS 40/38 który wg danych katalogowych dostarcza na wtórnym dwóch napięć: 20,5V/1.6A i 6.1V/1.07A co załatwiłoby mi super sprawę zasilania układów i pozwoliło uzyskać na wyjściu ok 18V i 1 - 1.2A.
    W związku z tym mam pytanie, czy z uzwojenia 6.1V mogę zasilać równocześnie część sterującą kitu, bo w projekcie stosowane są dwa transformatory (po to, by nie obciążać dodatkowo zasilacza? czy z uwagi na separację?)
    Nie znalazłem informacji, czy ten transformator ma odseparowane, osobne uzwojenia wtórne? Wizualnie raczej tak.
    Proszę o odpowiedź.
  • #10
    Paweł Es.
    VIP Meritorious for electroda.pl
    Ten układ to jak widzę to kolejny KIT produkcji AVT, jestem ciekaw czy ktoś chociażby sprawdził schemat pod kątem błędów i zasad projektowania !!!!


    1. Główne napięcie zasilania układu, mierzone na zaciskach kondensatora C7 nie może w żadnych warunkach przekroczyć 32V, bo wtedy nastąpi uszkodzenie układu U1 (LM358), którego maksymalne dopuszczalne napięcie zasilania wynosi 32V.

    Czyli napięcie z transformatora mierzone bez obciążenia i przy maksymalnej odchyłce napięcia sieciowego (230V+5% = 241.5V) może wynosić:

    $$Utr\ <\ \frac{Uc7+2*Ud}{\sqrt{2}}\ =\ \frac{32+1.5}{1.4142}\ \approx\ 23.7V$$

    A praktycznie napięcie powinno być jeszcze mniejsze, by nie pracować na maksymalnych wartościach dopuszczalnych napięć zasilania układu scalonego (jego uszkodzenie grozi wystąpieniem pełnego napięcia zasilania na wyjściu układu i zniszczeniem zasilanego układu) !!!!!!

    2. Napięcie zasilania stabilizatora 5V musi być o co najmniej 3V wyższe od napięcia wyjściowego czyli z transformatora trzeba podać napiecie:

    (Uwy+3V+1.5V)/1.41=9.5V/1.41V=6.71 Vsk~

    1.5V - jest na spadek napięcia na mostku prostowniczym.

    Czyli trzeba dać transformator dający od 7V wzwyż


    3. Na schemacie (Rys 2. ) jest błąd w narysowanym podłączeniu zasilania układu U1, bo przecież nie może on być podłączony jednocześnie w dwóch różnych miejscach.

    Podłączenie narysowane w części U1B jest niepoprawne !

    4. Zakładając, że napięcie sterujące zmienia się (w przybliżeniu) od 0 do 5V to wzmacniacz U1A wraz z tranzystorami T1 i T2 powinien mieć wzmocnienie 5 V/V. Zastosowany układ niwelacji spadku napięcia R5, przez podnoszenie poziomu masy zasilania mikroporocesora (GND2) nie bardzo ma sens, ponieważ, przy 1A prądu obciążenia poziom masy podnosi się o 0.1V za to napięcie wyjsciowe o 0.5V (5*(0.1V+Uśrednie_PWM) co przy małych wartościach ustawionych napięć może grać dużą rolę).

    5. Użyte potencjometry powinny być raczej typu wieloobrotowego, bo wtedy precyzyjne dostrojenie było by łatwiejsze a i stabilność nastaw byłaby większa (bo takie potencjometry są stabilniejsze i do tego hermetyczne, co izoluje je od wpływu kurzu, wilgoci).

    W części cyfrowej też są jakieś cuda porobione na schemacie:

    1. W spisie elementów podano, że wyświetlacze mają wspólną katodę a na schemacie na wspólną końcówkę danego wyświetlacza podawane jest dodatnie napięcie przez tranzystory T3, T4 i T5. Przypuszczalnie jednak są to wyświetlacze ze wspólną anodą.

    2. W układzie powinny być rezystory szeregowe z segmentami wyświetlaczy, zabezpieczające wyświetlacze i dekoder U4 przed uszkodzeniem w momencie zatrzymania multipleksowania (np. przy zawieszeniu się mikroprocesora).

    3. W szereg z przyciskami powinny być diody zabezpieczające przed zwarciem między sobą lini portów wyjściowych (na wypadek jakby kto chciał wcisnąć większą ilość przycisków na raz).

    4. Wygląda też, że złącze J3 i J4 (pomiędzy częścią wykonawczą i cyfrową) jest opisane odwrotnie - z jednej strony na pinie 1 jest +5V a z drugiej strony na pinie 1 jest sygnał PWM.

    Odwrócenie to grozi uszkodzeniem portu mikroprocesora gdy zewrze się go na czysto do +5V !!!
  • #11
    PC_maniak
    Level 13  
    Oczywiście nie odnoszę się do postu Kolegi Paweł Es. gdyż jest on napisany w kwestii ogólnej odnośnie kitu AVT-5083 i nie polemizuję z Kolegą. Po przeczytaniu można wywnioskować:

    Do kitów trzeba podchodzić jak do materiału wybuchowego i wcześniej długo analizować pod kątem poprawności. W tym zgadzam się z Kolegą w całej rozciągłości.
    Co do pkt. 1 to analizowałem wcześniej notkę aplikacyjną LM 358 i wiedziałem o ograniczeniach do 32V zasilania. Stąd mój wybór (okazja z posiadania trafka) padł na TS 40/38. Zadawalałoby mnie regulowane 18V i prąd w okolicy 1A.
    2. Schemat schematem. Płytka PCB wydaje się prowadzić zasilanie LM-a poprawnie.
    3. Również zasilanie 7805 ze źródła 6V wydawało mi się problematyczne i za niskie. Ale w opisie jest powiedziane konkretnie, że trafko dla części sterującej ma dać równe 6V. Może ma wystarczy wzrost napięcia po kondensatorze elektrolitycznym przy tym poborze prądu (chociaż aplikacja 7805 mówi to, co mówi).

    Co do reszty zastrzeżeń, to cenne uwagi i z innych postów i opisów uruchomienia można wywnioskować, że koledzy nie zwrócili na to uwagi.
    Zainkasowali nawet pady mikroprocka.

    Bardzo dziękuję Koledze za cennne uwagi zawarte w poscie i pozdrawiam.
  • #12
    Paweł Es.
    VIP Meritorious for electroda.pl
    Tak się też zastanawiam skąd się wzięło to obostrzenie:

    Mikroprocesorowy zasilacz laboratoryjny AVT-5083.

    szczególnie, że ten BDp391 to ma wg katalogów maksymalne wzmocnienie 250.

    Poza tym te tranzystory to jest tylko wzmacniacz prądowy nie zmieniający napięcia (oprócz przesunięcia w dół o Ube1+Ube2).

    W międzyczasie znalazłem rozmowę na temat zasilacza z samym autorem:

    https://www.elektroda.pl/rtvforum/topic62632.html
  • #13
    PC_maniak
    Level 13  
    Uruchamianie zasilacza zacząłem od sprawdzenia zasilania układu. Mam więc uprzejmą prośbę abyście Koledzy rzucili okiem na schemat z pdf-a pierwszego postu.
    Na wejściu (punkty 1,2 złącza J5) z transformatora podawane jest 24,3V na mostek. Natomiast na końcówkach kondensatora C7 po wyprostowaniu i wygładzeniu mam =31,8V no i w związku z tym obawiam się zasilić tym napięciem układ LM358, bo wg noty aplikacyjnej jest niebezpiecznie blisko granicznemu napięciu zasilania 32V dla tego wzmacniacza.
    Pomiaru dokonuję miernikiem cyfrowym. Obciążyłem tę część zasilacza rezystorkiem 6,8k/0,25W i napięcie nie "usiadło" ani o 1 mV. A skoro kondensator ładuje sie do naięcia 1,41 * U tr - 2Ud (1,5V), to powinno być 32,76V?

    Co robić, włączać kostkę czy też powalczyć o niższe napięcia, czy miernik przekłamuje pomiar?
  • #14
    Paweł Es.
    VIP Meritorious for electroda.pl
    Możesz wytracić trochę napięcia na dodatkowych diodach:

    Mikroprocesorowy zasilacz laboratoryjny AVT-5083.

    Spadek napięcia wyniesie około 0.7 do 0.8V na jedną diodę.

    4-5 diod i zapas bezpieczeństwa rośnie o minimum 2.8 do 3.5V.

    Diody mogą być od 1N5400 (3A na 50V) do 1N5408 zależnie, które dostaniesz.

    Może jest to toporne rozwiązanie ale za to dużo tańsze niż szukanie nowego transformatora (5 diod 1N5406 kosztuje około 1 zł, więc możesz i więcej wstawić, zależnie od potrzeb).

    Zamontuj te diody na kawałku płytki uniwersalnej i podłącz między mostek a kondensator elektrolityczny rozcinając ścieżkę.
  • #15
    PC_maniak
    Level 13  
    Genialne i proste rozwiązanie, że też nie pomyślałem.

    Jednak uruchomiłem ten zasilacz, ponieważ napięcie zasilania układu operacyjnego było stabilne. Ruszył od razu i pięknie się reguluje. Z tego transformatora uzyskałem 25V na wyjściu przy prądzie 990 mA bez maksymalnego obciążania. Czyli spełnia moje zakładane oczekiwania. Jak będzie przy pełnym obciążeniu to się okaże.

    Bardzo dziękuję za odpowiedź i pozdrawiam.
  • #16
    PC_maniak
    Level 13  
    Jeszcze pozwolę sobie dodać kilka fotek z konstrukcji zasilacza AVT5083, może nie ma się co chwalić, ale pokażę - co wyszło ...

    Mikroprocesorowy zasilacz laboratoryjny AVT-5083.
    Mikroprocesorowy zasilacz laboratoryjny AVT-5083.
    Mikroprocesorowy zasilacz laboratoryjny AVT-5083.
    Mikroprocesorowy zasilacz laboratoryjny AVT-5083.

    Pozdrawiam